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This chapter includes the following topics:

e Top Enhancements
e Performance
e For More Information

Model courtesy of Philipp Burgstaller, SOLIDWORKS 2022 Beta Splash Screen Prize Winner.
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75 easmur Video: What's New in SOLIDWORKS 2023

At SOLIDWORKS®, we know that you create great designs, and that your great designs get
built. To streamline and accelerate your product development process from concept through
manufactured products, SOLIDWORKS 2023 contains new, user-driven enhancements focused
on:

e Working Smarter. Reduce your workload when designing large assemblies and detailing
drawings, and handle more complex electrical routing scenarios.

e Working Faster. Work with bills of materials (BOMs) more efficiently, improve the
performance for searching and saving assemblies, and design large assemblies faster.

e Working Together. Help teams share and manage data more productively with a
streamlined user interface, reduced latency, and improved upgrade performance in
SOLIDWORKS PDM. Communicate changes to design data better with the ability to customize
PDM notification templates.

Top Enhancements

The top enhancements for SOLIDWORKS® 2023 provide improvements to existing products
and innovative new functionality.

Parts and Features Coordinate Systems
on page 26 e Dimension Support for the Move/Copy Body Command
¢ Single-Line Fonts for Wrap Features

Sheet Metal on
page 33

Sensors

Structure System Corner Treatment to Similar Corners in Structure Systems

and Weldments on « Configuration-Specific Size of Weldment Members
page 37

Assemblies on page Automatically Optimize Resolved Mode
41 e Repairing a Missing Mate Reference
¢ Additional End Conditions for Cut Features

Detailing and ¢ Overrides for Bills of Materials

Drawings on page e Filters for Bill of Materials
57


https://youtu.be/lnnixPXMM1g
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SOLIDWORKS ¢ Autoballoons for PDF Files

Inspection on page « Balloon Sequence

120 e Balloon Drawing Sheets Separately
e Export Sheets as Separate 2D PDF Files
e Export FAI Reports to Separate Microsoft® Excel® Documents
e User Interface Redesign

SOLIDWORKS MBD e Limiting Geometric Tolerances to a Standard
on page 131 e Dimension Extension Lines

Performance

SOLIDWORKS® 2023 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

SOLIDWORKS Fundamentals

You can use the Level of detail system option to improve the performance when
manipulating views.

To access this option, click Tools > Options > System Options > Performance.

Performance is improved for Zoom In/Out, Pan, and Rotate in draft quality HLR/HLV
and wireframe modes of models.

Section Views of Models

Starting and exiting the Section View B command is about five times faster than before.

While you are in the Section View g command, adding or removing section planes is
instantaneous.

Assemblies

e Improved performance when searching with Include sub-folders selected.

e For assemblies that contain parts with multiple imported bodies and body level
appearances, performance is improved when:

e Opening a file

e Changing a configuration

e Applying, modifying, or removing an appearance
e Rolling back or rolling forward assembly items

e The save efficiency of assemblies is improved to avoid saving unchanged model data.
This performance improvement is most noticeable in very large assemblies.
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SOLIDWORKS PDM

e SOLIDWORKS PDM 2023 makes significant performance improvements in the presence
of high latency to SOLIDWORKS PDM servers.

The improvements might vary depending on the amount of latency, size of datasets,
and operations.

e The following operations perform better when latency to the database server is
high:
e Check-in
e Check-in with automatic transition
e Undo Check-out
e Interactive operations such as menus, shortcut menus, reference dialog boxes,

SOLIDWORKS PDM File Explorer tabs
e The following operations perform better when latency to the archive server is high:

e Add files

¢ Change state on file modifications
o Get files

e Get latest version of files

e With performance improvements in the File Version Upgrade tool, you can upgrade
SOLIDWORKS files in a SOLIDWORKS PDM vault faster.

If you are upgrading assembly files and you select Overwrite and Latest Version in
the Version Settings page, the software skips upgrading and uploading references that
are not the latest in the assembly's as-built version. This improves the performance
of the upgrade process.

Structure Systems and Weldments

Performance is improved when you create or edit a corner management feature. A corner
gets trimmed when you select it under Corners in the Corner Management
PropertyManager or in the graphics area.

Previously, the corners were trimmed as soon as you created or edited the corner
management feature.
For More Information

Use the following resources to learn about SOLIDWORKS:
What's New in PDF This guide is available in PDF and HTML formats. Click:

and HTML
« @ > what's New > PDF
o @ > What's New > HTML
H::;rac“ve What's In SOLIDWORKS, @ appears next to new menu items and the

titles of new or significantly changed PropertyManagers. Click

10
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Online Help
SOLIDWORKS User

Forum

Release Notes

Legal Notices

@ to display the topic in this guide that describes the
enhancement.

To enable Interactive What's New, click @ > What's New >
Interactive.

Contains complete coverage of our products, including details
about the user interface and examples.

Contains posts from the SOLIDWORKS user community on the
3DEXPERIENCE® platform (login required).

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

SOLIDWORKS Legal Notices are available online.

11
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https://help.solidworks.com/Help.aspx?P=1&V=2023&F=sldworks/c_copyright_solidworks.htm

Installation

This chapter includes the following topics:

e Adding Serial Numbers for SolidNetWork License Installations
¢ Renewing and Reactivating Term SNL Licenses

e Load SOLIDWORKS Flow Simulation Modules

e Faster Startup for Borrowed Licenses

Adding Serial Numbers for SolidNetWork License Installations

m
Activate/Deactivale Your SOLIDWORKS Product
To actvate your SOLIDWORKS product you must reguest a license key from SOLDWORES.

The Activation Wizard will help you collsct the information necessany to ativate your
product.

Select All

Deselect All

Add Serial Mumbers X

Adding serial numbers to licenses for all SOLIDWORKS applications and add-ins is much
simpler for CAD administrators to handle.

You can use the Product Activation Wizard from the SOLIDWORKS SolidNetWork License
Manager Server to add and activate serial numbers for perpetual and term licenses.
Previously, serial numbers were entered when installing the License Manager Server. The
new method makes it easier to add serial numbers to existing installations. You can also
use the Activation Wizard to remove serial numbers that have not been activated.

12
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Renewing and Reactivating Term SNL Licenses

Reactivate Licenses

1o update the Expiration date.

Sarial

Al "

ASiSEIatEd
Froduct Flicenses Version Expires Repctivation Date
SOLIDWORKS Manage Professonal Editor 3 0.0 Kerver 12-17-2032
SOLIWORKS Manage Frofessional Viewer 5 300 lirver 12-17-2022
SOLIDWORKS PDM Professional Processer License 25 0.0 Rever 12-17-2022
SOLIWORKS Manbge Professonal Contributor 5 300 Rirver 12-17-2022
SOLID'WORKS Composar Path Planning 1 0.0 M i
SOLIVWORKS Compeser Professanal 5 0.0 Kever 12-17-2022

| SOLIDWORKS Cemposer Chesk (%) 1 30,0 ]
SOLIDWORKS Composer Enferprice Sync 1 300 lurver 12-17-2022
SOLIWORKS FOM Standard CAD Edeor 1 0.0 Kerver 12-47-2022
SOUIDWORKS. Standard 5 0.0 Kever 12-17-2022
SOLIDWORKS CAM Standand 5 300 12312025 12-31-2025

Select your installed Serial Numbers to view their associated Bcenses. Reactivate to update benses on this server.

* Contact your Value Added Reseller to renew these products.  you ave already renewed these products, Reactivate

For term licenses, renewal and reactivation warnings display in all SOLIDWORKS add-ins,

SOLIDWORKS PDM, and SOLIDWORKS Manage.

When users start these applications, if any term licenses are due to expire or require
activation within 30 days, warnings notify the users and prompt them to contact their

CAD administrator.

When you click Reactivate on the SolidNetWork License Manager Server Administration
tab, the Reactivate Licenses dialog box highlights in red all license expiration and
reactivation dates within 30 days. Asterisks mark licenses that require renewal. You can

also filter and view licenses associated with a specific serial number.

13
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Load SOLIDWORKS Flow Simulation Modules

[ SOLIDWORKS SolidNetWork License Manager

Bomowing License Order

] Automatically load Flow Simulation add-in modules # available

ensions | SOLIDWORKS Add-Ins | Analysis Preparation

L= S ¥ Kl S
SOLUDWORKS SOLDWORKS SOLIDWORKS TolAnalyst | SOLIDWORKS
Routing Simulation Toolbox Flow Simulation

SOLIDWORKS Flow Simulation
SOLIDWORKS Flow Simulation = HVAC

SOLIDWORKS Flow Simulation + Electronics Cooling

SOLIDWORKS Flow Simulation + HVAC « Electronics Cooling

As a SolidNetWork license customer, you can control how to load the HVAC and Electronics
Cooling add-in modules for Flow Simulation using two methods.

The first method lets you specify the default behavior for the add-ins when you load Flow
Simulation. The option Automatically load Flow Simulation add-in modules if
available is in the SolidNetWork License Manager Client > License Order tab. Clear
this option if you do not have a need for the Flow Simulation add-ins. The HVAC and
Electronics Cooling add-in modules do not load when Flow Simulation is added in with
existing methods.

The second method lets you override default behavior and include the HVAC and Electronics

Cooling add-in modules when you load Flow Simulation. Click the Down arrow * on
SOLIDWORKS Flow Simulation (SOLIDWORKS® Add-ins toolbar) or SOLIDWORKS
Flow Simulation with one or both of the add-modules to load.

Without these methods, the licenses for the add-in modules are consumed whether or
not you need them and may be denied to other users on your network.

14
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Faster Startup for Borrowed Licenses

I SOUDWORKS SoldNetWork License Manager

Licerme Usage  Server List  Lteras Bomowing  Licerme Cinder
b product boerme and then ik Fistum

For ksl product boensey

Poroeisct

Tuesday e 7 M2

o— [ Bomom > |

I [T Oy it bmmeed bceraers fathier tastugy

To bomew 8 boorde sslet & prodie kerde 1 Bomew and ther cho, Bomrow  To returm 2 looras select &

Baorowed produc boeraes

« Retum

O

If you are working remotely and your SOLIDWORKS apps are slow to open, you can make
them faster by blocking license server queries and using only borrowed licenses.

License server queries are slow in some environments. Your apps will start faster if you
block these queries, but will only use the licenses you have borrowed.

To block license server queries and use only borrowed licenses, click Start >
SOLIDWORKS Tools 2023 > SolidNetWork License Manager Client > License
Borrowing > Only use borrowed licenses for faster startup and restart your apps.

15




SOLIDWORKS Fundamentals

This chapter includes the following topics:

e Application Programming Interface

e Changes to System Options and Document Properties
e Ellipses

e Performance Improvement When Manipulating Views

Application Programming Interface

See SOLIDWORKS API Help: Release Notes for late-breaking updates.

Support
There is API support for:

e Mate controller features in assemblies
e Simple, two-member, and complex corner treatments in structure systems

Redesign

Sheet metal sketched bend features have been redesigned.

Other Enhancements

e Get whether an assembly configuration is defeatured

e Get and set whether to use gauge table values in a sheet metal sketched bend feature
e Get whether to override a preset bend angle in a sheet metal sketched bend feature
o Get and set whether to symmetrically thicken a bidirectional base flange feature

e Get and set whether to symmetrically thicken a bidirectional lofted bends feature

e Convert a solid body to a mesh body

e Create a surface body from a mesh body

e Create a surface body from a graphics body

16



SOLIDWORKS Fundamentals

Changes to System Options and Document Properties

The following options have been added, changed, or removed in the software.

System Options

Option Description Access

Drawings, Modified Cells Changes the default color of overridden Colors
(BOM) cells.

Sketch, Exploded Specifies a color for an explode line. Colors

Automatically optimize Loads component data as resolved when Performance
resolved mode, hide you open an assembly.
lightweight mode

Manually manage Controls when a component loads in Performance
resolved and lightweight lightweight or resolved mode.

modes

Load component Renamed from Automatically load Performance
lightweight components lightweight.

Export assembly Exports assemblies as atomic STEP files. Export

components as separate
STEP files (recommended
for large assemblies)

Export appearances Exports file's appearances with reduced Export
performance. Clear the option to skip
exporting appearances but make the
performance faster.

Document Properties

Option Description Access
Enable/Disable options Includes all geometric tolerance Annotations >
per standard symbols. To limit symbols to a standard, Geometric
select the option. Tolerances
Connect dimension Completes connection of dimension DimXpert >
extension lines to model extension lines to model. Display Options

See through transparent (Available for High quality drawing Drawings >
components in HLR/HLV views only). Shows edges behind Detailing
transparent components with solid lines.
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SOLIDWORKS Fundamentals

Option Description Access

Default Bill of Materials Specifies a value for the default BOM Configurations

part number for new part number. Options are Document
configurations Name or Configuration Name.
Ellipses

When you sketch an ellipse, you can apply construction geometry to the major and minor
axes.

In the Ellipse PropertyManager, under Options, select Add construction lines.

Performance Improvement When Manipulating Views
You can use the Level of detail system option to improve the performance when
manipulating views.
To access this option, click Tools > Options > System Options > Performance.

Performance is improved for Zoom In/Out, Pan, and Rotate in draft quality HLR/HLV
and wireframe modes of models.
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User Interface

This chapter includes the following topics:

e Comments Enhancements
e Enforcing Legal File Names
e Restoring Default Settings
e Component Name Display

(3 User Experience

SOLIDWORKS 2023

Video: What's New in SOLIDWORKS 2023 - User
Experience

Comments Enhancements

E‘ Fillet1
B I U
4/19/2022 8:54:53 Al
Description _’,@
[ show at start Save and Close| | Cancel |I| Help
v
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User Interface

Comments are enhanced to improve usability.

You can choose different background colors and add bold B, italics I, and underline

u to text.

Click Options in the Background Colors tab to open the Tools > Options > Document
Properties > Model Display dialog box where you can specify the Comment
background colors. You can customize the names or reset all names back to the
default. You cannot customize the colors.

Select Show at start in various places to show the comments in the View All Comments
dialog box when you reopen the file.

In the View All Comments dialog box, in the Show at start column, you can select
the comments to show when you open the file. In the Show menu, you can specify
the comments to show at the start or based on a color. Click Apply to save changes
to the Show at start status of comments.

|At Start
Description (|
High Priarity (|
Laow Priority (|
Complete [
Reminder (]

When you right-click a comment, a context toolbar and shortcut menu appear so you
can directly edit features when you read the comments.

Sensars
3 Annatatians @ @ 1% #
v [@] Solid Bodies(2) o
- Camments X < \I} %PI )

4 @ Base-Revo|
= Feat Base-Revolw
N ﬂ!g] Cut-Extruc ure (Base-Revolve)

v [E] Equations Comment r Edit Comment
$=5 1060 Alloy Parent/Child... Delete Comment
|E| Eront I'g& Configure Feature
|E| Top }( Delete...
|i| Right [ Addto Favorites
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User Interface

e Comment tooltips show the text <image> to indicate that the full comment contains
an image. The tooltip name matches the name from the Comment background
colors section in the Model Display dialog box.

I:? Fillet] | | Description

4 [E_I] Cut-Extr Comment:

41972022 8:34:53 AM JEL: Is this fillet large enough?
471972022 9:33:21 AM JEU:

<image»

e Images in comments retain their current aspect ratio and the display quality is
improved.

e When you import images into comments, in the Open dialog box, the All files
(*.bmp, *.jpg, *.tif, *.tiff, *.png) option is the default to display all acceptable image
types.

e In the FeatureManager® design tree, comment indicators appear by default next to
features that have comments. The color circle matches the color of the comment.

L. Origin
v @)|E5[Boss-Extrude

@I IFillet1

v @ E_y Cut-Extrude1

To control the display of the comment indicators, in the FeatureManager design tree,
right-click the part node and click Tree Display > Show Comment Indicator.

G EIB| 4 & <
V |P@- PR B 0P
G User [T @

C Go To..
H Part (User Library)

5 Hidden Tree ltems 4
» [x)Al @ Add to Library
r S Upgrade cosmetic thread features
§§ M Upgrade custom properties
ﬁ T Comment ’
[F Tree Display y Show Flat Tree View
R Document Properties... Show Feature Names
Lo Configuration Publisher... Show Feature Descriptions

' ﬁﬂ E Appearance
' @ C Material

] A e
ﬁﬂ B = Ton | evel Transnarency

@faYaalalalsl

Show Comment Indicator [}

21



User Interface

Enforcing Legal File Names

B save s *
&« v « WINDOWS (C:) » tmp v W) Search tmp
Organize « MNew folder == - 9
dev “ Mame Date modified
dotWorks
Mo iterns match your search,
Drivers
GraphicDrivefs
IFOR
Intel < MName
File name: | Assemn final .SLDAS %o Assem] final.SLDASM %

Save as type: | SOLIDWORKS Assembly (*.asm;*.sldasm)

|
Description:  Add a description ‘

To ensure compatibility with the 3DEXPERIENCE platform, you cannot save new
SOLIDWORKS documents with preceding or trailing spaces in their names. The software
automatically removes the preceding or trailing spaces when you save the file. Spaces
in the middle of the file name are supported.

This enforcement applies in these cases:

Save As dialog box, including the Advanced option

Renaming parts and assemblies in the FeatureManager design tree
Mirror Components PropertyManager

Split PropertyManager and Save Bodies PropertyManager

Pack and Go
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User Interface

Restoring Default Settings

& SOLIDWORKS Settings Wizard X

Welcome to the SOLIDWORKS Settings Wizard

This wizard lets you save, restore or reset customization settings for SOLIDWORKS toolbars, shortcuts,
menus and system preferences

+ Sawve Settings
Saves the SOLIDWORKS 2023 settings for JEU to a file.

" Restore Settings
Restores SOLIDWORKS settings from a file.

" Reset Settings
Saves all cument settings, resets all user-defined settings and retums SOLIDWORKS to the factory defaults.

| Meat = | Cancel

You can more easily restore the factory default settings in SOLIDWORKS®,
SOLIDWORKS Settings Wizard

The Copy Settings Wizard is renamed to the SOLIDWORKS Settings Wizard that has an
improved and simplified user interface with three options:

Save Settings Saves SOLIDWORKS settings to a file. You choose the location
for the settings file and the settings to save.

Restore Settings Restores SOLIDWORKS settings from a file.

Reset Settings Resets all custom settings and returns SOLIDWORKS to the

factory defaults. You have the option to save all custom settings
to a file before resetting SOLIDWORKS to the factory defaults.

Customize Dialog Box

o The |  ResettoDefaults button appears at the bottom of each tab in the Customize

dialog box so you can customize the settings to reset.

e The Customization tab is removed.

23



User Interface

Customize

Toolbars Shortcut Bars Commands Menus  Keyboard Mouse Gestures Customization

Shortcut customization

Show All |

Reset to Defaults

<<€ 2022

Menu customization

Show All

Reset to Defaults

The options from the Customization tab are reorganized as follows:

Customize *

Toolbars  Shortcut Bars  Commands  Menus eyboard Mouse Gestures

Categories: Commands:
------- Separator)--——- R
i
View Open..
Insert Open Recent
Tool
Window SOLIDWORKS %
Help
Others . .
cearch Reset User Interface Customizations
Macros
— Reset SOLIDWORKS menus
Resets all customizations of all menus to the factory defaults. ‘ 20 23
— Reset shortcut menus
Resets all shortcut (right-click} menus to the factory defaults.
— Reset all customizations
Resets all customizations on all tabs to the factory defaults.
Change what menu: | v|
e Shortcut customization:

Show All Removed because this was rarely used. The preferred
method is to keep the menu small and click ¥ to expand
the list

Reset to Default Moved to Menus tab > Reset shortcut menus.

¢ Menu customization:
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User Interface
Show All Removed because there was very little difference between
this command and Reset to Default for this customization.

Reset to Default Moved to Menus tab > Reset SOLIDWORKS menus.

Customizations and Upgrades

When you upgrade to a new version of SOLIDWORKS, the software keeps all the
customizations and also shows any new tabs, menus, toolbars, etc. that were added to
the software. Previously, warning dialogs prompted you to make choices that might have
led to lost settings.

Component Name Display

=1
Model View

X

e

f
i

)

Message
Select a part or assembly from which to create the view, then click Next,

Part/Assembly to Insert s

Open documents:

|&z| wormgear_assembly

When you specify display options for component names in a drawing, the names in the
PropertyManager and View Palette match those in the FeatureManager design tree.
To specify display options for component nhames:

1. In the FeatureManager design tree, right-click the drawing name and click Tree
Display > Component Name and Description.

2. (Optional.) Under Primary, specify an option:

e Component Name
e Component Description

Based on the selection under Primary display options:

e The Model View and Standard 3 View PropertyManagers update the Open documents
field.

e The View Palette updates. The View Palette displays the part or assembly icon and the
file name.
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Parts and Features

This chapter includes the following topics:

e Allowance of Library Feature Errors

e Coordinate Systems

o Defeatured Parts as Derived Configurations (2023 SP1)
e Dimension Support for the Move/Copy Body Command
e Hybrid Mesh BREP Modeling Improvements

e Section View Performance Improvements

e Section View through Axis

e Single-Line Fonts for Wrap Features
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Parts and Features

Video: What's New in SOLIDWORKS 2023 - Parts and

Features
Allowance of Library Feature Errors
SOLIDWORKS x
,f"| Inable to create library feature with selected
4 references.
SOLIDWORKS X

;"'l‘_\ The library feature has emors with these selections.

Click Yes to keep this result or No to modify selections.

[C] Don't show again | Yes || Mo |

2022 2023

When you insert a library feature into a model and get error messages, you can keep the
results to view and manually repair the errors.

In the warning message, click Yes to keep the results. In the FeatureManager® design

tree, you can manually repair the library feature or click Undo ™3 to remove it. If you
click No in the warning message, in the Library Feature PropertyManager, you can modify

the selections or click * to restore the FeatureManager design tree without the library
feature.

Previously, the warning message blocked you from inserting library features that generated
errors.
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Parts and Features

Coordinate Systems

Select Other n
‘J'_'_ Coordinate System1@[bishopl1_black]

' Coordinate System1'\XY Plane@[bishop1_black]
' Coordinate System1\¥Z Plane@ [bishop1_black]

oordinate System1'X Axis@[bishop1_black]

oordinate System|

You can reference coordinate system elements from additional entities, features, and
commands, including the Select Other command.

Item Description

3D sketches Create sketch relations between 3D sketch
entities and coordinate system axes, planes,
and origin.

2D sketch dimensions Create 2D sketch dimensions that reference

coordinate system axes, planes, and origin.

e Mirror [Bf features and bodies
Select a coordinate system plane as the

e Mirror Components Ed mirror plane.

e Insert > Mirror Part

Reference Plane i Select a coordinate system axis to create a
new plane perpendicular to that axis. Use
a vertex or point from the model to position
the plane.

Select Other (¥ Select coordinate system axes, planes, and
origin.
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Parts and Features

Defeatured Parts as Derived Configurations (2023 SP1)

g E RIS e T

%h Defeature @

v X e S IER[¢[C B ER]
Feature Removal Complete ~ Configurations

The Defeature operation completed = . .
successfully. Select a results option for the - % sheet_metal_bracket Configuration(s) (Default_defeature)

simplified model, » Tables

Pesults o - Default [ sheet_metal_bracket ]
W e |@@ +" Default_defeature [ sheet_metal_bracket ]'l\
d by
Link to original A

@ECreate a new configuration: [:}

DEuinsh to 30 ContentCentral

Dgtore settings for future use

You can save a defeatured version of a part as a derived configuration.

In the Defeature PropertyManager, on the Feature Removal Complete tab, under Results,
select Create a new configuration. You can quickly switch between the parent
configuration and the defeatured configuration. You also have fewer files to manage.
Previously, you could create only a separate external defeatured file.

Dimension Support for the Move/Copy Body Command

k 3 Base-Re

@ | - k E]Slut—Eict
E m =av2 E T’L 4 ﬁ Boss-Ex
A

|0.000mm |E ﬁa This Configuration

|13rl}.0l}l]mm |E E All Configurations

Rotate E Specify Configurations..
1

Translate
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Parts and Features

When you use the Move/Copy Body command, you can control the Translate and
Rotate values with equations. You can add these equations to a design table and control
them there. You can double-click the dimensions in the graphics area and specify them
using the Modify dialog box.

Under Rotate, you can select Euler's angular rotation and specify values for Yaw
(side-to-side), Pitch (up-down), and Roll (twist). This method delivers the same resulting
rotation regardless of the order in which you specify these values.

If models have configurations, you can specify the configurations to which the dimensions
apply for Translate and for Rotate when you select Euler method of angular
dimensions.

Hybrid Mesh BREP Modeling Improvements

-e

o

Hybrid mesh BREP modeling is improved to support more SOLIDWORKS® BREP features
that you can combine with mesh BREP geometry.

Hybrid mesh BREP modeling now supports features such as boss and cut sweeps, lofts,
and boundaries. For a complete list of supported features, see SOLIDWORKS Online Help:
List of Features Supporting Hybrid BREP Bodies.

Section View Performance Improvements

Performance is improved when you work with section views in models.

Starting and exiting the Section View B command is about five times faster than before.

While you are in the Section View B command, adding or removing section planes is
instantaneous.
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Parts and Features

Section View through Axis

[y ‘ 306.50214673deg | ~

. Edit Color

You can define a section view through an axis without constraining it to a secondary point,
such as a vertex. Previously, a secondary selection was mandatory. When you click Plane

about axis ﬁ, you can click Reverse Section Direction % to flip the section view
across the created plane.

Single-Line Fonts for Wrap Features

/

SOLIDWORKS
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Parts and Features

You can create wrap features from sketches that use single-line fonts when you select

Scribe & for Wrap Type in the Wrap PropertyManager. Previously, wrap features did
not support single-line fonts.

Single-line fonts are also called stick fonts. This functionality is particularly helpful for
users who want to engrave stick fonts on parts.

If text or characters do not display properly, you may be using an inauthentic single-line
font. To check the font, dissolve the sketch text and review the text entities.
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Sheet Metal

This chapter includes the following topics:

e Gauge Values in Cut List Properties
e Sensors

e Sensor PropertyManager

e Symmetrical Thickness

Mheial and Sir.

 SOLIDWORKS 2023

Video: What's New in SOLIDWORKS 2023 - Sheet Metal

Gauge Values in Cut List Properties

Bounding Box Len?th: 14.79in
Bounding Box Width: 1.8in

Sheet Metal Thickness: 0.21in
Bounding Box Areq: 246.62inA2
Bounding Box Area-Blank: 26.62inA2

L [y}
N Cutting Length-Outer: 33.18in
™ ™o ooz o ™ Cutting Length-Inner: Oin
e e e Cut Outs: 0
o s | & O g o Bends: 6 _
0 Bend Allowance: 0.52in

MATERIAL: Plain Carbon Steel

o o = = a o
> >0 O > ! Mass: 1.571b

o o Description: Sheet

Bend Radius: 0.25in
surface Treatment: Finish
Cost-TotalCost: 0
QUANTITY: 1

Sheet Metal Gauge: 5GA
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Sheet Metal

If you use gauge tables to define the thickness of sheet metal parts, the gauge number
appears in the Cut-List Properties dialog box. In the associated drawing, the gauge value
is available for annotations and cut lists.

In the Cut-List Properties dialog box, the Evaluated Value for Sheet Metal Gauge is
Gauge Number GA. For example, if you use a 3 Gauge in a sheet metal part, the
Evaluated Value is 3 GA.

In drawings, you can link an annotation to the Sheet Metal Gauge property and you
include the property in a cut list.

To link annotations to gauge values:

1. In a drawing of a sheet metal part, click an annotation, such as Note .A

2. In the PropertyManager, click Link to Property .
3. In the Link to property dialog box, in Property name, select Sheet Metal Gauge.

To include gauge value properties in cut lists:

1. Right-click a flat pattern view and select Annotations > Cut List Properties.
2. Click in the sheet to place the cut list properties.

Sensors
S| Bk ¢eFHER
Y
{% & Part? (Default) < <Default>_Display State 1>
v [ig) Histery

& Sensors
ﬁ & Sheet Metal Bounding Box Length1(8.470000 in}
Annotations
v B cutlist(1)
r Equations
EE Material <not specified=
[:1:] Front Plane
[:1:] Top Plane
(1] Right Plane
I_. Origin
[] Sheet-Metal
3 Sheet-Metall

4

You can use sensors to alert you when sheet metal models deviate from the limits specified
for a bounding box. In multibody parts, you can create sensors for individual bodies.

During the design process, if the model exceeds the bounding box parameters, an alert
appears in the FeatureManager® design tree. You can double-click an alert to see the
values in the Cut-List Properties dialog box.
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Sheet Metal

Sensor PropertyManager

Updates to the Sensor PropertyManager include support for sheet metal models.

Message

Displays a message if you do not select Create Cut Lists Automatically and Update
Automatically. Sheet metal bounding box sensors depend on up-to-date cut list

properties. In the FeatureManager design tree, right-click Cut list RQ] and select Create
Cut Lists Automatically and Update Automatically to generate automatic alerts.

Sensor Type

Iz Sheet Metal
Bounding Box
Properties

Specifies the smallest rectangle in which the flat pattern can
fit.

Properties

Iz Sheet Metal
Bounding Box

Specifies the longest side of the bounding box.
For multibody parts, this is the sum of the bounding box

Length length for all bodies in the part.
For assemblies, this is the sum of the bounding box length
for all parts in the assembly.
Sheet Metal Specifies the shortest side of the bounding box.
Bounding Box For multibody parts, this is the sum of the bounding box
Width width for all bodies in the part.
For assemblies, this is the sum of the bounding box width
for all parts in the assembly.
Sheet Metal Sheet Metal Bounding Box Length x Sheet Metal
Bounding Box Bounding Box Width
Area

For multibody parts, this is the sum of the bounding box
area for all bodies in the part.

For assemblies, this is the sum of the bounding box area for
all parts in the assembly.

35



Sheet Metal

Sheet Metal Specifies the area of the flat pattern excluding through
Bounding Box cut-outs.
Area Blank For multibody parts, this is the sum of the bounding box

area blank for all bodies in the part.

For assemblies, this is the sum of the bounding box area
blank for all parts in the assembly.

G Entities to Specifies the individual body or bodies to which the sensor
Monitor applies.

Symmetrical Thickness

When you create a sheet metal part as a base flange or lofted bend (with the Bent
Manufacturing Method), you can specify a symmetrical thickness that adds an equal
amount of material to both sides of the sketch.

Symmetrical thickness helps you create sheet metal parts from sketches to help achieve
equal bend radii for upward and downward bends. In the image above, Symmetric is
cleared for the example on the left and selected for the example on the right.

In the Base Flange or Lofted Bends PropertyManager, under Sheet Metal Parameters,
select Symmetric.
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Structure System and Weldments

This chapter includes the following topics:

e Corner Treatment to Similar Corners in Structure Systems

e Pattern Connection Element PropertyManager

e Configuration-Specific Size of Weldment Members

e Structure Systems and Weldments Performance Improvement

t Maal and Sir.

. SOLIDWORKS 2023 Video: What's New in SOLIDWORKS 2023 - Structure
Systems

Corner Treatment to Similar Corners in Structure Systems

= Corner Management & @
v X

Simple | Two member | Complex|

Corners ~

Corner Groupa

Similar Corners ~

Group Similar Carners

ﬁ:ﬁ':- Corner2 A
Carner i
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Structure System and Weldments

You can use Group Similar Corners to group similar corners, apply a corner treatment
to the group, and edit the groups as required.

This is helpful for large structure system files that have multiple corners.

1.
2.

3.
4.

5.

Open the structure system file.

In the FeatureManager® design tree, click Corner Management and select Edit
Feature.

In the Corner Management PropertyManager, under Corners, select a corner.
Click Group Similar Corners.

The similar corners are grouped together, appear as Corner Group xx under
Corners in the PropertyManager, and highlighted with arrows in the graphics area.

Apply corner treatment to the group.

The FeatureManager design tree groups the similar corners as Corner Group XX. In the
Corner Management PropertyManager, you can edit a group of similar corners and remove
a corner from the group. You can add this corner back to the group of similar corners, if
required.

Right-click a corner of the group and select one of the following:

Remove from Corner group Removes the selected corner from the
group of similar corners

Right-click the removed corner and
select Include back to Corner group.

Zoom to Selection Zooms in the selected corner

Clear Selections Degroups the corners

To degroup the corners, you can also
right-click the group and select Dissolve
Corner group.

Customize Menu Lets you select the context menu

You can use similar corner treatment for simple, two member, and complex corners.
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Structure System and Weldments

Pattern Connection Element PropertyManager

Pattern Connection Element @

v X
Message W
Selected Connection Element ~

Connection Element Gusset Plate2

Identify Similar Corners ~

D!gnure corners that have connection

elements

Corner2s ~

Camer3é !
Instances To Skip ~

In the Pattern Connection Element PropertyManager, you can insert a connection element

that is at a corner to similar corners.

To access this PropertyManager, click Insert > Structure System > Pattern

Connection.

Pattern Connection Element PropertyManager

Select the connection element in the graphics area. Similar corners are highlighted with
arrows and previews of connection elements appear at the corners.

Selected Connection Element

Displays the name of the selected
connection element.

Identify Similar Corners

Lists similar corners on which you can insert
the connection element.

You can right-click a corner and select Skip
Instance to exclude a connection element.

Ignore corners that have connection
elements

Excludes corners with connection elements.

Instances to Skip

Lists the corners that you excluded using
Skip Instance.
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Structure System and Weldments

Configuration-Specific Size of Weldment Members

¥ [@] Structure System'
~ [F) Corner Management1

Profile Alignment:

E 0.00deq

< Simple Corner Group1
’ Corner Group6

HorizontalAxis

~ [E) Two member Corner Group Configurations
4 Corner Group7 () This configuration
- Comple @ 1@ (® 2l configurations
F Cor () specify configurations
= cor s
Default<As Machined=

&
F Corl“njzoo..n to Selection .‘ Default<As Welded »
= cor A = -

test1«As Welded =

If you select a set of weldment members of the same size and type, in the Profile tab,
you can change the size of the members for specific configurations.

Using Zoom to Selection for Corners

If the structural member has multiple corners, you can zoom to a corner from the
FeatureManager design tree or the Corner Management PropertyManager using Zoom
to Selection.

Configuring the Size for Configurations in Structure Systems

To configure the size for configurations of structure systems:

1.
2.
3.

4.
5.

Edit the structure system from the FeatureManager design tree.
Select the members in the graphics area.

Optional: To edit a specific member, in the graphics area, right-click the member,
and select Edit Feature.

In Profile tab, change the size.
Under Configurations, select specific configuration and click OK.

Structure Systems and Weldments Performance Improvement

Performance is improved when you create or edit a corner management feature.

A corner gets trimmed when you select it from the Corners group in the Corner
Management PropertyManager or in the graphics area.

Previously, corners were trimmed when you created or edited the corner management
feature.
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Assemblies

This chapter includes the following topics:

e Automatically Optimize Resolved Mode

e Repairing a Missing Mate Reference

e Delete Missing Components from a Model (2023 SP1)

e Additional End Conditions for Cut Features

e Previewing a Replacement Component

e Specifying a Color for an Explode Line

e Selecting a Configuration for Skipped Instances

e Specifying a Default BOM Part Number

e Magnetic Mates

e Overriding Calculated Values in a Design Table

e Assembly Visualization

e Configuration Publisher: Updating a Multiple-Configuration Model
e Propagating Assembly Features to Parts Blocked for Toolbox Parts
e Assembly Performance Improvements
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Assemblies

3 Assembiag

SOLIDWORKS 20_'L2_3

Video: What's New in SOLIDWORKS 2023 - Assemblies

Automatically Optimize Resolved Mode

Assembly loading

@Automaticall}' optimize resolved mode, hide lightweight mode

O Manually manage resolved and lightweight modes

Load component lightweight
Always resolve subassemblies

Don't Check
Prompt

Prompt

You can optimize resolved mode automatically. Using this system option improves
performance by selectively using lightweight technology when you load components in
resolved mode.

Not available when your environment includes SOLIDWORKS PDM.

Options for lightweight and resolved modes are hidden as the components load as resolved.
Lightweight states do not appear in the FeatureManager® design tree.

You can manually manage when to resolve lightweight components by selecting Manually
manage resolved and lightweight modes.

Automatically load components lightweight is renamed to Load component
lightweight.

To automatically optimize resolved mode:

1. Click Tools > Options > System Options > Performance.

2. Under Assembly loading, select Automatically optimize resolved mode, hide
lightweight mode.
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Assemblies

Repairing a Missing Mate Reference

/\ OIMCICETILS TTTASE TSR =< 1 25 TTICITET TEET < S >0
@ Conce @ 1% mlg i
/ﬂ Coinci -
@ Conce a@
A, CoincidentTU (base plate<1>.rubber feet<4s)
@ Conce &3 Concentricio @
A, Coinci N
One of the entities or referenced features of

@ Concer this mate is suppressed, invalid, or no longer
/ﬂ Coinciq present.

QCO PPNt S I = | S =L | [ =TT b mie ‘J_
/\'. Coinci Feature (Concentric10) 1

You can repair missing mate references for references to faces, edges, planes, axes, and
points.

SOLIDWORKS® repairs the missing reference for a component by selecting a reference
on the component that is in the same location and orientation to the missing reference.
For models that contain multiple missing mate references, right-click the Mates (] folder
and click Auto Repair "

To repair a missing mate reference:

1. Open a model that contains a mate error.

2. Right-click the mate and in the context toolbar for the mate, click Auto Repair B

If SOLIDWORKS cannot repair the error, you are prompted to solve the mate
manually.
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Assemblies

Delete Missing Components from a Model (2023 SP1)

Find References

MName |In Felder

= €@ plungersldasm EAProjects
{L}J base_plunger.sidprt E\Projects
{L}J plunger.sldprt [Mot Found] [Fi e not found
'Qb link_plunger.sldprt [Not Found] |File not found
L’S’J arm left.sldprt [Not Found] ' e not found
&, arm right.SLDPRT [Not Found] |File not found
{L}_J short bolt_plunger.sidprt EA\Projects
& long bolt_plungersldprt 'E:\.Projects
L nut nlunaer <ldnet |FAPrnierts

<

Delete Missing References Print...

You can delete all missing components from a model in the Find References dialog box.

In the dialog box, Delete Missing References displays when the model has missing
components.

Delete Missing References does not delete missing external references like derived
parts, mirror parts, or split parts.

To delete missing components:

1. Open a model that has missing components.
2. Click File > Find References.

In the dialog box, under In Folder, File not found appears for the missing
components.

3. Click Delete Missing References.

The Confirm Delete dialog box opens.

If you previously selected Don't show again in the Confirm Delete dialog box, the
dialog box does not open, and the missing components are deleted when you click
Delete Missing References.

To show the dialog box, click Tools > Options and under
Messages/Errors/Warnings, click Dismissed messages. Clear Do you really
want to delete the following item(s)?.

4. Inthe Confirm Delete dialog box, click Yes to All to delete all the missing components.

44



Assemblies

Additional End Conditions for Cut Features

Cut-Extrude

v o X
Direction 1
2| Blind ~
A Through all
Through all - Bath
Up To Mext

(,? Up To Vertex

Up To Surface
Offset From Surface
Up To Body

i}] hid Plane

More end conditions are available for cut features in assemblies.
You can select these options for Direction 1 and Direction 2:

e Up To Next

e Up To Vertex

e Up To Surface

e Offset From Surface
e Up To Body

To select an end condition for a cut feature:

1. Open a model and create a sketch.
2. Click Insert > Assembly Feature > Cut > Extrude.
3. In Direction 1, select an end condition.
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Previewing a Replacement Component

a@ Replace
v X

Eﬁ Replace
v X

Instances to replace:
{® only selected

OAII in same parent
assembly

Oal

Thumbnail Preview Ll

With this one:

You can preview a replacement component in the Replace PropertyManager. You can
specify the scope of the replacement.

In the PropertyManager, Instances to replace replaces All instances. To specify the
scope of the replacement, select an option for Instances to replace:

Only selected

Replaces only the selected instance.

All in same parent assembly

Replaces all instances of the selected component that
are in the same assembly level.

If a selected component is in the top-level assembly,
only instances in the top level are replaced. If a selected
component is in a subassembly, only instances in the
subassembly are replaced.

All

All instances of the component are replaced in the
assembly and all subassemblies.

To preview a replacement component:

1. Open a model and click File > Replace.

In Replace these component(s) ':1’5, select a component.

2
3. For Instances to replace, select an option.
4

B

In the PropertyManager, select a component for With this one %™,

The selected component appears under Thumbnail Preview.
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Specifying a Color for an Explode Line

@T ExplView

@ () ADFxolade1 |
|ﬂ g Feature (3DExplode1)

e @ EditSketch
e X Delete...

H [ # Sketch Color
B ¥

[ M My

Color scheme settings

[]
>

Sketch, Inactive

sketch Shaded Contours
Sketch, Exploded

Grid Lines, Minor

Grid Lines, Major

You can use a system option to specify an explode color. You can change the color of
explode lines in an exploded view.

To specify a color for an explode line:

1. Click Options > System Options > Colors.
2. Under Color scheme settings, select Sketch, Exploded.

To change the sketch color in an exploded view:

Open a model that has an exploded view.

2. In the ConfigurationManager 2 tab, click " to expand Exploded View %T.
3. Right-click 3DExplode @" and click Sketch Color &,
4. In the Sketch/Curve Color PropertyManager, select a color.
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Selecting a Configuration for Skipped Instances

EE Linear Pattern

v X

Instances to Override ~

Skipped instances
&
(1, 3]

ﬁﬁ This Configuration

BB | All Configurations
B | Specify Configurations...

TS

You can select This Configuration [ILa, All Configurations [ , or Specify
Configurations 8 for skipped instances in assembly component patterns.
The configuration option is available for these assembly component patterns:

e Linear Component Pattern

e Circular Component Pattern

e Pattern Driven Component Pattern
e Sketch Driven Component Pattern
e Curve Driven Component Pattern

In a design table, you can use Sskipl<type of pattern><number> to specify skipped
instances. For example, $skipQLpatternl. If there is more than one skipped instance,
use a semicolon to separate values. For example: 10,1;10,2;.

To select a configuration for skipped instances:

1. Open a model with multiple configurations and edit a pattern feature.
2. In the PropertyManager, select an instance to skip and select This Configuration

[Iﬁ, All Configurations I8 , or Specify Configurations g

48



Assemblies

Specifying a Default BOM Part Number

Document Properties

DAdd Rebuild on Save mark to new configurations

[ Jadd Display Data Mark to new configurations

Default Bill &f Materials part number for new configurations

)
(@ Document Mame

() configuration Name

In a model, you can select Document Name or Configuration Name as the default Bill
of Materials (BOM) part number for new configurations.

This option does not apply to derived configurations.

The selected default value shows in the Configuration Properties PropertyManager under
Bill of Materials Options for Part number displayed when used in a bill of
materials.

To specify a default BOM part number:

1. Open a model and click Tools > Options > Document Properties.
2. Click Configurations.

3. Under Default Bill of Materials part number for new configurations, select
Document Name or Configuration Name.
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Magnetic Mates

+ [ Mates
@ Magneti| | 1®
& Magneti
& Magneti P
(& Magneticd [
i manneti Feature (Magneticd)

- 'n‘-‘ﬁ‘ Published References
ii_l} Ground Pla
[2] Connectar1

(2] Connector?

Connector]

lﬂl

E} Invert Selection

You can suppress magnetic mates and connection points.

When you suppress a component, magnetic mates associated with the component are
suppressed. Suppressed connection points are not available when you create a magnetic
mate.

When you have unused connection points and move a component chain, magnetic mates
are no longer created between components within the chain. When you move a component,
the color for all connection points is magenta.

To suppress a magnetic mate:

1. Open a model that contains magnetic mates.

2. In the FeatureManager design tree, expand the Mates 00 folder,
3. Right-click Magnetic Mate & and click Suppress 1B,

To suppress a connection point:

1. Open a model that contains magnetic mates.
2. Inthe FeatureManager design tree, expand a component and then expand Published

References Fﬁ’

3. Right-click Connector (5] and click Suppress 18,
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Overriding Calculated Values in a Design Table

A Design Table column conflicts with a model mass property

You have specified a value for $sw-mass in the Design Table. Select an option to proceed.

—> Use the mass value specified in the Design Table
Enables the override mass option in the Override Mass Properties dialog box. Uses
the values in the $sw-mass property from the Design Table.

—> Use the mass value calculated from the model geometry
Removes the values from the $sw-mass property in the Design Table. Calculates the
mass from the model geometry.

When you close a design table that contains manually entered values for $SWw-MASS and
$SW-C0G, SOLIDWORKS prompts you to use either the manually entered values or the
values calculated from the model geometry.

The prompt provides these options:

Use the mass value Enables Override mass or Override center of mass

specified in the Design Table and assigns the manually entered values to the mass
properties.

Use the mass value Deletes the $sW-MASS column or the $SW-COG column

calculated from the model that has the manually entered values. The model uses

geometry values calculated from the model geometry.

To override calculated values in a design table:

1. Open a model that has a design table with a $SW-MASS column or a $SW-COG column.
2. Clear the override properties:

a. Click Tools > Evaluate > Mass Properties.
b. Click Override Mass Properties.

51



Assemblies

# Mass Properties -

{Elﬂ rubber feet, SLOPRT

Override Mass Properties... Recalculate

c. In the Override Mass Properties dialog box:

e For $SW-MASS, clear Override mass.
e For $swW-Co0G, clear Override center of mass.

# Cverride Mass Properties

Properties for: rubber feet.SLDPRT

[ ]override mass: 0.51grams

|:| Override center of mass:

If these override options are enabled, the prompt does not show and the model is
saved with the manually entered values.

3. In the ConfigurationManager 2 tab, expand Tables =.
4. Right-click Excel Design Table % and click Edit Table.

G B R 4 S FERF

Configurations

- f.% rubber feet Configuration(s)
~ [@) Tables

% Excel Des— Tore-

[F@  Default [ @ Edit Feature
Edit Table

Edit Table in New Window

5. In the table, manually enter values for $SW-MASS or $SW-COG.

Close the design table.
7. When prompted, select Use the mass value specified in the Design Table to
override the calculated values with the manually entered values.

o
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Assembly Visualization

File Name ‘Quan...| Mass 4
@ [Base plate ¢ 83.39
{% drive sh.. 1 013
(B —dlrive-sh 1 1.96

s ' 1

In lightweight mode, SOLIDWORKS calculates more Assembly Visualization columns
without setting the lightweight components to resolved.

If SOLIDWORKS cannot calculate a column value for a component and you select Manually
manage resolved and lightweight modes and Prompt for Resolve lightweight
components, SOLIDWORKS prompts you to resolve the component.

To modify these options, click Options > System Options > Performance.

Assembly loading
OAutomaticall}f optimize resolved mode, hide lightweight mode

@Manuall}f manage resolved and lightweight modes

[ ]Load component lightweight
DAlwa}fs resolve subassemblies

Check out-of-date lightweight components: Don't Check b

Resolve lightweight components: Prompt ~

In the Custom Column dialog box, the columns display in alphabetical order. The Assembly
Visualization rollback bar increases in size when hovering over the bar. The font color is
black for all column values. You can add more than seven columns.

To view the Assembly Visualization improvements:

1. Open a model in lightweight mode.
2. Click Tools > Evaluate > Assembly Visualization.

All column values display in a black font color and the rollback bar is wider when you
hover over the bar. For calculated properties like Mass, the calculated values display
instead of 0.00.
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3. To open the Custom Column dialog box, in the Assembly Visualization panel, click
the arrow + to the right of the column headers and click More.

4. In the dialog box, click Properties.

The columns display in alphabetical order.

Configuration Publisher: Updating a Multiple-Configuration Model

Configuration(s) (200mm)

ropertyManauer|

"ables Edit Feature
50mm Update
100mn 75 Delete
150mr Go To...

[F‘fﬂ " 200mn Rename tree item
Collapse Items

Customize Menu

For models that have multiple configurations created with a custom PropertyManager,

the PropertyManager icon changes to Es after you manually add, delete, or rename a
configuration. Update appears when you right-click PropertyManager.

To update a multiple-configuration model:

1. Open a model with multiple configurations created with a custom PropertyManager.

Use Configuration Publisher to create a custom PropertyManager.

2. In the ConfigurationManager 2 tab, add a configuration.

The PropertyManager icon changes to E‘
3. Right-click PropertyManager s and click Update.

After clicking Update, the Excel design table % opens, updates, and closes. The
PropertyManager icon changes to .
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Propagating Assembly Features to Parts Blocked for Toolbox Parts

Feature Scope ~ Feature Scope ~
() &ll components () all components
(@) Selected components (@) selected components
Propagate feature to —— “ropagate feature to
W
D pDarts parts
[ ]auto-select [ ]auto-select

>

@ &
<

Toolbox components were removed from the selection
because the Propagate feature to parts option is
enabled

Assembly features cannot be propagated to Toolbox parts.
In an assembly feature PropertyManager, SOLIDWORKS displays a warning and removes

any Toolbox parts from Components to Affect G when you have Selected components
and Propagate features to parts selected.

When you select All components and Propagate features to parts under Feature
Scope and the model contains Toolbox parts, the warning does not appear. The assembly
features are not propagated to the Toolbox parts.

When Propagate features to parts is selected, you cannot select a Toolbox part.

For assembly features like fillets and chamfers that do not have the All components
and Selected components options, the warning does not appear and the assembly
features are not propagated to Toolbox parts. You cannot select a Toolbox part for a Hole
Series as this assembly feature is always propagated to parts.

To view the warning:

Open a model that contains a Toolbox part.
Select a sketch and click Insert > Assembly Feature > Cut > Extrude.
In the PropertyManager, under Feature Scope, clear Auto-select.

For Components to Affect %, select a Toolbox part.
Select Propagate features to parts.

A Wi

SOLIDWORKS removes the Toolbox part from Components to Affect G and the
warning appears in the graphics area.
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Assembly Performance Improvements

Assembly performance is improved when:
e Searching with Include sub-folders selected.

To select this option, click Tools > Options > External References > Reference
Documents specified in File Locations > Include sub-folders.

e For assemblies that contain parts with multiple imported bodies and body level
appearances:

e Opening a file

e Changing a configuration

e Applying, modifying, or removing an appearance
e Rolling back or rolling forward assembly items

e Saving assemblies is faster as only changed model data is saved. This improvement
is noticeable in very large assemblies. Previously, SOLIDWORKS saved all model data
when an assembly or a component changed.

56



Detailing and Drawings

This chapter includes the following topics:

e Overrides for Bills of Materials

e Displaying Transparent Models

¢ Filtering Bill of Materials Columns
e Component Name Display

e Detached Drawings
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po: What's New in SOLIDWORKS 2023 - Drawings

=

EEE At ﬁ' E " 2y if!.:'l_‘un j( > il).[!d-ln : : El ﬁ L

0 ITEM NO. PART NUMBER QTY.
] emitter |
2 grip ]
3 grip-focuser-lens- |
spinring
4 grip-focuser-lens-lens ]
5 grip-fgcuser-lens- ]
innerring
\t/)\llhen you override a value in a bill of materials (BOM) using Break Link, the value turns
Youue;:an:

Change the highlight color (default is blue) when you override values using Break
Link. Click Tools > Options > System Options > Colors, and specify the color for
Drawings, Modified Cells (BOM).

Restore overridden values to their original values. Right-click a row, column, or the
entire BOM and click Restore Original Value.

Prevent unwanted changes to BOMs. Click a table cell, row, or column, and click the

lock & in the context toolbar. To unlock, click the lock & in the context toolbar.
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Detailing and Drawings

Displaying Transparent Models

You can display transparent models in drawings with Hidden Lines Removed (HLR) Eﬁ

and Hidden Lines Visible (HLV) ia modes.

You can see through transparent bodies in HLR and HLV display states including
components in assemblies and bodies in multibody parts.

Available for High quality drawing views only.

To display transparent models:

1. Click Tools > Options > Document Properties > Detailing .
2. Select See through transparent components in HLR/HLV.
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Filtering Bill of Materials Columns

< A T : D [
<.ﬂ.
| ITEM N QTY.

Custom Filter...

? Search H Q

: (Select All) A “

4 Chassis ]
Computer Chassis

5 Fan '|
1 pcB

—_—

A Vintans Switrh
< >

O || WK

oK Cancel

Filtering a bill of materials (BOM) lets you focus on what you need to see.
When you filter a BOM:

¢ You can filter a range of data based on your criteria. When you hover over the BOM
column headers, there is an arrow in each column.

e Only the balloons for the filtered items appear in the view.
e To filter BOM columns:

1. Click " 'in the column to filter.
2. In the dialog box, select filter criteria.

The ~ changes to ~7 indicating that the filter applies to the column.
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Component Name Display

|

Madel View @
X =

Message A

Select a part or assembly from which to create the view, then click Next.

Part/Assembly to Insert -~

Open documents:

|-(; wormgear_assembly

When you specify display options for component names in a drawing, the names in the
PropertyManager and View Palette match those in the FeatureManager design tree.

To specify display options for component names:

1. In the FeatureManager design tree, right-click the drawing name and click Tree
Display > Component Name and Description.

2. (Optional.) Under Primary, specify an option:

e Component Name
e Component Description

Based on the selection under Primary display options:

e The Model View and Standard 3 View PropertyManagers update the Open documents
field.

e The View Palette updates. The View Palette displays the part or assembly icon and the
file name.

Detached Drawings

Detached drawings are no longer supported.

Detached drawings are no longer supported as of SOLIDWORKS 2023. Detailing mode is
available. Existing detached drawings continue to work as they do today. Once you save
a detached drawing back to a regular drawing, you cannot save it as a detached drawing
in SOLIDWORKS 2023.
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Import/Export

This chapter includes the following topics:

e Exporting Large Assemblies as STEP Files
e OBJ Mesh Import Improvements
e Installing the 3SDEXPERIENCE Exchange Add-In

Exporting Large Assemblies as STEP Files

Syestern Options - STEP

System Options

General
MEBD
Drawings
Display Shyle
Area Hatch/Fill
Performance
Colors
Sketch
Relations/Snaps
Display
Selection
Perfarmance
Assemblies
External References
Default Ternplates
File Locations
FeatureManager
Spin Box Increments
Wiew

| File Format:

STEP i

Cutput as
(@) solid/Surface geometry
() wireframe

Export sketch entities

g1 gl [ e L [aly data
EAexport facesedge properties
[ Export appearances
[CJExport 30 Curve features
@ Split periodic faces

[CJExport azsembly components as separate STEP files
[recommended for large assemblies)

You can export large SOLIDWORKS® assemblies as STEP files.

In Tools > Options > System Options > Export > STEP, select Export assembly
components as separate STEP files (recommended for large assemblies). This
option exports assemblies as atomic STEP files. Separate STEP files get created for each

component in the assembly.

OBJ Mesh Import Improvements

Textured .0BJ import by ScanTo3D is improved.

.OBJ import to graphics body supports textures, excluding bump maps.
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Installing the 3DEXPERIENCE Exchange Add-In

;;’S SOLIDWORKS

Product Selection
Select products to install,
SOLIDWORKS Premium Select different packages gr products
o FLILTE VTR IH)PE\UVII LT
¥ SOLIDWORKS Visualize S
[+] SOLIDWORKS Visualize Boost (582 Mz
[+ SOLIDWORKS CAM 2353
[ SOLIDWORKS PCE Viewer 1552
¥ ] SOLIDWORKS Manage Client (542 v
¥ [ SOLIDAWORKS PO Clisnt (500 s
E IDEXPERIENCE Marketplace iz ma
| 3DEXPERIENCE Exchange for SOLIDWORKS |
¥ [ AP Tooks
[+/] SOLIDWORKS Simulation
[+] SOLIDWORKS Metion

W
R . ill be i 33 MEBE CI F . Studi

The 3DEXPERIENCE Exchange add-in installs by default with your installation.

The 3DEXPERIENCE Exchange add-in lets SOLIDWORKS users safely work with a package
of content from a 3DEXPERIENCE source, such as SOLIDWORKS Connected or the Design
with SOLIDWORKS app. SOLIDWORKS users can seamlessly open the package, modify
files, and return the 3DEXPERIENCE content package to the 3DEXPERIENCE source.

To enable the add-in, in SOLIDWORKS, click Tools > Add-ins and under Other Add-ins,

select 3BDEXPERIENCE Exchange. The 3DEXPERIENCE Exchange & appears in the Task
Pane.

See SOLIDWORKS Help: Import and Export > 3DEXPERIENCE Exchange.
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This chapter includes the following topics:

e Managing Deleted Users

e Configuring Transition Actions

e Adding Tooltips to the Data Card Controls

e Automatic login to the Administration Tool

e Data Card Controls

e Performance Improvements for File Version Upgrade Tool
e Logging File Retrieval Operations

e Support for Microsoft Edge WebView2-Based Controls

¢ Removing Computers from the Task Execution List

e Display Groups for Inherited Permissions

¢ Notification Templates

e Synchronizing Users with Windows Active Directory (2023 SP1)
e Days in State Variable (2023 SP1)

e SOLIDWORKS PDM Performance Improvements

e Other SOLIDWORKS PDM Enhancements

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small humber of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased license.
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Z5 SOLIDWORKS 2023 FOM

SOLIDWORKS 2023 Video: What's New in SOLIDWORKS 2023 - SOLIDWORKS
PDM
Managing Deleted Users
B Doc_2023a1_B220 - Deleted Users
w
Marne Full Marne Initials (] Restore login | Warning
8 Carla Carla Coe CC 7 |:| ‘ ‘
8 John John Doe 1o g E
B Mary Maty Major MM ] |:| Fm
& Richard  Richard Mies  RM i | M Open..
Mew User..,
[ Serial M Settings...
& SOLIDW Permission Assignments
Tasks Export
By, Ternplate History
v @ Usersan Yalidate | ngin
> g Grau Deleted users... }
v 3 Users
& Admin (Systern Adrminist ‘ ‘

You can use the Administration tool to restore deleted users and to refuse login to users.

You must have Can administrate users administrative permission.

To restore a deleted user, expand Users and Groups Management, right-click Users,
and select Deleted users. In the Deleted Users dialog box, select the user in the Restore
login column.

To refuse login to a user, expand Users and Groups Management, right-click Users,
and select Open. In the Users dialog box, select a user in the Refuse login column.

Deleted Users Dialog Box

Use the Deleted Users dialog box to restore the login for deleted users.
To display this dialog box:

Expand Users and Groups Management, right-click Users, and select Deleted users.

Name Name the user enters in the login dialog box.
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SOLIDWORKS PDM

Full Name The user's full name.
The default is the user's login name.

Initials The user's initials.
The default is the first letter of the user's login name.

ID ID that is unique for each user.
Restore login When selected, restores the login of the selected user.
Warning Displays a warning message if the login name you are

attempting to restore is already active.

To save changes, click Save or close the dialog box and click Yes when prompted to save
changes.

Configuring Transition Actions

| User Data
Date User Datal
Dest. State User Dataz
Filename Work Phone
Filename without extension Home Phon
Folderpath Mobile Phor
Mext Revision Company
Mext Version Department
Revision lob Title
Source State Office
Tirme Address
Transition Comment Zip Code
Wersion City
Version Comment State
Country
Variable »

The variable list in the Transition Action dialog box includes the user properties fields that
were introduced in SOLIDWORKS PDM 2022.

These fields are:

e First name

e Last name

¢ Middle name
¢ Prefix

o Suffix

e E-mail

e E-mail2
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e E-mail3

e User Data
e User Data2
e User Data3
e Work phone
e Home phone
e Cellphone

e Company

e Department
e Job title

e Office

e Address

e Zipcode

e City

e State

e Country

These are available under the User list and administrators can use these fields in the
following transition actions:

Import data from XML
Inc. Revision

Send Mail

Set Variable

Adding Tooltips to the Data Card Controls

Edit-box properties
Yalue

Wanable name:

) BOM Cluantity V|

Variables. .. |

Toaltip
Title

Biody

W alidation

[Decimal value range]

In the Card Editor, you can add tooltips to the data card controls.
In the Tooltip pane, enter the Title and Body of the tooltip.
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You cannot specify tooltips for tab and frame controls.

In SOLIDWORKS PDM File Explorer, when you hover over the corresponding data card
control, the tooltip displays.

Automatic login to the Administration Tool

Adrminiztration Login
Wault

Daoc ault w
Uge automatic login for thiz vault

(®) Login as the following user,

|dzername: | |

Pazzword: | |

() Login as the currently logged in user in \Windows,

Cancel Help

You can configure SOLIDWORKS PDM to log you in to the Administration tool using a
specific name or the name of the current Microsoft® Windows® profile.

In the Administration tool, under Local Settings, double-click Settings or right-click
Settings and click Open.

In the dialog box, under Administration Login, select a Vault and Use automatic
login for this vault. You can specify:

¢ Login as the following user. Logs you in using the specified user name and password.

e Log in as the currently logged in user in Windows. Logs you in using the user
name and password of the current Microsoft Windows profile. (Available only for vaults
that are configured to use a Microsoft Windows login.)
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Data Card Controls

- Mendar: ﬁ‘-ﬁendur | “Cog|, Flags

[ Read-only

[+] Show in E=plarer
] Show in web card
] tultline
[JUpdates all configurations

#| Control Logic

| Control Logic

You can apply control logic in data cards more easily.
In addition to the Control menu, you can also access the Control Logic command when
you:

e Click I* in the Controls toolbar.
e Click Control Logic in the properties pane.

Not available for card search control and variable search control.

In the Controls toolbar, if you select Show Controls with Control Logic, an indicator
appears in the top-left corner of the controls that have control logic applied.

You can also configure the Find User command type for a button control to return more
user properties. Previously, only Login name was available as the user value to populate
the Destination variable for the Find User list.

Command type:
Find User ~

Dialog bow caption:

Destination wariable:

SendeMame w
Uszer Walue:
Full narne W

] Pemit multiple selection
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Performance Improvements for File Version Upgrade Tool

You can upgrade SOLIDWORKS files in a SOLIDWORKS PDM vault faster.

If you are upgrading assembly files and you select Overwrite and Latest Version in
the Version Settings page, the software skips upgrading and uploading references that
are not the latest in the assembly's as-built version. This improves the performance of
the upgrade process.

Logging File Retrieval Operations

@ lzl Search bext:

Tvpe Date Description Destination Machine | Destination IP Address Lser
oInFDrmatiDn 2022-03-04 10:30:10  Get via PDM Client - 4 A8, b Adm
oInFDrmation 2022-03-04 10:37:30  Get wia PDM Client = - i 45t ant 45 Adri
oInFDrmatiDn 2022-03-04 11:00:17  Get via PDM Client - 4 A8, b Adm
oInFDrmation 2022-03-04 11:24:12  Get wia PDM Client - - i 45 anh 45 Adri
oInFDrmatiDn 2022-03-04 11:25:27  Get via PDM Client - I AR, o Admi
oInFDrmation 2022-03-04 11:26:55  Get wia PDM Client - - i 45 anh 45 Adri
o Information  2022-03-04 11:29:36  Get via COM API i S| Admi

You can maintain a server-side log of files retrieved for a vault. (SOLIDWORKS PDM
Professional only.)

To enable logging, in the Administration tool, right-click a vault and select Properties.
In the File Vault Properties dialog box, under Logging operations, select Get. This
enables logging of the Get operation for the vault on all archive servers.

You must have File vault management administrative permission.

To view the file retrieval log, in the Administration tool, right-click a vault, and select
Show the Get Log. The Log File dialog box displays log information for each file in the
vault that is downloaded from the archive server to the local view of a client machine,
Web2 server, or Web API server.

Log File - Get Operations Dialog Box

The Get Operations dialog box lets you view informational and error events for the files
retrieved for a vault on all archive servers.
To display the log file:

In the Administration tool, right-click a vault, and select Show the Get Log.
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Type Event type: error, informational, or warning.
Date Date and time of the event.
Description Method used to invoke the Get operation:

e Desktop client

e COM API

e Web API

e Web?2 server

Destination Machine Name of the destination machine that receives data from the
archive server.

Client IP Address IP address of the client machine

For file retrieval operations through Web2 or Web API
servers, the IP address of the server machine is logged.

User Login name of the user who performed the Get operation.
Document ID ID of the document

Document Name Name of the document

Version Version of the document

Document Path Path of the document in the vault

Archive Server Name of the archive server on which the event occurred.

Support for Microsoft Edge WebView2-Based Controls

In SOLIDWORKS PDM, the Internet Explorer-based controls are replaced with
WebView2-based controls.

This applies for:

e Preview pane in SOLIDWORKS PDM File Explorer. You can preview the HTML documents
that are present in the vault.

e EXALEAD OnePart Search view
e Web Card Configuration Editor dialog box

You must have the WebView?2 runtime installed on your machine.
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Removing Computers from the Task Execution List

[# New Task - Properties

A task can be executed on one or more machines. Only computers marked with
the list below will be considered.

() Let the system choose the computers to execute the task
() Prompt the user to choose a computer when the task is initiated
() Execute on the computer where the task is initiated

Computers supporting the task: I: Ref

[JHOST 1
[JHOsT 2

O
Remove from SWiaskAddin
Remove from All Add-ins

You can remove computers from the list of hosts that support task execution.

In the Administration tool, open the task's Properties dialog box. In the left pane, click
Execution Method. In the Computers supporting the task list, right-click a computer,
and select one of the following:

e Remove from Add-in Name. This removes the computer as a supported host for all
tasks that use the same add-in.

e Remove from All Add-ins. This removes the computer as a supported host for all
task add-ins.

A confirmation message lists all the affected tasks.
The Task History dialog box displays a list of computers that are removed for that task.
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Display Groups for Inherited Permissions

1e - Properties ?

Administrative permissions:

|:| Can accept basks to execute on a host
|:| Can administrate add-ins

|:| Can administrate templates

E Can administrate E’
|:| Can delete labels + X
|:| Can purge histor
|:| Can set labels
[L]can undo check o Purchase Management
|:| Can update cold 5 Quality Assurance

|:| Can update colury
|:| Can update docur
|:| Can update ERP I
D Can update hiskol
E Can update index
|:| Can update item g
|:| Can update licens
|:| Can update lists

Can administrate users

In the Administration tool, in the user Properties pages, you can hover over the group
icon of a permission to view the groups from which the permission is granted to the user.

A pop-up dialog box appears that lists these groups.

Notification Templates

Custornize Motification *

Marne: | Document added

Template:

() Defaulk

Subject: | Document *¥afilename?s’ has been added |

Biody:

:
<hkml=

wsbyla=

a{color: #349aff;

hr.linel {height:1px;border-width:0;background-color ; #DEDEDE-
b1 {kext-align: left;

font: normal normal normal 16p:xf1S8px Arial;

letter-spacing: Op:;

rolars #7CFCF
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SOLIDWORKS PDM lets administrators customize the templates for automatic notifications
for a vault. This helps to display information that is more relevant to the user.

e You must have Can update mail configuration administrative permission.

e You can customize notifications only for files and not for items and Bills of Material
(BOMs).

You can customize notification templates for the following file operations:

e Added

e Changed State
e Checked In

¢ Checked Out

e Delayed in State

Lists
) Message Systern

v L) Motification Templates
v [A File Notifications
g Added
Fm Changed State
& Checked In
@ Checked Qut
@, Delayed In State
T Replication
[#] Revisions

You can edit the subject and body of the template in HTML format and also use variables
in the notification message.

You can also export notification templates. To export:

e All notification templates. Right-click the Notification Templates node and select
Export.

o File notification templates. Expand Notification Templates, right-click File
Notifications, and select Export.

e The notification template for a file operation. Expand Notification Templates > File
Notifications, right-click a file operation, and select Export.

Customize Notification Dialog Box

This dialog box lets you customize the templates for automatic notifications for a vault.
To access this dialog box, do one of the following:

e Expand Notification Templates > File Notifications, right-click a subnode, and
select Open.

e Expand Notification Templates > File Notifications, and double-click a subnode.
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Name Displays the name of the notification template. This field is
read-only.

Preview Displays how the template appears to users.

Template Lets you select either of the notification templates:
e Default
e Custom
If you select Custom, the fields listed below in the table are
enabled. This lets you customize the notification template.

Subject Displays the notification subject. You can edit the notification
subject for custom notifications. To include variables, click
and select a variable.

Body Displays the notification body. You can edit the notification

body for custom notifications. To include variables, click
and select a variable.

Load from File

Imports HTML text into the body of the notification.

Reset

Resets the notification template to the default template.

Synchronizing Users with Windows Active Directory (2023 SP1)

Active Directory Sync Settings X

Groups

|:| Remove groups
|Update groups:
[ add users

Add users not Found on the archive server
Copy permissions and setkings For new users From;

Miane

[ |remave users From group
[ JUpdate users

Users
[ ]add users

Copy permissions and settings From:

R
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You can synchronize users and groups in a vault with Windows® Active Directory as an
on-demand operation.

You must have Can administrate users administrative permission.

You can define preferences for sync in the Active Directory Sync Settings dialog box. To
access this dialog box, right-click the Users and Groups Management node and select
Active Directory Sync > Settings.

To perform Active Directory sync, right-click the Users and Groups Management node
and select Active Directory Sync > Run Sync.

The Update from Active Directory command is now also available for Windows users
in a vault. Previously, it was available only for Windows groups in a vault.

Active Directory Sync Settings Dialog Box
Use the Active Directory Sync Settings dialog box to define preferences for on-demand
sync of users and groups in a vault with Windows Active Directory.
To access this dialog box:

Right-click the Users and Groups Management node and select Active Directory
Sync > Settings.

Groups

Remove Groups Removes Windows groups from SOLIDWORKS PDM vault that
no longer exist in Active Directory.

Update Groups

Add users Adds existing users or creates new users in the vault based on
the group membership in the Active Directory group.

Add users not found Creates new users in a vault even if
on the archive server they are not found on the archive
server.

Copy permissions For new users, copies permissions
and settings from and settings from the selected user.

Remove users from Removes Windows users from the SOLIDWORKS PDM group
group who are no longer members of the Active Directory group.

Update users Updates Windows user properties for existing members of a
Windows users group with the attributes of the user account
in Active Directory.
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Users
Add users Adds new Windows users that exist in users and groups defined
in the Windows login settings on the archive server but not in
the vault.
Copy permissions For new users, copies permissions
and settings from and settings from the selected user.
Remove users Removes Windows users from the vault if they no longer exist
in the Windows login settings on the archive server.
Delete Deletes the user from the
SOLIDWORKS PDM vault.
Refuse login Specifies the Refuse Login option
in the Administrative permissions
page of user properties.
Update users Updates user properties for existing Windows users with the

attributes of the user account in the Active Directory.

Days in State Variable (2023 SP1)
In the Customizable Columns dialog box, for a column, you can select Days in State as
Variable.

This system variable is available for the following column set types:

¢ File List
¢ Quick Search Result
e Search Result

SOLIDWORKS PDM Performance Improvements

SOLIDWORKS PDM 2023 makes significant performance improvements in the presence
of high latency to SOLIDWORKS PDM servers.

The improvements might vary depending on the amount of latency, size of datasets,
and operations.

e The following operations perform better when latency to the database server is high:
e Check-in
e Check-in with automatic transition
e Undo Check-out
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e Interactive operations such as menus, shortcut menus, reference dialog boxes,
SOLIDWORKS PDM File Explorer tabs

e The following operations perform better when latency to the archive server is high:

e Add files

e Change state on file modifications
o Get files

o Get latest version of files

Other SOLIDWORKS PDM Enhancements

SOLIDWORKS PDM 2023 offers enhanced data security, support for the latest Windows®
operating system, and other improvements.

e SOLIDWORKS PDM encrypts all the data traffic to and from the archive server.

e SOLIDWORKS PDM 2023 supports the Windows® 11 operating system.

e In SOLIDWORKS PDM File Explorer, you can copy static text from data cards.

e The language for the user interface of eDrawings® Web Viewer follows the language
specified in Web2.
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This chapter includes the following topics:

e Automatic Update of Mapped Linked Record Properties
e Using the New From Option

e Task Administration Access

e Linked Record BOM Compare Field Selection
e Support for Variable Driven BOM Quantities
e Timesheets to Approve Node

e Cancelled Task Line in Capacity Planning

e Capacity Planning User Efficiency

e Hide Labels

e Marking Tasks as Complete

e Task Snooze Reminder Time

e Tasks Board Time Display

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Automatic Update of Mapped Linked Record Properties

% Linked Record Options

Fields Mapping
Document fields on the LEFT - Record fields on the RIGHT

Document Object Calumn Record Object Column | Update method | Update Automatically | Info
Constructed by

ContextCategary

Copyright

Cost

CreationTime

Customer Name

Date

Derived From

Description Description Always i
Description

Description 2

Dest. doc. ID

You can update mapped properties automatically to connect primary references and the
linked record they are associated with.

The Linked Record updates when the Primary Reference changes and the record is
checked in. Previously, you must check out the linked record and click Get values from
Primary Reference. You can define each mapped field to update automatically.

Updating Mapped Fields Automatically

1. Inthe SOLIDWORKS Manage Administration Settings tool, edit the Primary Reference
object.

2. On the Linked Record Object wizard page (for PDM objects) or on the Linked Record
tab for document objects, click Configure.

3. On the Fields Mapping wizard page:

a) Select the check box in the Update Automatically column for the field to update
automatically.

b) In the right pane, for Linked Record with the status, select a status to update
when the primary reference is updated.
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Using the New From Option

Mame Visible On Grid | Unique Key | Reguired |Type C

4 I_'_‘| Properties
[ab] Part Mumber Fa I fes System (Mumbering Scheme) -
[ab| Description W fes System (Text) s
[ab] Current Stage Mame W System (Text) s
[ab]| Derived From | System (Text) s
@] Web Link System (Hyperlink) =
[ | Decision : List Text -

———— ‘-:ﬁr Edit

Mew From

Copy selected value

Refresh
Expand All
Collapse All
Delete

Export

1B x

Thamme Cialdd Cemon

New From lets you copy a field within an object to create new fields with the same
settings.

It saves the time required for administrators to configure objects.

New From is not available when you configure BOM fields or process item fields.

To use the New From option:

1. In the Administration tool, edit an object or right-click an object in the main user
interface.

2. Navigate to the Fields tab or wizard page.

Right-click a field and select New From.

4. Inthe New From dialog box, enter a display name for the new field and do one of the
following:

w

e Click Save to create the new field and close the dialog box.
e Save and create a new field based on the originally selected field.
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Task Administration Access

+ 4 JhiTE= G 0O lew [ OpenTask (@3 @ | EE Tasks Board g4 Chars [E

& o @ Add filter...
& N o Part Mumber | Subject
" Fli
B2 Oy B
#2 U 3 Refresh
Other

e Expand All

Collapse All

| Administration "l & User (Admin User)...
All Users...

Replace User...

-I:I- Tasks...

You can open the Task Administration dialog box using the Tasks option.

To open the dialog box, in the Administration tool, click All Tasks > Administration >
Tasks.

Linked Record BOM Compare Field Selection

Indude

|T| Hﬂ Export

[E (select Al
Description
[] Marker
PDM Qty
[ oty Manual
Quantity
Record Mumber -

4

CK Cancel
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When you compare a linked record BOM to the BOM of its primary references, you can
select fields to compare.

For example, when you assign a new part number to the linked records, the field is always
different from the primary reference part number. So you can exclude this field from
comparison because it always shows a difference.

Support for Variable Driven BOM Quantities

Edit Variable O

Variable name:
| | [ version free
Variahle . [ImMandatery values
Dedmal number ~ Only look for mandatory
values in @ tab for SLOC
files
[Junique values
Attributes:
Block Attribute Extensions
CustomProperty UNIT_OF_MEASLURE sldprt

SOLIDWORKS Manage reads the BOM quantity from a SOLIDWORKS PDM variable set
and uses it for the UNIT_OF_MEASURE attribute.

Previously, SOLIDWORKS Manage used the instance count for the UNIT_OF_MEASURE
attribute.
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Timesheets to Approve Node

Home <

&l &l

{f# My Dashboard
@ My Work
[## Tasks

My Timesheets ) New Properties | (3
|Item Mumber |WeekNumbE

B2 Other Users

1
2
3

ge g5 68

ﬁﬂl Favorite Reports

f% Timesheets

Timesheets to approve lets you see the timesheets that a user needs to work on, to
complete the timesheet approval process.

Cancelled Task Line in Capacity Planning

483 User Details
User: Admin User Year: w22 || &
Activity Jan Feb Mar Apr May Jun Jul Aug
z
3 @ Mon-Working Time 10 8 8 9 9 8 10 8
4 [ Tasks 7.2 0 0 0 0 0 a 0
[##] Assigned Tasks 22.2 0.2 0 0 0 0 0 0
[##] Completed 0 0.2 0 0 0 0 0 0
@ Cancelled 15 0 0 0 0 0 0 0
< Available capacity
|-|q Task Charts
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You can see the number of hours of cancelled tasks in the Cancelled row of the User
Details dialog box.

The Assigned Tasks row displays total assigned task hours including the cancelled task
hours. The Available capacity row displays assigned task hours minus cancelled task
hours.

Capacity Planning User Efficiency
When you view user details, the Efficiency (%) value that appears in the Capacity
Planning dialog box is applied to the user’s time.

Previously, the Efficiency in user details was 100% regardless of the setting in the
Capacity Planning dialog box.

Hide Labels
L 2
Find
YEpy O G SW-201781 GEAR HOUSING
o O & SW-201826 WASHER
)
€<
v
Properties E= BOM [km sinicanfinurations & Related Files D) Histary o, Wherellsed =i Audit Trail
A
B4 Show Tabs onthe Left GFie Bopehes Import Data
Hide Labels f
#* Mumber SwW-20
¥ Description SPINDL
Revision 2
e la Created By: Systen

Rl Checked Date
Rl CheckedBy

Hide Labels lets you hide captions. This creates more space in the software so you can
see the displayed tabs on the user interface.

To hide captions for the following items, right-click tabs, and select Hide Labels:

e Bottom tabs in the main user interface for all objects

e Property card tabs for processes

e Administration for document and record objects (not SOLIDWORKS PDM)
e Administration for relationships and resource objects

To hide labels for property cards for document and record objects, click
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Marking Tasks as Complete

(7)) Dashboards
5 Timesheets
‘% Tasks

If a task is assigned to multiple users, this field will be disabled for the spe

(®) Allow more time than alocated
: (") Do not allow more time than allocated

Create new tasks as “private” or “public”

|Nlow users to dedde (My Options) | - | This setting does not overwrite tash
Default time for new tasks (hours)

[ "] Email task owner when task is completed  This setting can be changed in individ.

[+] Enable "Mark as completed” for any assignee when multiple users are assigned:

In the System Administration dialog box, you can select a check box that enables Mark
as Completed for a task that is assigned to multiple users.

Previously, the assigned user must enter the required time in the progress area to mark
the task as complete.

Task Snooze Reminder Time

# SOLIDWORKS Manage Reminder x
4 TSKO00792 Create CAD Models in SOLIDWORKS
Due 8/9/2021 15:00
Subject Due In Type
TSK000792 Create CAD Models in SOLIDWORKS Overdue 179 Days Normal
Dismiss Al Open Dismiss
:30 Minutes |- Snooze
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The SOLIDWORKS Manage Reminder saves the last task snooze time.

If you want to keep the same reminder time, only click Snooze. Previously, the task
snooze time was 5 minutes by default so every time user must change the time.

Tasks Board Time Display

9 Tasks Board

3. Need input from others 4. Completed 5.¢

= 0.0/10 (Hours), Due -971 (Lrays)

[}
=

TSK000558 - Bill of Materials Creation

TSKOQ00388 - Assembly Instructions
Manual

= 8.0/8 (Hours), Due 1 (Days)

= 6.4/16 (Hours), Due -31 (Days)
TSK000308 - Bill of Materials Creation

TSKO000393 - Begin user manual

£ 8.0/8 (Hours), Due 159 (Days)

= 2.0/16 (Hours), Due 0 (Days)

The Tasks Board displays the time required for completion, total assigned time, and
number of due days until the next task.

The text is color coded depending on the state of the task. Green indicates complete
tasks, red indicates overdue tasks, and gray indicates tasks that are not overdue.
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This chapter includes the following topics:

e Bonding Interactions

e Diagnostic Tools

e Linkage Rod Connector

e Penalty Stiffness Control for Contact

e Simulation Solvers

e SOLIDWORKS Simulation Knowledge Base (2023 SP1)
e Underconstrained Bodies

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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& souows

SOLIDWORKS 2023 Video: What's New in SOLIDWORKS 2023 - SOLIDWORKS
Simulation

Bonding Interactions

An improved surface-to-surface bonding algorithm enforces bonding interactions for faces
that are not facing each other and have no projection area between them.

A pair of faces qualifies for bonding if these conditions apply:
e The angle between the faces is less than a threshold value.

If the angle between the faces exceeds the threshold value, the pair of faces does not
qualify for bonding.

e At least one face of the pair is a flat face (selected as Set 1 or Set 2 in the Local
Interactions PropertyManager).

The solver considers the flat face as the target face to enforce bonding. The source
face can be either flat or curved.

The enhanced bonding algorithm applies to the surface-to-surface formulation and is
available for bonded interaction sets that you define using the Local Interactions
PropertyManager. It applies to these studies: linear static, frequency, buckling, linear
dynamic studies, and also fatigue and design studies associated with linear static studies.

89



https://youtu.be/BELNazirSa4
https://youtu.be/BELNazirSa4

SOLIDWORKS Simulation

Diagnostic Tools

4

i~ = g

8 o} ~  Partl*

Shell Diagnostic | |Run This = Results Compare
Manage| Tools Study Advisor Results
Dimension: .@aa Underconstrained Bodies MBD | Analysis Pr
ﬁ Simulation Evaluator B & @ S t]
@ Interaction Viewer
Mesh Failure Diagnostics
[':El Mesh Quality Diagnostics

You can access the diagnostic tools available for simulations from the CommandManager.
To access the diagnostic tools:

From the Simulation toolbar, click Diagnostic Tools.

Linkage Rod Connector
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The application of Linkage Rod connectors is extended to nonlinear static and nonlinear
dynamic studies.

You can specify a Linkage Rod connector between cylindrical faces, circular edges (for
shells), or vertices to model the behavior of connecting rods.

To open the Linkage Rod PropertyManager:

In the simulation study tree, right-click Connections ‘?3 and click Linkage Rod ﬁ)’ﬁ'
You can list a linkage rod connector's forces such as shear force, axial force, bending

moments, and torque after you run a simulation. Right-click Results ™ and click List
Connector Force.

Penalty Stiffness Control for Contact

Static >

Options  Adaptive Flow,/Thermal Effects Motification Remark

Solver

Selection
@Automatic
OManual

FFEPIus

|:| Use inplane effect
|:| Use soft spring to stabilize model
|:| Use inertial relief

Contact penalty stiffness scale facton

0.0 0.03 0.1 0.3 1.0
[Approximate] [Precise]

You can specify a scale factor for the penalty stiffness for contact that is used in linear
static studies.

SOLIDWORKS Simulation uses a default scale factor of 1.0 for the penalty stiffness to
reach an accurate solution for linear static studies with contact interactions. However,
you can select a lower scale factor to obtain an approximate solution faster to assess
design iterations and the overall behavior of a model.

You can set the study-level scale factor for the penalty stiffness in the Study Properties
dialog box. For global-level settings, select Simulation > Options > Default Options
> Interactions.
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Simulation Solvers

350

2022 m2023

(98]
o
o

250
200
150
100

Ln
=]

Total Solution Time (Sec)

Draft Mesh  High Quality Mesh

Function-based processing for the FFEPIus iterative solver is extended to frequency and
buckling studies, and to the linear static studies that include node-to-surface interactions
and virtual wall definitions.

e FFEPIlus Iterative Solver

The transfer of stiffness data to solve the systems of equations is optimized for linear
static, frequency, and buckling studies because file-based processing is replaced with
function-based processing. Solution performance is improved for frequency and buckling
studies. The image illustrates the solution performance for a typical frequency study.

In addition, solution performance is improved for linear static studies that contain:

e Node-to-surface bonding and contact interactions
e Virtual wall definitions

e The FEEPIlus and Large Problem Direct Sparse solvers can now handle multiple
translational and rotational degrees of freedom that are applied remotely with the
distributed connection type.
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SOLIDWORKS Simulation Knowledge Base (2023 SP1)

Simulation o

@ irhe lterative Solver stopped.
Iterative solver failed to converge.

Results up to current iteration are saved.

See Knowledge Base article QAI105638

OK

The SOLIDWORKS Simulation Knowledge Base articles have migrated from the
SOLIDWORKS Knowledge Base portal to the Dassault Systemes Knowledge Base portal.

The hyperlinks to the Knowledge Base articles that appear in the simulation solver error
messages direct you to the Q&A articles in the Dassault Systemes Knowledge portal.

You can use the Solution ID of an article published in the SOLIDWORKS Knowledge Base
to search for the corresponding Q&A article in the Dassault Systemes Knowledge Base.
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Underconstrained Bodies

In SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium, for
static studies only, the Underconstrained Bodies algorithm includes contact interactions
and bolt connectors when detecting rigid (or free) body modes of components.

In SOLIDWORKS Simulation Standard and SOLIDWORKS Premium, the Underconstrained
Bodies algorithm does not include these improvements and remains unchanged from
previous releases.

To open the Underconstrained Bodies PropertyManager:

In the Simulation study tree, right-click the Connections node, and click Find
Underconstrained Bodies.

The improved algorithm offers the following advantages compared to the legacy
Underconstrained Bodies functionality:

e Faster detection of free body modes because the solver performs Singular Value
Decomposition (SVD) over the reduced stiffness matrix.

¢ Inclusion of contact interactions and bolt connectors when analyzing free body modes.

e Realistic visualization of free body modes in planes that are inclined to the orthogonal
planes that are defined by the global X-, Y-, and Z-axes.

e Improved visualization of unconstrained displacements for the whole assembly.
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This chapter includes the following topics:

e Color Picker

e DSPBR Material Support
e Importing Options

e System Info

e Sunlight Environment

e Stellar Physically Correct
e PhotoView 360

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.
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3 Visualize

SOLIDWORHKS 2023 Video: What's New in SOLIDWORKS 2023 - SOLIDWORKS
Visualize

Color Picker

Swatches

Recent Calors

L1 ]|

In the Color Picker, you have more ways to define colors, you can display recently used
colors, and you can import and export color swatch palettes.

The Color Picker includes two tabs: Color and Swatches.
On the Color tab you can:
e Define color codes including:

e CMYK, which lets you modify color through CMYK components.
e HEX, which lets you view and edit the hexadecimal code.

e Access the most recently used colors in Recent Colors.
On the Swatches tab you can:

e Click Import Swatch Palette to import existing color swatch palettes from:
e SOLIDWORKS Palettes (.sldclr)
e ACO files (.aco)
e SVGfiles (.svg)
e HTML files
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SOLIDWORKS Visualize

e Click Export Swatch Palette . to export color swatch palettes from SOLIDWORKS
Visualize and use them in SOLIDWORKS.

e Select preset swatch palette libraries such as Bright, Pastel, and Grayscale.

e Manage existing or new swatch palettes by adding, naming, duplicating, deleting, and
locking them.

DSPBR Material Support

2022 Preview 2023 Preview Accurate

MDL

PBR

In the Preview render mode, display has improved for Physically Based Rendering (PBR)
materials, as well as NVIDIA® Material Definition Language (MDL) appearances, and AxF™
appearances.

Improvements include the display of:

e Physically based rendering appearances for better render consistency.

e Materials that use texture distilling in the background, such as MDL and AxF
appearances.
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Importing Options

4 6 Top_Assembly (D... @TI_JFI_ASSEH’IHY {Default) <Displa 4 @ Top Assembly (D...
. v {5 () Axle And_Chassis Sub_A
v ) (-) Axle_Sub_Assem<1
v By () TC_Chasis<1> (Défa
e Bl 4 EEIH] MirrorComponent]
TC_Tank-2 ~ [ Other Parts » 5 MirrorCo...
TC Seat-1 + %TC_Back<‘l}(Défaut)< 4 1 Other Parts-1
v 8y TC_Tank<1> (Défaut) < » ) TC_Back-1
> %TC_TEHI(<2} (Défaut) <
v B () TC_Seat<1> (Défaut

Axle_And_Ch... 4 ) Axle_And_Ch..

TC_Back-1 » ) Axle_Sub._...

¥ 551 TC Chasis...

Axle And Ch...

Aule_And Ch... » B TC_Tank-1

TC Seat-2 ¥ B TC Tank-2

= EE Axle_Chassi_Patterned
TC Seat-3 v @8 Axle_And_Chassis_Sub |
TC_Back-2

b B TC Seat-1

4 [ Ashe_Chassi_P...

¥ 5 Axle And...

) TC_Back-3

2022 2023

When you import SOLIDWORKS parts and assemblies in SOLIDWORKS Visualize, the
Part Grouping options include only two choices to streamline the import process.

To access the importing options:

1. Open a project.

2. Click File > Import.

3. Browse to a .SLDPRT or .SLDASM and click Open.

4. In the dialog box, on the Geometry tab, specify Part Grouping options.

Part Grouping includes:

e The Part Grouping menu, which provides two choices when importing SOLIDWORKS
.SLDPRT or .SLDASM files.

e Component/Part/Body

e Creates nested SOLIDWORKS Visualize groups for SOLIDWORKS assembly
components down to the SOLIDWORKS parts and bodies.

e Creates nested groups for subassembly components, mirror components, pattern
components, and SOLIDWORKS folders.

e Refines SOLIDWORKS Visualize parts based on appearance assignments in each
SOLIDWORKS body.

e Imports saved SOLIDWORKS configurations, animations, and supports Monitor
File functionality.

e Appearance

e Creates a SOLIDWORKS Visualize part based on every unique SOLIDWORKS
appearance.

e Combines SOLIDWORKS geometry having the same appearance into a single
SOLIDWORKS Visualize part.
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e Imports saved SOLIDWORKS configurations.

e Does not import saved SOLIDWORKS animations and does not support Monitor
File functionality.

Imported part names are based on their ancestry. Previously, the name was based on
the imported appearance.

System Info

In the System Info dialog box, you can view the requirements and hardware status of a
given renderer and every GPU on your system.

To access the System Info dialog box, click Help > System Info.

Because SOLIDWORKS Visualize supports multiple renderers, the System Info dialog
box only reports on the renderer actively running on your system. To select a renderer,
click Tools > Options > 3D Viewport. Under Render Engine, select a renderer.

Sunlight Environment

With a sunlight environment, you can specify the north direction of the sunlight with
respect to the model and enter a location in decimal degrees.

To access a new sunlight environment, click Project > Scenes > New Sunlight
Environment.

You can:

e Import sunlight data from SOLIDWORKS to SOLIDWORKS Visualize. In SOLIDWORKS,
click Export Advanced.
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i
e Rotate parts or assemblies with Launch Animation Wizard .

Stellar Physically Correct

Stellar Physically Correct yields photo-realistic rendering results.

SOLIDWORKS Visualize supports Stellar Physically Correct, Dassault Systémes Global
Illumination renderer, using the Deep Learning Al Denoiser for optimal rendering
performance. It is designed to run on high-performance devices like GPUs or multicore
CPUs.

To use Stellar Physically Correct:

1. Click Tools > Options > 3D Viewport.
2. Under Render Engine, select Stellar Physically Correct.

PhotoView 360

SOLIDWORKS 2023 SP5 is the last supported release of PhotoView 360.
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This chapter includes the following topics:

e Barrel Tool Support

e Geometry Tab in Operations Parameters Dialog Box

e Improved Leadin and Leadout Calculations for Contour Mill Toolpaths
e Lines Only Option in VoluMill Toolpath

e Update to Machine to Mean Calculation

SOLIDWORKS® CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Barrel Tool Support

Edit Tool Parameters x

Bamel Tool | Ml Holder  Station

[~ Preview
Tool type : | Conical v
Yool Dimensions Standard - - 7
s Gamee O1: i
Comer radius (R1) : | Tapered
Fiute length (L2) : | L™ .
Advanced 3. 15in
Overall length (L1) : == =
Profile radius (R2) : |1.97in > E?Oh 1.67i
Taper angle (A2): Zdeg = L N —
0. D3in
Upper radius (R4) : 0020 =

No. of flutes ; |4
Center cutting
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You can define barrel tools to generate toolpaths, mainly for multiaxis finishing operations
in SOLIDWORKS CAM and the Technology Database. An advantage to using barrel tools
is that they provide a larger area of contact, which results in a better surface finish.

In the Operations Parameters dialog box, under the Tool tab, you can select Standard,
Conical Tangent, Tapered, Lens, or Advanced as the barrel tool type. You can also
define profiles to create custom barrel tools.

Geometry Tab in Operations Parameters Dialog Box

The Geometry tab in the Operations Parameters dialog box lets you define and modify

Multisurface features, Avoid features, and Contain and Avoid areas for 3 axis
milling.

The tab also includes group boxes for Automatic contain area and Avoid small profiles
formerly in the Advanced tab.

Improved Leadin and Leadout Calculations for Contour Mill Toolpaths

Operation Parameters

Tool F/S CnmcurlNC |Fea1ure0p1mns Leadin Advanced Posting Optimize

CNC finish parameters
CNC compensaton

() None

(®) ves (For example 6G41/G42)

Toolpath center

(O With compensation
[Toolpath is offset by tool radius)

(@ Without compensation
(Tool center is on feature geometry)

Look ahead
Limited look ahead (Gouge check)

[[]internal sharp corners
(Comner radius <= Tool radius)

The calculation of Leadin and Leadout moves is improved so that the XY start and end
points are accurately represented in a compensated toolpath.

In addition to maintaining the same XY start and end points, SOLIDWORKS CAM

automatically adds the tool radius to any arc moves you specify for Leadins and
Leadouts.

For example, if you use a 10mm diameter tool with an arc Leadin of 3mm, the calculated
Leadin arc value is 8mm. When the toolpath is compensated on the machine, the resulting
motion produces an arc move of 3mm. For other types of Leadin and Leadout moves,
the length and angle of the Leadin and Leadout line segments automatically adjust.
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For legacy parts, you need to regenerate contour mill toolpaths for these changes to
take effect.

Lines Only Option in VoluMill Toolpath

VoluMill Settings ? X

Entry / Retract

£

Entry method : | Spiral
Ramp angle : | 3deg

Entry length ; | 2-3mm

Ak dF 4k

Floor dearance ;| 2.5mm

Full entry spiral : E:

Options

Smoothing radius @ | 45 =
(% tool dia.)

Smoothing radius ; | $mm

__]Erufnrce man feedrate :

:I Line mowves only :

[ ]side mil only

[ avoid sharp corners for repositioning

You can split arcs that are larger than 90 degrees into smaller lines using Lines only.
This option is available in the VoluMill Settings dialog box in SOLIDWORKS CAM and
Technology Database, and applies to 2.5 axis and 3 axis VoluMill toolpaths.

You can specify a deviation for this option. This value splits the arcs into linear moves.

Also when you use a pattern with the VoluMill module, you can select an option to Convert

rapid moves to high feed moves in the F/S tab of the Operations Parameters dialog
box.

Update to Machine to Mean Calculation

SOLIDWORKS CAM tolerance-based machining only uses dimensional tolerances for the
Machine to Mean value of a feature. It no longer uses positional tolerances to calculate
the Machine to Mean value.

When a feature includes asymmetrical tolerances, the tolerance allowance automatically
calculates to the Maximum Material Condition. Positional tolerances are not used because
they can overcut or undercut a feature.
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This chapter includes the following topics:

e Accessing Online Help for SOLIDWORKS Composer Products

e Creating View Collections

e Player Documentation No Longer Bundled in Composer Packages
e Data Management with ENOVIA 3DLive

e Composer Player 64-Bit Version

e Supported Import Formats

e Support of Meta-Properties from Pro/E Creo and STEP Files

e Other SOLIDWORKS Composer Enhancements

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

Accessing Online Help for SOLIDWORKS Composer Products

v @
Contextual Help...

@ Help Tapics...

& Getting Started...
Programming Guide...
Video Tips...

What's New?..,

Save Log File...

Activate License...

Deactivate License..,

About...

You can access the online help for all SOLIDWORKS Composer products.

Click Help > Use Web Help to access the online help, clear it to access the local help.
Previously, only local help was available. See Composer Help: Working with the Ribbon

104



SOLIDWORKS Composer

> Help Menu, Sync Help: Menus and Commands, and Player Help

> Menu Bar > Help Menu.

Creating View Collections

: Interface Description

B, Update View

Baeg Bl aaad

4 Delault Collector

Bhue

File Home Remder Author Style
Delete Unused Properias
o _ Bike with collections.smg
% Views | Add Collection |
2 Drelete Collection
o

Rename Collection

Deactivate Collection

Expand All

Collapse All

Copy Views (Ctrl=C)

E%. Create Emply View
(@ Delete views [Del)

Drelete All Views

Rename View [F2)

You can manage and organize views into collections in the Views pane.

You can also:

Drag views into collections
Expand or collapse collections
Rename collections

Activate or deactivate collections
Delete collection views

You can create a collection of views in the Views pane by doing the following:

e In the Views pane, click Create View Collection @

Right-click a view and select Add Collection.

See Composer Help: Working with Views > View Collections and Working with the Left

Panes > Views Pane.

Player Documentation No Longer Bundled in Composer Packages

When you save the active Composer document as an auto-executable package (.exe
file), the Player documentation is no longer bundled in the package.

You can access the Player documentation online from the Player. See Composer Help:
Importing and Opening Files > About Composer File Types, Interface Description > Dialog
Boxes > Save Package As, and Interface Description > Dialog Boxes > Send by E-mail.
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Data Management with ENOVIA 3DLive

You can no longer import and update models from an ENOVIA® 3DLive session.
The following commands are removed from the user interface:

e Import from 3DLive and Update from 3DLive from the File menu.

e ENOVIA 3DLive > Import and ENOVIA 3DLive > Open in ENOVIA 3DLive
right-click commands from the Assembly pane.

Composer Player 64-Bit Version

The Use Composer Player 64-bit version option is removed from the Package options
in (Default) Document Properties > Output.

See Composer Help: Managing (Default) Document Properties > Output.

Supported Import Formats

SOLIDWORKS Composer and SOLIDWORKS Composer Sync support higher versions of
several import formats.

See Composer Help: Importing and Opening Files > About Supported Import Formats
and Sync Help: About Import Formats and File Types > About Supported Import Formats.

Support of Meta-Properties from Pro/E Creo and STEP Files

You can import meta-properties from Pro/E Creo (*.prt, *.asm), and STEP (*.stp,
* step) files in SOLIDWORKS Composer and SOLIDWORKS Composer Sync.

Meta-properties are user-defined attributes such as part number (P/N), designation, and
revision number. They appear as user properties of the string type in the Properties pane.
See Composer Help: Managing (Default) Document Properties > Input and Sync Help:
Managing Default Document Properties > Input.

Other SOLIDWORKS Composer Enhancements

SOLIDWORKS Composer products have additional enhancements.

e In the Technical Illustration workshop, you can no longer select svGz as the format
for saving vector images. The svG format is still available. If the svG file is too large,
you can convert it into the svGz compressed format using a standard file compression
tool. See Composer Help: Working in Workshops > Technical Illustration Workshop.

¢ On the Publish page, you can no longer select svGz as the output format for vector
images. The svG format is still available. If the svG file is too large, you can convert
it into the svGz compressed format using a standard file compression tool. See Sync
Help: Configuring Conversion Properties > Publish.

e In SOLIDWORKS Composer Player, you can see views grouped into collections in the
Views pane.
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SOLIDWORKS Electrical

This chapter includes the following topics:

e Defining Open-Ended Wires for Routes

e Propagating Electrical Properties from 2D to 3D

e Associate Feature Improvements

e Electrical Manager Tree Improvements

e Dynamic Connection Labels

e Origin-Destination Symbol

e Displaying Column Header Text in All Electrical Project Languages
e Manufacturer Part Weight

e Automatic Orientation in PDF Export

e Deleting Components

e Additional Variables in Origin-Destination Formula
e Resetting Dismissed Messages

e Multilingual Attributes

e Microsoft Excel Automation Improvements

e Embedding Report Tables

e Additional File Formats for Images

SOLIDWORKS® Electrical is a separately purchased product.
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#C SOLIDWORKS 2027 Elecuics

SOLIDWORKS 2023 Video: What's New in SOLIDWORKS 2023 - SOLIDWORKS
Electrical

Open-ended wires have one extremity that is disconnected from a component or terminal.

The open-ended wire property automatically propagates to the From-To list for routes.
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Propagating Electrical Properties from 2D to 3D

f Fanufacturer part properties Schneider Electnc: 21113

ES Properties % Circuits, terminals —
Depth:
Al
- Summary Custom | Configurstion Specific
Voltage:
Apply to:
Frequency: !
4 Control Delete 21113|Schneider Elednc 458975~
Voltage:
Frequency: Properly Mame Type Value | Text Expression
4 Manufacturer data 1 |Reference Text ™ XX Y
Current rating: 2| manufacturer [ Tiexk [ schne der Electric |54
Curve ¥ [Description Texk wef| 2064 FASM motor protection mick i
Current of thesmal setting: 4 |Ciass name Text ]l Circuit-breaker AMagneto-thermal [l
Current of magnetic setting: 5 |Type Text l_l-'\'ﬁ (64
Residual current threshold: b |article number Text v
Trme: T (External ID Text 7 | I
4 Description B [Zeries Tet ™ |
4 [53 Description (Englsh): | [Data sheet Text = |
i Description (French): W) [Supplier name Todt ol
4 [§f] Cormmercial reference (English): "1 [stock numbe Tt ?
BE Commercial reference (French): 792 [Mumber of Groutts — ?
dl Llzar dats T =
13 |rumber of terminal: Teut vl [

For each component, you can propagate the electrical properties to the 3D part or
assembly.

If you modify the electrical properties in the 2D application, you must click Update BOM
Properties in the SOLIDWORKS Electrical menu, to update the 3D part properties.

You can use these properties to complete tables like the Bill of Materials.

Associate Feature Improvements

Associate component
v x|}

Message
Seledk a compomnent in 30 assembly.

Part or Assembly to Assodate:

Propertics

Mark | CF... | €o... | CPoint ... | 205ch... |
i 1] a (X))
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In SOLIDWORKS Electrical 3D, the Associate command lets you associate electrical
components with 3D parts or assemblies.

The Associate Component PropertyManager lets you:

e Select several components to associate them with several 3D parts or assemblies.

e Display the properties of the selected component to check the consistency with the
3D part or the assembly.

Electrical Manager Tree Improvements

A EAEIER:

Jaa6a60866 -~

e 3

In SOLIDWORKS Electrical 3D, the Electrical Manager tree displays the list of components
in the electrical project.

In the Electrical Manager tree, an icon before each component indicates whether the
component is associated or not associated with an assembly or a 3D part. Selecting a
component in the tree highlights the associated assembly or 3D part in the graphical
area.

Selecting the location from the Electrical Manager highlights the assembly in the Feature
Manager tree if the corresponding assembly is inserted in the main assembly.

The Electrical Manager lets you:

e Show or hide inserted components
e Expand or collapse all tree nodes

110



SOLIDWORKS Electrical

Dynamic Connection Labels

_lolele
-EV1
56356

-EV1

Terminal Wire mark Length (nm ) Color
L1 L1-6 i} Red
J L1-7 0 Red

L5 1 O ange

L2-7 1] Orargea

L35 0 Bromwm

| L3-7 0 Brown

11 03/3; 03/3 ;0 Viokt; Yiolet
12 03/4; 03/4 0;0 Viokt; Yiolet

Dynamic connection labels are specific symbols that display connection information about

a component. You can dynamically insert the symbols into schemes.

The dynamic connection labels use configuration files where you enter the parameters
to draw them. Click Electrical project > Configurations > Connection label to manage

the configuration files.

To insert dynamic connection labels, click Schematic > Connection label > Insert a

dynamic connection label for a component.
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Origin-Destination Symbol

=W
Arrow symbol insertion
x
Message Origin - destination group .
Specify insertion g SOLIDWORKS Electrical P
Right-click for syr
—» Create new grq Origin - destination group
Specify the symb
o Mame:
— Select existing
—b--i | |
— Cancel
' =2 0K
-
=2 Cancel
Cther symbal, ..

You can manually insert origin-destination arrow symbols at the end of the wires. You
associate a group number with each inserted symbol. All the wires connected on the same
group number have the same equipotential number.

To insert an origin-destination symbol, click Schematic > Origin — destination arrows
> Insert a single origin - destination arrow symbol.

Displaying Column Header Text in All Electrical Project Languages

M o o
b

neral  fy Themes M Columns [ Layout 5] S« |® _C
Header

- eneral e Teut heinht: o

Text height: 2 —I For Tat i

Fonk: Tahoma | Bioild: W

Bold: [ It ]

Ttahc |— Color W 150

Ciodor . 150 R Se Auboimals

Rows height:
| Shiows all praect languanss | |
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In the report, you can display column header text in all three languages specified in the
electrical project configuration.

To activate this feature, in the report configuration, select Show all project languages.

Manufacturer Part Weight

ﬁ L T PPy “':1':.'j|-':||:-i't|-':.'
0e4685-4@431
E Properties User data .\ Circuits, terminals {&
(8] Description (English): 20-23A P25M motor pro
53] Commercial reference (English): I
= 5 Creerride Mass Properties... |
Supplier !
Information 3] Include hidden bodies/components
llustration [ ] Create Center of Mass feature
4 Size :l Show weld bead mass
Width: 45 mm
. Report coordinate values rélative to: |:
Height: 89 mm
Depth: 75 mm tass properties of 06453
P — — Canfiguration: Défaut
[ Weight (kg): 0.08548 | Caordinate system: - default -
4 |se
o . The center of mass and the moments of
Voltage: 690 Density = 000 grams per cubic millimets
Eromspamerr B

IM::SS = 85,48 gram3

Wolume = 8547970 cubic millimeters

You can manage the weight of a manufacturer part.

The weight propagates to the Mass properties of the 3D assembly associated with the
component on which you assign the manufacturer part. For components that are cut, like

rails or ducts, the weight updates according to the Depth value that you use in the cabinet
layout.
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Automatic Orientation in PDF Export

& Export POF files

Export FOF Files

Paper Forrnat: IS0 A3 (297,00 x 420,00 KM -

File name | E:\MyProject. pdf
Create bookmarks and hvperlinks
Export one PDF file by book,

Export data filas

Orientation Drawings
| (®) Aukomatic | aal
() Portrait (®) Selection

() Landscape

[CIPlat with symmetry

Scale Export fonts as geometry

Fit Fn Frrmnat w [JTruetype fonts

When you export the electrical project drawings to a PDF file, you can keep the same
page orientation.

Drawings in Landscape orientation convert to PDF pages in Landscape orientation, and
drawings in Portrait convert to PDF pages in Portrait orientation.

Select the Automatic option, available in Import/Export > Export PDF files.

Deleting Components

Components =] [ED02 - Wiring line d
D G [
= @] Tralnlng | Delete cormponent *
- [ L1 - et fre you sure that you want to delzte the selected component and all the symbaols represanting it
o {7) =F1-g \ This operation cannot be undone.
a0 =F1- ——
&) _|:1 d | 2 symbaols Fram Component “F3" will be removed frarm Following drawings:
- -1 - My book:
= E:I *03 - Electrical schems;
@ 1 +03-8 - One pole + neutral Fuse disconnsckor (1,2,..)
z *21 - TGBT:
7.5 =F1+ +21 - 005820
-
| N ‘fes ]
| [_:l =F1-%
@[] =F1< OB Copy CerlC
i -[2] =F1-% @
7o) =F1= &
#-{2) =F1-: ¥ Delete component.., Del
7. =Fi-5{F |
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In the Components dockable panel, you can delete a component and all the symbols
representing it in the drawings.

A component without inserted symbols is automatically deleted. If you want to delete a
component with inserted symbols in the drawings, a dialog box opens, lets you select the
option to delete all the symbols associated with this component. If the component is
associated with a 3D part or assembly, it is automatically dissociated.

Additional Variables in Origin-Destination Formula

e

(@ Geneeal AZ Graphic & Sywbol B Awibute M Tedt | [B) Mok [B Tieblock @ Library and palette

o 1gh cld ¥ Inderine Codor
1 = r B PlElack ! whie
i E | FPlBlack /i

Yes Font Height | Bold | Ita Caobor Forrridla Fx

1AE Tahoma =13 [ FlElack / \w/het

& -1 [ WL

| 75 0iigin - destriatics Tahoma | 1.5 [ By Ly 1 -1 IF{ LENIBOOK,_TaG) == 0, BODK_TAG + ) |

oF onena cable cole Tahoma =] 1.5 | (G & LABLE_TAlL: « W™ = LABLE_LURE_DESLHIFTI

[ Lire: chaygram ca Tahoma x| 3 N W By Laper 5 - CABLE_TAG « " ["+ CABLE_REFERENCE + T

[ Loc: - - L LOCATION

By Fur o & Formula management: Origin - destination D LA FLINCTIO

W Ela - - . -

& Predefimed formulas D Recent formulas () Variables and simple formulas /& Functions
[[] Use symbsal foe| | Simide Formul
3- FO -
oo Eeiriinal - veitazal
® er on § characters E— L
r Rarscier
Fil

New variables for components and wires are available in the Formula Management dialog
box.

To use these variables, open the electrical project configuration, and in the Text tab,
click the FX cell for Origin - destination.
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Resetting Dismissed Messages

Do you want to open the last opened
| drawing for this project?

B Interface configuratios

Training
1 Graghic options B8 Pretesences | @l Appheation language @ Rights manags
Ve
- 4 Behavior
— No Selection mode & Use "Contra

" Click on ent

S N N N S S N A A N S A W W

= Do not show again

Dizmizzed mesiages
Checked messages that wil be shown again

Open tecent diawng. Do o wank 1o open the last opened diawing for this project?

A new option lets you manage dismissed messages.

Some dialog boxes have the Do not show again option to permanently dismiss them.
To reset this status, in the Interface configuration dialog box, in the Preferences tab,
select the dialog boxes to show again.

Multilingual Attributes

TOIE
! 0
0] IVL372006 |1, Smitt
{[§'¥] DATE O FMODIFICATIONS FOLIQ
D par [ o 03
TGET |ae O7/00/2016
0
v i Tl ME
TGBT |a8 i If L)

116



SOLIDWORKS Electrical

The multilingual attributes are specific attributes that propagate a multilingual text. This
multilingual text displays the desired language when you change the main language of
the electrical project.

You can use this type of attribute in title blocks or specific symbols like wiring cable labels.

You manage multilingual attributes in the title block editor or the symbol.

Microsoft Excel Automation Improvements

: Macro

Excel automation allows you to automatically generate schematic drawings from data

2
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: File |
Mark | Type |Description |Mark
. Li-1
#il_ite | #l_dleaype |#ira_0 1 "
73 3 R Ll
h:!:l [ﬂ I-—P‘ Li=1
L - h-l
N . -
Slus e
H E slz =5 - | b
| i - L \ - -
1= 13k
AR AN Il =LY
.z .
00 B

contained in a Microsoft® Excel® file.

With the Excel automation, you can:

e Manage the origin and destination arrows
e Replace a symbol while inserting a macro
e Select the folder for the generated drawings
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Embedding Report Tables
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You can insert report tables anywhere into electrical project drawings.

According to configuration parameters, you can automatically insert specific report tables
into graphical drawings like schematic, wiring line diagram, or 2D cabinet layout schemes.

After changes of the electrical project data, you can update the report content.

Additional File Formats for Images
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You can use several file formats to insert or attach images to drawings.
The supported file formats are:

e Bitmap images (*.bmp)

e DIB images (*.dib)

e JPEG File Interchange Format (*.jpg)

e Portable Network Graphics (*.png)

e Tagged Image File Format (*.tiff)

e Graphics Interchange Format (*.gif)
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This chapter includes the following topics:

e SOLIDWORKS Inspection Add-in
e SOLIDWORKS Inspection Standalone

SOLIDWORKS® Inspection is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application (see SOLIDWORKS Inspection Standalone).

120



SOLIDWORKS Inspection

A% SOLIDWORKS 2023 Inspection

SOLIDWORKS 2023 Video: What's New in SOLIDWORKS 2023 - SOLIDWORKS
Inspection

SOLIDWORKS Inspection Add-in

Balloon Sequence

o8
Balloon Sequence @

v X

Sequence Mame Starting Value
b Default 1

Hundreds 100

Custom 2

Add Delete

You can use the Balloon Sequence tool to define the balloon numbering sequence in
multisheet drawings.

In the SOLIDWORKS Inspection add-in, click Balloon Sequence B (SOLIDWORKS
Inspection toolbar) and specify options in the PropertyManager.

Balloon Sequence PropertyManager

To open this PropertyManager, in the SOLIDWORKS Inspection add-in, click Balloon
Sequence & (SOLIDWORKS Inspection toolbar).

Sequence Name

Specifies the different balloon sequences to define. You can change the name of the
sequences.

Starting Value

Specifies the starting numeric value (whole numbers only) of each balloon sequence.
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Add

Adds a row to the balloon sequence table.

Delete

Removes a selected row from the balloon sequence table.

Balloon Drawing Sheets Separately

!'\ g
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sheet 1 Sheet 2

In multisheet drawings, you can specify sheets to balloon instead of ballooning all sheets
in a drawing.

In the Create Inspection Project PropertyManager, under Sheets, select Include All or
you can specify sheets. With Include All, the entire drawing is ballooned. When you
select sheets, you can specify each sheet in the drawing to balloon in inspection reports.
You can also specify the balloon sequence. You define the balloon sequence with the

Balloon Sequence & tool or by entering it in Sequence/Starting Value.

If you have two or more sheets to balloon continuously, in Sequence/Starting Value,
select Continue from previous sheet.
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Export Sheets as Separate 2D PDF Files

2D PDF Export

(®) Export drawing as single FDF
D Export sheets as separate PDFs

Selected Sheets

Save Sheets
Sheetl
Sheet2
Sheet3

-
HHHH

Sheet4

Ok Cancel

If you balloon drawing sheets separately, you can export the Microsoft® Excel® and .pdf
reports separately. Previously, the reports exported as a continuous report with all sheets
included.

In the SOLIDWORKS Inspection add-in, click Export to 2D PDF = (SOLIDWORKS
Inspection toolbar). In the 2D PDF Export dialog box, specify options:

e Export drawing as single PDF. Exports the entire drawing as a single .pdf file.

e Export sheets as separate PDFs. Exports each drawing sheet as a separate .pdf
file.
e Selected Sheets. Specifies the drawing sheets to save in the .pdf file.
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Export FAI Reports to Separate Microsoft Excel Documents

=i

Exporting

" Template. xt

Export Excel Settings

(®) Export drawing to single excel

() Export sheets ko separate excel

Sheets
b v Sheetl
J Sheet2

Multisheet

When you export a First Article Inspection (FAI) report to Microsoft® Excel®, you can export

characteristics to multiple spreadsheets.

In the SOLIDWORKS Inspection add-in, click Export to Excel &, In the Exporting
PropertyManager, under Excel Export Settings, specify options:

to one Microsoft Excel spreadsheet.

to separate Microsoft Excel spreadsheets.
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SOLIDWORKS Inspection Manager

98
SOLIDWORKS Inspection 27 |
Characteristics

Characteristic Table Characteristic Tree
—I-Sheetl (i PR
- Drawing View2 .

- Drawing View3

- Drawing View4

- Drawing View 13

- Drawing View30

- Drawing View47
- Drawing Views1

+]- Sheet2
| Sheet3 DETAILH

The SOLIDWORKS Inspection Manager contains a Characteristics section with tabs for
Characteristic Table and Characteristic Tree. If you select an item in the characteristic
table or characteristic tree, the corresponding entity highlights in the graphics area.

The characteristic table is existing functionality that contains the Bill of Characteristics,
which lists each ballooned entity. You can select multiple balloons from the same view
and reorder them in the characteristic table. When you drag a balloon to reorder it in the
table, scrolling speed and usability is improved. The View column in the table lists the
view to which each characteristic belongs.

The characteristic tree contains information for each sheet and view in the drawing. It
only displays sheets and views that have ballooned items. In the characteristic tree, you
can reorder:

e Balloons by dragging views.
e Views that belong to the same sheet.

e Sheets. The sheet and its views are reordered and renumbered according to the new
position in the characteristic tree.

SOLIDWORKS Inspection Standalone

SOLIDWORKS® Inspection is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as
a completely separate application (see SOLIDWORKS Inspection Standalone).
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Autoballoons for PDF Files

7 03 4

g?ﬁm

The Auto Extract tool automatically applies balloons to characteristics in PDF files, which
reduces the time and effort needed to balloon PDF files.

Auto Extract uses a machine learning technique to locate the positions and types of
annotations, then attaches balloons to them. You can also use this tool to automatically
apply balloons to CAD files. The Auto Extract tool replaces the Smart Extract tool.

1
In a PDF file, on the Document ribbon, click Auto Extract /l\f. Auto Extract does not
support notes or weld symbols.

(1
You can also manually extract characteristics with the Manual Extract }@ tool (Document
ribbon).

Autoballooning PDF Files

To autoballoon PDF files:
1. In SOLIDWORKS Inspection Standalone, click New L.

2. In the Project Template dialog box, select a template and click «
3. In the Open CAD/PDF File dialog box, select a PDF file and click Open.

}’j_\]
4. Click Auto Extract ©#* (Document ribbon).
5. Specify settings in the Auto Extract PropertyManager and click +.
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Auto Extract PropertyManager

You can use the Auto Extract PropertyManager to automatically apply balloons to
characteristics in CAD models, drawings, and PDF files.

To open the Auto Extract PropertyManager, in a model, drawing, or PDF file, click Auto

/,T\I
Extract 7 7.

Extraction Settings

(pDF files only.) Specifies the characteristics to balloon. Notes and weld symbols are not
supported.

Include All Balloons all dimensions, geometric tolerance

symbols, surface finish symbols, and datums

in the file.

Dimensions

Balloons all dimensions.

GD&Ts

Balloons all geometric tolerance symbols.

Surface Finishes

Balloons all surface finish symbols.

Datum

Balloons all datums.

Dimensions

(CAD models and drawings only.)

Include

Balloons all basic, feature, and reference
dimensions.

Clear Include to select individual Basic,
Feature, or Reference dimensions.

Inspection Only

Balloons all inspection dimensions.

Auto-explode hole callouts

(SOLIDWORKS files only.) Balloons and
splits compound hole callouts into
subballoons.

Notes

(CAD models and drawings only.)
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Include

Balloons all datum feature, datum target,
and flag note symbols.

Clear Include to select individual Datums,
Datum Targets, Flag Notes, Correlate
Flag Notes, or Auto-explode multi-line
notes.

GD&Ts
(CAD models and drawings only.)

Include

Balloons all geometric dimensioning and
tolerancing feature control frames.

Welds
(CAD models and drawings only.)

Include

Balloons all weld symbols.

Surface Finishes

(CAD models and drawings only.)

Include

Balloons all surface finish symbols.

Geometry Options
(CAD models and drawings only.)

Load Invisible Components

Loads hidden components into
SOLIDWORKS Inspection.

Page 2 of PropertyManager

Click Next P in the PropertyManager to access these options.

Entire Drawing

(Drawings and PDF files only.) Balloons all
characteristics in the document.

Sheets, Include All, sheetn
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Entire Document
(CAD models only.)

Entire Document Balloons all characteristics in the document.

Include All Includes all annotation views, otherwise you
can select individual annotation views.

Captures

Include All Balloons all model based definition screen
captures, or you can specify screen captures
to include.

Views

Include All Balloons all annotation views, or you can

specify views to include.

Manually Ballooning PDF Files

The Manual Extract tool replaces the optical character recognition (OCR) editor tool. It
is streamlined to make manual extraction of annotations quicker to balloon.

To manually balloon PDF files:
1. In SOLIDWORKS Inspection Standalone, click New .
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2. In the Project Template dialog box, select a template and click J
3. In the Open CAD/PDF File dialog box, select a pPDF file and click Open.
/1_\1
4. Click Manual Extract /l\@ (Document ribbon) and select the type of annotation to
balloon:

e Dimension

e Geometric Tolerances

¢ Note

e Surface Finish

e Weld

e Other. Includes annotations such as temperature, torque, and electrical resistance.

5. Inthe pDF file, box-select an annotation of the type you selected in the previous step.

6. In the Properties/Preferences PropertyManager, under General, Inspection,
Ballooning, and Custom, enter values for the remaining data in the annotation.

User Interface Redesign

SOLIDWORKS Inspection
View Getting Started

HQ 4 5 P PH (=] Fit Width “‘3 ™ - o, \1& DJ
I FitHeight ol &8 I '
First Previous /12 Next Last Zoom 100% Zoom Zoom = Pan Zoomto Top

] Fit Page In Out Area | Left
Sheet Zoom 5

2022

SOLIDWORKS Inspection

View Getting Started

”4 q > b b” =5 Fit Width g ) % g) g ) gi p Eg
IC Fit Height
First Previous /12  Mext Last Zoom 100% Zoom Zoom = Pan Zoomto  Top

Fit Page In  Out Area Left

Sheet Zoom 5

2023

The user interface for SOLIDWORKS Inspection Standalone is redesigned to provide better
support for high-resolution, high-pixel-density displays. Icons are consistent with those
in SOLIDWORKS.

Icons are more crisp and readable, and they scale properly when used with high-resolution
displays.
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This chapter includes the following topics:

e Annotations and Dimensions in 3D PDF Files
e Editing Compound Features

e Dimension Extension Lines

e Wedges

e ISO Tolerance-Modifying Symbols

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Annotations and Dimensions in 3D PDF Files

When you create a 3D PDF for an assembly, you can view all dimensions in the assembly
and 3D views, even in the viewport, with no data loss.

You can view component dimensions in 3D PDF files, including feature dimensions,
reference dimensions, and DimXpert annotations.
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Editing Compound Features

You can add or remove faces on an existing compound feature while maintaining the
annotations.

You can edit compound planes, holes, and cylinders.
To edit compound features:

1. In the DimXpertManager, right-click the compound feature and click Edit Feature.
2. Select features to add or remove from the compound feature.

o To add a face, select a feature and click OK.
e To remove a face, right-click a feature and select Delete.
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Dimension Extension Lines

You can use dimension extension lines to connect the dimensions to the model.
To show dimension extension lines:

1. Click Tools > Options > Document Properties > DimXpert > Display Options.
2. Under Linear Dimension, select Connect dimension extension lines to model.

Wedges

\ “35e°
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MBD supports wedge features. A wedge has two nonparallel planes with opposing vectors.
To create a wedge:

1. Click Size Dimension (MBD Dimension toolbar).
2. Select the first plane.

3. From the Feature Selector, click Create Width/Wedge Feature “
4. Select the second plane.

5. In the Feature Selector, click ¥ .
6. Click to place the dimension.

35n
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ISO Tolerance-Modifying Symbols

Symbol Library — O et

Insert

Categories:

Symbals
ANSI Lay Symbols

AMSI Weld Contour Symbols

ANSI Weld Spacer Symbals

AMNSI Weld Symbols
Drraft

Flag Cir 1-3%

Flag Cir 1.-59,

Flag Cir A-Z

Flag Cir A.-Z. @ @ @ @
Flag Squ 1-99

Flag Squ 1.-99, | : }'

Flag Squ A-Z @ @ @ ACS
Flag Squ A.-Z.

Flag Squ-Cir 1-39 SCS ALS CT UF

Flag Sgu-Cir 1.-99

You can apply ISO 14405-1:2016 standards-based symbols to dimensions and tolerances
in DimXpert.

You can add symbols and other text directly to ISO dimensions and their tolerances from
the Tolerance Modifier section in the DimXpert PropertyManager.
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This chapter includes the following topics:

e Assembly Graphics

e Configuration Pane

e Components Pane (2023 SP1)

e Configuration Support on Mobile Devices

e Display States

e Display Styles

e Supported Versions of File Types

e Using Localized Versions of eDrawings Web HTML
e Using Fractional Measurements

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Assembly Graphics

Graphics in eDrawings assemblies have improved. When you publish SOLIDWORKS
assemblies as eDrawings assemblies, the graphics more closely resemble the original
SOLIDWORKS files.

If the eDrawings assembly contains linked display states, the Configuration pane shows
Display States (Linked).
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Configuration Pane

Configurations

Vs & =
Default e L'i
Markup Annotations Configuration

When you open files in eDrawings that have only one configuration, the Configuration
pane is available. Previously, there was no Configuration pane.

Components Pane (2023 SP1)

Components o)

T Enter text to filter list

4 S IF10152001-A1_finished (Color Ink)
@ F210172001.01-1 [Ink Folder Cariage] (Color Ink)

@ 1F10172001.04-1 [ink Cartridge Extractor] (Default)

b @ pivot link assy-1 (Default)

@ 1F10172001.05-1 [ink Cartridge Lock Down] (Defau

@ m10172001.01-1 [Ink Floder] (Color Ink)
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You can display component properties in the assembly tree of the eDrawings Components
pane.

Component properties are only available if you published an .EASM file from SOLIDWORKS
with Save file properties for each component in the assembly selected.

On the Components pane, click Options E and select Show property. This displays
the specified property when you open the Components pane. You can also filter on the
text to find components in a large assembly tree.

Configuration Support on Mobile Devices

You can specify configurations of SOLIDWORKS parts and assemblies to be available when
you open the models in eDrawings for iOS™ and eDrawings for Android™.

In the SOLIDWORKS software, set configurations with Add Display Data Mark to view
the configurations in eDrawings. For information, see SOLIDWORKS Help: Generating
Display Lists.

138



eDrawings

Display States

Configurations

Display States {Linked)

Body

Head

Body HLR
X -

- -
‘!‘ -
- Default ﬂ - ﬁ
Stamps Annotations Configuration Components

When you publish SOLIDWORKS assemblies as eDrawings assemblies (.EASM), display
state data (for the selected configurations in the Save Configurations to eDrawings file
dialog box) is stored in the eDrawings assembly files. This gives you important information
to communicate and collaborate in eDrawings.

Display state data is also supported when you save an assembly as an eDrawings Web
HTML file from eDrawings Professional. You can view the display states in supported
browsers and in SOLIDWORKS PDM Web2.

On the Configuration pane, the option, Link display states to configurations, is
removed. Display states are linked or unlinked based on the setting in the SOLIDWORKS
assembly at the time of publishing the eDrawings assembly file fromm SOLIDWORKS. When
the display states are linked to the configuration, only the display states that are associated
with the selected configurations are published. If display states are linked to the
configurations, the header says Display States (Linked).

Textures are not supported in the display state data.
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Display Styles

Hidden Lines Removed Wireframe

You can view models in hidden lines visible (HLV) and wireframe modes. The tooltip for
Wireframe has changed to Hidden Lines Removed (HLR).

Click Display Style ﬂ (Heads-up View toolbar) and select Hidden Lines Visible ,

Hidden Lines Removed m, or Wireframe .

Supported Versions of File Types

eDrawings has updated the supported versions for several file types.

ACIS (.sat, .sab) Up to 2020

Autodesk® Inventor® (.ipt., .iam) Up to 2022

CATIA V4 (.MODEL, .SESSION, .DLV, .EXP) Up to 4.2.5

CATIA V5 (.CATDrawing, .CATPart, Up to V5_6R2021
.CATProduct, .CATShape, .CGR)

CATIA V6 / BDEXPERIENCE (. 3DXML) Up to V5-6 R2019 (R29)

Creo - Pro/Engineer (.ASM, .NEU, .PRT, Pro/Engineer 19.0 to Creo 8.0
.XAS, .XPR)
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IGES (.igs, .iges) 5.1,5.2,5.3
JT(.3t) Up to v10.5
NX (Unigraphics) (.prt) V11 to v18, NX to NX12, NX1847 Series to

NX1980 Series

Parasolid (.x b, .x t, .xmt, .xmt txt) Up to 33.1

Solid Edge (.asm, .par, .pwd, .psm) V19-20, ST-ST10, 2021
STEP (.stp, .step, .stpz) AP 203 E1/E2, AP 214, AP 242
Wavefront OBJ (.obj) Any

Using Localized Versions of eDrawings Web HTML

A& ®OQ @ F

jh" -'? L |

Cestina

Deutsch

English

Espariol

Francais

Italiano

H4:g

(Available in eDrawings Professional.) When you save a file as eDrawings Web HTML,
then open the .html file, you can select a language to display the user interface in the
localized language. The file itself retains its native language.

This is helpful if you share the file with a user who speaks a different language.
To use a localized version of eDrawings Web HTML:

1. In eDrawings, click File > Save As.
2. In the dialog box, in Save as type, select eDrawings Web HTML Files (*.html).
3. Double-click the file that you saved.
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4. In eDrawings Web HTML, click Languages iA' and select a language.

Using Fractional Measurements

2 1/2in

If you use the English unit system to measure eDrawings models, you can display
measurements as fractions with the Measure tool.

To use fractional measurements:

B
Click Measure .

2. On the Measure pane, under Units:

[

a. In Length, select Inches or Feet and Inches.

b. Select Display In Fractions.

c. For Denominator, enter the maximum digits for the fraction denominator.
d

Optional: Select Round to nearest fraction to round to the next highest fraction
if the measurement does not have a fractional value for the denominator.
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This chapter includes the following topics:

e Plastics Materials Database - Material Grades
e Plastics Materials Database Manager
e Summary and Report

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS

Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Plastics Materials Database - Material Grades

[PA12 : EMS-GRIVORY / Grilamid LC-15H]

362,278} ----- - - oo beenenmnna dremn e S EEETTE S RLECEEREREE

1000.000-

316,228

100,000

31.623-

Viscosity (Pa.s)

10.000-

3062 -

1.000 -; 0 i ] 0
1.000e+00 1.000e=01 1.000e+02 1.000e+03 1.000e 04
Shear Rate (1/sec)

-

The Plastics material database is updated according to the latest data from the material
manufacturers.

Materials Description

New Materials Added 14 new material grades from material manufacturer
EMS-GRIVORY.
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Materials Description

Modified Materials Updated 54 material grades with the latest material property values
from material manufacturer EMS-GRIVORY.

Removed Materials Removed obsolete material grades from the database:
e EMS-GRIVORY: 1

e CHI MEI Corporation: 37

Plastics Materials Database Manager

g PC : Covestro [ Makrolon 2556

= Makrolon 2556

Melt Temperature 300 °C Polymer Family FPC

Max. Melt Temperature 320 °C Manufacturer Covestro

Min. Melt Temperature 280 °C Recommended Melt Temperature | 300 °C

Maold Temperature 100 °C Maximum Melt Temperature 320 °C

Max. Mold Temperature 120 °C Minimum Melt Temperature 280 °C

Min. Mold Temperature 80 °C Recommended Mold Temperature | 100 °C

Ejection Temperature 130 °C Maximum Mold Temperature 120 °C

Transition Temperature 150 °C Minimum Mold Temperature 80 °C
Wiscosity : 7-Parameters Modified 5.86e+11 Ejection Temperature 130 °C
PWT : Modified Tait Equation 0.0008722 Thermoset Conversions Mot Available

Solid Density 1198 Kg/m3 Transition Temperature 180 °C

Specific Heat - Constant 2100 Ji(Kg-K) Viscosity - 7-Parameters Modified 1 5.86e+11

Thermal Conductivity : Constant 0214 W/{m-K PVT : Modified Tait Equation 0.0008722
Elastic Modulus : Constant 2400 2400 Density 1198 Kg/m3

2022 2023

Several user interface enhancements to the Plastics Materials Database Manager improve

its usability.

Display enhancements:

e Gray color border and gray gridlines replace the yellow color border and gridlines to
improve the readability of the material properties.

e The Elastic Modulus, Poisson’s Ratio, and Thermal Expansion Coefficient plots

are removed.

e The material's polymer family and manufacturer name are removed from the title bar
and are listed in separate material property fields.

Material properties enhancements:

e The database stores detailed fiber and filler properties for filled materials. You can
view these properties under the Filler Properties section.
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=| Filler Properties

Filler 1

Description Glass Fiber
Filler Percentage 55 %
Aspect Ratio 20

Initial Length Mot Available
Awverage Diameter Mot Available
Density 2500 Kg/m3
Specific Heat 700 Jikg. K
Thermal Conductivity 1 Wim.K
Elastic Modulus (E1) 70000 MPa
Elastic Modulus (E2) 70000 MPa
Tensile Strength (o1) 3500 MPa
Tensile Strength (a2} 3500 MPa
Poisson's Ratio (v12) 0.29
Poisson's Ratio (v23) 0.29

e In addition to the material's solid density, the database stores its melt density. You
can view the material densities under the Density section.

Viscosity PVT Specific Heat Thermal Conductivity
Shear Relaxation Modulus Curing Model Polymer-Material Parameters
=) Density 990 7T&0
Solid Density 990 Kg/m3
Melt Density 780 Kg/m3

e The database stores the following Thermoset material properties, if they are available
from the manufacturers:

e PVT data for the cured and uncured states.
¢ Heat of Reaction and Induction Time Constants.
e Ejection Conversion and Initial Conversion.

The solver is also enhanced to account for these additional material properties (when
available) to improve the accuracy of Fill, Pack, and Warp simulations.

The classifications of the material's Data Source and Information field are revised.

Classification Description

Manufacturer Name Name of the manufacturer who provided
the grade-specific material data.

Manufacturer Name; Generic PVT Data The Pressure Volume Temperature (PVT)
data are generic, while the rest of the data
are grade-specific and provided by the
material manufacturer.

Manufacturer Name;*to be phased out The material manufacturer is planning to
phase out the specific material grade.
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Classification Description

SIMPOE The material data are from a legacy source
and are not updated.

SIMPOE; Generic PVT Data The material data are from a legacy source
and have been updated from constant
density to generic PVT data to improve the
accuracy of Fill, Pack, and Warp simulations.

Summary and Report

Summary

@ Summary and Report
il
@ Clipping Plane Settings
Pa
% @ Isosurface Manager
e
& Yy PathLine
b @ OF
@ Export

@ Remove All Results

Report
Clipping Plane Settings

Isosurface Manager
Path Line
Export

Remove All Results

2022 2023

You can access the Summary and Report features from the PlasticsManager
independently. In addition, there are several enhancements for the Summary and Report.

¢ To access the Summary:
In the PlasticsManager, right-click Results and click Summary.
e To access the Report:

In the PlasticsManager, right-click Results and click Report.

Enhancements to the Summary feature include:

e Quick access to key results.
e Improved content organization into three sections for the Model tab:

Study Characteristics Lists the following features: study name, injection process,
number of injection units, analysis mesh procedure, and
the simulation sequence.
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Injection Unit Settings Lists the following features for each injection unit: polymer
material and the material's melt, mold, transition, and
ejection temperatures.

Physical Attributes Lists the model volume, mass, and overall dimensions.

e Addition of the plastic part's mass at the end of packing in the Pack tab.

@ Summary

v X

Model | Fill | Pack

¥-dir, Clamping Force = 467.2219 Tonne

¥-dir, Clamping Force 15049500 Tonne

Z-dir. Clamping Force 2194.3810 Tonne

Max, real temperature = 2366219 *C
Max, bulk temperature = 237.5223°C
Max. shear stress = [0.7933 Mpa

Max, shear rate 75,3348 1/s5ec

Max. residual stress

194.3600 Mpa

295898 (q)

Mass at the end of packing

Enhancements to the Report feature include:

e Updated Microsoft Word report templates. The Classic and Light report templates of
previous versions are replaced with a single template that has a more modern look
and feel.

e Additional formats are available for saving a report. In addition to Microsoft Word, you
can save a report as a Microsoft PowerPoint or HTML document. The default option All
(HTML, MS Word, MS PowerPoint) saves a report to all three formats.
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Report Generator

Header Info  Description

Save as:

Save to:

Generate Image File Save Options

All (HTML, MS Word. MS PowerPoint)

All (HTML, MS Ward, M5 PowerPaint)

M5 PowerPoint
HTML
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This chapter includes the following topics:

e Routing Library Manager Enhancements

e Complex Splices

e Displaying the Cross Section of a Harness Segment
e Flatten Route Improvements

e Reorienting Connectors in Flattened Routes

Routing is available in SOLIDWORKS® Premium.

SOLIDWORKS 2023

Video: What's New in SOLIDWORKS 2023 - Routing

Routing Library Manager Enhancements

M Functionality point is of the wrong route type.
RPaint
| Add | 1 or mare Opticna
%]} Route Point{RPoint) is only —— e e

o fitting i.e. drop the flange il T

Close Routing Component Wirard

CPoint Configuration
o Clases routing component wizard & returms o routing hbrary manager.

# Add all CPoints

Do not connect CPoint
- Close Routing Library Manager

Select CPoints Closes routing component wizard & closes routing hbrary manager.

Restart Wizar
Restart the wi| — CPoint Type
&) Default CPoint Siohes Modify

5 & e 1 CPoant with Circamt snformation ,
[ Do not show 2 1 Required

! CPoant frem Manufacturer part

Cable CPoint (EWCable Point)

Add

149


https://youtu.be/ekCM-_mK84M

Routing

The Routing Library Manager has improved ergonomics and usability, several
enhancements have been done:
e Improved discoverability and guidance in the user interface by tooltips.

e Better management of the connection points and Mate References (create, edit, and
delete workflows).

e Improved saving and canceling of modifications.

Complex Splices

' N\ \

A complex splice has multiple circuits to which you connect wires or cable cores.

To connect wires or cable cores to a complex splice, you must insert the CPoints, and the
RPoints if the wire crosses the splice, corresponding to the different circuits.

You can use complex splices in a manual routing or using the From-To list.
The complex splices are not supported in the flattening.
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Displaying the Cross Section of a Harness Segment

m.

—

show et
’

You can access the cross section of a harness segment.
In the Electrical Attibutes PropertyManager, select Show Cross Section to view a graphical
cross section of the harness segment. The formula to calculate the diameter of this

segment takes into consideration if it contains a cable.

Flatten Route Improvements

= | ==
S ER e e | =
- 5 Flaiten Route ltems @
= Hatten Route & = @
=
o ¥ W K
Flattened Route Drawing. - Message e
Select the ikems to be displaed ir
Flattemn Type Ead Araasin g i s
(®) Anngtatiog
Y S N NP N NN Tables ~
fPrgeTip o » &
- 4+
B cannectar Table
- ! ] component Reterence
I B Display Connector Balloons |
= reriComponent
B Display Wire Balloons M
M Hide Empty Pin Renac
i Accessory Components ]
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Improvements to the flatten route design deliver higher-quality flatten route drawings.
Improvements relate to the following items:

e The Auto-Balloon option applies to balloons for connectors and wires

¢ When you modify a connector table, you can apply this change to all existing connector
tables

The Show/Hide Flatten Route Items command is available in the Electrical toolbar

In the Flatten Route Items PropertyManager, you can select Manufacturer

(component name) to split the text displayed for the component in the flattened
route drawing

Reorienting Connectors in Flattened Routes

LEE

Ef

e B B ¢
55 Bt Plattered Route

W K o

SEEraam

You can reorient the connectors to be parallel to a selected plane.

In the Edit Flattened Route PropertyManager, select a plane in Faces and Planes.
This does not affect the Maintain 3D Orientation process.
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DraftSight

This chapter includes the following topics:

e Contextual Ribbon Tabs (2023 SP1)
e Cycling Selection (2023 SP1)

e Data Extraction (2023 SP1)

e Page Layout Manager (2023 SP1)

e Annotation Monitor (2023 SP1)

DraftSight® is a separately purchased product that you can use to create professional CAD
drawings. It is available as DraftSight Professional and DraftSight Premium. In addition,

DraftSight Enterprise and Enterprise Plus are available on network license. 3DEXPERIENCE
DraftSight is a combined solution of DraftSight with the power of 3DEXPERIENCE platform.

Contextual Ribbon Tabs (2023 SP1)

DraftSight

Toolbox Add-Ins

Powertools Toolbox Add-Ins

Powertools  Toolbox Add-Ins

0.oo
o.on -

=N 1

1125 .
114 | Decimal

Units

You can display specific tools on the ribbon when you select particular entities or run the
commands to create new entities.
The contextual ribbon tab provides:

e An uninterrupted view of the graphics area because it is not blocked by the dialog box
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e Immediate visibility of changes that you apply to entities
e Relevant tools for completing a task

DraftSight offers contextual ribbon tabs for the following operations:

e Creating and editing hatches

e Editing table cells

e Editing PDF and DGN underlays

e Editing images and external references

e Editing annotation entities, dimensions, leaders, multileaders, and tolerance symbols.

Cycling Selection (2023 SP1)

Hatch
Hatch

MNone

You can select specific entities from the list of overlapped entities displayed in the Cycling
Selection dialog box.

In previous releases, it was difficult to select an overlapped entity when working on a
complex drawing.
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Data Extraction (2023 SP1)

mm Data Extraction - Begin (Step 1 of &)
The wizard extracts entity data from drawings that can be exported to a table or to
mm Data Extraction - Define Data Source (Step 2 of &)

Select whether to create a new dz Data source
extraction. (® Drawings

mm Data Extraction - More Settings
(® Create a new data extracti Indude all entities in the current d

Extraction settings

[] Use previous extractiol () Select entities in the current drawing
Extract entities from blocks

Drawing files and folders:
< Extract entities from references |

(") Edit an existing data extra Folders
E- | | Drawings [ Indude references in block cour

_| CAUsers\redrigo\Desktop\Kitch pyrpen ion from

() Entities in model spz

You can use the Data Extraction wizard to specify a set of entities or blocks and extract
properties and attributes information.

You can:

e Create a bill of materials from the set of entities.
e Display the result in a table on the drawing.
e Save the result in an external file that you can exchange with others.

Use the Extractbata command to open the Data Extraction wizard.
Options in the Data Extraction wizard let you:

e Specify the set of drawings or folders.
¢ Filter entities.

¢ Organize the extracted data.

e Specify an output format.

e Format the output data in a table.

DraftSight saves the data source selections, entities and property selection, and table
formatting in a Data Extraction File (.det). You can use the already created Data Extraction
File as a template to perform the same type of extraction for another drawing.
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mm Page Layout Manager

"% Specifies the sheet p

eet Se size, and settings foi General
Print... Apply page layout to: Mode
& o . ., Page layout for current sheet: <MNone
Cirl+Shift<S Prints a drawing to a plot
| *Model*
b Print Preview Layout1
. [El Shows how the drawing w
printed or plotted
- BatchPrint...
b % Print multiple drawings tc
files
»
Scale List...
[{[:= Edit drawing scale list g
Printer name: Microsoft Print to PDF
Printer type: Microsoft Print To PD

You can use Page Layout Manager to save the print settings in a drawing file.

In previous versions, the Print Configuration Manager saved the print settings in the
.CFG file. When you shared the drawing file with users, you had to share the .CFG file to
retain the print settings.

Under System Options > Printing > General Options, select Use Page Layout
Manager.

DraftSight reads and lets you print the print settings of a drawing file created in other
software, for example AutoCAD®.
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Delete

| | | —m
W AN\ | } \
Annotation Monitor identifies annotations that are no longer associated with their related
geometry.

DraftSight displays the Reassociate and Delete options. You can either reassociate the
annotations or delete them.
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