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1
Welcome to SOLIDWORKS 2022

This chapter includes the following topics:

• Top Enhancements
• Performance
• SPR Fixes
• For More Information

Model courtesy of Rahul Gawde, SOLIDWORKS 2021 Beta Splash Screen Prize winner.

Video: What's New in SOLIDWORKS 2022

At SOLIDWORKS, we know that you create great designs, and that your great designs get
built. To streamline and accelerate your product development process from concept through
manufactured products, SOLIDWORKS 2022 contains new, user-driven enhancements focused
on:
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• Work Smarter. Create better products in less steps with new workflows and feature
enhancements in assembly and part design, drawing detailing, simulation, and product data
management. Take advantage of new features in parts such as hybrid modeling and creating
standardized threaded studs. Benefit from dozens of user interface enhancements such as
the shortcut bar, configuration management, integrated messages, geometric tolerancing,
and more.

• Work Faster. Get more done in less time with significant quality and performance
improvements when working with large assemblies, importing STEP, IFC, and DXF/DWG
files, detailing your drawings, and managing your product data. Optimize assembly
performance automatically without worrying about modes and settings. Experience the
freedom of our fastest graphics to date with improved display response and quality.

• Work Together. Improve innovation and decision making by connecting to the
3DEXPERIENCE platform and leveraging its collaborative capabilities. Increase your
competitive advantage by tapping into the power and breadth of the cloud-based
3DEXPERIENCE Works portfolio. These expanded tools help your entire enterprise across
the design and engineering, simulation, manufacturing, and governance domains.

Top Enhancements
The top enhancements for SOLIDWORKS® 2022 provide improvements to existing products
and innovative new functionality.

Standard, Remote, and Compressed Administrative ImagesInstallation on
page 14

Parts and Features
on page 39

• Using Numeric Values to Define Coordinate Systems
• Selection for Coordinate Systems
• Draft Across Parting Lines
• External Threaded Stud Wizard
• Hole Wizard Slots
• Hybrid Modeling
• Mirroring About Two Planes

Etched Contours on BendsSheet Metal on
page 55

Connection Element for a Structure SystemStructure System
and Weldments on
page 57

Assemblies on
page 69

• Open subassemblies in Large Design Review or resolved mode
from an assembly opened in Large Design Review mode.

• Use Configuration Table to modify configuration
parameters for parts and assemblies with multiple
configurations.

Detailing and
Drawings on page
78

• Detailing Mode
• Geometric Tolerance Symbols
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• Symmetric Linear Diameter Dimensions

Importing Selective IFC Entities from IFC FilesImport/Export on
page 89

Performance
SOLIDWORKS® 2022 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

Import
Performance is improved for importing:

• A large DXF or DWG file into a part sketch.

You can import a large DXF or DWG file into a part sketch with the Explode Block option
turned off. You no longer need to explode the blocks to improve import performance.

• STEP files in SOLIDWORKS.

Assemblies
Improved performance when opening, saving, and closing assemblies.

Model Display
SOLIDWORKS 2022 offers improved performance for 3D textures and silhouette edges.

Performance ImprovementFunctionality

3D textures accelerate the process of refining the mesh to
better match the detail in the textural appearance image. You
can further refine the Maximum Element Size below its
previous limit.

3D textures

Performance is improved for rendering silhouette edges in
dynamic mode. You can see the silhouette edges in Shaded
With Edges mode.

Silhouette edges

Drawings
Performance is improved when you print large drawings on paper or to file. This applies
to drawings where you:

• Have at least one drawing view as draft quality
• Specify these options in the Page Setup dialog box:

• High quality
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• Color / Gray scale

SOLIDWORKS Manage
SOLIDWORKS Manage 2022 offers improved performance for enhancing the user
experience.

Performance ImprovementFunctionality

When specifying the Number of BOM
levels to display options at 1, large BOMs
display up to five times faster. For BOMs
with Link to 3rd Party fields configured,
the time required to calculate the values
has decreased.

Bill of material (BOM) display

For projects with a high number of stages
or Tasks, the Gantt chart display is faster
than in previous releases.

Projects

In previous releases, the Check Out/Check
In operations refreshed the entire grid in
the background. Now, only the individual
line item that last changed refreshes,
making performance faster.

Check out/Check in of SOLIDWORKS PDM
files from SOLIDWORKS Manage

Pack and Go
Pack and Go gathers references faster in 2022 than in previous releases. The time between
initiating Pack and Go for a document and when the Pack and Go dialog box appears is
reduced substantially.

SOLIDWORKS PDM
With SOLIDWORKS PDM 2022, you can experience improved performance of many
file-based operations. You can perform the following actions faster for database servers
with high latency:

• Open files
• Display the Save As dialog box
• Copy Tree
• Create a document in SOLIDWORKS

SOLIDWORKS PDM has improved performance for the following:

• Saving a data card with a large number of file extensions is faster by 15% to 60%.
• Checking in a drawing with a large SOLIDWORKS bill of materials (BOM) is significantly

quicker.
• Displaying files in the Where Used tab with the Show All option and additional custom

columns is many times faster for certain vaults.
• Displaying the Transition dialog box for dynamic notifications is quicker.
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• Loading a Web2 preview is between 1.5 and 2 times faster for large models.

SOLIDWORKS Simulation
• Saving models that have simulation studies is faster, if at least one or more simulation

studies are not modified.
• Function-based processing for the FFEPlus iterative and Intel Direct Sparse solvers is

extended to simulation studies that include connectors and other features. The
automatic solver selection is extended to Nonlinear, Frequency, and Buckling studies.

SOLIDWORKS Plastics
The performance of the Cool and Fill analysis modules is improved to accelerate the overall
analysis time.

• For simulations where the Cool analysis takes up a large proportion of the overall
solution time, the overall solution time is reduced by at least 20% compared to previous
releases.

• The performance of the Fill and Pack analyses with the Direct solver option is optimized.
The overall solution time is reduced by approximately 50% compared to previous
releases. For relatively thick parts that are meshed with hexahedral elements, the
Direct solver more accurately predicts the inertial effects.

SPR Fixes
We have fixed a large number of Software Performance Reports (SPRs) in SOLIDWORKS
2022 by development projects specifically selected to address quality and performance
issues reported by customers.

See the full list of fixed SPRs.

ResolutionSPR

Dimensions import properly when you replace a model in a drawing.828867

If you open a .JT file and select Include PMI when importing the file,
the text on part faces imports properly.

1195411

Hole Wizard data imports properly for drawings with mirrored parts.1024876

In an assembly, a driven part uses saved data to recreate geometry
when data from the driving part is not available. This issue occurs when
you switch configurations for the driven part and the data from the
driving part is not available because it is in the inactive configuration.

1083466

Includes the paper color when you save drawings as image and PDF file
formats.

190949
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For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML

• > What's New > PDF

• > What's New > HTML

In SOLIDWORKS, appears next to new menu items and the
titles of new or significantly changed PropertyManagers. Click

Interactive What's
New

to display the topic in this guide that describes the
enhancement.

To enable Interactive What's New, click > What's New >
Interactive.

Contains complete coverage of our products, including details
about the user interface and examples.

Online Help

Contains posts from the SOLIDWORKS user community on the
3DEXPERIENCE platform (login required).

SOLIDWORKS User
Forum

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

Release Notes

SOLIDWORKS Legal Notices are available online.Legal Notices
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2
Installation

This chapter includes the following topics:

• Standard, Remote, and Compressed Administrative Images
• Allow Subgroups in the Administrator Image Option Editor
• Improved SOLIDWORKS Electrical Client Installation
• Set Up a PDM Vault View When Creating an Administrative Image

Video: What's New in SOLIDWORKS 2022 - Installation

Standard, Remote, and Compressed Administrative Images

14

https://www.solidworks.com/media/solidworks-2022-administration


You can use the Administrative Image Option Editor to create several types of images
for remote users and for those on your network.

DescriptionAdministrative
Image Type

This image is the default for all new administrative images. It is a
standard Windows Installer Administrative image ideal for users who
have reliable access to the company network. It stores all the files
required to install the selected SOLIDWORKS products in a shared
image folder. When users upgrade to a new service pack, they can
download and apply patch files and do not need to download the
entire image.

Standard

This image is designed for remote users who do not have reliable
access to the company network. When installing this type of image,
remote users inherit all the installation options you specify, such as
the serial number and the products to install.
Users download these images over the internet from the Dassault
Systèmes SOLIDWORKS Downloads site. Accessing and installing
these files from the internet is more reliable than downloading them
from the company network and may reduce the load on the networks.

Remote users install this image using the same techniques supported
by the standard administrative image. You can still script installations
using the sldim.exe and startwinstall.exe files.

Installation files download to a path specified in the Administrative
Image Option Editor before they install. Users must access the
administrative image folder to start the installation and run any
batch or settings files hosted there.

Remote users must have enough available disk space to store all
the files in the image, although users can delete the image after
the installation completes.

Remote Client

The compressed administrative image is for organizations that need
to copy administrative images to multiple sites or client machines
and want to minimize the impact on the network. This image is 60%
smaller than a standard administrative image, but it installs in the
same amount of time. It supports all install operations, such as
modify and repair.
Compressed administrative images also have short file paths. This
avoids problems when images are stored in deep folder structures.

When users upgrade to a new service pack, they must download
the entire image, not only patches.

Compressed

Selecting an Administrative Image Type

To select an administrative image type:
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1. On the Welcome page of the SOLIDWORKS Installation Manager, click Create an
administrative Image to deploy to multiple computers.

2. On the Summary page, next to the Administrative Image Type, click Change .
3. Select the type and click Back to return to the Summary page.
4. Click Create Now.

Specifying the Download Folder

In the Administrative Image Option Editor, you can specify the download folder for the
remote client administrative image. This option is not available for any other administrative
image type.

To specify the download folder:

1. In the Administrative Image Option Editor, under Setup, select a machine or group
and click Change to edit options.

2. In the Client Installation Options, forWhere youwant to download the required
files, click Edit Path and specify the file path.

Allow Subgroups in the Administrator Image Option Editor

You can create subgroups in the Administrative Image Option Editor.

For example, if you have a group for all users in a country, you can create subgroups for
users in different sites in the country, or with different roles. The parent group inherits
the administrative image settings, but you can change those settings for subgroups. You
can also move settings between groups and edit groups of machines.
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Improved SOLIDWORKS Electrical Client Installation

The SOLIDWORKS Installation Manager makes it more apparent if you are installing the
Client only or if you are including Server components for SOLIDWORKS Electrical.

This helps organizations that share SOLIDWORKS Electrical data and databases on a
server instead of on individual machines. For this case, administrators install Server
components once on a server and install the Client only on all machines running
SOLIDWORKS Electrical.

Updates include:

• The Summary page of the SOLIDWORKS Installation Manager identifies if you are
installing a Client Only or if you are including Server components.

• The SQL Server options display only the options that are appropriate for a Client only
installation.

• When the SOLIDWORKS Installation Manager cannot connect to the existing SQL
Server, a warning displays, but the installation continues.

You can connect to the SQL Server later in SOLIDWORKS Electrical.

• The Client and Server options for installing SOLIDWORKS Electrical are also available
in the Administrative Image Option Editor.
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Set Up a PDM Vault View When Creating an Administrative Image

Administrators can set up a local vault view when creating an administrative image for
SOLIDWORKS Enterprise PDM client users.

A local file vault view is the local working folder on a client workstation where files are
cached and where a user edits the content of files that are checked out.

This feature lets administrators create a local vault view without having to create and run
a separate script.

To create the vault view on the client machine, you need a Conisio View Setup (.cvs)
file that defines the parameters for configuring the vault view on the client machine.
You can reference an existing .cvs file or create this file from the Administrative Image
Option Editor.

Creating a PDM Vault View in the Administrative Image Option Editor

To create a PDM vault view in the Administrative Image Option Editor:

1. Under the SOLIDWORKS PDM Client options, click Set up Vault View after
installation.

2. Do one of the following:

• To reference an existing .cvs file, specify the path to this file.
• To create a new .cvs file, click Launch View Setup wizard.

To open the View Setup wizard, you must run the Administrative Image Option
Editor on a machine that has the SOLIDWORKS PDM client installed.
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3
Administration

This chapter includes the following topics:

• Copy Settings When Options Are Locked
• Pack and Go Includes Split and Save Bodies Features in Parts
• Controlling Display of Graphics Warnings in the Settings Administrator Tool

Copy Settings When Options Are Locked

You can use the Copy Settings Wizard in SOLIDWORKS even if your administrator has
locked options.

If an administrator defines options for you, the settings in your swSettings.sldreg file
merge with the administrator settings. When settings conflict, the administrator settings
override the individual settings.

To access the Copy Settings Wizard in SOLIDWORKS, click Tools > Save/Restore
Settings.
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Pack and Go Includes Split and Save Bodies Features in Parts

You can include parts that you create with the Split and Save Bodies features.

When you select a parent part, Pack and Go lists the Split and Save Bodies features as
references of the parent. Pack and Go also updates the names and file paths of the parent
part and features when you rename and move the files.

Controlling Display of Graphics Warnings in the Settings Administrator Tool
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Administrators can control whether or not users can see notifications in their Notifications
area about graphics card and driver certification status.

You can turn Hide graphics card/driver notification on or off and optionally lock the
setting. Click Tools > Options > System Options > Messages/Errors/Warnings.

This option does not affect graphics check results, which are always written to the
performance log.
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4
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Changes to System Options and Document Properties
• Application Programming Interface
• Quick Copy Setting

Changes to System Options and Document Properties
The following options are new, changed, or removed in the software.

System Options

AccessDescriptionOption

Drawings >
Performance

Removed from System Options.Include Detailing
Mode Data when
saving

ImportImports IFC files into SOLIDWORKS.
You can also specify IFC entities to
import from the IFC files by defining
filters in System Options.

IFC

• Export >
TIF/PSD/JPG/PNG.
Available when you
select Use
specified color
for drawings
paper color
(disable image in
sheet
background) in
System Options
> Colors.

• Export > PDF.

Includes the paper color when you save
drawings as image and PDF file formats.

Include drawings
paper color
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AccessDescriptionOption

Export >
EDRW/EPRT/EASM

Renamed from Okay to measure this
eDrawings file.

Enable measure

Export >
EDRW/EPRT/EASM

Renamed from Allow export to STL
for parts & assemblies.

Allow STL export

Export >
EDRW/EPRT/EASM

Renamed from Save table features to
eDrawings file.

Save table features

Export >
EDRW/EPRT/EASM

Saves custom properties from a
SOLIDWORKS document in the resulting
eDrawings

®

files when you Save As an
eDrawings document or Publish to
eDrawings in SOLIDWORKS.

When selected, you can specify Save
file properties for each component
in the assembly. This option saves
custom properties including
configuration-specific properties for each
component in the SOLIDWORKS
assembly.

Save file properties

Export >
EDRW/EPRT/EASM

Renamed from Save shaded data in
drawings.

Save shaded data

Export >
EDRW/EPRT/EASM

Renamed from Save Motion Studies
to eDrawings file.

Save Motion Studies

Messages / Errors
/ Warnings >
Dismissed
Messages

Moved to a separate tab under
Messages / Errors / Warnings.

Dismissed Messages

Messages / Errors
/ Warnings

Renamed from Show reminder if
document has not been saved for n
minutes.

Moved from Backup/Recover to
Messages / Errors / Warnings.

Remind me when a
document has not
been saved for n
minutes

Messages / Errors
/ Warnings

Renamed from Automatically dismiss
after n seconds.

Moved from Backup/Recover to
Messages / Errors / Warnings

Automatically dismiss
notifications after n
seconds

Messages / Errors
/ Warnings

Moved from General to Messages /
Errors / Warnings.

When rebuild error
occurs
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AccessDescriptionOption

Messages / Errors
/ Warnings

Hides notifications about graphics card
and driver certification status.

Hide graphics
card/driver
notifications

PerformanceRenamed from Automatically load
components lightweight.

Load components
lightweight

Document Properties

AccessDescriptionOption

Tables > Bill of
Materials

Renamed from Combine cutlist items
in BOM regardless to profile when
lengths are changed to be the same
(legacy behavior).

Combine same length cut
list items with different
profiles (pre-2019
behavior)

PerformanceSaves all drawings with model data to
use in Detailing mode.

Save model data

PerformanceCreates standard views (such as front,
back, top) when you add drawing views
from the View Palette.

Include standard views
in View Palette

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

Support
There is API support for:

• SOLIDWORKS Inspection Add-In
• SOLIDWORKS PDM Professional Web
• Belt/chain assembly features
• Structure systems
• Graphics mesh and mesh BREP bodies

Redesign
The following have been redesigned:

• Sheet metal base flange and corner relief features
• Messages and alerts for add-ins
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Other Enhancements
• Replace a sketch entity with construction or contour geometry
• Get all decals applied to a component face in an assembly
• Get and set drawing sheet zone parameters
• Get angular ordinate dimension information from the current drawing sheet or view
• Restore default values of Hole Wizard hole or slot feature data
• Upgrade legacy custom properties
• Create a coordinate system based on position and orientation relative to the global

coordinate system
• Add doubled distance dimensions and toggle between single and doubled distance

dimensions
• Get and set whether to use the properties of the material applied when creating a new

sheet metal feature
• For SOLIDWORKS Connected:

• Add new Physical Products and Representations (configurations) to SOLIDWORKS
Connected models

• Convert between parent and derived configurations
• Get and set whether a Representation configuration is shared
• Add and replace assembly components from a 3DEXPERIENCE

®

collaborative space

Quick Copy Setting

The Quick Copy Setting functionality in the Measure tool is re-enabled. You can use it
to copy a value in the Measure dialog box.

To use Quick Copy Setting:

1. Click Measure (Tools toolbar).
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2. In the Measure dialog box, click Quick Copy Setting .
3. In the Quick copy setting dialog box, specify options:

• Turn on quick copy. Enables the Quick Copy Setting functionality in the Measure
dialog box.

• Select number only. Highlights the numerical value in the measurement text
when you hover over it in the Measure dialog box.

• Select number and units. Highlights the numerical value and units in the
measurement text when you hover over it in the Measure dialog box.

4. Click OK.

The next time you measure an entity, you can select Click to copy when you hover
over a value in the Measure dialog box.
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5
User Interface

This chapter includes the following topics:

• Dismissed Messages
• Message Bar
• Redesigned Notifications
• Shortcut Bar and Command Search
• General Usability
• Reference Geometry
• Junk Characters in Beta Unicode View Resolved
• Component Name and Description
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Video: What's New in SOLIDWORKS 2022 - User
Experience

Dismissed Messages

You can view the full information about dismissed messages on a separate tab in the
System Options dialog box. Previously, dismissed messages were truncated and harder
to find.

To view dismissed messages, click Tools > Options > System Options >
Messages/Errors/Warnings > Dismissed Messages.

In the Dismissed Messages table, hover over a truncated message to view the full text.
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Message Bar

A Message Bar is a modeless bar at the top of the main SOLIDWORKS window that
provides information specific to the active document.

There are four types of Message Bars:

• Information
• Acknowledgment
• Warning
• Error

A Message Bar can open in several situations. It is usually a warning about a document
state, for example, that your changes will not be saved because you did not check out
the document. A Message Bar never auto-dismisses - you must manually dismiss it.
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Redesigned Notifications

Notifications are redesigned so they are more intuitive and use a consistent layout. This
includes informational, acknowledgement, warning, and error messages.

Notifications appear for 5 seconds by default, then disappear. Hover over them to keep
them visible. In Tools > Options > System Options > Messages/Errors/Warnings,
the layout is modified to support the redesign. For additional information about
notifications, see Controlling Display of Graphics Warnings in the Settings
Administrator Tool on page 20.
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DescriptionOption

Replaces options in Tools > Options >
System Options > Backup/Recover.

Notifications:

• Remind me when a document has
not been saved for X minutes

• Automatically dismiss notifications
after X seconds

Moved from Tools > Options > System
Options > General

Rebuild Errors > When rebuild error
occurs

NewSystem Notifications area

Shortcut Bar and Command Search

Search All Commands appears in the shortcut bar by default so you can quickly search
for tools from the pointer location and add them to the shortcut bar. You can customize
shortcuts directly from the shortcut bar.

Press S to open the shortcut bar. Type in Search All Commands, select a tool, and click

Insert Command to add it to the shortcut bar.

To customize the shortcut bar, right-click it and click Customize to open the Customize
dialog box to the Shortcut Bar tab. Then drag tools from the tab to the shortcut bar. To
control the display of the Command Search, select or clear Show Command Search in
the shortcut bars.
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General Usability
The user interface is enhanced to improve productivity.

User InterfaceEnhancement

In Tools > Options > System Options >
Import, tooltips provide more information.
Hover over to display the information.

When you drag a non-SOLIDWORKS file into
a part file, a persistent tooltip prompts you
to hold the Alt key to access the Import
Options dialog box for the file type. Drop
the file to open the dialog box.

When you import mesh models with the File
Format of STL/OBJ/OFF/PLY/PLY2, the
appropriate CommandManager tab opens.
If you import mesh models as solid bodies
or surface bodies, the Data Migration
CommandManager tab appears. If you
import mesh files as graphics bodies, the
Mesh Modeling CommandManager tab
appears.

If the tabs do not automatically appear, a
notification prompts you to use the
appropriate tab to edit the imported model.

In Tools > Options > System Options >
Import, text alerts you that the options
Automatically perform import
diagnostics - healing and Perform full
entity check and repair errors do not
apply to STL files.

The DXF/DWG Import dialog box displays
the options in a more visible location and
has an improved user interface.

When you import a drawing into a part file,
a tooltip points out the 2D to 3D toolbar.
The tooltip disappears when you click in the
graphics area.
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User InterfaceEnhancement

On the Align toolbar, a tooltip indicates
when selected entities are aligned.
Previously, there was no indication. This
helps you align 2D files that you import and
use as references to create 3D geometry.

You can add comments to selection sets and
they appear in the Comments folder in the
FeatureManager

®

design tree.

In group boxes of PropertyManagers, you
can select entities, right-click, and save
them to selection sets.

Reference Geometry
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Reference geometry has improved usability that helps you select axes and planes directly
in the graphics area. This is useful for commands such as Mate, Measure, or patterns.

Hover over temporary axes of cylindrical faces and surfaces to display the axes. Hover
over faces, then press Q to display reference planes. Select multiple reference geometry
entities by pressing the Shift or Ctrl keys. After you select reference geometry,
SOLIDWORKS automatically dismisses all unneeded reference geometry.

You can right-click a component in the graphics area, click Reference Geometry Display,
then show primary planes, reference planes, reference axes, or the coordinate system.
Previously, these options were available only from the FeatureManager design tree.

Junk Characters in Beta Unicode View Resolved

In Windows 10 Version 1803 or later, if you selected the Beta: Use Unicode UTF-8 for
worldwide language support option, many user interface elements in SOLIDWORKS
displayed garbled text. Most of these issues have been fixed in SOLIDWORKS

®

2022.

For example, in the Tools > Options dialog box, text in several drop-down lists displayed
incorrect characters. This was a problem seen in almost all languages but it affected Asian
languages more severely.
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Component Name and Description

You can use the Component Name and Description dialog box to specify display options
for the FeatureManager design tree.

The dialog box contains these options:

• Component Name
• Component Description

Primary

• Configuration Name
• Component Description
• Configuration Description

( Secondary )

• Display State Name< Tertiary >

Suppresses the configuration and display state names
when there is only one configuration.

Do not show Configuration
or Display State name if
only one exists

Displays the component name based on the selected
options.

Name Preview
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To access these options, right-click the part or assembly name in the FeatureManager
design tree and click Tree Display > Component Name and Description.

Under Tree Display, Component Name and Description replaces:

• Do not show Configuration/Display State Names if only one exists
• Show Component Names
• Show Component Description
• Show Component Configuration Names
• Show Component Configuration Descriptions
• Show Display State Names
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6
Sketching

This chapter includes the following topics:

• Linear Sketch Entity as Direction Reference
• Pattern and Copy Text in Sketches

Linear Sketch Entity as Direction Reference

For direction reference in a linear sketch pattern, you can select a line from the same
sketch that contains the entities to pattern. Previously, the selected line became a part
of the entities to pattern rather than the direction reference.

• You cannot select a line from a block for direction reference.
• You cannot select and pattern the line that you use for a direction reference.

Selecting Linear Sketch Entities for Direction References

To select linear sketch entities for direction references:

1. Select a plane or a face to sketch on.
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2. Sketch a line for direction reference.
3. Sketch the entities to pattern.

4. Click Linear Sketch Pattern (Sketch toolbar) or Tools > Sketch Tools > Linear
Pattern.

5. In the PropertyManager, under Entities to Pattern, select the sketch entities to

pattern .
6. Select the line to define Direction 1.
7. Define Direction 2.

8. Click .

Pattern and Copy Text in Sketches

In a linear sketch pattern, you can select text as an entity to pattern. You can use Copy
Entities to copy text.
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7
Parts and Features

This chapter includes the following topics:

• Coordinate Systems
• Cosmetic Threads
• Draft Across Parting Lines
• External Threaded Stud Wizard
• Hole Wizard Slots
• Hybrid Modeling
• Mirroring About Two Planes
• Rotating a Section View About a Hole or Axis
• Thickness Analysis Resolution
• Redo Support for Parts
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Video: What's New in SOLIDWORKS 2022 - Parts

Coordinate Systems
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Coordinate systems have improved in how you define and select them.

Using Numeric Values to Define Coordinate Systems

In parts and assemblies, you can define coordinate systems by entering absolute numeric
values for position and orientation.

In the Coordinate System PropertyManager, under Position, select Define position

with numeric values and enter numeric values for the X, Y, and Z coordinates ( ,

, and ). The values define the position relative to the local origin, not the global
origin (0, 0, 0).

To rotate the coordinate system, under Orientation, select Define rotation with
numeric values and enter numeric values for at least one axis. The axes always rotate

in the sequence , then , then .
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Position and rotation definedPosition definedOriginal

Selection for Coordinate Systems

You can reference all parts of coordinate systems, such as planes, axes, and origin, in
downstream features. For example, you can sketch on the XY plane of a coordinate
system or use the Z axis of a coordinate system as the axis for a revolve feature.

In a part or assembly, click Insert > Reference Geometry > Coordinate System
and create the coordinate system. Hover over a plane, axis, or the origin to highlight
each entity. This functionality is useful for actions such as sketching, mating, and more.

To see this functionality, show coordinate systems. Click View > Hide/Show >
Coordinate Systems.
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Cosmetic Threads

Cosmetic threads have improved in appearance and ease of use.

Appearances and Textures

When you apply a cosmetic thread to a part, any underlying appearances or textures on
the part appear between the cosmetic threads.

The cosmetic threads that you apply in SOLIDWORKS are also supported in SOLIDWORKS
Visualize. See Cosmetic Threads on page 139.
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Depth and Feature Ownership

Cosmetic thread behavior is modified to improve usability.

This functionality applies to new parts created in SOLIDWORKS 2022 and later. To

apply this functionality to legacy parts and upgrade them, right-click the part node
in the FeatureManager

®

design tree and select Upgrade cosmetic thread features.

For part templates created in SOLIDWORKS 2022 and later, you can retain the legacy
functionality for Depth and feature ownership. In part templates, before you add
cosmetic threads, click Tools > Options > Document Properties > Drafting
Standard > Annotations and clear Apply new cosmetic thread behavior to new
parts. This option is selected by default for new part templates and cleared for legacy
part templates. This option is enabled for new part templates only; it is disabled for
part documents.

If you use the Insert > Mirror Part command, the mirrored part inherits the cosmetic
thread behavior from the base part. For example, if the base part is created in
SOLIDWORKS 2021, the mirrored part inherits the legacy behavior for cosmetic threads
from the base part.

SOLIDWORKS measures Depth from the original location of an edge regardless of changes
made by downstream features that relocate that edge. In the image above, the original
thread depth is 80 from the edge of the cut extrude. If you add a second cut extrude that
relocates that edge, the cosmetic thread retains the original thread depth of 80 mm.

Cosmetic threads are owned by the latest feature in the FeatureManager design tree
whose face shares the common edge selected for attaching the thread. In the image
below, you create the cut extrude, add a chamfer, then add a cosmetic thread from the
chamfer edge. In SOLIDWORKS

®

2022, the chamfer feature owns the cosmetic thread
because its face shares the common edge with the cosmetic thread.
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Draft Across Parting Lines

You can create draft on both sides of parting lines at the same time from the
PropertyManager. Previously, this process required multiple drafts.

In the Draft PropertyManager, under Draft Angle, select Direction 2 and specify the
draft angles. To use the same draft angle in both directions, select Symmetrical Draft.

Under Parting Lines, select the geometry. Select Show preview to display a detailed
preview of the draft.
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External Threaded Stud Wizard

You can use the Stud Wizard to create external threaded stud features. This tool works
similar to the Hole Wizard. You define the stud parameters then position the studs on the
model. You can also apply thread parameters to existing circular studs.

To create stud features, click Stud Wizard (Features toolbar) or Insert > Features

> StudWizard . To view the threads, click Tools > Options > Document Properties
> Detailing and under Display Filter, select Cosmetic threads or Shaded cosmetic
threads.
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Creating External Threaded Studs

In this example, you create a new stud on a planar surface. You can also create a stud
on an existing cylindrical stud that you can then modify.

To create external threaded studs:

1. In a part, click Stud Wizard (Features toolbar) or Insert > Features > Stud

Wizard .

2. In the PropertyManager, click Creates Stud on a Surface .

3. On the Stud tab:

a) Under Shaft Length , specify a value.
b) Under Standard, select a standard, the Type of thread, and the thread Size.

The Major Diameter value is based on the Size.
c) Under Thread, for End Condition, select Blind and specify the Thread Depth

.
d) To add an external Thread class, select the check box and a class.

You can access this information in drawings.

e) To add an Undercut, select the check box and specify the Undercut diameter

, Undercut depth , and Undercut radius .

4. On the Position tab, select the face to position the stud.

You can position only one stud per feature.
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5. Click .

To view the threads, click Tools > Options > Document Properties > Detailing
and under Display Filter, select Cosmetic threads or Shaded cosmetic threads.

Hole Wizard Slots

When you create and position Hole Wizard slots, press Tab to rotate the orientation 90°
clockwise. You can dimension the slot length using the arc centers.

Previously, you could only drag slots to reposition them and dimension them only with
end-to-end dimensions.
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Hybrid Modeling

You can create a hybrid solid or surface body that includes mesh BREP geometry and
standard SOLIDWORKS BREP geometry. Previously, you could not combine mesh BREP
and standard SOLIDWORKS BREP geometries in a single body.

In this example, do the following:

1. Mold the custom grip in a piece of clay and scan it to create an .stl file.

2. Import the .stl file as a graphics body and convert it to mesh BREP.
3. Add standard SOLIDWORKS BREP features to the part.
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Surface extrude and surface cut

Cut extrude and fillet

Boss extrude

Because the blade is standard SOLIDWORKS BREP geometry, you could refine it with
additional features. For example, you can sharpen the blade, add a serrated edge, or add
back blade features.
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Mirroring About Two Planes

You can mirror about two planes at once. Previously, you needed to create multiple
features to achieve this.

In the Mirror PropertyManager, select a second plane in Secondary Mirror Face/Plane.

Rotating a Section View About a Hole or Axis
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In parts and assemblies, you can rotate a section view plane about an axis, temporary
axis, hole, or cylindrical face.

In the Section View PropertyManager, under Section, click Section About Axis .

Select an axis, hole, or cylindrical face plus a point or vertex to create the section
view plane.

Thickness Analysis Resolution

To optimize the results of a thickness analysis, you can specify the resolution, regardless
of the model size. Previously, the resolution used depended on the model size.

Enable the SOLIDWORKS Utilities add-in. Click Tools > Thickness Analysis . In the
PropertyManager, under Performance/Accuracy, for Resolution, select Low,Medium,
or High. Under Tesselation size, the value updates to reflect the suggested values. To
customize the resolution, enter a custom value. Consider using custom values for models
that have a large bounding box or to define a specific resolution.

The custom Tesselation size value cannot exceed the suggested value for the Low
resolution.
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Redo Support for Parts

Redo support is extended to more commands and actions.

• Inserting and editing of features:

• Hole Wizard

• Simple Hole

• Linear Pattern

• Commands and actions:

• Instant2D
• Reorder features
• Rollback
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8
Model Display

Video: What's New in SOLIDWORKS 2022 - Graphics

Model Display Performance Improvements
SOLIDWORKS 2022

®

offers improved performance for 3D textures and silhouette edges.

Performance ImprovementFunctionality

3D textures accelerate the process of refining the mesh to
better match the detail in the textural appearance image. You
can further refine the Maximum Element Size below its
previous limit.

3D textures

Performance is improved for rendering silhouette edges in
dynamic mode. You can see the silhouette edges in Shaded
With Edges mode.

Silhouette edges
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9
Sheet Metal

This chapter includes the following topics:

• Edge Flanges
• Etched Contours on Bends

Edge Flanges

If you create an edge flange on a nonlinear edge, you can edit the sketch for the nonlinear
edge flange.

In a sheet metal part, select a nonlinear edge and click Edge Flange (Sheet Metal
toolbar). In the PropertyManager, click Edit Flange Profile and edit the sketch.
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Etched Contours on Bends

In sheet metal parts with inscribed text or split line features on the bend face, you can
specify an option to keep the text or split line intact when you flatten, unfold, or fold the
part.

For conical bends, the text or split line only appears in the flattened state when the conical
face is an analytical face. To determine whether the face is analytical, create an axis by
selecting the conical face. If the conical face is analytical, you can create the axis.

To use etched contours on bends:

1. In the FeatureManager design tree of a folded sheet metal part:

a. Expand Flat-Pattern .
b. Right-click Flat-Patternn and click Edit Feature.

2. In the PropertyManager, under Parameters, selectMerge faces and Retain Scribed

Faces and click .

Flattened - 2022Flattened - 2021Folded part
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10
Structure System and Weldments

This chapter includes the following topics:

• End Cap Support
• Custom Properties Architecture
• Complex Corner PropertyManager
• Secondary Members
• Connection Element for Structure Systems
• Properties Dialog Box

End Cap Support

You can add end caps to structure system bodies with closed profiles like tubes, squares,
and rectangular tubes.

Previously, you could add an end cap to weldments only.

Click End Cap (Weldments toolbar) or Weldments > End Cap.
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Custom Properties Architecture

You can upgrade custom properties of files created in SOLIDWORKS 2017 or earlier.

When you run Upgrade custom property on legacy files, their custom properties are
upgraded to the new architecture. After the upgrade, the following features are available
to the legacy files:

• Linked column in the Custom Properties dialog box
• Configuration-specific cut list and custom properties
• Equation in File Properties
• Enhanced Configuration Specific Properties dialog box

When you upgrade the custom properties of a part, you may have to fix issues with
assemblies and drawings where the part is used. For example, the assemblies and drawings
that include derived parts, annotations, and BOMs.

You can upgrade a file manually or in batches using the API (IModelDocExtension::
UpgradeLegacyCustomProperties).

For information, see SOLIDWORKS API Help. You can also contact SOLIDWORKS Technical
Support.
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Upgrading Custom Properties

You can upgrade the custom properties of parts, assemblies, and drawings.

To upgrade custom properties:

1. In the FeatureManager design tree, right-click the top item and select Upgrade
custom properties.
After you upgrade, Upgrade custom properties, is no longer available for that
model.
When you upgrade the custom properties of a drawing, the custom properties of its
model views do not upgrade.

2. Optional: Right-click an assembly that includes parts or subassemblies and click
Upgrade custom properties, then select Upgrade top level assembly or Upgrade
all the components.

Complex Corner PropertyManager

Improvements in the Complex Corner PropertyManager provide a clear workflow to use
the Corner Management functionality.

• On the Two member tab, under Corner Management, the Miter trim plane point
lets you select a point from the graphics area to create the miter trim through the
selected point.

• Options related to Corner Treatment are displayed only if you select the Corner
Treatment check box.

• Icons for planar trim options are smaller than icons for trim type to depict the hierarchy.
• Transfer Material from Profile transfers the material of the selected library profile

if the profile has a material assigned to it.
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Secondary Members

You can create multiple secondary members using Between Points Member for the

selected pair and create secondary members with the Up to Members method.
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Creating Multiple Secondary Members Using Between Point Member

You can create multiple secondary members for a pair of members.

To create multiple secondary members using Between Points Member:

1. In the Secondary Member PropertyManager, click Between Points Member .
2. Under Member Pair, select the pair of members.

3. Under Member Parameter, click to add a secondary member.

Click to delete the selected secondary member.

4. Optional: Adjust the offset usingOffset from First Member and Offset from Second
Member and flip it for the member that is selected under Member Parameter.

Creating Secondary Members with the Up to Members Method

You can create secondary members with Up to Members methods, for example, with
the Point Member pair or From Point options.

To create secondary members with the Up to Members Method:

1. In the Secondary Member PropertyManager, on the Member tab, for Secondary

Member Type, click Up to Members .
2. For Member Point Parameters, select an option:

• Point Member pair. When you select a point and member, creates a member
between them.

• From Point. When you select a point and multiple members, creates multiple
members.

3. Optional: Adjust the offset or flip the members.
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Connection Element for Structure Systems

SOLIDWORKS supports connection elements for structure systems. You can define the
connection element and insert it on a structure system part.

Defining and Inserting Connection Elements

To define and insert connection elements:

1. Click Define Connection Element (Structure System toolbar) or Insert >
Structure System > Define Connection.
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2. In the PropertyManager, on the References tab, specify options to define the connection
element.

3. Click .
4. Save the connection element.

The default location to save the connection element is
install_dir\data\Structure System - Connection Elements. If you cannot
save the connection element to the installation directory, save it locally. You can
add the file location for Structure System-Connection Elements in Tools >
Options > System Options > File Locations.

5. Click Insert Connection Element (Structure System toolbar) or Insert >
Structure System > Insert Connection.

6. In the PropertyManager, on the Connection tab, specify options to insert the connection
element.

7. On the Placement tab, specify options.

8. Click .

Connection Definition PropertyManager - References Tab

The References tab in the Connection Definition PropertyManager lets you create a
connection element for a structure system from a part.

Placement Type

Places the connection element based on the face selection.Generic
Connection
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Places the connection element at the end.End Connection

Generic Connection
If you selected Generic Connection for the Placement Type, you can select the faces
or planes to place the connection element.

Select Primary Reference and Secondary
Reference.

Placement Reference

Specifies the first face or plane.Primary Reference

Specifies the second face or plane.Secondary Reference

Select Coincident, Concentric, or Parallel
based on the Secondary Reference.

Mate Type

Specifies the third face or plane.Tertiary Reference

Select Coincident, Concentric, or Parallel
based on the Tertiary Reference.

Mate Type

Feature Propagation
You can select features such as extruded cuts, holes, advanced holes, patterns, and
mirrors to propagate to the target part. However, if you created a hole based on the
extruded boss feature, you cannot propagate the hole.

End Connection
If you selected End Connection for the Placement Type, you can select a face on which
you want to insert the connection element.

Specifies a face. You cannot select reference planes as inputs.Primary
Reference

Connection Definition PropertyManager - Dimensions Tab

You can select the dimensions of the connection element and then modify them when
you insert the connection element.

Click Define Connection Element (Structure System toolbar) or Insert > Structure
System > Define Connection, and select the Dimensions tab.

Dimension Group
You can create different dimension groups and select dimensions in the graphics area.
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Creates a new dimension group.New Dimension Group

When you insert the connection element, you can edit the selected dimensions.

Insert Connection PropertyManager

This PropertyManager lets you insert the connection element on a structure system part.

To open this PropertyManager:

Click Insert Connection Element (Structure System toolbar) or Insert > Structure
System > Insert Connection.

Connection Tab
This tab displays the default values for Standard, Type, and Size. You can select the
values based on the connection element you saved.

Placement Tab
This tab displays dimension, placement reference, and cut scope.

Dimension
Change the dimension of the feature that you selected in the Dimension Group when
you defined the connection element.
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Placement Reference

Specifies a face in the graphics area to
coincide with the primary reference of the
connection element.

Primary Reference Entity

Specifies a face in the graphics area to
coincide with the secondary reference of the
connection element.

Secondary Reference Entity

Specifies a face in the graphics area to
coincide with the tertiary reference of the
connection element.

Tertiary Reference Entity

Cut Scope
In the graphics area, select the members on which to propagate the cut features. Select
one of the following options:

Propagates the cut feature up to the
adjacent face

Up to Next

Propagates the cut features throughout the
member

Through All

Properties Dialog Box
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The enhanced Properties dialog box provides flexibility to add or edit custom properties.

Click File Properties (Standard toolbar) or File > Properties.

The Summary Information dialog box is renamed to the Properties dialog box. The tabs
included in this dialog box are Summary, Custom, Configuration Properties, and Properties
Summary.

Configuration Properties Tab
The Configuration Properties tab contains two sections.

The first section lists configurations and derived configurations. You can select only one
configuration at a time and enter the properties.

The second section displays the configurations and the values of the selected property.
In the Value/Text Expression column, you can select This Configuration, All
Configuration, or Specify Configuration to apply the property to the selected
configuration, all configurations, or specific configurations.

Properties Summary Tab

The Properties Summary tab contains two sections. The first section lists the properties
of all configurations. The second section lists all configurations. You can add or modify
the property values.

Adding or Modifying a Property

You can add or modify configuration properties.

To add or modify a property:

1. Click Properties (Standard toolbar) or File > Properties.
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2. In the dialog box, on the Configuration Properties tab, click a blank row of the table
and select a property name.

3. In Type, select a property type.
4. For Value/Text Expression, enter the value and select one of the following:

Applies the property to the selected
configuration.

This Configuration

Applies the property to all configurations.All Configurations

Applies the property to specific
configurations.

Specify Configurations

5. Optional: On the Properties Summary tab, select the property and the edit the value.
6. Click OK.

Properties Dialog Box in Large Design Review Mode

The Properties dialog box in Large Design Review (LDR) mode displays only the
Configuration Properties tab in view-only mode.

The Configuration Properties tab contains two sections, and you cannot add or edit the
properties.

• The first section displays only the last saved active configuration with representation
(if any).

• The second section displays all properties of the configuration.
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11
Assemblies

This chapter includes the following topics:

• Opening Subassemblies in a Different Mode
• Excluding a Component from a Bill of Materials
• Configuration Table
• Default Seed Position for Patterns
• Excluding Failed Components in a Section Views
• Resolving Equations in Lightweight Mode
• Move with Triad
• Quick Mates Context Toolbar
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Video: What's New in SOLIDWORKS 2022 - Assemblies

Opening Subassemblies in a Different Mode

You can open a subassembly in Large Design Review or resolved mode from an assembly
opened in Large Design Review mode. You can also open a drawing in Detailing mode.

To open subassemblies in a different mode:

1. Open an assembly that contains a subassembly in Large Design Review mode.

2. Right-click a subassembly and click the down arrow for Open .
3. Click Large Design Review or Resolved.

To open a drawing in Detailing mode:

1. Open an assembly that contains a drawing in Large Design Review mode.

2. Right-click the assembly and click Open Drawing in Detailing Mode .
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Excluding a Component from a Bill of Materials

You can exclude a component, configuration, or model from the bill of materials. When
you select this option, the exclusion occurs the next time you insert the component,
configuration, or model.

To exclude a component from a bill of materials:

1. Open a component and click the ConfigurationManager tab.
2. Right-click a configuration and click Properties.
3. In the PropertyManager, under Bill of Materials Options, select Set 'Exclude from

bill of materials' when inserted into assembly.
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Configuration Table

You can use Configuration Table to modify configuration parameters for parts and
assemblies. SOLIDWORKS creates this table automatically when the part or assembly
has multiple configurations. The configuration table extends the functionality provided in
the Modify Configurations dialog box.

The configuration table contains the following sections:

Feature dimension values and suppression states.Sketches and
Features

Component suppression states and referenced configuration.
Assemblies only.

Components

Configuration-specific custom properties.Custom Properties

Parameters applied to the configuration.Parameters

The Configuration Table dialog box includes options from the Modify Configuration dialog
box and these options:

Controls the visibility of columns that contain suppression
states, and sketch and feature dimensions.

Hide/Show
Sketches and
Features

Controls the visibility of columns that contain component
configurations, fix/float states, and suppression states.

Hide/Show
Components
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Controls the visibility of columns that contain configuration
parameters.

Hide/Show
Configuration
Parameters

Prevents updates to the model. To select this option,
right-click a column header.

When you block edits, the column displays in a different
color. To change this color, click Tools > Options > System
Options > Colors. Modify the Dimensions, Controlled
by Design Table color setting.

In the graphics area, dimensions that are blocked for editing
appear in the same color.

Block model
edits

You can modify the following parameters:

Parts only.Suppress new features

Assemblies only.Suppress new features and
mates

Suppress new components

Assemblies only.Fix / Float

Configures the setting for Child component display
when used as a subassembly in the Configuration
Properties PropertyManager.

Select Show, Hide, or Promote.

Child components in BOM

Configures the setting for Set 'Exclude from bill
of materials' when inserted into assembly in
the Configuration Properties PropertyManager.

Exclude from BOM on Insert

Design Table is renamed to Excel Design Table.

To enable configuration tables:

1. Click Options > Tools > System Options > General.
2. Select Create configuration tables on open.

Using this option can affect performance.

To access a configuration table:

1. Open an assembly that has multiple configurations and click the ConfigurationManager
tab.

2. Expand Tables .

3. Right-click Configuration Table and click Show Table.
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Default Seed Position for Patterns

SOLIDWORKS selection for the default seed position is improved when you create Pattern
Driven Component Patterns.

To view the default seed position for patterns:

1. Open a model and click Insert > Component Pattern > Pattern Driven
Component Pattern.

2. In the PropertyManager, select components for Components to Pattern and Driving
Feature or Component.

The default seed position appears as the Seed Component in the graphics area.

When you select a driving feature, Seed Feature appears in the graphics area.
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Excluding Failed Components in a Section Views

When SOLIDWORKS cannot calculate a section view in an assembly, you can exclude the
components causing the failure, switch to a graphics-only section view, or edit settings
in the PropertyManager.

To exclude failed components in a section view:

1. In an assembly, click View > Display > Section View.

2. Specify options in the PropertyManager and click .
3. When you receive the message that a component cannot be sectioned, select Exclude

the failed components from the section view.

In the PropertyManager, the failed components move to Section by Component
and Exclude selected is selected.

4. Optional: To view the list of excluded components, open the PropertyManager and
review Section by Component.

If you switch to a graphics-only section view, Graphics-only section is selected in the
PropertyManager.
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Resolving Equations in Lightweight Mode

When you open an assembly in lightweight mode, components referenced by equations
in the top-level assembly display as resolved.

When you resolve a part or subassembly that has equations and the equations reference
another lightweight component, the referenced component is resolved.

Move with Triad
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The triad appears automatically when you select one or more components.

When the triad is available, Ctrl + drag to copy the selected components along the
specified direction.

Quick Mates Context Toolbar

By default, Add/Finish Mate is hidden in the Quick Mates context toolbar for the
following mates: coincident, concentric, parallel, symmetric, and tangent.

Lock Rotation and Flip Mate Alignment appear in the Quick Mates context
toolbar.

To show Add/Finish Mate in the toolbar, open a document and click Tools >
Customize. On the Toolbars tab, under Context toolbar, select Show quick mates
and Show OK button.

Show flip alignment and lock rotation after quick mates is removed from the context
toolbar.
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12
Detailing and Drawings

This chapter includes the following topics:

• Cropping an Alternate Position View
• Predefined Views
• Detailing Mode
• Geometric Tolerance Symbols
• Switching Between Radius and Diameter Dimensions
• Bend Lines in Drawing Views
• Bill of Materials
• Cut List Support in BOM Tables
• Symmetric Linear Diameter Dimensions

Video: What's New in SOLIDWORKS 2022 - Drawings

Cropping an Alternate Position View
You can create a cropped view of an alternate position view.

Previously, the Crop View tool did not crop the images of the alternate position view.

1. In an alternate position view, sketch a closed profile such as a circle.
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2. Click Crop View (Drawing toolbar) or Insert > Drawing View > Crop.

Predefined Views

When you create a predefined view in a drawing, you can specify the model orientation
as trimetric, dimetric, or flat pattern. This is helpful if you need drawing templates that
contain specific predefined views.

Click Predefined View or Insert > Drawing View > Predefined. In the
PropertyManager, under Orientation, select Flat pattern, Trimetric, or Dimetric.
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Detailing Mode

Detailing mode is available for all drawings (except detached drawings), regardless of
the SOLIDWORKS version in which you saved the drawing or whether you saved the
drawing in Detailing mode.

In Detailing mode, you can:

• Use limited Detailing mode if you saved drawings in previous versions of SOLIDWORKS
or in SOLIDWORKS

®

2022 without model data. If you open a drawing in limited Detailing
mode, the window title displays file name - sheet name [Detailing - Limited].
(Limited Detailing mode is an automatic mode - you cannot specifically select it.)

• Create hole tables.
• Drag standard views (such as front, top, back) from the View Palette to the drawing.

In Tools > Options > Document Properties > Performance, there are two new
options:

• Save model data. Saves all drawings with model data to use in Detailing mode.
• Include standard views in View Palette. Lets you create standard views when you

add drawing views from the View Palette.

You cannot change these options while in Detailing mode, and they only apply when you
save resolved drawings.

In Tools > Options > System Options > Drawings > Performance, the option,
Include Detailing Mode Data when saving, has been removed.

Detailing mode has replaced Quick view mode. Quick view mode has been removed from
SOLIDWORKS 2022.
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Geometric Tolerance Symbols

The user interface for geometric tolerancing improves your workflow. You work directly
in the graphics area, and the interface guides you as you build feature control frames
cell-by-cell.

With cell-specific context menus and on-screen handles, you can build complex feature
control frames while keeping focus on the frame itself rather than a separate dialog box.

To enter content into the active cell, you enter values and select items from the context
menu. You can randomly enter and edit all the content in the frame. Various cell types
are available, including

• Datum/Datum Group
• Indicator
• Text Box

To add another cell, click a handle and select the cell type. Depending on the location
of the handle, other options are available, for example New Frame and Text Box.

Creating Geometric Tolerance Symbols

When creating geometric tolerance symbols, you can use the handles surrounding the
feature control frame to build the symbol.

To create geometric tolerance symbols:

1. In a part or drawing, click Geometric Tolerance or Insert > Annotations >
Geometric Tolerance.
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2. In the graphics area, click to place the symbol.

A feature control frame appears with handles and a Tolerance dialog box surrounding
it.

3. In the dialog box, specify options to add content to the feature control frame.

4. Click any handle surrounding the feature control frame to add more content.

82

Detailing and Drawings



Switching Between Radius and Diameter Dimensions

In drawings, parts, and assemblies, for dimensions of arcs and circles, you can use the
context toolbar to switch the dimension to display as a radius, diameter, or linear diameter.

Click an existing circular or radial dimension to access the context toolbar.
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Display as Linear

DiameterDisplay as DiameterDisplay as Radius

Bend Lines in Drawing Views

In flat pattern drawing views of sheet metal parts, bend lines are independent of sketches.
You can hide sketches while keeping bend lines visible. Previously, if you hid sketches in
a flat pattern view, the bend lines would also be hidden.

Click View > Hide/Show > Bend Lines or Sketches.
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Bill of Materials

The user interface for bill of materials (BOMs) tables has been updated for ease of use.
When you expand or collapse a BOM, the selectable area spans the entire side of the BOM
table.

Cut List Support in BOM Tables
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The user interface and functionality for detailed cut lists in Bill of Materials (BOM) tables
has been updated for ease of use.

Updates to weldment cut lists tables:

• Table icons match those used in the FeatureManager
®

design tree.
• In Tools > Options > Document Properties > Bill of Materials, the option,

Combine cutlist items in BOM regardless to profile when lengths are changed
to be the same (legacy behavior) is renamed to Combine same length cut list
items with different profiles (pre-2019 behavior).

• Detailed cut lists are available for all BOM types. Previously, detailed cut lists were
only available for indented BOMs. You can specify options in the Detailed Cut List
section of the Bill of Materials PropertyManager.

• You can dissolve components in indented BOMs automatically or manually. In the Bill
of Materials PropertyManager, select Dissolve part level rows to dissolve all weldment
part level rows automatically.

Detailed Cut List selected,
Dissolve part level rows

selected

Detailed Cut List selected,
Dissolve part level rows

cleared

Detailed Cut List cleared,
Dissolve part level rows

cleared

• In the Configuration Properties PropertyManager, under Bill of Materials Options,
you can specify options for Cut list item display when component is used in an
assembly (Indented BOM type with detailed cut list only). This option shows,
hides, or promotes cut list items of indented BOMs. Promote dissolves the part level
row and shows the cut list items in the indented BOM when you select Detailed Cut
List. In the FeatureManager design tree, you can right-click any component and click
Restore in BOM to move the components back to Show Cutlist.

• When you use balloons for subweldment cut list items in BOMs, the balloon properties
correspond to the linked BOM. Before SOLIDWORKS 2022, balloons applied to bodies
that belonged to subweldments appeared with an asterisk. Now the balloons have a
corresponding item number.
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Symmetric Linear Diameter Dimensions

You can create symmetric linear diameter dimensions for diameter dimensions that need
only one side of a leader displayed. This is helpful for drawings with turned components
and detailed section views.

To create symmetric linear diameter dimensions:

1. Open a drawing with a turned component or a section view.

The symmetric linear diameter dimension is available for any drawing view, but it is
best suited for drawings views that need only one side of a leader.

2. Click Symmetric Linear Diameter Dimension (Dimensions/Relations toolbar)
or Tools > Dimensions > Symmetric Linear Diameter Dimension.

3. In the PropertyManager, specify options:
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Single. Lets you manually dimension entities. Select Rapid dimensioning to
dimension entities with the rapid dimension functionality.

•

• Multiple. Lets you create multiple dimensions based on a specified axis. The
dimensions are automatically arranged.

4. Dimension the drawing view.
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13
Import/Export

This chapter includes the following topics:

• Import Performance Improvements
• Importing Selective IFC Entities from IFC Files
• Colors in Exported Sketches
• Opening Non-Native Assemblies with Reference Files Located in Different Folders

Video: What's New in SOLIDWORKS 2022 - Import

Import Performance Improvements
SOLIDWORKS 2022

®

offers improved performance for importing certain file types.

Performance is improved for importing:

• A large DXF or DWG file into a part sketch.

You can import a large DXF or DWG file into a part sketch with the Explode Block option
turned off. You no longer need to explode the blocks to improve import performance.

• STEP files in SOLIDWORKS.
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Importing Selective IFC Entities from IFC Files

You can select which IFC entities to import from the IFC files by defining filters in System
Options.

The file format, IFC, is added to Tools > Options > System Options > Import > File
Format.

To import selective IFC entities from IFC files:

1. In an IFC file, click Tools > Options > System Options > Import.
2. Under File Format, select IFC.
3. Under Entities to import, expand the IFC entities under Classification.
4. Under Import, select the IFC entities to import.
5. Click OK.

After you open the IFC file, only the IFC entities that you specified in the System Options
dialog box are imported.
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Colors in Exported Sketches

When you save a part or drawing as a DWG or DXF file, sketch entities appear in the
assigned sketch color in the exported file. The colors are also supported for sketches in
flat patterns of sheet metal parts if you specify Flat pattern colors in Tools > Options
> Document Properties > Sheet Metal MBD.

Opening Non-Native Assemblies with Reference Files Located in Different
Folders

You can open non-native assemblies whose reference component files are stored in folders
that are not in the same folder tree as the assembly files.

In Tools > Options > System Options > File Locations, in Show folders for, select
Referenced Documents. SOLIDWORKS searches the specified folders that contain the
referenced files in addition to the main folder tree to resolve assembly components.

Supported file formats are Autodesk® Inventor, Pro/E, Solid Edge®, and UG-NX.
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14
SOLIDWORKS PDM

This chapter includes the following topics:

• Integration with Microsoft Windows Active Directory
• Configuration Handling
• Exporting Archive Server and User Logs
• SOLIDWORKS PDM User Interface Enhancements
• Viewing Configurations for All Versions in the Where Used Tab
• Using EXALEAD OnePart Search in SOLIDWORKS PDM
• SOLIDWORKS eDrawings Viewer in the Preview Tab
• Support for Neutral CAD File Formats in eDrawings Web Preview
• Opening a Drawing from the SOLIDWORKS PDM Add-In
• SOLIDWORKS PDM Performance Improvements
• Web2 Data Cards
• Resizing an Image in a Data Card
• Other SOLIDWORKS PDM Enhancements

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased license.
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Video:What's New in SOLIDWORKS 2022 - SOLIDWORKS
PDM

Integration with Microsoft Windows Active Directory

With improved integration with Microsoft® Windows Active Directory, you have more
options to manage users and groups that use Windows login.

The User Properties dialog box has additional fields. You can override the default property
mappings or map properties such as User data that are not mapped to any Active
Directory attribute. In the Administration tool, right-click Users and Groups Management
and click Active Directory Property Mapping.

• You must have Can administrate users administrative permission.
• You can map a user property to only one Active Directory attribute.

You can also:

• Import the user's profile picture from the Active Directory.
• View the profile picture in the SOLIDWORKS PDM menu bar if you have set it in the

Active Directory. Hover over Logged in as to view the image in larger size.
• Edit the presence note directly from the user pop-up window.

• Identify Windows users and groups through an indicator in the icons .
• Validate Windows groups. In the Administration tool, under Users and Groups

Management, right-click Groups and click Validate Groups from Active Directory.
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If the group does not exist in the Active Directory, the icon displays with a red plus

indicator . Right-click the group name and click Information to view details.
• Validate SOLIDWORKS PDM and Windows user logins. Right-click the user name and

click Validate Logins. If SOLIDWORKS PDM user information is invalid, the user icon

displays with a red lock indicator . Right-click the user name and click Information
to view details.

Configuration Handling

SOLIDWORKS PDM 2022 offers more control over configurations.

• For many card controls, you can assign a default value to automatically fill in the control
variable when a user saves a new file or item or adds it to the vault. Previously, you
could either apply default values to all configurations or use Exclude configurations
to specify a list of configurations to exclude. You also have the ability to apply default
values only for @ configuration.

• You can configure the display of configurations in data cards. In SOLIDWORKS PDM
File Explorer, click Display, select Datacard Configuration Display, and select one
of the following:

• Show all configurations
• Show @ configuration only
• Hide @ configuration

For SOLIDWORKS PDM 2021 or earlier client versions, if you selected Hide @
configuration, it remains selected after you upgrade to SOLIDWORKS PDM 2022.

You can add Datacard Configuration Display to shortcut menus and SOLIDWORKS
PDM menus located above the right pane. In the Administration tool, right-click a user
or group and click Settings. Use theMenus page to add the Datacard Configuration
Display command to the menus.
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Exporting Archive Server and User Logs

You can export a summary of archive server and user logs in multiple file formats.

You can export the logs in:

• Comma Separated Value Files (*.csv)
• JSON Files (*.json)
• Text Files (*.txt)
• All Files (*.*)

Exporting Archive Server Logs

To export archive server logs:

1. In the Administration tool, right-click archive server name and click Show the Archive
Server Log.

2. In the Log File dialog box, click Save As.
3. In the Save As dialog box, enter a name in File name, select Save as type, and

click Save.

Exporting User Logs

To export user logs:

1. In the Administration tool, under Local Settings, double-click Log File.
2. In the Log File dialog box, click Save As.
3. In the Save As dialog box, enter a file name in File name, select Save as type, and

click Save.
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SOLIDWORKS PDM User Interface Enhancements

The SOLIDWORKS PDM user interface has improvements that enhance usability and
readability.

• When you perform a file operation, you can see the number and type of files affected
by that operation. This feature is available in the following dialog boxes:

• Check In
• Check Out
• Undo Check Out
• Change State
• Get
• Rollback

• You can resize columns of the variables area in the SOLIDWORKS PDM task pane
add-in. This improves the readability of variables and values.

• The SOLIDWORKS PDM task pane add-in follows the color theme of SOLIDWORKS.
When you hover over any row in the file list of the add-in, it is highlighted.
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Viewing Configurations for All Versions in the Where Used Tab

You can view configurations of part or assembly files when you select All Versions in
the Where Used tab.

The list contains all configurations across all versions of the selected file to which you
have access permission. From the list, select a Configuration to view its references.

Using EXALEAD OnePart Search in SOLIDWORKS PDM
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EXALEAD OnePart Search is now integrated in SOLIDWORKS PDM.

You must configure EXALEAD
®

OnePart in the Administration tool. Right-click EXALEAD
OnePart and click Open. In the EXALEAD OnePart dialog box, enter URL, Connection
name, and select Protocol.

• This functionality is available only in SOLIDWORKS PDM Professional.
• This requires an EXALEAD OnePart license. The SOLIDWORKS PDM Installation

package does not include this license and you need to obtain it separately. Contact
your SOLIDWORKS Value Added Reseller for more information.

• You must have File vault management administrative permission.

To perform a search in the SOLIDWORKS PDM File Explorer, click on the SOLIDWORKS
PDM menu bar, and select EXALEAD OnePart Search. The EXALEAD OnePart Search
user interface displays in an embedded browser control in the vault view.

SOLIDWORKS eDrawings Viewer in the Preview Tab

All of the view functions in eDrawings
®

Viewer are available in the Preview tab of
SOLIDWORKS PDM File Explorer.

DescriptionOption

Click Display > Options > Show full UI in SOLIDWORKS
preview.

View SOLIDWORKS
eDrawings toolbar

Displays a markup if the selected file contains a markup.
View markup associated
to a file
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DescriptionOption

Click Display > Options > Show bitmap for SOLIDWORKS
files. On the Preview tab, click Load Preview. Previously, you
had to click the thumbnail preview image to access the
eDrawings preview.

View eDrawings preview
for SOLIDWORKS files

Support for Neutral CAD File Formats in eDrawings Web Preview
In SOLIDWORKS PDM Web2, you can open and view neutral file formats for eDrawings
WebGL.

Support is available for the following file formats:

• STEP (.step, .stp)
• IGES (.iges, .igs)
• Parasolid (.X_B, .X_T, .XMT, .XMT_TXT)
• JT (.JT)
• Acis Sat (.SAT, .SAB)

Opening a Drawing from the SOLIDWORKS PDM Add-In

In the SOLIDWORKS PDM Add-in, you can open a drawing of a SOLIDWORKS part or
assembly file.

To open a drawing, click on the SOLIDWORKS PDM task pane or right-click the part
or assembly and click Open Drawing.

The drawings may not be locally cached, can have a different name from the part or
assembly file, and can exist in a different folder.

99

SOLIDWORKS PDM



SOLIDWORKS PDM Performance Improvements
With SOLIDWORKS PDM 2022, you can experience improved performance of many
file-based operations.

You can perform the following actions faster for database servers with high latency:

• Open files
• Display the Save As dialog box
• Copy Tree
• Create a document in SOLIDWORKS

SOLIDWORKS PDM has improved performance for the following:

• Saving a data card with a large number of file extensions is faster by 15% to 60%.
• Checking in a drawing with a large SOLIDWORKS bill of materials (BOM) is significantly

quicker.
• Displaying files in the Where Used tab with the Show All option and additional custom

columns is many times faster for certain vaults.
• Displaying the Transition dialog box for dynamic notifications is quicker.
• Loading a Web2 preview is between 1.5 and 2 times faster for large models.

Web2 Data Cards

SOLIDWORKS PDM offers more ways to configure the layout of the data card for Web2
and improve the readability of your data.

Available in SOLIDWORKS PDM Professional only.

In the Administration tool, in the Card Editor window, click Configure card for web on
the Card Properties pane.
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You can control the visibility of data card control for Web2. In the Card Editor window,
in the right pane, under Flags, select Show in web card. This lists the data card control
in the web configuration editor and displays it in the data card for Web2.

• Available only for file cards.
• Available only for the following data card controls:

• Checkbox
• Combobox Dropdown
• Combobox Droplist
• Combobox Simple
• Edit
• List
• Date Field
• Radio Button

In the web configuration editor of data cards, you can:

• Click Settings and specify the layout of the data card controls as Flat or Tree.
• Edit labels and change the order of controls.

You cannot add or remove controls from tabs. To do so, use the main card editor.

• Add controls in a frame in the Tree layout and define their order of appearance.

The user interface of Web2 data card has the following improvements:

• Navigation control for Tree layout
• Date picker to specify DATE type controls
• Multiline box to enter descriptions
• Radio button and check box controls
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Resizing an Image in a Data Card

In the Administration tool, you can resize an image on a data card by dragging the control
handles.

In the Card Editor, in the Image properties pane, select Lock aspect ratio to maintain
the image aspect ratio. Click Reset to restore the image to its original size.

Other SOLIDWORKS PDM Enhancements
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SOLIDWORKS PDM 2022 has new APIs and other improvements.

• You can save a card that has more than 2000 characters in an alias in an input formula.
• In the Transition Action dialog box, when you specify Type as Set Variable, you can

define the value of the selected variable as Filename without extension.

SOLIDWORKS PDM APIs are available to:

• Define Next counter value for serial numbers in the Administration tool.
• Add or modify some of the user settings.
• Edit the name of a named BOM.
• Select files to destroy from the deleted files.
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15
SOLIDWORKS Manage

This chapter includes the following topics:

• Create Record Process Output
• Recent Files
• Object Structure Editor
• Record Hyperlinks
• User Interface
• Avatar Images and Icons
• Plenary Web Client
• Check Out Rights for Affected Items
• Replace User
• Creating and Deleting Multiple Field Groups
• SOLIDWORKS PDM User-Defined References
• SOLIDWORKS Manage Performance Improvements

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Video:What's New in SOLIDWORKS 2022 - SOLIDWORKS
Manage

Create Record Process Output

The Create Record process outputs have improved with new record attachments and
subfolder locations.

You can:

• Attach a new record created by a Create Record process output as an affected item in
the process.

• Specify a subfolder in which the new record is created.
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Recent Files

When you add new file data, you can choose from a list of recently accessed files in
Windows. This is a convenient way to add data by not having to browse to recent locations.

Click the Recent tab in the Primary File Source dialog box when creating a new document
record or click Add > Add from Recent Files when adding related files.

Object Structure Editor
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For ease of use when administrators work with object structures, you can access the
Administration (Structures) dialog box directly from the user interface.

In the Module Objects area, right-click and click Tools > Administration (Structures).

Record Hyperlinks

You can copy a hyperlink to a record that you can copy into a document or email, to
provide quick access through the Plenary Web client. Right-click and click Tools > Copy
Hyperlink.

You can also open the record in the web client directly from the desktop client. Right-click
and click Tools > Open Record in Web Browser.
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User Interface

The SOLIDWORKS Manage user interface has many improvements that create consistency
and a better user experience.

ImprovementFunctionality

The controls in the BOM interface are modernized and
consistent.

Bill of Materials (BOM) layout

The flyout panel in the BOM tab is reorganized. You can
collapse different areas, providing a better view of
information.

BOM flyout panel

You can reorder columns in the Open and Structure tabs
of the SOLIDWORKS Manage Add-in.

SOLIDWORKS Add-in

The object grouping displayed in the Where Used As Field
tab (usually displayed as the Referenced tab) shows the
associated icon, module name, and number of results for
each module type.

Where Used As Field tab

You can specify the position of the history lines in the
Process tab to display at the bottom or on the right side.
This improves screen usage depending on the layout of
the process diagram.

Process tab

The project Properties card displays a yellow information
bar for consistency with other record types. You can
collapse the system property and thumbnail image area
to provide more space.

Project Properties card
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Avatar Images and Icons

To make users more recognizable in SOLIDWORKS Manage, you can add default avatar
icons for users. Avatar images are displayed on the Users tab of the Administration tool.

To specify avatar images and icons:

1. In the Administration tool, click the Users tab.
2. Right-click and click Set > User image.
3. In the dialog box, specify options:

• Create new image for all selected users
• Create new image for selected users without an image

4. Click Apply.
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Plenary Web Client

You can log in to the Plenary Web Client with a SOLIDWORKS PDM username and
password. Previously you had to use a SOLIDWORKS Manage password, then separately
log in to a SOLIDWORKS PDM object.

Check Out Rights for Affected Items
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Process administrators have additional controls over who can check out affected items
while they are in a process.

Options include:

• User who accepts this stage. Limits check out rights to a single user who accepts
the stage.

• User(s) from this field. Allows administrators to specify check out rights to users
for a specified object type field defined for the process.

Replace User

You can select specific objects to replace users and specify the Change "Checked Out
By" value for someone who is replacing the selected user.

Replacing users is helpful when importing data where there are duplicate usernames. It
is also useful when a user leaves the company and you need to reassign their work to
another user.

You cannot replace users for SOLIDWORKS PDM objects.
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Creating and Deleting Multiple Field Groups

You can create multiple field groups at once, by entering multiple lines or copying and
pasting from a text-based file (such as .xlsx, .txt, or .csv). You can Shift + or Ctrl
+ select multiple field groups to delete them.

To create multiple field groups:

1. In the Field Groups dialog box, click the New tab and click Create multiple Field
Groups.

2. In the Create multiple Field Groups dialog box, copy and paste field groups from a
text-based file.

3. Click .
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SOLIDWORKS PDM User-Defined References

There is expanded support for displaying SOLIDWORKS PDM user-defined references
(Paste as Reference).

You can include references between:

• SOLIDWORKS part files and other SOLIDWORKS part files
• Non-SOLIDWORKS files (such as Microsoft® Word documents) and SOLIDWORKS part

files

SOLIDWORKS Manage Performance Improvements
SOLIDWORKS Manage 2022 offers improved performance for enhancing the user
experience.

Performance ImprovementFunctionality

When specifying the Number of BOM levels to display
options at 1, large BOMs display up to five times faster. For
BOMs with Link to 3rd Party fields configured, the time
required to calculate the values has decreased.

Bill of material (BOM)
display

For projects with a high number of stages or Tasks, the Gantt
chart display is faster than in previous releases.

Projects

In previous releases, the Check Out/Check In operations
refreshed the entire grid in the background. Now, only the
individual line item that last changed refreshes, making
performance faster.

Check out/check in of
SOLIDWORKS PDM files
from SOLIDWORKS
Manage
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16
SOLIDWORKS Simulation

This chapter includes the following topics:

• Blended Curvature-Based Mesher
• Bonding and Contact Architecture
• Linkage Rod Connector
• Simulation Solvers
• Simulation Performance

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Video:What's New in SOLIDWORKS 2022 - SOLIDWORKS
Simulation

Blended Curvature-Based Mesher

Using the Blended Curvature-based mesher, you can apply mesh control that has a larger
element size than the global mesh size.

Create a coarser mesh for bodies that may be not critical for the simulation to reduce the
analysis time. Previously, you could only apply a mesh control to refine the mesh of
selected bodies and geometric entities.

After creating a mesh, you can access the Mesh summary, which reports the size
assignments of individual bodies and geometric entities. In a Simulation study tree,
right-click Mesh and click Summary.

The Blended Curvature-based mesher is the default mesher for new simulation studies.

The option Calculate Minimum Element Size (available for the Blended
curvature-based mesher) is removed from the Mesh PropertyManager.
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Bonding and Contact Architecture

Several enhancements to the bonding and contact architecture improve the overall
performance and accuracy of the simulations.

• Removal of duplicate degrees of freedom in bonding and contact constraint equations
• Reduced bonding and contact constraint equations
• Measurement of bonding and contact strains in units of distance rather than volume
• Improved calculation for the constraint area
• Optimization of unitless parameter associated to bonding and contact penalty stiffness
• Elimination of unnecessary function calls for small tasks within the contact search code

Performance improvements based on these enhancements are more noticeable for
simulations that run with the FFEPlus iterative solver and have a large percentage of
nodes participating in bonded and contact interactions.
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Linkage Rod Connector

You can specify a Linkage Rod connector between cylindrical faces, circular edges (for
shells), or vertices to model the behavior of connecting rods.

The Linkage Rod connector is available with SOLIDWORKS Simulation Professional and
SOLIDWORKS Simulation Premium.

To open the Linkage Rod PropertyManager:

In the Simulation study tree, right-click Connections and click Linkage Rod .

The following table describes the key options of the Linkage Rod PropertyManager.

Specifies cylindrical faces or shell edges to attach a linkage
rod connector.
You select two geometric entities to position the end joints
of the connector.

Concentric
cylindrical faces
or edges (for
shells)

Specifies two vertices to attach a linkage rod connector.

You can also select a vertex for one end joint of the
connector and a cylindrical face or shell edge for the other
end joint.

Vertex

Specifies the connector's end joint to a rigid joint.
A rigid joint prevents any rotations or deformations. A
linkage rod connector with rigid joints can transfer all
moments from one part to another.

Rigid joint
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Specifies the connector's end joint to a pivot joint.
A pivot joint allows only one rotation about the axis normal
to the connector's axis.

Pivot joint

Specifies the connector's end joint to a spherical joint.
A spherical joint acts like a ball and socket joint where the
ball can rotate inside the socket, but it cannot dislocate from
the socket.

Spherical joint

Specifies an offset distance to position the end joints of the
connector. You can only select cylindrical faces or circular
edges to define an offset distance.

Offset

Specifies the cross section geometry of the connector:
• Solid circular
• Hollow circular
• Solid rectangular
• Hollow rectangular

Section
Parameters

Applies a material to the connector from the SOLIDWORKS
material library or applies a custom material.

Material

You can list a linkage rod connector's forces such as shear force, axial force, bending

moments, and torque after you run a simulation. Right-click Results and click List
Connector Force.

The linkage rod connector is not available for nonlinear and thermal studies.
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Simulation Solvers

Function-based processing for the FFEPlus iterative and Intel Direct Sparse solvers is
extended to simulation studies that include connectors and other features. The automatic
solver selection is extended to Nonlinear, Frequency, and Buckling studies.

• FFEPlus iterative and Intel Direct Sparse solvers

The transfer of stiffness data to solve the systems of equations is optimized because
file-based processing is replaced with function-based processing. Performance is
improved for simulations that contain:

• Connectors: spring, bearing, bolt, and rigid
• Cyclic symmetry, remote load with rigid connection, and beams acting as stiffeners.

• Automatic Solver Selection

The algorithm that selects the best equation solver is improved to include Nonlinear,
Frequency, and Buckling studies. The selection of the best equation solver (Intel Direct
Sparse or FFEPlus Iterative) depends on the number of equations, load cases, mesh
type, geometric features, contact and connector features, and available systemmemory.

For Frequency studies, in addition to the previously mentioned parameters, the
algorithm also factors in the number of frequencies. For Buckling studies, it factors in
the number of modes.

• Intel Direct Sparse solver for Linear Dynamic studies

You can use the Intel Direct Sparse solver for Linear Dynamic studies with Selected
Base Excitation for frequency and response calculations.

• If you experience a solver failure while running a simulation, SOLIDWORKS Simulation
prompts you to send the file that records information related to the solver failure to
the technical support team.
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The development team can extract information from the modules that caused the
solver failure based on the data from the SIMSTACK-*.dmp file without using any
additional information. The benefit of this enhancement is that you do not need to
share confidential model data to troubleshoot a simulation solver failure.

Simulation Performance
It takes less time to save SOLIDWORKS models that have simulation studies.

Saving models that have simulation studies is faster, if at least one or more simulation
studies are not modified.
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17
SOLIDWORKS Visualize

This chapter includes the following topics:

• Match Camera Perspective to Backplate
• Shadow Catcher Property
• Scenes Tab
• Animations
• Render Output Viewer
• Patterns
• Corner Radius
• Cosmetic Threads

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.
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Video:What's New in SOLIDWORKS 2022 - SOLIDWORKS
Visualize

Match Camera Perspective to Backplate

With the Match Camera tool, you can manipulate a camera by aligning vanishing lines
to a backplate image. This allows more precise positioning of a model in front of a
backplate.

A common challenge when placing a model in front of a background image (backplate)
is that you have to manually adjust the extrinsic (position and orientation) and intrinsic
(perspective and focal length) camera parameters so the composition looks plausible. In
SOLIDWORKS Visualize Professional, the Match Camera tool helps you find the perfect
camera parameters for real world photographs.

Click Tools > Match Camera.

Using the Match Camera Tool

To use the Match Camera tool:

1. In SOLIDWORKS Visualize Professional, open a project that has a backplate.
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2. Click Tools > Match Camera.

Solid and dashed lines appear over the backplate image.

3. In the Match Camera dialog box, specify options.
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4. In the 3D Viewport, align the lines and points with the backplate's vanishing lines.

DescriptionLine/Point Type

Vanishing line in the X direction
(horizontal). Drag the line or its points to
match the backplate image.

Red solid line and solid points

Extension of the vanishing line in the X
direction beyond its endpoints. The hollow
red point is the vanishing point on the
horizon line (which may be outside of the
3D Viewport).

Red dashed lines and hollow points

Vanishing line in Z direction
(horizontal).Drag the line or its points to
match the backplate image.

Blue solid line and solid points

Extension of the vanishing line in Z
direction beyond its endpoints. The hollow
blue point is the vanishing point on the
horizon line (which may be outside of the
3D Viewport).

Blue dashed line and hollow points.

Vanishing line in Y direction (vertical).
Drag the line or its points to match the
backplate image. This is optional and only
displayed when you specify Vanishing
Points as Three. The vertical vanishing
line does not result in a vanishing point
on the horizon line.

Green solid line and solid points

Horizon line that connects the two
(horizontal) vanishing points. Match the
horizon line to the actual horizon in the
backplate image. It validates the result.

Yellow dashed line

124

SOLIDWORKS Visualize



5. Click OK.

Match Camera Dialog Box

To access this dialog box:

1. In SOLIDWORKS Visualize Professional, open a project that has a backplate.
2. Click Tools > Match Camera.

Specifies Two dimensions (horizontal) or Three dimensions
(horizontal and vertical axes).

Two is recommended.

Vanishing Points

Flips the reference axes.
Depending on the order and direction of the axes, the Camera
Match tool may result in a camera that is oriented upside down.

Reference Axes

Locks the camera longitude so that the object remains focused
from the same angle.

Lock Rotation

• Horizon. Shows the horizon line (yellow dashed line).
• Line Extensions. Shows the dashed extensions of the

vanishing lines (red, blue, green lines).
• Vanishing Points. Shows the vanishing points (hollow red

and blue points) on the Horizon.

Display Options

Resets the vanishing lines and points to their default locations.Reset

Indicates whether the match camera solution is mathematically
solvable. If Undefined, the camera properties remain
unchanged.

Status
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Shadow Catcher Property

You can turn any part object geometry into a shadow catcher object. Shadow catchers
show the background through them and display shadows cast from lighting in the scene.
For example, you can create a wall and specify it as a shadow catcher.

The shadow catcher object allows control over the shadow intensity, reflection and
reflection roughness.

Shadow catcher is only available:

• In SOLIDWORKS Visualize Professional or SOLIDWORKS Connected.
• When you specify Rendering Selection as Accurate.

Using a Shadow Catcher

To use a shadow catcher:

1. In the Palette, on the Models tab, select a part in the Model tree to use as a shadow
catcher.
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2. On the General subtab, under Shadow Catcher, specify:

• Enable. Turns on the shadow catcher functionality.
• Shadow Intensity. Lightens or darkens the shadow.
• Reflection. Specifies the amount of reflectivity on the shadow catcher object.
• Roughness. Specifies how blurry the reflections appear for Reflections greater

than 0.
• Advanced Caustics. Improves the quality of caustic reflections in some scenes.

This applies globally in the scene (not per shadow catcher object). An example is
the shifting patterns of light and shade cast on the floor of a swimming pool on a
sunny day.

When you specify the plane as a shadow
catcher, you see the backplate image with

the shadow cast more naturally
A plane is at the back wall of the stage in

the backplate image

Scenes Tab
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Floor Effects parameters on the Scenes tab have been renamed for consistency with
the shadow catcher functionality.

The following updates are available in the Palette, on the Scenes tab, on the Advanced
subtab.

2022 User Interface2021 User Interface

Ground Shadow CatcherFloor Effects

Advanced CausticsCaustics

RemovedFloor Caustics

ReflectionFloor Reflection

RoughnessFloor Roughness

EnableFloor Shadow

Animations

Animations are improved in areas such as motion studies, organization, keyframes, and
cameras.

Improvements include:

• Support for multiple motion studies per model set. You can import multiple
SOLIDWORKS motion studies for SOLIDWORKS parts and assemblies. This is helpful
because you:

• Do not have to reanimate the part or assembly in SOLIDWORKS Visualize.
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• Can use tools such as Mate Controller and flexible subassemblies.

• You can organize animated items in each animation with grouping functionality. You
can also use tools to sort and filter the animation timeline.

• Suppress or unsuppress individual keyframes in animations and copy keyframe
properties from one keyframe to another.

• Use multiple cameras in animation sequences to switch among multiple cameras during
animation playback.

Animation List User Interface

The user interface for SOLIDWORKS Visualize animation list has additional functionality
and is updated for ease of use.

Tools

Updates to animation tools:

• Basic animation tools. Located at the top center of the animation timeline.
• Advanced animation tools. Located at the upper right of the animation timeline.
• Motion study tools. Above the animation list, click the Motion Study list to create a

new motion study or change to a different motion study.

On the menu next to the Motion Study list, you can:

• Adds a new item . Creates a new motion study. Subsequent animation editing
applies to the new motion study only.

• Duplicates the current item . Copies the active motion study.

• Edit the name of the current item . Renames the active motion study.

• Camera switch animations. You can create a Camera Sequence layer to switch among
multiple cameras during animation playback.
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Animation list

Updates to the animation list:

1. Add . Lets you:

• Create New Group. Creates a new group into which you can drag animation
tracks.

• Add to New Group. Adds selected animation tracks into a group.
• Create New Camera Sequence Animation. Creates a camera switch so you

can assign or switch cameras in the animation timeline. The camera automatically
switches during animation playback.

2. Change View . Increases (Large List) or decreases (Small List) the animation
timeline icons and font.

3. Change Sort Mode . Sorts the animations based on Name, Type, and in an
ascending or descending order. You can also filter object types in the animation list
by Decals, Environment, and so on.

4. Search . Narrows the animation list when you enter search criteria.
5. Animated Object Types . Displays a column with an icon representing the animated

object type, such as Model , Group , and Part .
6. Animation track colors. Assigns colors to the animation tracks depending on the object

type. You can change the colors in Animation Properties.
7. Selection. If you select an animation track, the animated object highlights in the

viewport and Model tab, and vice versa.
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Keyframes
Updates to keyframes:

• Suppress Keyframe/Unsuppress Keyframe. Suppresses or unsuppresses animation
keys. On the timeline, right-click an animation key and click Suppress Keyframe or
Unsuppress Keyframe. When suppressed, the animation keys are ignored during
playback..

• Transition, Tension, and Motion Ease.

• In the Keyframe Properties dialog box, you can specify numerical values for Tension
and Motion Ease. You can specify their default keyframe properties in Tools >
Options > User Interface.

• You can copy/paste keyframe values across other animations. Right-click a keyframe
and click Copy Settings. Right-click another keyframe and click Paste Settings.
In the Paste Settings dialog box, you can select Transition, Tension, and Motion
Ease settings to paste.

Render Output Viewer

You can use the render Output Viewer to manage render jobs and their respective output
on a per project basis. You can recall (or re-execute) any previous rendering done in a
project, directly from the render Output Viewer.

Previously, rendered jobs were not stored with the project and thumbnails were not
available for viewing. This made it difficult to share renderings among users. With the
render Output Viewer:

• Referenced rendered output remains when you save a project. For example, if you
send the project to another user, that user can see the rendered output content in the
Output Viewer.

• Render jobs can include an individual image or multiple rendered images. Content
includes:
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Single image renders•
• 360 camera renders
• Rendered layers (such as Albedo, Alpha, and Depth)
• Configurations
• All camera renders

• You can scroll through thumbnails of rendered output content and multiselect rendered
content to publish to 3DSpace or 3DSwym

®

.

The Render tab has been renamed to the Output Viewer tab. Click Output Tools
(Main toolbar). In the Output Tools dialog box, click Start Render or click View > Show
Output Viewer.

User Interface

The Output Viewer tab (formerly the Render tab), is redesigned for a better user
experience.

Areas of the Output Viewer tab include:
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DescriptionArea

Displays a list of render job
submissions. You can:
• Monitor render progress
• Pause or save renders
• Initiate rerenderings
• Review the Output Tools

options for the renders
• Right-click a render job and

click Remove Job
• Right-click in the render job

palette and:

• Delete unlinked render
jobs

• Sort render jobs

• Right-click the scroll bar
and scroll to various areas

1. Render job palette

Displays output content being
rendered. It also acts as a
content viewer where you can
see completed render jobs.
In the upper right corner of
the render viewport, you can:

• Publish to 3DSpace .

• Publish to 3DSwym .
Publishes rendered content
to 3DSwym.

2. Render viewport

Lets you select renderings to
open or view in the render
viewport.
When you click a thumbnail,
the image opens in the render
viewport. If you double-click
a thumbnail, the image opens
in an external viewer.

3. Image thumbnails
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Patterns

The Pattern tool is an evolution of the traditional Formation functionality.

You can base a pattern on a single model that you instance multiple times or on several
different models.

Click Project > Models > New Pattern.

Creating Patterns

To create patterns:

1. Click Project > Models > New Pattern.

2. In the Palette, on the Models tab, on the General subtab, under Formation,
specify options.

Formation Settings

The Formation settings apply when you pattern a model.

To access this dialog box, click Project > Models > New Pattern.

Specifies the model to pattern. The selected model is hidden in the
3D Viewport.

You can drag different models into the pattern to form a customized
pattern. In this case, Formation is not available.

Formation

Specifies the pattern type: Vee, Circle, Grid, Scatter.Type
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Vee

Vee formations use an angle to specify the opening angle of the vee.

Specifies the number of objects in the pattern.Number of
Objects

Specifies the opening angle of the vee.Angle

Specifies a vector whose length defines the distance between
instances and whose direction affects the pattern orientation.

Distance XYZ

Specifies the rotation of the instances in the pattern in Euler angles
(degrees).

Rotation XYZ

Specifies the scale of the instances in the pattern in X,Y, and Z
dimensions.

Scale XYZ

Accumulates the distance, rotation, or scale over the sequence of
instances. When cleared, the distance, rotation, or scale is absolute
(constant).

Relative

Specifies an overall scale multiplier to the X, Y, and Z dimensions
of the scale for all instances.

Scale All

Circle

You can use the Circle formation to arrange instances in a circle or arc. The Circle is the
only formation where several parameters are linked such that changing one affects the
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others. For example, if you increase the Number of Objects, the Distance XYZ value
decreases so the Radius stays the same.

Specifies the number of objects in the pattern.Number of
Objects

Specifies the radius of the circular pattern.Radius

Specifies a circle or an arc by specifying a value less than 360°.Angle

Specifies a vector whose length defines the distance between
instances and whose direction affects the pattern orientation.

Distance XYZ

Specifies the rotation of the instances in the pattern in Euler angles
(degrees).

Rotation XYZ

Specifies the scale of the instances in the pattern in X,Y, and Z
dimensions.

Scale XYZ

Accumulates the rotation or scale over the sequence of instances.
When cleared, the rotation or scale is absolute (constant).

Relative

Specifies an overall scale multiplier to the X, Y, and Z dimensions
of the scale for all instances.

Scale All

Grid

Depending on the value of Number of Objects X, Y, and Z, the Grid formation can be
a line (a value greater than 1 in a single dimension and a value of 1 in the other two
dimensions), a plane (a value greater than 1 in two dimensions and a value of 1 in the
third dimension), or a cube (a value greater than one in all three dimensions). The total
number of instances is equal to the product of the Number of Objects X, Y, and Z.

The total number of objects is the product of the values of Number of Objects X,
Number of Objects Y, and Number of Objects Z.

Specifies the number of objects in the X dimension.Number of
Objects X
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Specifies the number of objects in the Y dimension.Number of
Objects Y

Specifies the number of objects in the Z dimension.Number of
Objects Z

Specifies a vector whose length defines the distance between
instances and whose direction affects the pattern orientation.

Distance XYZ

Specifies the rotation of the instances in the pattern in Euler angles
(degrees).

Rotation XYZ

Specifies the scale of the instances in the pattern in X,Y, and Z
dimensions.

Scale XYZ

Accumulates the distance, rotation, or scale over the sequence of
instances. When cleared, the distance, rotation, or scale is absolute
(constant).

Relative

Specifies an overall scale multiplier to the X, Y, and Z dimensions
of the scale for all instances.

Scale All

Scatter

The Scatter formation allows completely random arrangements of objects within a specific
range. Equal values for Minimum and Maximum create a deterministic transformation
value for that degree of freedom.

Specifies the number of objects in the pattern.Number of
Objects

Specifies the Minimum and Maximum limits for the random
computation of translations (position) of each instance.

Position Range
XYZ

Specifies the Minimum and Maximum limits for the Euler angles
X, Y, Z for the random computation of the rotations of each instance.

Rotation Range
XYZ
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Specifies the Minimum and Maximum limits for the random
computation of scale of each instance.

Uniform specifies a random scale in the X, Y, and Z dimension.

Scale Range XYZ

Specifies an overall scale multiplier to the X, Y, and Z dimensions
of the minimum and maximum scales for all instances.

Scale All

Corner Radius

The Corner Radius functionality is enhanced to smooth edges in parts.

Previously, the effect of Corner Radius was visible only if the appearance attached to
the geometry did not use a bump or normal map.

2021: All hard edges are
sharp because the
appearance attached to the
part uses a bump or normal
map.
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2022: The Corner Radius is
visible even when the
appearance on the part uses
a bump or normal map.

In the Palette, on the Models tab, on the Advanced subtab, specify Corner Radius
(mm).

Cosmetic Threads

For more realistic-looking models, SOLIDWORKS Visualize automatically applies a normal
map to models imported with cosmetic threads.
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18
SOLIDWORKS CAM

This chapter includes the following topics:

• Assembly Support for Turn
• Customize Color Settings for Toolpath End Points
• Display Color for Hidden Toolpath Moves
• Filter for Mill and Turn Tools and Assemblies with Text
• Manage Multiple Technology Databases
• Support for Nonplanar Surfaces for Z Axis Probing
• Revised CNC Finish Parameters for Clarity
• Supported Platforms for SOLIDWORKS CAM

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Assembly Support for Turn
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Turn mode supports assemblies that contain a single Turn part model.

You must define the following:

• In theMachine tab of the Machine dialog box, ttheMain Spindle Coordinate system
for machining the parts in the assembly

• Under the Stock Manager node, the stock for the individual parts that will be listed
as subnodes

• In the Manage Parts dialog box, the turn part, the spindle designation, origin of the
coordinate system and turn feature section plane

• In the Spindle work coordinate dialog box, the programmable offsets for the main
spindle of the machine
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Customize Color Settings for Toolpath End Points

From the Display tab in the Options dialog box, you can apply color settings for toolpath
end points.

Display Color for Hidden Toolpath Moves
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In the Display tab of the Options dialog box, you can assign a color to display Toolpath
hidden moves in the graphics area.

Filter for Mill and Turn Tools and Assemblies with Text

The Tool Select Filter dialog box lets you enter text to filter for mill and turn tools and
assemblies.

Manage Multiple Technology Databases
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You can manage multiple technology databases in the Manage Database tab.

In Settings, the Link Database tab has been renamed Manage Database.

The Manage Database tab lets you specify multiple technology database source files, but
you can only assign one database as the active database to the application.

Support for Nonplanar Surfaces for Z Axis Probing

You can select nonplanar surfaces in the direction of the Z axis for probe cycles.

The Z Probe Cycle is available in the Probe tab of the Operation Parameters dialog box.
The default touch off point for toolpath generation is the top-most point of the selected
face in the Z direction.
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Revised CNC Finish Parameters for Clarity

The NC tab in the Operation Parameters dialog box and the interface of the Technology
Database have updated and rearranged labels to improve the readability of CNC finish
parameters.

Supported Platforms for SOLIDWORKS CAM
SOLIDWORKS CAM supports the 64-bit version of SOLIDWORKS 2022 and SOLIDWORKS
2021 running on the 64-bit of Windows 10.
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19
SOLIDWORKS Composer

This chapter includes the following topics:

• Importing Decals from SOLIDWORKS Files
• Support for Higher Version of Import Formats

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

Importing Decals from SOLIDWORKS Files

You can import decals from SOLIDWORKS files to Composer files.

To import decals:

• In SOLIDWORKS Composer, click File > Open and select a SOLIDWORKS file. Under
SOLIDWORKS, select Import SOLIDWORKS decals in the dialog box.

• In SOLIDWORKS Composer, click File > Properties > Default Document Properties
> Advanced Properties. Under INPUT - IMPORT, select IOSWImportDecals.
See Managing (Default) Document Properties > Input in Composer Help.

• In SOLIDWORKS Composer Sync, at the bottom of the window, clickMore Properties
> Advanced Properties. In the dialog box, under INPUT - IMPORT, select
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Batch.IOSWImportDecals to enable batch import of decals. See Sync > Managing
Default Document Properties > Advanced Properties in Composer Help.

Support for Higher Version of Import Formats
SOLIDWORKS Composer and SOLIDWORKS Composer Sync support higher versions of
the following import formats:

• ACIS™ up to R2021 1.0
• Pro/E® Creo 1.0 to 7.0
• SOLIDWORKS 2006 to 2022

See Importing and Opening Files > About Supported Import Formats or Sync > About
Import Formats and File Types > About Supported Import Formats in Composer Help.
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20
SOLIDWORKS Electrical

This chapter includes the following topics:

• Links in BOMs
• Add Data Files in the Export PDF
• Testing the Query in the Expert Mode
• Displaying ERP Data in the Manufacturer Parts Manager
• Including Data Sheets in Exported PDFs
• Displaying Break Condition in Report Manager
• User Interface Redesign
• Attribute in Origin - Destination Arrows
• Displaying All the Wire Numbers on the Middle of the Line
• Electrical Content Portal Integration
• Connection Point Creation Enhancements

SOLIDWORKS® Electrical is a separately purchased product.

Links in BOMs
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In BOMs, you can manage links in a merged cell, for example, when several components
use the same manufacturer part.

In a BOM or other reports, the report viewer displays links. These links display information
like the properties, the location in the drawings of the selected element, or open the
drawing and zoom the component. By clicking the right mouse button on the link, you
can select the component you want to display the information.

Add Data Files in the Export PDF

If you attach PDF files to the project as data files, you can export them in the exported
PDF file.

When you select Export data files, a message displays the PDF file size. The PDF file
gathers all the datafiles in a new section.
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Testing the Query in the Expert Mode

When you edit report configurations in Expert mode, Test fully query includes the sort
conditions and filters.

In report configurations, the Expert mode option is on the SQL Query tab.

Displaying ERP Data in the Manufacturer Parts Manager
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If you connect the ERP data, you can display it in the Manufacturer Parts Manager.

To display the ERP data in the Manufacturer Parts Manager, open the Column configuration
and select the ERP data you want to show.

If you do not connect the ERP Data, you can only select the User data.

Including Data Sheets in Exported PDFs

You can include the data sheets associated with the manufacturer parts in exported PDF
files.

A data sheet is a file or a link associated to a manufacturer part. When you export the
project drawings in a PDF file, the data sheets appear in the Data sheets section of the
PDF. Click Export PDF file and select Create bookmarks and hyperlinks to create
the Data sheets section.

151

SOLIDWORKS Electrical



Displaying Break Condition in Report Manager

In the Report Manager, you can display a Break condition column that shows the field
in which you have created the break condition.

To display this column, select Break Condition. This column is not printable.

User Interface Redesign

The user interface is enhanced to be more ergonomic and user friendly.

• New icons
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• You can Expand or Collapse the ribbon menu
• The commands to manage external files are in a File menu
• You can select the theme color of the interface
• The Drawing style commands move from the Tools menu to the Modify menu
• The Search and Verify project commands move from the Toolsmenu to the Project

menu

Attribute in Origin - Destination Arrows

In the Origin - Destination arrows feature, the attribute #P_CONNECTED_0 lets you
display the mark of the components connected through the arrows.

From the Symbols manager, edit the symbol of the type Origin - Destination arrows
to add the attribute #P_CONNECTED_0.
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Displaying All the Wire Numbers on the Middle of the Line

When you number the wires, you can select a specific mode allowing you to display the
wire number on the middle of the line segment.

When you connect an equipotential to three or more components, this Displaymode lets
show all the wire numbers on the middle of the line segment. You can select this mode
in the Wire styles manager.

Electrical Content Portal Integration
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Electrical Content Portal (ECP) is where you can download content, such as manufacturer
parts, cable references, and files for 2D layouts.

A dockable panel displays the ECP interface. It lets you download content and automatically
unarchive it into the respective libraries.

Video: What's New in SOLIDWORKS 2022 -
SOLIDWORKS Electrical

Connection Point Creation Enhancements

Connection points (CPoints) let you connect wires or cables with connectors.

• Commands to create the CPoints are available in the SOLIDWORKS Electrical menu.
• You can assign Cpoints by selecting an edge or a cylindrical surface.
• To delete an assignment in the CPoint Assignment table, right-click the row and

select Delete CPoint(s).
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21
SOLIDWORKS Inspection

This chapter includes the following topics:

• SOLIDWORKS Inspection Add-in
• SOLIDWORKS Inspection Standalone

SOLIDWORKS Inspection is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application (see SOLIDWORKS Inspection Standalone).
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SOLIDWORKS Inspection Add-in

Video: What's New in SOLIDWORKS 2022 -
SOLIDWORKS Inspection

Application Programming Interface

SOLIDWORKS Inspection functionality is available through the Application Programming
Interface (API).

You can use the API to:

• Automatically open SOLIDWORKS files
• Create inspection projects
• Export First Article Inspection (FAI) reports
• Balloon drawings
• Invoke any feature available in the user interface

SOLIDWORKS Inspection Standalone
SOLIDWORKS® Inspection is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as
a completely separate application (see SOLIDWORKS Inspection Standalone).
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Video: What's New in SOLIDWORKS 2022 -
SOLIDWORKS Inspection

Supported File Types

SOLIDWORKS Inspection Standalone supports SOLIDWORKS (.SLDPRT, .SLDASM,
.SLDDRW) and NX™/Unigraphics® (.prt) files.

Smart Extract

The Smart Extract tool has improved character recognition and parsing. This improves
accuracy when extracting information from pdf files.
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22
SOLIDWORKS MBD

This chapter includes the following topics:

• Creating HTML Output from the 3D PDF
• DimXpert Angle Dimension Tool
• Geometric Tolerancing for DimXpert

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Creating HTML Output from the 3D PDF

When you publish a 3D PDF of a model, you can create an .html file in addition to the
3D PDF file.

When you are ready to publish:

1. Click Publish to 3D PDF (MBD toolbar).
2. In the Template Selection dialog box, select a template and click OK.
3. In the Publish to 3D PDF PropertyManager, under the template name, select Create

HTML from PDF and click .
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DimXpert Angle Dimension Tool

You can manually create DimXpert angle dimensions with the Angle Dimension tool,
similar to creating reference angle dimensions with Smart Dimension tool.

To create a DimXpert angle dimension, you can select two or three DimXpert features,
where the first two selections define the origin and the third selection establishes the
toleranced feature. Previously, you could only use the Auto Dimension Scheme tool to
create DimXpert angle dimensions, which did not allow specific input for the dimensioned
angle.

Click Angle Dimension (MBD Dimension toolbar) or Tools > MBD Dimension >
Angle Dimension.
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Geometric Tolerancing for DimXpert

Geometric tolerancing for DimXpert includes several improvements in addition to the new
user interface described in Geometric Tolerance Symbols on page 81 in the Detailing
and Drawings chapter.

In Tools > Options > Document Properties > DimXpert, you can specify the Base
DimXpert standard. If you select the ANSI/ASME Y14.5 or ISO standard, you can also
select a release date for the standard.

Release Date OptionsStandard

• 1994
• 2009
• 2018

ANSI/ASME Y14.5

• 1983
• 2004
• 2012
• 2017

ISO 1101

When you first click Geometric Tolerance (MBD or MBD Dimension toolbar), you
must then select an existing DimXpert feature or define a new DimXpert feature.

When you select a feature, the software evaluates the feature and tolerance specifications
for the drafting standard you selected. In the dialog box, options are available based on
the standard.
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23
eDrawings

This chapter includes the following topics:

• Configuration Support
• eDrawings Options in SOLIDWORKS
• File List
• Custom Properties Options
• User Interface
• Components Pane

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Configuration Support

You can specify configurations of SOLIDWORKS parts and assemblies to be available when
you open them in eDrawings® for Mac®.

In SOLIDWORKS, in the ConfigurationManager, right-click one or more configurations
and click Add Display Data Mark.
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eDrawings Options in SOLIDWORKS
eDrawings related options in SOLIDWORKS have been renamed and reorganized for ease
of use.

In SOLIDWORKS, click Tools > Options > System Options > Export. In File Format,
select EDRW/EPRT/EASM.

The following options have been renamed, but the functionality remains the same.

Previous nameNew name

Okay to measure this eDrawings fileEnable measure

Allow export to STL for parts &
assemblies

Allow STL export

Save table features to eDrawings fileSave table features

Save shaded data in drawingsSave shaded data

Save Motion Studies to eDrawings fileSave motion studies

File List

The file list in eDrawings for iOS™ is enhanced.

In the list, you can:

• See detailed file information
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• Sort on file parameters, such as filename, date, extension, and size by tapping
• Share or delete files by touching and holding a file name

Custom Properties Options
You can save custom properties from a SOLIDWORKS document in resulting eDrawings
files when you Save As an eDrawings document or Publish to eDrawings in
SOLIDWORKS.

For lightweight assemblies, only custom properties for the top-level assembly are available
in the resulting eDrawings files.

Configuration-specific properties are not available for assemblies opened in lightweight
mode.

To specify custom properties options:

1. In SOLIDWORKS, click Tools > Options > System Options > Export.
2. In the dialog box, in File Format, select EDRW/EPRT/EASM.
3. Select options:

• Save file properties. Saves custom properties from a SOLIDWORKS document
in resulting eDrawings files when you Save As an eDrawings document or Publish
to eDrawings in SOLIDWORKS.

• Save file properties for each component in the assembly. (Available if you
select Save file properties.) Saves custom properties including
configuration-specific properties for each component in the SOLIDWORKS assembly.

When you open the file in eDrawings, the Properties tool is available if the file
has custom properties.

Exporting Custom Properties

When you save a SOLIDWORKS file as an eDrawings file from within eDrawings, you can
include custom properties in the eDrawings file.

To export custom properties:

1. In eDrawings, open a SOLIDWORKS file.
2. Click File > Save As.
3. In the dialog box, select Include file properties and click Save.

Custom and configuration-specific properties in the SOLIDWORKS file are saved in
the eDrawings file.
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User Interface

The eDrawings user interface is updated for ease of use.

The tools, File Properties and Mass Properties, have changed to Properties and
Mass, respectively.

To reduce the height of the tools at the bottom of the eDrawings window, you can remove
the labels. Right-click a tool and click Show labels.

Show labels clearedShow labels selected
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Components Pane

When you work with assemblies in eDrawings, the Components pane is enhanced for
ease of use.

DescriptionEnhancement

The following are options in the Components
pane:

• Highlight parents on hover. Highlights
the parent row when you hover over a
child row.

• Show Component Descriptions. This
option has moved from the Options
dialog box.

Options

Clears previously filtered content.Clear filtered text

Displays the top-level assembly node in the
components tree.

Top-level assembly display

Displays the Components pane at full height
to reduce scrolling.

Pane height

Expands or collapses all items below the
selected assembly node.

Expand All/Collapse All
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24
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

• Scene Plot
• Compare: Results Summary
• Compare: Merged Plots
• Compare: Difference Plot
• Heat Source
• Range Function
• Remove Missing Entities
• Check Geometry
• Goals
• Flux Plot
• Surface Parameters
• Probes

SOLIDWORKS® Flow Simulation is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Video: What's New in SOLIDWORKS 2022 - Flow
Simulation

Scene Plot
Scene plot stores all displayed plots, model orientation, zoom, and part visibility. Switching
between scenes displays the plots saved in the scene and retains the corresponding model
display, zoom, and orientation.

Compare: Results Summary
The Compare and Parametric Studies include a Results Summary.

Compare: Merged Plots
With the Compare tool, you can merge plots from different projects to see critical results
in one image.

For example, you can merge contour plots by maximum value to show the maximum
temperature for all design cases in one image.
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Compare: Difference Plot
With the Compare tool, you can create a plot image displaying the difference of one
particular case to a reference case.

Heat Source
The specific power (W/m3) can be dependent on local (calculated in the cell) temperature
in formula or table dependency.

Range Function
The RANGE function gets goal values at any time during calculation. This lets you model
complex behavior of the transient system, for example, power derating based on a
temperature sensor.

Remove Missing Entities
You can automatically remove reference geometry (faces, edges, and points) of missing
or suppressed bodies from the selection.

Check Geometry
You can create solid and fluid bodies for Improve Geometry Handling mode.

Goals
You can show equation goals based on defined goals after calculation.

Flux Plot
You can display a Flux Plot in the Transient Explorer.

Surface Parameters
Crop region is accounted for when evaluating surface parameters.

Probes
Probes are copied to projects together with plots that define the probes.
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25
SOLIDWORKS Plastics

This chapter includes the following topics:

• Cavity and Runner Layouts
• Injection Location Advisor
• Plastics Materials Database
• PlasticsManager Tree
• Scaling for High-Resolution Displays
• SOLIDWORKS Plastics Solvers

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Video:What's New in SOLIDWORKS 2022 - SOLIDWORKS
Plastics

Cavity and Runner Layouts

You can create dedicated boundary conditions for cyclic and symmetric cavity and runner
layouts. You can also preview the cavity and runner layouts during the modeling stage
to confirm their design specifications.

To open the Symmetry or the Cyclic PropertyManager:

In the PlasticsManager tree, right-click Boundary Conditions and click Symmetry

or Cyclic .

You can use solid bodies and sketch-based runners to create the layouts. For cavity
layouts with symmetry conditions, you can also visualize results for the whole layout,
even though the simulation runs only for the symmetric part.
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Injection Location Advisor

The Injection Location Advisor assesses a part's geometry to identify up to four suitable
injection locations by considering the specified material, process conditions, and mold
opening direction.

To open the Injection Location Advisor PropertyManager:

In the PlasticsManager tree, right-click Boundary Conditions and click Injection
Location Advisor.

The following table describes the options of the Injection Location Advisor PropertyManager.

Specifies the number of the suitable injection locations (maximum
of four).

Number of locations

Specifies the plane for the mold open direction. The default is
the Front Plane, which corresponds to the positive Z-axis.

Mold open direction

Defines regions of a model that the Injection Location Advisor
excludes from consideration.

Excluded regions

Shows the recommended injection locations and a preview of
the fill plot. You can predict how the plastic material fills the
mold based on the recommended injection locations.

Result Preview
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Plastics Materials Database

The Plastics material database is updated according to the latest data from the material
manufacturers.

Removed MaterialsModified MaterialsNew Materials

Removed 76 materials from
the database because they

Added 112 new material
grades from these material
manufacturers:

• Renamed 441 grades
according to the latest
data from the SABIC
website

were duplicates or obsolete
per manufacturer:• SABIC Specialties: 49
• SABIC Specialties: 29•• Consolidated seven

different SABIC
Polyplastics: 40

• LANXESS GmbH: 17• Solvay Specialty
Polymers: 16 manufacturer categories

under the single category
SABIC Specialties

• Polyplastics: 4
• •RadiciGroup: 6 BASF: 4

•• ICI: 4LANXESS: 1
• Updated 1167 grades

from constant density to • ARKEMA: 3
• DuPont Engineering

Plastics: 2
generic Pressure Volume
Temperature (PVT) data

• DuPont Engineering
Polymers: 2

to improve the accuracy
of Fill, Pack, and Warp
simulations • Rhodia Engineering

Plastics: 2
• Rhone-Poulenc: 2
• KUO FU: 2
• CWH, Chemwerk Huls: 2
• DSM Engineering Plastics:

2
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Removed MaterialsModified MaterialsNew Materials

• UBE: 1

Material grade with constant Pressure Volume Temperature (PVT) data (2021)

Same material grade updated with generic PVT data (2022)
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PlasticsManager Tree

Usability is improved for the PlasticsManager tree.

• The PlasticsManager tree displays the simulation type under the study node to provide
more clarity on the active analysis module (Fill, Pack, Cool, and Warp).

• Modeling features and boundary conditions are filtered based on the simulation type
to provide a simulation-centric user experience.

• You can run a simulation without explicitly creating a mesh if you have defined an
injection unit and injection location. SOLIDWORKS Plastics automatically generates a
mesh before the start of the simulation.

• You can delete the mesh from the Solid Mesh (or Shell Mesh) node of the
PlasticsManager tree. Right-click Solid Mesh, and click Delete Mesh.

• The Results node becomes visible after you create a mesh.
• You can right-click the top study node and click Run to run a simulation.
• You can right-click Results to access these features:

• Summary and Report
• Clipping Plane Settings
• Isosurface Manager
• Path Line
• Export
• Remove All Results

• You can delete the results for a specific analysis module. For example, right-click Fill
Results and click Remove Results. In previous releases, only Remove All Results
was available.

• The term Fill replaces the term Flow in all user interface instances to match conventional
industry terminology.

175

SOLIDWORKS Plastics



Scaling for High-Resolution Displays

SOLIDWORKS Plastics supports monitors with 4K and higher resolution displays.

The user interface icons scale to an appropriate size so that their appearance does not
degrade or become blurry on high-resolution and high-pixel density displays. The user
interface of the PlasticsManager tree, dialog boxes, and PropertyManagers responds to
the Microsoft Windows® display scaling setting.

Icons with text scale to a size appropriate for the text.
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SOLIDWORKS Plastics Solvers

The performance of the Cool and Fill analysis modules is improved to accelerate the overall
analysis time.

• For simulations where the Cool analysis takes up a large proportion of the overall
solution time, the overall solution time is reduced by at least 20% compared to previous
releases. The image shows the performance gains of a Cool analysis for three models
that have a varying number of elements.

• The performance of the Fill and Pack analyses with the Direct solver option is optimized.
The overall solution time is reduced by approximately 50% compared to previous
releases. For relatively thick parts that are meshed with hexahedral elements, the
Direct solver more accurately predicts the inertial effects.

The following image shows the performance gains for the Fill and Pack analyses of two
models that have a varying number of elements.
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To access the Direct solver, from the PlasticsManager, select Global Parameters
> Fill-Pack > Solver Settings > Volume of Fluids (VoF) Algorithm > Direct.
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26
Routing

This chapter includes the following topics:

• Flatten Route Improvements
• External Connectors in the Flattened Routes
• Backshells for Connectors
• Backshells and Flatten Routes
• Replacing a Connector in a Routing Assembly

Routing is available in SOLIDWORKS® Premium.

Video: What's New in SOLIDWORKS 2022 - Routing

Flatten Route Improvements

179

https://www.solidworks.com/media/solidworks-2022-routing


The Flatten Route Property Manager lets you manage the creation of the flattened route
from a route assembly.

• The tool to start the Flatten Route Property Manager is in the SOLIDWORKS Electrical
menu.

• In Horizontal Route Segment Selection, you can select several continuous route
segments to be appeared as horizontal in the flatten configuration.

• Create Flatten with Lines Only allows you to convert the splines to lines.
• The Flatten Route Property Manager automatically detects the connected segments

when you select the first sketch segment and displays them in a selected dialog box.
• Select Components to Maintain 3D orientation for splices with loops to have

loops with splices maintain their 3D orientation wherever you place them.
• When the Edit Flatten Route Property Manager is open, left-click on a route segment

in the graphics area to access modification tools.

External Connectors in the Flattened Routes

In the flattened routes, you can select connectors that are not in the harness but connected
to the cables.

To select the connectors, in the Connector Tables Property Manager, click Select All
Connectors, then remove those that you want to exclude.

The Flattened Route drawing displays the External connectors. In the Circuit Summary
tables, the From and To columns display the External connector tags.
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Backshells for Connectors

Backshells protect connectors and connected cables from electrical interference or physical
damage due to environmental conditions. Backshells can include a clamping device.

To use a backshell, you must:

• Add an axis to the backshell to align the backshell with the route.
• Add a mate between the backshell and the connector.

Backshells and Flatten Routes
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When you flatten the Route Assembly having Backshell, the location and the orientation
of the Backshell are displayed properly in the Flatten Route.

Replacing a Connector in a Routing Assembly

In a routing assembly, when you replace a connector in a From/To list, you can keep
the original connections and the electrical data.

In the Import Electrical Data PropertyManager, select Replace component to replace
the existing connector by the new one in the From/To list. Select Delete existing
segment and create new guidelines if the new connector does not have the same
connections.

Select Update data to add new data or to change the data of an existing component
without resetting any unchanged components.
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