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1
Welcome to SOLIDWORKS 2021

This chapter includes the following topics:

• Top Enhancements
• Performance
• SPR Fixes
• For More Information

Model courtesy of Rahul Gawde, SOLIDWORKS 2020 Beta Splash Screen Prize winner.

At SOLIDWORKS, we know that you create great designs, and that your great designs get
built. To streamline and accelerate your product development process from concept through
manufactured products, SOLIDWORKS 2021 contains new, user-driven enhancements focused
on:

• Expanded functionality. Defeature simplification for large assemblies, more commands
available in Detailing mode for drawings, and additional capabilities for plastics simulations
provide new workflow possibilities for design, detailing, and validation.

• Performance. Faster mesh generation significantly improves simulation time. More
streamlined data management with collaboration reduces errors and project management
time, giving you more time for design refinement.

• Staying Connected. An improved connection to the 3DEXPERIENCE® platform provides
extensive cloud collaboration, data management, and advanced applications. This ensures
you can access the tools and services you need to get your entire job done.
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Top Enhancements
The top enhancements for SOLIDWORKS® 2021 provide improvements to existing products
and innovative new functionality.

Detailing Mode • Work with improved drawing creation performance
• Take advantage of improvements to adding hole callouts, editing

existing dimensions and annotations, and adding detail, break,
and crop views

Assemblies • Export interference detection reports with images to Microsoft®
Excel®

• Use Change mate alignments on edit to warn you when
mate changes result in errors that can be avoided by flipping
the alignment of the edited mate

• Automatically resolve lightweight components on expanding
the FeatureManager® node

• Save defeatured models as configurations, change between full
and simplified versions, and mimic other configurations

• Benefit from improvements for design tables, exploded views,
mates, and mirror and pattern features

• Open, save, and close assemblies with significant performance
improvements

• Use curve length in chain patterns along paths, not chord length
• Detect and report circular references

Model Display • Work with improved performance of occlusion culling, silhouette
edges and drawings, and quick configuration switches

User Interface • Pick colors for appearances from external applications
• Search for tools on Shortcut Bars and Commands tabs in the

Customize dialog box
• Display translated feature names in the FeatureManager® design

tree

Parts and Features • Use Redo for more than 60 features and tools in parts
• Add edge flanges on nonplanar tangent edges in sheet metal

parts and flatten complex flanges
• Add and evaluate equations in file properties and cut list

properties
• Transfer part-level materials when you insert or mirror a part,

derived component part, or mirrored component part

SOLIDWORKS
Simulation

• Use mesh diagnostics to identify, isolate, and prompt to fix
poor-quality elements

• Use faster and more robust meshing with accuracy bonding
improvements

8

Welcome to SOLIDWORKS 2021



• Access improved convergence through contact stabilization
• Get faster contact simulation calculations
• Automatically calculate and apply geometry correction terms

for contact between curved surfaces
• Ensure accuracy for bonding interactions to enable robust and

fast meshing
• Get a more accurate auto-selection of the equation solver with

commensurate improvements in speed and memory usage

SOLIDWORKS
Electrical

• Use splines, lines, or other sketch entities to route harnesses
in 3D

• Use multiple wires or cables to pass through and arrange
through clips

• Join wires using splice component or splice without component
• Access support for end terminations in Connector Tables,

Interconnects, and the Accessories Library
• Combine 3D representations and flattened areas in harness

board drawings
• Archive electrical projects automatically or by schedule
• Generate PDF files of projects up to nine times faster depending

on project size
• Update engineering units for wires, cables, and electrical harness

data using the Routing Library Manager (RLM)
• Use the Terminal Types Manager to handle terminals and

interconnections
• Bring information on end terminations from SOLIDWORKS

Electrical schematics into 3D for more complete documentation
• Fit entire workflows, from schematic to 3D, for wires without

end terminations
• Leverage Microsoft Excel for electrical design automation with

an add-in to streamline the process

SOLIDWORKS
Plastics

• Streamline the plastics simulation workflow with the redesigned
PlasticsManager tree

• Improve cooling results accuracy with enhanced baffling and
bubbler modeling and meshing

• Access more accurate and up-to-date plastics material data

SOLIDWORKS Flow
Simulation

• Calculate free surface for tasks, including rotating equipment

SOLIDWORKS
Inspection

• Access quality control information directly from SOLIDWORKS
parts containing 3D annotations

• Leverage existing 3D CAD data to save time creating First Article
Inspection reports

• Expand drawingless manufacturing strategy for quality control

SOLIDWORKSMBD • Publish sheet metal bend tables as 3D PDF files

9
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• Define driving and driven locating dimensions as semantically
correct datum targets

• Take advantage of improved 3D PDF display quality

SOLIDWORKS CAM • Control changes by ensuring all necessary information stays
current with design changes

• Use cylindrical stock for milling operations
• Specify drill peck amounts based on the drill diameter

SOLIDWORKS PDM • Use more consistent integration with Microsoft® Windows® File
Explorer and better thumbnail support

• Control custom column sets in a more flexible way
• Reduce mistakes and improve efficiency when working with

BOM settings
• Save time when modifying bills of materials for use by other

fields, such as manufacturing
• Use icon selection for workflow states, and improved transitions

to quickly determine the status of a particular file
• Add files to the vault significantly faster
• Access the Treehouse view in the Contains and Where Used

tabs
• Save time on Web2 by quickly browsing through data card

properties and updating values with modern controls
• Share file data with external users with more efficiency and

control
• Streamline project management with multiple projects

connected to a common project manager or program
• Use modeless windows to open multiple property card windows

and switch between them for editing and data gathering
• Automatically update project stage progress, resources, and

deliverables from related task data at specified time intervals

3DEXPERIENCE
Connector for
SOLIDWORKS

• Use the Derived Format Converter to create derived outputs
for broader consumption and exact geometry to use in
downstream design, simulation, and manufacturing applications

• Use multiple sheets and markups on drawings, with improved
drawings quality

• Manage Open tools with similar options to SOLIDWORKS when
opening data from the 3DEXPERIENCE® platform

• Control configurations to save on the 3DEXPERIENCE platform

Access to Dassault Systèmes User Assistance requires
3DEXPERIENCE credentials.
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Performance
SOLIDWORKS® 2021 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

Installation
SOLIDWORKS 2021 Installation Manager downloads and extracts installation media faster.
Internal testing shows that the download time is improved by 25% or more compared to
the methods used before SOLIDWORKS 2021.

Model Display
SOLIDWORKS 2021 improves performance for occlusion culling, silhouette edges, and
drawings.

Areas of ImprovementFeature

• Large Assemblies
• Parts opened in Resolved, Large Assembly Settings, and

Large Design Review modes
• Legacy or nonrender pipelines

Hidden geometry based on view direction and view frustum is
not rendered. This boosts the performance and also allows the
performance to scale from low-end to high-end GPUs.

GPU-based Occlusion
Culling

• Large assemblies and parts while in HLR (Hidden Lines
Removed), HLG (Hidden Lines Grayed), and Wireframe
modes

• Shaded with edges and edge modes

GPU-based Silhouette
Edges

The performance is improved for drawings when panning and
zooming.

Drawing

• Large assemblies
• Multilevel assemblies with components that have overridden

properties (appearance, display mode, visibility, and referred
display state)

Switching Configuration
of Large Assemblies

Sheet Metal
Flat patterns use efficient algorithms to identify bend connections. This reduces the time
to flatten complex sheet metal bodies with many flanges by about 20-25 times.

11

Welcome to SOLIDWORKS 2021



Assemblies
Assembly performance is improved when:

• Opening resolved and lightweight assemblies
• Opening assemblies with parts that have many configurations
• Updating assemblies that have many mates
• Closing assemblies without saving

Detailing Mode and Drawings
In Detailing Mode:

• Robust referencing saves you a dramatic amount of time by eliminating the need to
resolve and save to maintain final annotation and dimension associativity

• Several new operations help to improve your overall performance while you detail your
drawings. See Detailing Mode Enhancements on page 53.

For massive drawings, display performance is improved in many areas:

• While sketches are shown:

• Zoom and pan performance is improved substantially
• For Zoom to Area, the shaded box keeps up with the pointer movement

• Zoom and pan performance is more consistent regardless of zoom scale, for example,
when zooming tight versus zooming to fit

• The latency issue that occurred for the first pan is eliminated
• Selecting and moving annotations is improved
• Dynamic highlighting is improved

Performance is also improved when:

• Creating and updating large section views
• Using Auto Insert to add center marks when creating section views
• Canceling Edit Sketch in broken-out section views
• Creating a detail view in a section view
• Importing a model’s cosmetic threads into a view
• HLR background processing for high-quality display of cosmetic threads, by taking

advantage of available CPU cores

12
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• Sorting a BOM
• Opening drawing files
• Selecting items in drawings
• Saving a drawing as a .dwg file

SOLIDWORKS PDM
SOLIDWORKS PDM 2021 has improved performance of file-based operations and related
workflows.

• Add Files, Check-in, and Change State

Improvements in system performance help you to quickly open, add, check in, and
change the state of files with large reference structures. The Add Files operation is
between 1.5 and 3 times faster. The Check-in and Change State operations are
approximately 25% faster.

The level of improvement can vary depending on the number of files, network
bandwidth, and CPU cores.

The Check-in dialog box itself displays much more quickly (in seconds rather than
minutes) for very large assemblies or parts with a high number of configurations.

• Destroy

You can more quickly destroy files or folders. The operation is many times faster when
you are destroying a large number of files.

• Other Operations and Workflows

Performance is significantly improved for the following operations:

• For folders containing a very large number of files:

• Check-in and Check-out of a file
• Adding a new file by dragging or by copying and pasting
• Creating a new file from a template

• For assemblies with a large number of components at a single level, when working
in SOLIDWORKS:

• Opening files
• Saving files
• Switching windows

• Editing a target file name in the Copy Tree dialog box in a high-latency environment
• Using Copy Tree when a user setting is added to clear variable values

Simulation
The performance of simulation solvers is improved for linear static and nonlinear studies.

• FFEPlus Iterative and Large Problem Direct Sparse solvers:

The solution time is improved by using parallel multicore processing to calculate the
stiffness for surface-to-surface elements that are in contact.

13
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The transfer of stiffness data between the preconditioning and equation solving steps
is optimized because file-based processing is replaced with function-based processing.

These performance gains are more apparent for large models that have at least 10%
of the total elements in contact.

• Intel Direct Sparse solver:

The solver can handle significantly larger linear and nonlinear simulation studies by
taking full advantage of available memory. When the solver exceeds the available
memory, it uses available disk space to run the simulation.

The solver can run simulations for linear static and nonlinear studies with more than
4 million equations.

• Automatic Solver Selection:

The default option for linear static studies considers the number of equations, load
cases, and available system memory to optimize the selection of the best equation
solver (Intel Direct Sparse or FFEPlus).

• Shell Manager: Performance is improved when editing a large number of shells.
• Load Case Manager: Performance is improved when defining sensors to track

simulation results.

SPR Fixes
We have fixed a large number of Software Performance Reports (SPRs) in SOLIDWORKS
2021 by development projects specifically selected to address quality and performance
issues reported by customers.

See forum.solidworks.com/docs/DOC-3881 for the full list of fixed SPRs.

ResolutionSPR

If you open an assembly in Large Design Review mode with Scroll
selected item into view selected, then select multiple entities in the
graphics area, the FeatureManager design tree only scrolls the last item
into view.

1173747
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ResolutionSPR

Sheet metal:
• Flat pattern corner treatments use updated algorithms to correctly

identify corner geometry and apply appropriate corner treatments to
avoid sharp cuts and notches.

• Fixed issues for mirrored and derived parts to create proper corner
treatments.

418002,
444908,
477042,
515495,
622837,
804884,
915862

• Assembly features can propagate to individual components even if
there are multiple instances of the same part in the assembly. Sheet
metal parts created in SOLIDWORKS 2013 and later did not support
this functionality.

Cosmetic threads are no longer visible if they are on the back side of a
model.

277376

While you are adding a dimension, the preview of the dimension is now
semitransparent so you can see the geometry under the preview.

627329
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ResolutionSPR

SOLIDWORKS PDM:
• In the reference dialog boxes, the preference you select for Show

Tree Lines is retained across sessions.
• In the Bill of Materials tab, the thumbnail previews are larger.
• In the file list, the file size is displayed in a single unit for ease of

comparison and is consistent with Microsoft® Windows® File Explorer.
• In the file view tabs, the quality of thumbnail images has improved

significantly.
• In the Preview tab, a thumbnail preview is available for DWG and

DXF format files.
• In SOLIDWORKS PDM File Explorer, file lists follow the sort preference

(numeric or literal) specified for Windows File Explorer.
• In the Contains and Where Used tabs, when you expand a file node,

only the immediate child references are displayed.

617225,
678924,
1015070,
1032525,
1125484,
923080,
1159398

SOLIDWORKS PDM:
• Fixed issues in the execution of the Copy as Path command.
• Fixed issues with Get Latest Version of a file that had versions

cold-stored, was rolled back, and was recreated on a replicated server.
• Fixed issues in the CSV format export of Bills of Material that had

special characters, such as comma or double quotes, in the description
field.

• You can now select the option to look for mandatory values only in
the @ tab for SLDDRW files.

953237,
1070099,
1105835,
518149

SOLIDWORKS PDM:
• Check-in of drawings with user-defined references are now faster.
• The display of files with large data sets is now faster in the Bill of

Materials and Contains tab.
• The performance of the Change State operation is improved.

1150640,
1156689,
1156701,
1156718

For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML • Help > What's New > PDF

• Help > What's New > HTML

In SOLIDWORKS, appears next to new menu items and the
titles of new or significantly changed PropertyManagers. Click

Interactive What's
New

to display the topic in this guide that describes the
enhancement.
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To enable Interactive What's New, click Help > What's New
> Interactive.

Contains complete coverage of our products, including details
about the user interface, samples, and examples.

Online Help

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

Release Notes

SOLIDWORKS Legal Notices are available online.Legal Notices

17
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2
Installation

Download Performance Improvement

SOLIDWORKS 2021 Installation Manager downloads and extracts installation media faster
than earlier versions of the Installation Manager. Internal testing shows that total download
times improve by 25% or more compared to the methods used before SOLIDWORKS
2021.
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3
Administration

This chapter includes the following topics:

• Apply and Lock Color Settings
• Updated SOLIDWORKS Rx Performance Benchmark Tests

Apply and Lock Color Settings

Administrators can use the SOLIDWORKS® Settings Administrator tool to apply and lock
color settings either for the first session of SOLIDWORKS or for every session. They can
lock those colors to prevent users from changing them and control the background
appearance.

Administrators can lock only the active color and background appearance. Users cannot
change these settings. Inactive settings are not affected. If a color or background
appearance is locked, then users cannot change their color scheme.

To access the Settings Administrator tool, run the tool from the location where you stored
the administrative image.
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Updated SOLIDWORKS Rx Performance Benchmark Tests

Updates to the Performance Benchmark Test make it easier to compare the graphics
performance between computers.

System Options > Performance > Enhanced graphics performance is enabled by
default. Specifying this option ensures uniform results in the graphics and RealView tests
across benchmark systems.

Because of these changes, you cannot compare graphics and RealView performance
between SOLIDWORKS 2021 and earlier versions using the Performance Tests. You can
only make comparisons between two systems running the same version of SOLIDWORKS.
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4
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Changes to System Options and Document Properties
• Color Selections
• Searching for Commands
• Displaying Translated Feature Names
• Application Programming Interface
• Other Fundamentals Enhancements

Changes to System Options and Document Properties
The following options have been added, changed, or removed in the software.

System Options

AccessDescriptionOption

GeneralThe option is independent of Use
English language menus.

Use English language
feature and file names

GeneralRemoved from the dialog box. VSTA
components are installed by default.
They are no longer optional.

Enable VSTA version 3.0

File LocationsSpecifies a different location for the
hatch pattern file (sldwks.ptn).

Hatch Pattern File

File LocationsUnder Show folders for, specifies the
search path.

Inspection Project
Template Folder

File LocationsUnder Show folders for, specifies
search path.

Inspection Report
Template Folder

AssembliesReplaced by Changemate alignments
on edit. To determine when you receive
the warning, specify Always, Prompt,
or Never.

Prompt before changing
mate alignments on edit
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AccessDescriptionOption

SketchEnabled by default.Auto-rotate view normal
to sketch plane on sketch
creation and sketch edit

ColorsTwo new color options, Selected Item
5 and Selected Item 6, are available.

Color scheme settings

FeatureManagerDisplay features names in a selected
language in the FeatureManager® design
tree.

Show translated feature
names in
FeatureManager tree

External
References

Removed from system options.Update component
names when documents
are replaced

Document Properties

AccessDescriptionOption

MatesSpecifies a default constraint type.
Available options are Free, Center
Along Slot, Distance Along Slot, and
Percent Along Slot.

Slot mates

WeldmentsSpecifies a property ID to support
3DEXPERIENCE® PLMServices for
Structure Cut Lists, Sheet Metal Cut
Lists, and Generic Cut Lists.

Generate Cut list IDs

22
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Color Selections

Two new color options, Selected Item 5 and Selected Item 6, are available for color
settings.

Under Color scheme settings, the Selected Item color options moved to the top of
the list. Selected Item 1 is the default color scheme and the selected color appears to
the right of each color option.

To select a color, click Options > System Options > Colors. Under Color scheme
settings, select an option.

23
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Searching for Commands

You can search for commands on the Shortcut Bars and the Command tabs in the
Customize dialog box.

To search for a command, click Tools > Customize > Shortcut Bars or Tools >
Customize > Customize and enter a command name. Matching commands appear in
the Buttons box.

Displaying Translated Feature Names

24
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You can use a system option to show translated features names in the FeatureManager®
design tree.

Click Options > SystemOptions > FeatureManager. Select Show translated feature
names in FeatureManager tree and select a language.

This option replaces the Show Translated Feature Name in Tooltip option under Tree
Display.

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

Enhancements
• Create and modify sheet metal swept flanges, optionally using gauge table parameters.
• Vary the dimensions and locations of pattern instances in linear and circular patterns

of parts and assemblies.
• Get or set whether to synchronize the configurations of pattern components by

configuring the seed component in assembly component patterns.
• Insert chain dimensions in drawing documents.
• Change the type of existing assembly mates.
• Export a Microsoft® Excel® spreadsheet of results during interference detection.
• Handle an event that occurs when you change the file type in the File > Save As

dialog box.

Other Fundamentals Enhancements
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Other enhancements for fundamentals include user interface improvements.

• You can resize the Materials dialog box. In the dialog box, Open is renamed to Add.
This option is available when SOLIDWORKS Simulation is active.

• You can select Use English language feature and file names independently from
Use English language menus. Click Options > System Options > General to
select these options.

• Quick Copy is removed from the Measure tool. To copy a numeric value, double-click
the numeric value and press CTRL+C.

• Help opens in your default browser.
• For Search, the following options under MySolidWorks are removed:

• Knowledge Base
• Community Forum
• Blogs
• CAD Models
• Training
• YouTube
• Twitter
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5
User Interface

This chapter includes the following topics:

• Collapsible CommandManager
• Active Window Highlighted
• Accelerated Zoom
• Welcome Dialog Box Background Colors
• Other User Interface Enhancements

Video: What's New in SOLIDWORKS 2021 - User
Experience

Collapsible CommandManager
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You can collapse the CommandManager to show only the tabs until you want to access
the tools.

To collapse the CommandManager, click . In the collapsed view, click a tab to expand

the CommandManager and access the tools. In the expanded view, click to keep the
CommandManager expanded.

Active Window Highlighted

When you have multiple windows open and you hover over the SOLIDWORKS® icon in
the taskbar, the window with an open PropertyManager shows as the active thumbnail.
You must close the PropertyManager before you can select a different window.

In some cases, an open PropertyManager does not prevent you from switching windows.
All thumbnails are active when you hover over the icon.
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Accelerated Zoom

In the graphics area, you can press Shift + mouse wheel for accelerated zooming.

To use accelerated zoom:

1. Close all documents.
2. Click System Options > Display.
3. Clear Display scrollbars in graphics view for parts and assemblies.
4. In an open document, press Shift + mouse wheel and zoom in or out.
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Welcome Dialog Box Background Colors

The brightness of the Welcome dialog box varies according to the selected background.

To change the background, click Options > System Options > Colors and select an
option for Background.

Other User Interface Enhancements
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Other enhancements for user interface include a default search option and renamed
Sketch Ink tools.

• On the Sketch Ink toolbar, Pen is renamed to Draw. To change the color or the

thickness of the line, click Color .
• Commands is the default option in the search menu.
• When you modify a dimension, the Modify dialog box opens before the Dimension

PropertyManager.
• Auto-rotate view normal to sketch plane on sketch creation and sketch edit

is enabled by default. To clear this option, click Tools > Options > System Options
> Sketch.
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6
Parts and Features

This chapter includes the following topics:

• Adding and Evaluating Equations
• Redo Support for Part Features
• Transfer Body Material or Part Material

Video: What's New in SOLIDWORKS 2021 - Parts

Adding and Evaluating Equations

You can add and evaluate equations in file properties and cut list properties.

You can add equations in the following dialog boxes:

• Custom Properties
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• Configuration Specific Properties
• Weldment Cut List Properties
• Sheet Metal Cut List Properties

Adding Equations for File Properties

To add equations in file properties:

1. Click File > Properties.
2. In either Custom or Configuration Specific, in Type select Equation.
3. Add a term to the equation by doing one of the following:

• Enter a number or a conditional statement.
• On the Value/Text Expression tab, select a Global Variables, Functions, or

File Properties.
• Use $PRP and any File Property to include in the equation.

Redo Support for Part Features

You can use Redo for more than 60 features and commands in parts. Previously,
Redo was only available in sketches.

You can reverse multiple Undo changes by clicking next to Redo, and selecting
an item on the list.

Not all part commands support Redo in SOLIDWORKS 2021. Exceptions include:

• Annotations
• Hole features
• Instant3D modifications
• Mold tools
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• Sheet Metal
• Weldments

Transfer Body Material or Part Material

You can transfer body material or part material when you insert or a part, a derived
component part, or a mirrored component part.

Previously, the Insert Part PropertyManager provided only Material as an option for
transferring material. For mirror legacy files, material properties are mapped to Body
Material.
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7
Model Display

This chapter includes the following topics:

• 3MF Files
• Picking Color for Appearances from External Applications
• Model Display Performance Improvements
• Semi-Transparent Text for Dimensions

3MF Files

SOLIDWORKS® 2021 features extended graphical support for 3MF files.

3MF is an industry consortium working to define a 3D printing format that allows design
applications to send full-fidelity 3D models to a mix of other applications, platforms,
services, and printers.

The following graphical items appear in SOLIDWORKS when you import 3MF files:

35



Classic BREP
(solid or open)

Mesh BREP (open
or closed)

Graphics bodyItems

NoNoYesPer-vertex coloring

YesNoYesPer-facet coloring

NoNoYesDecals

NoNoYesTextures

YesYesYesTransparency

The following graphical items are exported from SOLIDWORKS to the 3MF format:

• The color of procedural appearances
• Textures of all mapping types such as UV mapping, projection mapping, cylindrical

mapping, box mapping, and spherical mapping
• Transparency

Picking Color for Appearances from External Applications
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You can click and drag the dropper icon to pick a color from external applications for
appearances.

Model Display Performance Improvements

SOLIDWORKS 2021 offers improved performance for occlusion culling, silhouette edges,
and drawings. You can switch configurations quickly.

Areas of ImprovementFeature

• Boosts dynamics performance for large assemblies and parts
in resolved, LAM, and LDR (Large Design Review) modes.

• Legacy or nonrender pipelines

Hidden geometry based on view direction and view frustum is
not rendered.

Performance scales with low-end to high-end GPUs.

GPU-based Occlusion
Culling

• Large assemblies and parts while in HLR (Hidden Lines
Removed), HLG (Hidden Lines Grayed), and Wireframe
modes

• Shaded with edges and edge modes

GPU-based Silhouette
Edges

The performance is improved for drawings when panning and
zooming.

Drawing

• Large assemblies
• Multilevel assemblies with components that have overridden

properties (appearance, display mode, visibility, and referred
display state)

Switching Configuration
of Large Assemblies
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Semi-Transparent Text for Dimensions

When you use Smart Dimension to define dimensions, the dimension text is
semi-transparent during placement. You can see and select geometry that is behind the
dimension text.

Once you define the dimension, the dimension text is fully visible.
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8
Sheet Metal

This chapter includes the following topics:

• Edge Flanges
• Performance Improvements in Sheet Metal

Edge Flanges

You can create edge flanges on nonlinear (circular) edges of nonplanar faces.

Click Edge Flange (Sheet Metal toolbar) or Insert > Sheet Metal > Edge Flange.
See SOLIDWORKS Online Help: Edge Flanges.
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Performance Improvements in Sheet Metal

Flat patterns use efficient algorithms to identify bend connections. This reduces the time
to flatten complex sheet metal bodies with many flanges by about 20-25 times.
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9
Structure System and Weldments

This chapter includes the following topics:

• Graphical Manipulator in Structure System
• Correct Cut List Length of Weldment Member
• Trims for End Miter Joints
• Generating Cut List IDs

Graphical Manipulator in Structure System

You can interact graphically on screen with the profile of the structural member. When
you select the profile, the graphical manipulator appears in the graphics area at the pierce
points. You can drag the profile horizontally or vertically, or rotate it to suit your alignment.

When you drag the profiles, they automatically update in the Profile PropertyManager.
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Correct Cut List Length of Weldment Member

You can calculate the correct cut list length of a weldment member in the cut list
properties.

You can calculate the correct length when you:

• Use a Move Face or Move/Copy Body feature and then extrude a cut or a hole
• Create the part that contains multiple sketches by selecting Merge miter trimmed

bodies
• Create an extruded cut or hole that modifies multiple faces across groups
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Trims for End Miter Joints

In the Trim/Extend PropertyManager, you can trim the end corner miters at an angle or
make them flush.

Click Trim/Extend (Weldments toolbar) orInsert > Weldments > Trim/Extend and

for Corner Type, select End Miter . If the weldment profiles of the end segments are

of different sizes, click Angle Bisector . If they are of equal size, click Full Flush

.
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Generating Cut List IDs

You can generate cut list IDs or unique reference IDs for each cut list in a cut list folder
based on the cut list attributes.

Click Tools > Options > Document Properties > Weldments. Under Cut list IDs,
select Generate Cut list IDs.

Each generated cut list ID is added in the corresponding cut list folder. Unique cut list
IDs result in unique naming convention of cut lists and are also used to index the database.

You can define different expression values based on the type of cut list.
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10
Assemblies

This chapter includes the following topics:

• Saving a Defeatured Model as a Configuration
• Performance Evaluation Checks for Circular References
• Spacing Options for Chain Patterns
• Auto-Resolving Lightweight Components
• Exporting Interference Detection Results
• Slot Mates
• Synchronizing a Patterned Component to a Seed
• Mate Alignment
• Assemblies Performance Improvements
• Mate PropertyManager
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Video: What's New in SOLIDWORKS 2021 - Assembly
Productivity Tools

Saving a Defeatured Model as a Configuration

When you use the Silhouette method for defeaturing, you can create a configuration
from a defeatured assembly. In the assembly, you can switch between the defeatured
configuration and the full model.

You can have only one defeature configuration under a parent configuration.

To save a defeatured assembly to a configuration, on the Defeature - Defeature Complete
page, click Create a new configuration and select Include top level reference
geometry.
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Performance Evaluation Checks for Circular References

Performance Evaluation detects circular references in assemblies.

To check for circular references, click Tools > Evaluate > Performance Evaluation.
Under Rebuild Performance, check the Circular References section for issues.

For information on the circular references, click Show These Files to open the Circular
Reference dialog box.

Spacing Options for Chain Patterns
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You can define spacing between chain pattern instances as a measure along a path for
Distance and Distance Linkage chain patterns.

In the Chain Pattern PropertyManager, select a spacing method:

Spaces pattern instances at the specified
distance as measured along a path.

Distance along path

Spaces pattern instances at the specified
distance as measured as a linear distance.

Linear distance

Auto-Resolving Lightweight Components
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For assemblies opened in lightweight mode, top-level components and subassemblies

resolve automatically when you click to expand the item in the FeatureManager® design
tree. Components in subassemblies remain in lightweight mode until you expand them.

Exporting Interference Detection Results

You can export results for interference detection to a Microsoft® Excel® spreadsheet.

To export results:

1. Click Tools > Evaluate > Interference Detection and click Calculate.
2. Click Save Results.
3. Enter a file name and select Thumbnails to include an image of the interference.
4. Click Save.

49

Assemblies



Slot Mates

You can specify a default constraint type and lock the rotation for slot mates.

To select a default constraint type, click Options > Document Properties > Mates and
under Slot mates, select an option for Default constraint.

To lock rotation for a slot mate:

• Under the Mates folder, right-click the slot mate and click Lock Rotation.

• Right-click the Mates folder and click Lock Rotation.

• In the Mates PropertyManager for slot mates, select Lock Rotation.
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Synchronizing a Patterned Component to a Seed

You can use Synchronize configuration of patterned components to seed to block
changes to the configuration of patterned instances.

This option is available for component patterns and mirror components, and applies to
all configurations.

Mate Alignment
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When you flip the alignment of a mate, the edited mate flips.

In Assemblies system options, select Change mate alignments on edit to warn you
when mate changes result in errors that can be avoided by flipping the mate alignment.
Specify Always, Prompt, or Never to determine when you receive the warning.

Change mate alignments on edit is renamed from Prompt before changing mate
alignments on edit.

Assemblies Performance Improvements

Video: What's New in SOLIDWORKS 2021 - Assembly
Performance

Assembly performance is improved when:

• Opening resolved and lightweight assemblies
• Opening assemblies with parts that have many configurations
• Updating assemblies that have many mates
• Closing assemblies without saving

Mate PropertyManager

In the Mate PropertyManager, the standard, mechanical, and advanced mate types moved
into separate tabs.
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11
Detailing and Drawings

This chapter includes the following topics:

• Detailing Mode Enhancements
• Context Toolbars and Menus in Drawings
• Location of the Hatch Pattern File
• VDA Balloons
• Performance Improvements in Detailing and Drawings

Video: What's New in SOLIDWORKS 2021 - Detailing
Mode and Drawing Delighters

Detailing Mode Enhancements

Dimensions and annotations created in Detailing Mode now update to reflect changes
that you make to the model. In addition, you can create and modify break, crop, and
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detail views, add and edit hole callouts, and edit additional characteristics of existing
dimensions and annotations.

• Robust Referencing in Detailing Mode

Robust referencing saves you a dramatic amount of time by eliminating the need to
resolve and save to maintain final annotation and dimension associativity. Previously,
you had to fully resolve and save the drawing to avoid dangling dimensions and
annotations.

• Break, Crop, and Detail Views in Detailing Mode

In Detailing Mode, you can create and modify break, crop, and detail views. You can
also add dimensions and annotations to the views.

You must save the drawing in SOLIDWORKS 2021 before you can add or edit break,
crop, or detail views to it in Detailing Mode.

• Hole Callouts in Detailing Mode

In Detailing Mode, you can add and edit hole callouts for holes that use Hole Wizard,
Advanced Hole, Hole, Extruded Cut, Swept Cut, and Revolved Cut features.

• Editing Existing Dimensions and Annotations in Detailing Mode

In Detailing Mode, for existing dimensions and annotations created in resolved mode,
you can edit additional characteristics. You can do the following:

• Edit dimension tolerance values
• Edit dimension characteristics such as line type and arrow type
• Add and remove dimensions in sets of chain and baseline dimensions
• Edit annotation note characteristics and content

Context Toolbars and Menus in Drawings
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In drawings, you can access context toolbars and menus for centerlines, sketches, drawing
views, and markups.

Click an item to display the context toolbar.

Right-click an item to display the context toolbar and menu.

Location of the Hatch Pattern File

You can save the hatch pattern file, sldwks.ptn, in any searchable folder so it is not
overwritten when you upgrade SOLIDWORKS®. This is useful if you customize the file.

By default, the hatch pattern file is saved in a SOLIDWORKS installation folder and is
overwritten with the default file every time you upgrade SOLIDWORKS.

To specify a new location for the hatch pattern file:

1. Move your modified sldwks.ptn file to the location of your choice.

2. Click Options (Standard toolbar) or Tools > Options.
3. On the System Options tab, click File Locations.
4. In Show folders for, select Hatch Pattern File.
5. Select the current location of the hatch pattern file and click Delete.
6. To specify the new location, click Add, browse to the new location, and click OK.

If you share a drawing that uses a custom hatch pattern, also share the custom
sldwks.ptn file for the recipient to use so that the pattern renders correctly.
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VDA Balloons

In drawings, you can tag inspection points according to VDA requirements. VDA balloons
are frequently used in the German automotive industry.

You use circular balloons with a VDA leader type to create VDA balloons.

Before you begin, specify options for the VDA leader:

1. Open the drawing.

2. Click Options (Standard toolbar), select the Document Properties tab, and then
select Annotations.

3. On the Balloons page, under Leader display, for Single/Stacked Balloons, select
VDA.

4. On the Notes page, under Leader display, for Single/Stacked Balloons, select
VDA.

5. Click OK.

To add VDA balloons:

1. Click Balloon (Annotation toolbar), or click Insert > Annotations > Balloon.
2. Under Settings, for Balloon text, select Text.
3. Click a location for the balloon.

A circular balloon appears.

4. In the PropertyManager, click OK .
5. Click the balloon, and then in the PropertyManager, click More Properties.

6. In the Note PropertyManager, under Leader, click VDA Leader .
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The balloon changes to a VDA balloon.

You can move and rotate VDA balloons and edit the text. Select the balloon and do the
following:

To move it, drag the attachment point.
Optionally, you can attach the leader to an
item such as an edge or vertex. Drag over
the item and drop when the item
highlights.

To rotate it, drag any part of it except the
attachment point.

To change the text, select the balloon and
edit Balloon text in the PropertyManager.

Performance Improvements in Detailing and Drawings

Video: What's New in SOLIDWORKS 2021 - Drawing
Performance

Areas of improvement include Detailing Mode, massive drawings, section views, bills of
materials (BOM), cosmetic threads, and opening and saving drawings.

In Detailing Mode, robust referencing saves you a dramatic amount of time by eliminating
the need to resolve and save to maintain final annotation and dimension associativity.

For massive drawings, display performance is improved in many areas.

• While sketches are shown:

• Zoom and pan performance is improved substantially.
• For Zoom to Area, the shaded box keeps up with the pointer movement.
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• Zoom and pan performance is more consistent regardless of zoom scale, for example,
when zooming tight versus zooming to fit.

• The latency issue that occurred for the first pan is eliminated.
• Selecting and moving annotations is improved.
• Dynamic highlighting is improved.

Performance is also improved when:

• Creating and updating large section views
• Using Auto Insert to add center marks when creating section views
• Canceling Edit Sketch in broken-out section views
• Creating a detail view in a section view
• Importing a model’s cosmetic threads into a view
• HLR background processing for high-quality display of cosmetic threads, by taking

advantage of available CPU cores
• Sorting a BOM
• Opening a drawing file
• Selecting items in drawings
• Saving a drawing as a .dwg file
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12
SOLIDWORKS PDM

This chapter includes the following topics:

• Customizing Columns
• Supporting Cut List References in Computed Bill of Materials
• SOLIDWORKS PDM File Explorer Enhancements
• Icon Changes for Workflow States and Transitions
• Treehouse View in the Where Used Tab
• SOLIDWORKS PDM Performance Improvements
• Displaying Derived Part References
• Using Bill of Materials Options Defined in SOLIDWORKS

Video:What's New in SOLIDWORKS 2021 - SOLIDWORKS
PDM

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased product.
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Customizing Columns

SOLIDWORKS PDM offers flexibility and control for column sets. You can assign multiple
column sets to users or groups for all column set types. In SOLIDWORKS PDM File Explorer,
you can view the file list based on assigned column sets.

• In the Administration tool, the Columns node contains column set types that list
column sets.

• The following table describes the column set types that you can define:

60

SOLIDWORKS PDM



Available InType

• Contains tab
• Where used tab

File Details

• Change state dialog box
• Check in dialog box
• Check out dialog box
• Get dialog box
• Undo check out dialog box

File Operations

For Search Result columns, you can assign multiple column sets through a search card.

• In the SOLIDWORKS PDM File Explorer, to view and switch between column sets,
right-click any column header or empty space and select Column Sets. You can also
change the order, adjust the width, and sort by column for each column set.

User customizations for column width and positions that were made on SOLIDWORKS
PDM clients in a prior release are not available in the SOLIDWORKS PDM 2021 client.

• If you have the required administrative permissions, you can add and remove columns
directly in the file details and file operations user interface. Right-click any column
header, select Column Sets, and then select My Columns to specify it as the active
column set. You can then use the Columns menu to add or remove columns.

This column set is specific to the user's login and the client machine.

You must have the following administrative permissions to access My Columns:

• Can view and modify My Columns in File Details
• Can view and modify My Columns in File Operations

Configuring Column Sets

The Customizable Columns dialog box has new features that let you configure column
sets.

Columns Tab

DescriptionOption

The move to top and move to bottom controls let you arrange
the columns.

and

Defines a default sort column and sort direction for each column
set.

Sort Column
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DescriptionOption

Restores columns to the default for the column set type.Reset

Lets you enter a configuration name and add it to the list of
configurations.

Available only for File List column sets.

Look for variable in
given list of
configurations

Permissions Tab

DescriptionOption

Assigns a column set to a user or group.View

Assigns a column set as the preferred one for users or groups.Preferred

You can also assign user and group permissions for column sets through the user properties
and group properties dialog boxes.

1. In the Properties dialog box, click Columns.
2. In the Columns page, select Type.

A list of available column sets appears.

3. Select View to assign permission and select Preferred if you want to specify it as
the preferred column set.
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Supporting Cut List References in Computed Bill of Materials

You can configure a computed BOM to include cut list references and then export it to an
XML file.

In the Administration tool, in the Bill of Materials dialog box, select Include cut list
references. You can base the cut list references on the Weldment cut list or the
Weldment BOM.

If a cut list item is defined as Exclude from cut list in SOLIDWORKS, it is not displayed
in the computed BOM.
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SOLIDWORKS PDM File Explorer Enhancements

The ribbon control of Microsoft® Windows® File Explorer is also available in SOLIDWORKS
PDM File Explorer.

Currently, in SOLIDWORKS PDM File Explorer, only View commands and few other
commands of the ribbon control are supported.

• In SOLIDWORKS PDM File Explorer, you can use the Quick Access Toolbar to easily
access commonly used commands. In the Administration tool, right-click a user or
group and click Settings. In the left pane of the Settings dialog box, click Quick
Access Toolbar and specify the commands.

• The file list and the search result lists support all Windows File Explorer view types
except for Content.

• Workflow state icons beside the state name in the file list view make it easier to identify
the state of the file.

• Click to change the Language and view the About information of the installed
SOLIDWORKS PDM product.

• Use Back and Forward from the address bar and return to the previously selected
file.

• Use keyboard shortcuts for commonly used commands:

Keyboard ShortcutAction

Ctrl + ICheck In

Ctrl + OCheck Out

Ctrl + UUndo Check Out
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Keyboard ShortcutAction

Ctrl + TChange State

Icon Changes for Workflow States and Transitions

SOLIDWORKS PDM has new icons for workflow states and transitions. The colors and
appearance of existing icons are improved.

In the Administration tool, open a workflow, and in the Properties dialog box of a state,
click Change. In the Select Icon dialog box, icons are grouped under categories that
make the selection process easier.
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Treehouse View in the Where Used Tab

SOLIDWORKS PDM 2021 extends Treehouse view in the Contains tab to the Where Used
tab. This helps you to view all the parent relationships of the selected child in a hierarchical
and graphical format.

Available in SOLIDWORKS PDM Professional only.

SOLIDWORKS PDM Performance Improvements
SOLIDWORKS PDM 2021 has improved performance of file-based operations and related
workflows.

• Add Files, Check-in, and Change State

Improvements in system performance help you to quickly open, add, check in, and
change the state of files with large reference structure. The Add Files operation is
between 1.5 and 3 times faster. The Check-in and Change State operations are
approximately 25% faster.

The level of improvement can vary depending on the number of files, network
bandwidth, and CPU cores.

The Check-in dialog box itself displays much more quickly (in seconds rather than
minutes) for very large assemblies or parts with a high number of configurations.

• Destroy

You can more quickly destroy files or folders. The operation is many times faster when
you are destroying a large number of files.

• Other Operations and Workflows
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Performance is significantly improved for the following operations:

• For folders containing a very large number of files:

• Check-in and Check-out of a file
• Adding a new file by dragging or by copying and pasting
• Creating a new file from a template

• For assemblies with a large number of components at a single level, when working
in SOLIDWORKS:

• Opening files
• Saving files
• Switching windows

• Editing a target file name in the Copy Tree dialog box in a high latency environment
• Using Copy Tree when a user setting is added to clear variable values

Displaying Derived Part References

The support for the derived part references is improved and you can view them in the
file view tabs and SOLIDWORKS PDM Add-in.

• Computed BOM

You can configure a computed BOM to include derived part references. In the
Administration tool, open the Bill of Materials dialog box, and select Include derived
part references.

• Contains and Where Used tabs

You can view derived part references in the Contains and Where Used tabs regardless
of the selected configuration. Previously, derived part references were displayed only
when you selected the Do not show configurations option for the configuration.

67

SOLIDWORKS PDM



• SOLIDWORKS PDM Add-in

In SOLIDWORKS, click Tools > SOLIDWORKS PDM > Options. In the View Setting
tab, select Display top level derived part references in assemblies and drawings.
You can view the top-level derived part references in the reference structure for
assemblies and drawings.

You can also view 3D Interconnect derived part references in the reference structure
of the parent part file.

Using Bill of Materials Options Defined in SOLIDWORKS

SOLIDWORKS PDM uses the Bill of Materials component display settings that are specified
in SOLIDWORKS.

In SOLIDWORKS, in the Configuration Properties PropertyManager, the parameters that
you specify in the Bill of Materials Options are also supported in computed BOMs of
SOLIDWORKS PDM.

• In SOLIDWORKS, the Promote option for Child component display when used as
a subassembly dissolves the subassemblies in the BOM and displays the child
components. The computed BOMs follow this behavior for subassembly references that
are defined to Promote.

This option applies only to computed BOMs. The assembly is included as a reference
in the Contains and Where Used tabs.

• In SOLIDWORKS, the Link to Parent Configuration option for Part number
displayed when used in a bill of materials sets the configuration to use the same
part number as the parent configuration. If you define this option, the computed BOM
uses the part number of the parent configuration.

This option is available only for derived configurations.
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13
SOLIDWORKS Manage

This chapter includes the following topics:

• Bill of Materials Enhancements
• Task Enhancements
• SOLIDWORKS Manage User Interface Enhancements
• Database Debug Log Viewer
• Promotion Settings for SOLIDWORKS PDM Reference Files
• Multiselect Project Stages and Show Substages Options
• Access to the Capacity Planning Dashboard
• SOLIDWORKS File Preview in the Plenary Web Client
• Thumbnail Utility for SOLIDWORKS PDM Objects
• Access to Numbering Schemes
• Partial Administrators for Dashboards
• Save as Recursive
• Viewer Licenses
• Multi-Language Display Names
• Controlling Field Values
• Optionally Upgrading the Database
• File Sharing Option
• Other SOLIDWORKS Manage Enhancements

Video: What's New in SOLIDWORKS 2021 - Manage

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Bill of Materials Enhancements

SOLIDWORKS Manage offers more capabilities for managing and exporting Bills of Material.

• You can check out and edit the Bill of Materials (BOM) values of a parent file without
checking out its child files or items.

Available only for limited field types.

• You can export a BOM in tree format with Export BOM items in Tree Style. The BOM
export settings of the selected object are applicable for all files and items of the BOM.

• You can compare all the levels of BOMs by specifying the Multi-line compare option
in the Bill of Materials (BOM) compare tool.

• You can create linked records directly from a BOM view even if the record is not checked
out.
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Bill of Materials Editing Features

SOLIDWORKS Manage 2021 has Bill of Materials editing features that allow streamlined
editing and rearranging of line items.

These new features are available in the Bill of Materials toolbar:

DescriptionOption

Click Dissolve and use the Dissolve dialog box to remove
parent sub-structures and promote their child items into the
current level that is under an editing state.

Dissolve

Click Add New and use the Add New dialog box to add a new
item to a BOM. If you have permission, you can select records
from multiple objects.

Add New

Click Add New From and use the Add New From dialog box
to add a new item using the selected item as the source record.
This is similar to the New From function available in other areas.

Add New From

Use the Cut, Copy, and Paste commands to copy or move
items across levels.

Cut, Copy, and Paste

Use Replace to directly replace a selected item with a newly
created record.

Replace

Click Copy From and use the Copy From dialog box to view
the structure of the selected record and also select the items
that you want to copy.

Copy From
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Task Enhancements

SOLIDWORKS Manage lets you control and manage tasks efficiently.

• Task Board is now accessible from the Capacity Planning dashboard and My Work area.
You can group tasks based on priority or status. You can also order them by subject,
start date, due date, created date, or progress.

• The following new context menu items are available for the Tasks in the My Work area:

• Assign To
• Mark as complete
• Delete

• In the Default Dashboard - Tasks, the following enhancements are done:

• Part number and Priority columns are available.
• Urgent tasks are highlighted.
• The order of tasks is the same as in My Tasks.
• The user interface retains the order, filter, and item selection even after a refresh.

• The owners can control the tasks that an assignee can do. In the Task Templates form,
under Allow assigned users to, select the following:

• Add attachments
• Remove attachments
• Change details list

• The following options are selected by default to make the newly created tasks private:

• Create new tasks as “private” in the My Options dialog box
• Private option in the Stage Task dialog box

These tasks are visible only to the owner and the assignee.
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• When you select Email task owner when task is completed in the System
Administration tool, the owner of the tasks automatically gets notified on the task
completion. The email is sent to the owners for the tasks that are created after you
select the option.

• Tasks can have a main attachment such as a project or process that can be edited or
deleted.

SOLIDWORKS Manage User Interface Enhancements

The SOLIDWORKS Manage user interface has many improvements that improve usability,
including new options and controls, and new locations for existing controls.

• When you add records to a Reference folder with a single object enabled, the specified
object is automatically selected from the list.

• When you create a new record using New From, the Derived From system field
appears and automatically displays the source record’s part number.

• The Project stage properties page has a link to update third-party fields.
• The Objects and Fields form, added in 2020 Service Pack 1, has icons for objects and

fields.
• The move command is also available in the main project grid. Previously, it was

available only in the project property card.
• The Capacity planning user selection form has all the custom fields for users. Previously,

only system fields were available.
• The Change owner option in Tasks displays all user fields instead of a simplified list.
• The Data Sources dialog box is available in the field definition for Data Source type

fields. To access this, in the Field Properties dialog box, in the Properties tab, click the
ellipsis to select from the Data Source list.

• The default sort order for new objects is set to Created Date in descending order so
the newest records are on top. You can also change the default sort order.

• In the Administration tool, you can display context-sensitive help from various dialog
boxes.
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• The Notification editor has buttons that let you insert dynamic field values. Previously,
the dynamic content was only available through the context menu and was not
discoverable.

• You can use a context menu to move records available as deliverables in a project
stage.

• The Preview pane displays the selected files in the Where Used tab. You can visualize
parent assembly structures without navigating to the parent record.

• When you write queries, you can get the ID information about the fields and objects
from the Objects and Fields Information dialog box.

• The field control icons appear on the left side of the field entry box instead of the right
side. This improves your view in full screen mode as you do not need to move the
cursor away from the field label.

Database Debug Log Viewer

In the Administration tool, for Audit Trail, administrators can specify that tracked errors
are written to a log file on the user's computer. The user can then send this log file to
the administrators or to the SOLIDWORKS Technical Support team for analysis.

To enable database debug mode, in the My Option dialog box, specify Database debug
mode.
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Promotion Settings for SOLIDWORKS PDM Reference Files

You can select the options that are available to define the handling of missing file
references during promotion through SOLIDWORKS PDM state change.

The options are:

• Notify user and stop the transition in SOLIDWORKS PDM. This is the default
behavior.

• Notify user and continue the transition in SOLIDWORKS PDM
• Do not notify user and continue the transition in SOLIDWORKS PDM

If you select this option, it may result in differences between SOLIDWORKS PDM
and SOLIDWORKS Manage BOMs.
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Multiselect Project Stages and Show Substages Options

You can select multiple stages and view associated resources, tasks, and deliverables.

In the record Property Card, select Show All Sub-Stages to view the project tasks,
resources, and deliverables connected to the substages of the selected stage.

Access to the Capacity Planning Dashboard
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You can access the Capacity Planning dashboard from the Toolsmenu and the Resources
tab of a project property card.

The users that you select in the Resources tab appear in the Capacity Planning dashboard.

SOLIDWORKS File Preview in the Plenary Web Client

You can view thumbnail images for SOLIDWORKS files in the Preview pane. You can also
maximize the image.

For files stored in a SOLIDWORKS PDM vault object, click the link and open the file in the
SOLIDWORKS PDM Web2 browser for dynamic viewing.
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Thumbnail Utility for SOLIDWORKS PDM Objects

A new utility is available in the SOLIDWORKS PDM object administration wizard.

This utility gets the thumbnail images for SOLIDWORKS parts, assemblies, and drawings
from the SOLIDWORKS PDM archive server. It also helps to attach a new SOLIDWORKS
PDM vault where the files do not have images stored in SOLIDWORKS Manage.

Access to Numbering Schemes
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When you define the object or field, you can directly add or edit numbering schemes.

Previously you had to close the Object properties dialog box and open the Administration
tool to access the numbering schemes.

Partial Administrators for Dashboards

Administrators can assign partial administrators to the dashboards. Partial administrators
can create and edit dashboards.

Save as Recursive
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The Save as (Recursive) option in the SOLIDWORKS Manage add-in for SOLIDWORKS
imports assemblies and references. It also applies the numbering scheme defined in
SOLIDWORKS Manage to those assembly structures.

To access this option, in the Structure view, right-click, and select Save as (Recursive).

You can enter other field values and read pre-existing custom properties in files.

Viewer Licenses
Users who log in with a Viewer license can accept a process and send it to the next stage.

Some processes have outputs that create new records including new processes. If the
newly created processes are not allowed by the Viewer license, then the users cannot
create or participate in any stage of the process. However, they can create subprocesses.

Multi-Language Display Names

Users who use different language versions of SOLIDWORKS Manage can enter the text
in different languages.

The text includes field display names, property card tabs, and module names. The
administrator can define the display names specific to languages in the Administration
tool. This enhancement lets each user see most of the user interface in their native
language.
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Controlling Field Values

When you create a record using the Copy From function, the administrator of an object
can:

• Clear the field values
• Set field values to their default values

Optionally Upgrading the Database
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When you upgrade a client and log in to the environment, SOLIDWORKS Manage lets you
optionally upgrade the database.

If you choose not to upgrade the database, the database remains unchanged and you
cannot use it with the upgraded client. Previously, when you upgraded the client, the
database upgraded automatically too.

File Sharing Option

You can share files from SOLIDWORKS Manage with anyone, even if they do not have
SOLIDWORKS Manage installed.

To share a file, right-click and select Share. You can then edit settings for each shared
file from the File Sharing tab in both the desktop and the Plenary web client interface.

The Share command creates a special link to the files through the Plenary web client.
You can copy, email, and password protect this link. You can also define a time limit after
which the link becomes invalid.

Administrators enable sharing for users and groups and define limits on the number of
files that can be shared simultaneously. They can also define the number of links that
can be created for a particular object.
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Other SOLIDWORKS Manage Enhancements

Other enhancements for SOLIDWORKS Manage include process and search improvements,
and new options for administrators.

• You can do full text searches of imported files. In the Files and Excel Importer tool,
specify the Full Text Search option.

• You can change the data type (Text, Date, or Number) of a link to a third-party field.
The software warns you that it deletes incompatible data. Previously, to change the
data type, you had to delete and create the field again.

• Released (approved) icons appear for status change outputs from Timesheet processes
as the processes complete.

• When you add references to document objects, you can use the File Name column
in the Add Reference(s) dialog box to quickly find records.

• In the Process Wizard, on the Main Configuration page, you can clear Automatically
fill process description field from affected items.

• You can create a new project record from existing project records and add attributes
such as stages, tasks, resources, and deliverables from the source project.

• The Gantt chart tools and functionality of the Project Planning tool provide better
performance. The tools are more responsive when you add or edit predecessors or
move stages in the Project Planning tool.

• When you save a process record, you must fill in all the required fields at each stage.

If you want to receive a warning when you do not fill all the required fields, in the
Process Wizard, select All process fields must be completed when a process is
created.

• Administrators can control the layout of main grids and prohibit users from saving
their changes.

The changes that the users make are applicable for the ongoing session only. When
they log in again, they get the default configuration saved by the administrators.
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• Administrators can enter a password instead of getting a system-generated password
when they reset passwords for external users.
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14
SOLIDWORKS Simulation

This chapter includes the following topics:

• Terminology Updates for SOLIDWORKS Simulation
• Contact Stabilization
• Robust Default Interaction Settings
• Improved Bonded Formulation
• Geometry Corrections for Surfaces in Contact
• Switch Source and Target Faces for Local Interactions
• Default Mesh Settings
• Enhanced Blended Curvature-Based Mesher
• Mesh Quality-Diagnostics Tool
• Simulation Solvers
• Improved Post-Processing for Very Large Models
• Simulation Evaluator
• Pin Connector Forces
• Copy Tabular Simulation Results to Clipboard
• Performance Improvements in SOLIDWORKS Simulation Professional and

SOLIDWORKS Simulation Premium

Video: What's New in SOLIDWORKS 2021 - Simulation

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Terminology Updates for SOLIDWORKS Simulation

User interface terms related to contact and mesh are updated to match conventional
industry terminology. The term Interaction is introduced to describe the type of behavior
between components during a simulation (bonded, contact, or free).

As in previous releases, you specify the type of interactions between components at three
levels:

Defines the conditions that apply to all components. Specify
the default global interaction conditions in the new Simulation
Options > Default Options > Interaction dialog box.

Global Interaction

Defines the conditions that apply to selected components in
the Component Interaction PropertyManager.

Component
Interaction

Defines the conditions that apply to selected sets of geometric
entities in the Local Interactions PropertyManager.

Local Interaction

Local interactions settings override component-level interactions, while component-level
interactions override global-level interactions.

The interface term for the No Penetration interaction type is replaced with the term
Contact. The term for the Allow Penetration interaction type is replaced with the term
Free.

For the Bonded interaction type, the term Incompatible mesh is removed from the
user interface. In SOLIDWORKS Simulation 2021, improved algorithms make the bonding
formulation for components that mesh independently more robust and accurate (known
previously as incompatible bonding). The option to bond components by enforcing common
mesh nodes at their boundaries (known previously as compatible bonding) is still available.
When you select Enforce Common Nodes at Touching Boundaries, the selected
components are meshed as one body. These components behave as if they are welded
at their touching boundaries.
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SOLIDWORKS Simulation 2021 - User
Interface

SOLIDWORKS Simulation 2020 - User
Interface

Local Interactions > ContactContact Sets > No penetration
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SOLIDWORKS Simulation 2021 - User
Interface

SOLIDWORKS Simulation 2020 - User
Interface

Unlimited gap distance replaces legacy
option Always ignore clearance.

If gap is less than replaces legacy option
Ignore clearance only if gap is less than.

Component Interactions > BondedComponent Contact > Bonded

Contact Stabilization
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Contact detection is enhanced with a contact stabilization algorithm that can resolve
under-constrained conditions. Contact stabilization acts as a numerical stabilizer by adding
a small stiffness to qualified areas before they come into contact.

With contact stabilization, the solver can resolve instability issues encountered at the
start of the solution before contact is initiated. You can specify the threshold value of the
clearance between geometric entities to qualify them for contact stabilization. You set
the clearance in:

Default Options > Interaction > Stabilize the area if the gap is value% of
characteristic length.

By default, the software always applies contact stabilization to geometries that have an
initial clearance within a threshold value of 1% of the model's characteristic length.

For example, for the two bodies that come into contact as shown in the image above,
areas within the green frame qualify for contact stabilization because their clearances are
within the gap threshold (x). Areas inside the red frame do not qualify for contact
stabilization because they are either interfering or their clearance exceeds the gap
threshold.
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Application of Contact Stabilization

Example of two bodies that have an initial clearance and come into contact under load
application. Contact stabilization enables the accurate solution in SOLIDWORKS Simulation

2021.

Accurate stress plot results with the enablement of contact stabilization in SOLIDWORKS
Simulation 2021.
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Application of Contact Stabilization

Inaccurate stress plot in SOLIDWORKS Simulation 2020.

Robust Default Interaction Settings

Simulations that have bonded and contact definitions are more robust, even for models
with slightly imperfect geometries. Algorithms that detect clearances between geometries
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and enforce appropriate interactions are improved, and user interface selections are
simplified.

Enhancements for defining interactions between geometries include:

• Separate options to set the global interaction type for linear static and other studies
(Default Options > Interaction > Global interaction type > Bonded, Contact,
or Free).

• Global settings for qualifying areas propagate to the component interaction and local
interaction definitions. The default global settings for new studies ensure that
simulations can run even for models with slightly imperfect geometries. The software
calculates the qualified regions based on a percentage of the characteristic length of
the participating geometries.

DescriptionGlobal Default Options - Interactions

Geometry entities that are within this
clearance qualify for a bonding definition.

Gap range for bonding: 0.01% of
characteristic length

Geometry entities that are within this
clearance qualify for a contact definition.

Gap range to consider contact: 10 %
of characteristic length

Applies a small stiffness to the qualified
regions so the solver can overcome
instability issues and start the simulation.

Stabilize the area if the gap is: 1% of
characteristic length

These default settings for qualifying interactions are recommended for novice users
that might encounter difficulties running simulations. More experienced users can
customize these settings to fit their models.

• Separate options for the global contact and bonding formulations (Default Options
> Interaction > Contact Formulation, or Bonding Formulation).

• Removal of node-to-node contact formulation. When you open models with legacy
node-to-node contact definitions, SOLIDWORKS Simulation 2021 converts them to
node-to-surface contact during the analysis.
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Improved Bonded Formulation

The accuracy of results for static, frequency, and buckling studies is improved for
geometries that have bonded interactions. Improved algorithms that mesh bodies
independently drive this improvement.

For simulations with bonded interactions between geometries, you can observe solution
improvements in these cases:

• Gaps or small interferences exist between the independent meshes of geometries that
are bonded, even though the actual geometries have no clearances (solid-to-solid,
shell-to-shell, and solid-to-shell bonded interactions).
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The gap between the two cylinders represents the shell thickness (inner solid body,
outer shell body). In reality, the two cylinders are touching with no clearance.

• There is a physical clearance between bodies that you want to bond.
• For frequency studies, detection is accurate for the six rigid-body modes for

unconstrained assemblies.
• For assemblies that experience rigid-body rotations, detection is accurate for a nearly

zero stress-state

Geometry Corrections for Surfaces in Contact

Simulations for linear static studies are more accurate for curved surfaces that come into
contact.

The contact detection algorithm integrates geometry correction factors that improve the
representation of curved surfaces of cylindrical, spherical, and conical geometries.

The image above shows one-quarter of a cylindrical model with a spherical cavity. The
two parts mesh independently. A pressure load is applied at the top of the spherical cavity.
During simulation, contact forces develop at the spherical boundaries. The stress gradient
plot shown at the right represents accurately the contact behavior.

Another example where results are improved for SOLIDWORKS Simulation 2021 because
of the integration of geometry correction factors in contact simulation is shown below.
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Two cylindrical bodies come into contact under a pressure load. The bodies mesh
independently. The inner body has a draft-quality mesh with a higher mesh density.

The outer body has a high-quality mesh with a lower mesh density.

With the integration of geometry corrections, the deformation contour plot is accurate
(SOLIDWORKS Simulation 2021).
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Inaccurate deformation contour plot (SOLIDWORKS Simulation 2020).

Switch Source and Target Faces for Local Interactions

For local interactions, you can switch the geometry selections between the source and
target sets to resolve convergence issues. When you are working with complex geometries
that have multiple faces, switching the geometry entities between the source and target
sets with the Swap interaction faces tool saves you time.

In the Local Interactions PropertyManager, click Swap interaction faces .
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Default Mesh Settings

The default mesh settings for new studies facilitate mesh assignments for most models.

Enhancements for mesh settings include:

• You can select the Blended curvature-based mesher as the default mesher for new
studies. In the Default Options >Mesh dialog box, forMesher type, select Blended
curvature-based.

• A new option Mesh all solid bodies with solid mesh (Default Options > Mesh)
allows you to mesh all solid, sheet metal, and weldment bodies with a solid mesh.
Meshing all solid bodies with solid elements saves you time in preparing the model for
meshing (particularly useful for novice simulation users), but can increase the overall
solution time.

• At a study level, you can override the mesh assignments enforced by the option Mesh
all solid bodies with solid mesh. In a simulation study tree, right-click the top Parts
folder, and select Treat all sheet metals as shells, or Treat all weldments as
beams.

• You can select the type of a mesh contour plot that becomes visible after meshing in
the new dialog box Default Options > Plot > Mesh Plot.

• For new studies, the default setting for a mesh quality plot based on the Jacobian ratio
is 16 points.
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Enhanced Blended Curvature-Based Mesher

The Blended Curvature-based mesher has improved performance based on optimized
code architecture, multithreading, and parallel multicore processing. The improved mesher
can mesh parts and large assemblies significantly faster.

It can also mesh models that previously failed to mesh. In addition, mesh cancellation is
immediate, and performance issues including program termination that are related to
mesh cancellation are resolved. These performance improvements also apply to the
Curvature-based mesher.

For example, for the clamp assembly with 11 parts shown above, mesh generation with
the enhanced Blended Curvature-based mesher is approximately 5 times faster. The table
lists the mesh details of the clamp assembly model for the 2020 and 2021 releases.
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20212020Mesh Details

Enhanced Blended
Curvature-based

Blended Curvature-basedMesher

SolidSolidMesh Type

5.815 mm / 0.291 mm5.815 mm / 0.291 mmMaximum element size/
Minimum element size

46,729 / 27,02845,918 / 26,490Total nodes / total elements

00:110:50Time to complete mesh
(minutes:seconds)

The performance improvement of the enhanced Blended Curvature-based mesher depends
on the number of parts in an assembly, the number of physical cores, and available
memory.

The table lists the SOLIDWORKS Simulation licenses that support single-core processing
and multicore processing for the Blended Curvature-based mesher.

Licenses with Multicore
Processing

Licenses with Single-core
Processing

Mesher

Blended Curvature-based
(surface meshing)

• SOLIDWORKS Simulation
Professional

• Simulation Xpress
• Simulation in

SOLIDWORKS Premium • SOLIDWORKS Simulation
Premium• SOLIDWORKS Simulation

Standard There is no limit to the
number of physical cores
that the Blended
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Licenses with Multicore
Processing

Licenses with Single-core
Processing

Mesher

Curvature-based mesher can
access.

Mesh Quality-Diagnostics Tool

Improved diagnostic tools help you examine the quality of a mesh and detect poor-quality
elements.

After meshing, right-click Mesh (Simulation study tree), and select Mesh Quality
Diagnostics. The Mesh Quality Diagnostics plots display the Jacobian ratio, Aspect
ratio, or Element volume for the whole model or selected bodies. By default, the software
evaluates an element with a Jacobian ratio and Aspect ratio greater than 20 as poor
quality. You can edit the default value to evaluate poor quality elements. For example,
in the image above 24 elements are highlighted as poor quality based on the failure
criterion for Aspect ratio greater than 10.

To isolate poor-quality elements:

1. In the Mesh Quality Diagnostics PropertyManager, under Advanced Options, select
Switch to Probe and Diagnose when poor quality elements are detected.

2. In the Probe and Diagnose PropertyManager, select Isolate poor quality elements.
3. ClickMesh Helper to get assistance refining the mesh at key areas and resolve mesh

quality issues before proceeding with the analysis.
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Simulation Solvers

The solution time of linear static studies with many surface-to-suface contact elements
is improved. The Intel Direct Sparse solver can handle linear static and nonlinear studies
with more than 4 million equations.

The image shows the total solution time in minutes for a linear static analysis of a large
model solved with the FFEPlus Iterative solver. The model has 1.0 million tetrahedron
elements and 0.5 million contact elements with friction. Because of the FFEPlus solver
enhancements in SOLIDWORKS Simulation 2021, the overall solution time for this
particular model that has 1/3 surface-to-surface contact elements of all total elements
is decreased by more than 50%.

• FFEPlus Iterative

The solution time for linear static studies is improved by using parallel multicore
processing to calculate the stiffness for surface-to-surface contact elements.

The transfer of stiffness data to solve the systems of equations is optimized because
file-based processing is replaced with function-based processing.

These performance gains are more apparent for large models that have at least 10%
contact elements of the total elements.

Function-based processing is not implemented for models that include any of these
features:

• Connectors: spring, bearing, bolt, and rigid connector
• Node-to-surface contact, virtual wall contact, cyclic symmetry, remote load with

rigid connection, and beams acting as stiffeners.

These limitations also apply to the Large Problem Direct Sparse solver.

• Intel Direct Sparse

101

SOLIDWORKS Simulation



The solver can handle significantly larger linear and nonlinear simulation studies by
taking full advantage of available memory. When the solver exceeds the available
memory, it uses available disk space to run the simulation.

The solver can run simulations for linear static and nonlinear studies with more than
4 million equations.

• Large Problem Direct Sparse

The solver has limited performance improvement based on improved function-based
data transfer of stiffness data and parallel multicore processing to calculate the stiffness
for surface-to-surface contact elements for linear static studies.

• Automatic Solver Selection

The algorithm that selects the best equation solver for linear static studies is optimized.
The selection of the best equation solver (Intel Direct Sparse or FFEPlus Iterative))
depends on: the number of equations, load cases, mesh type, geometric features,
contact and connector features, and available system memory.

• Manual Solver Selection

The user interface for manual solver selection is improved to provide quick access to
the most efficient solvers. To view all available solvers, in the Options dialog box, select
Solver > Manual > More Solvers.

• Multicore Processing

The table lists the multicore processing specifications of simulation solvers for each
Simulation license.
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Simulation Licenses - No
Limit on Number of
Physical Cores

Simulation Licenses -
Limited to Maximum of 8
Physical Cores

Solvers

• SOLIDWORKS Simulation
Professional

• SOLIDWORKS Simulation
Premium

• Simulation Xpress

FFEPlus is the only
solver option for
Simulation Xpress.

• Simulation in
SOLIDWORKS Premium

• SOLIDWORKS Simulation
Standard

• FFEPlus
• Intel Direct Sparse
• Direct Sparse
• Large Problem Direct

Sparse
• Intel Network Sparse

Improved Post-Processing for Very Large Models

The post-processing of stress and strain results is enhanced for models that have more
than 10 million elements.

The software can list simulation results and process stress and strain contour plots for
very large models that have up to 2,000 million elements.

This improvement applies to Linear Static, Nonlinear, Fatigue, Linear Dynamic, and
Topology studies.
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Simulation Evaluator

The Simulation Evaluator is enhanced to flag study definitions related to the assigned
friction coefficient for contacts and materials for invalid Poisson's ratio values.

The Simulation Evaluator flags interactions that have a coefficient of friction greater than
0.2 indicating possible convergence issues. For linear static studies, it detects material
definitions with a Poisson's ratio larger than 0.5, which is an invalid definition.

Pin Connector Forces
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Listing pin connector loads at the pin joints is more accurate for shear forces and bending
moments in the global or a user-defined coordinate system.

The direction of applied loads along the pin connector is taken into account when listing
pin connector loads. Although the vector representing the direction of axial force and
torque remains the same for all pin joints, the direction of the shear force and bending
moment vectors can change from one joint to another.

The local pin axis is a vector that connects the first pin joint to the last joint. The list
of pin loads includes the axial force and torque along the local pin axis. The shear forces
and bending moments are normal to the pin's axial vector.

The table lists the connector forces of the six-part assembly connected with a multijoint
pin (6 joints) shown above. The forces exerted on the pin connector act at an angle
measured from the pin axis. In SOLIDWORKS Simulation 2021, the connector shear forces
and bending moments are more accurate because their directions are correctly defined
at each pin joint.
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List of Connector Forces (2021)

List of Connector Forces (2020)

Copy Tabular Simulation Results to Clipboard
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You can copy tabular simulation results displayed inside PropertyManagers to the clipboard
and paste the copied data from the clipboard into a Microsoft® Excel® or Word document.
You can copy reaction forces, free body forces, contact/friction forces, connector forces,
and probed results.

In a PropertyManager that contains simulation results, under Report Options, select

Copy to Clipboard .

Performance Improvements in SOLIDWORKS Simulation Professional and
SOLIDWORKS Simulation Premium

Improvements in contact calculations and multicore meshing make simulations faster.

• Calculation of contact interactions with the FFEPlus Iterative solver for linear static
studies is faster than previous releases. The overall solution time is improved by using
parallel multicore processing to calculate the stiffness for surface-to-surface contact
elements. In addition, the transfer of stiffness data to solve the systems of equations
is optimized because file-based processing is replaced with function-based processing.

• The Blended Curvature-based mesher supports multicore meshing. There is no limit
to the number of physical cores that the Blended Curvature-based mesher can access.
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15
SOLIDWORKS Visualize

This chapter includes the following topics:

• Capping Cut Planes
• Draco Compression for SOLIDWORKS Visualize GLTF and GLB Exporter
• Support for SOLIDWORKS Configurations
• Toon Shading
• Displacement Mapping
• Shaders
• User Interface Enhancements for SOLIDWORKS Visualize
• Render Layers
• Viewport Settings Dialog Box

Video: What's New in SOLIDWORKS 2021 - Visualize

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.
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Capping Cut Planes

When you create a section view, you can cap the geometry that the cut plane slices.

On the Models tab, when you add or edit a cut plane, use the following options:

Caps the geometry that the cut plane slices.Display Cut Plane
Caps

Assigns a color for all caps in the scene.Cap Color
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Draco Compression for SOLIDWORKS Visualize GLTF and GLB Exporter

You can use Draco compression when exporting 3D scenes from SOLIDWORKS Visualize
to .glTF and .glB files.

3D scenes from SOLIDWORKS Visualize often have large file sizes, which can cause
problems in scenarios that require the .glTF or .glB formats, such as augmented reality
and web streaming. Draco is the standard compression mechanism for .glTF and .glB
files.

You can also export to .glTF and .glB without Draco compression. Not all viewers or
external applications can decompress it.

To export to .glTF and .glB files, click File > Export > Export Project. In the Export
dialog box, for Save as type, select one of the following:

• To export with Draco compression:

• Compressed GL Transmission Format (*.draco.gltf)
• Compressed Binary GL Transmission Format (*.draco.glb)

• To export without Draco compression:

• GL Transmission Format (*.gltf)
• Binary GL Transmission Format (*.glb)
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Support for SOLIDWORKS Configurations

You can specify configurations of a SOLIDWORKS part or assembly model to be available
when you open the model in SOLIDWORKS Visualize.

In SOLIDWORKS, you must add the Display Data Mark to the configurations you want to
import into SOLIDWORKS Visualize. In the ConfigurationManager, right-click one or more
configurations and click Add Display Data Mark. Then when you import the model into
SOLIDWORKS Visualize, each configuration becomes a Model Set. The Model Set name
matches the configuration name.
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Toon Shading

Toon shading mimics the style of a comic book or cartoon and provides a characteristic
paper-like texture. Toon shading is available only with Visualize Professional.

To add Toon shading:

1. In the Palette, on the Cameras tab, select the Filters subtab.

Because Toon shading is added as a camera filter, your primary appearance
assignments remain unchanged.

2. Under Toon, select Enable Toon and specify parameters:

Provides a list of predefined toon profiles that you can select.
Black Edges

White on Black

Black on White

Ambient Occlusion

Custom

Toon Presets

Changes the color of the outlines. Click the color box to open
the Color Picker dialog box.

Edge Color
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Select a style:
Normal

Toon Shaded Toon Detail

Color Override

Plain Shaded

Shading Style

You can save the camera .svcm file, which contains the Toon shading parameters, and
use it in other Visualize projects or share it with other users.

Displacement Mapping

New options in the Appearances tab provide more overall control of displacements.

• New displacement options include:

• Depth. Controls how high the bumps display on the surface. Increase the depth to
make the surface bumpier. Decrease the depth to make the surface smoother.

• Displacement Density. Specifies the maximum length of the edge of a subtriangle.
Higher values result in smaller triangles and better quality.

• The Type list replaces check boxes for selecting a map type. You can select:

• Bump
• Normal
• Displacement

• Because multiple types of bump maps are available, Invert Bump is renamed Invert.
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Shaders

SOLIDWORKS Visualize uses a rendering technique that adds light to most appearance
types. This makes it easier to generate first-class commercial looks without violating the
photo-realistic principles of physically based appearances.

In previous versions, SOLIDWORKS Visualize appearances offered a high level of
photo-realism, but you had to use excessive light and camera filter adjustments to
generate sufficient brightness and saturation.

User Interface Enhancements for SOLIDWORKS Visualize
User interface enhancements for SOLIDWORKS Visualize include improvements for
animations, properties, decals, and appearances.

• Animations. You can drag an existing animation from the timeline animation list to
another model, part, or group, to apply an identical animation without having to recreate
it. You can drag the animation only onto the same type of object (model, part, or
group) that the animation belongs to.

• Properties. You can copy and paste settings across Camera and Light objects.
Right-click an object and click Copy Settings. Then right-click another object and
click Paste Settings. Previously, you could only do this for Environment and Sunlight
objects.

• Decals. Decals created from an image sequence or video have dynamic thumbnails
in the palette view. Hover the pointer over the decal thumbnail in the Appearances
tab. The thumbnail displays a preview of the video decal.

• Appearances. You can double-click a part in the viewport to select its appearance in
the Appearance tree, where you can edit it.
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Render Layers

In the Output Tools dialog box, Render Layers replaces Render Output Passes for
generating specialized output layers that you can use in post-processing software. Render
Layers, which uses Iray’s compositing elements, provides massively improved performance
by rendering simultaneously rather than sequentially.

The rendered layers created by Render Layers align more closely with industry standard
render passes known as Arbitrary Output Variables (AOVs).

Render Layers is available in SOLIDWORKS Visualize Professional.

Limitation: Render Layers does not work with Toon. If Toon is enabled in Camera,
the rendered layers are not displayed in the viewport and are not available for final renders
in Output Tools.

To select layers to render, open a model and click Output Tools (main toolbar). Then,
on the Render, Animation, Turntable, or Sun Study tab, in Render Layers, select layers
from the list.

In the new Viewport Settings dialog box, you can select rendered layers to display.

Different render modes (Preview, Fast, Accurate) support different sets of layers to
render.

DescriptionAccurateFastPreviewLayer

Contains the rendered image with all
contributions.

Beauty
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DescriptionAccurateFastPreviewLayer

Contains the alpha channel
(transparency) based on primary
visibility.

Alpha

Contains the depth of the hit point
along the (negative) Z-coordinate in
camera space. The depth is zero at
the camera position (black) and
extends in a positive direction into the
scene (brighter, white).

Depth

Contains the surface shading normal
in camera space.

Normal

Contains the texture (or UVW)
coordinate at the hit point.

UVWs

Contains the ID for the scene element
at the hit point.

Clown

Contains all light transport paths that
are diffuse at the first bounce.

Diffuse

Contains all light transport paths that
are specular at the first bounce.

Specular

Contains all light transport paths that
are glossy at the first bounce.

Glossy

Contains the emission contribution
from directly visible light sources and
emitting surfaces.

Emission

Contains the shadow in the scene.
More precisely, the layer contains the
light contributions that are missing at
a certain point because it is blocked
by an object (the shadow caster).

Shadow

Contains the ambient occlusion in the
scene in the range from 0 (fully
occluded) to 1 (not occluded).

Ambient
Occlusion

Contains approximate color weights
for the constituent bidirectional
scattering distribution functions
(BSDFs) of the material at the first
hit. This value generally reflects
textures (bitmap and procedural) used
to color material components.

Albedo
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Viewport Settings Dialog Box

The Viewport Settings dialog box provides quick access directly in the viewport to some
frequently used settings.

To open the Viewport Settings dialog box, click View > Show Viewport Settings. The
dialog box remains available in the viewport until you close it. It provides access to these
commands:

Changes the resolution (in pixels, width x height) of the 3D
Viewport and output snapshots. This option is also available in
Tools > Options > 3D Viewport.

Maximum Resolution

When in Fast or Accurate mode, the following options are
available:

No accelerating technique is used.Steady

Causes the scene to automatically switch to
Preview mode whenever you do anything –
such as moving the camera or model, playing
an animation, dragging a material, or clicking
the mouse in the viewport.

When you stop clicking or moving the mouse,
the scene blends into the raytrace mode you
have selected (Fast or Accurate).

Blended

Reduces the viewport size during interaction.
This option improves interactivity but with lower
interactive image quality.

Downscaled

These options are also available in Tools > Options > 3D
Viewport.

Interactivity
Acceleration Mode
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Captures an image from the current viewport.Take Snapshot

Displays the selected render layer in the viewport.Render Layer
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16
SOLIDWORKS CAM

This chapter includes the following topics:

• Additional Stock Types Available in Stock Manager
• Rebuild Data When Stock Parameters Are Modified
• End Conditions for Part Perimeter Feature
• Modify Path to Post Processors in the Technology Database
• Defining Peck Amounts for Point-to-Point Operations
• Supported Platforms for SOLIDWORKS CAM

Video: What's New in SOLIDWORKS 2021 - CAM

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Additional Stock Types Available in Stock Manager

The Stock Manager lets you define Bounding Box and Cylindrical Stock for mill parts
and assemblies.

You can use the Bounding Box to align the stock. You can assign the premachined
Bounding Box to a unique material group in the Technology Database.

You can define Cylindrical Stock parameters such as the center axis, origin, diameter,
and length of the cylinder, and offsets.
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Rebuild Data When Stock Parameters Are Modified

In theMillmodule, when you modify stock parameters after generating features, options,
or toolpaths, a warning lets you rebuild data for entities affected by the change. These
entities may include coordinate systems, mill part setups, features, and operations.

If you decide not to rebuild, exclamation marks appear over the entities' icons in the
Feature tree and Operations tree. You can display the warning by right-clicking the entities
affected and selecting What's Wrong in the context menu so you can rebuild the CAM
data.

The warning message is enabled by default in Tools > SOLIDWORKS CAM > Options.
To change the setting, click the Update tab and under Prompt to Rebuild, clear On
stock parameters notification.
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End Conditions for Part Perimeter Feature

You can store end condition settings for the part perimeter feature in the Technology
Database. This data is helpful in automating and maintaining consistency between parts
that are similar when programming.

Modify Path to Post Processors in the Technology Database
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In the Settings tab of the Technology Database, you can specify a folder location for post
processors associated with a Mill or Turning machine.

You can then select post processors in the General tab of the Mill machine or Turning
machine.

Defining Peck Amounts for Point-to-Point Operations

You can define peck amounts for point-to-point operations as a percentage of the diameter
or the flute length of a tool, as well as an absolute value.

Supported Platforms for SOLIDWORKS CAM
SOLIDWORKS® CAM 2021 Beta supports the 64-bit version of SOLIDWORKS 2020, running
on a 64-bit version of Windows® 10, Windows 8.1, or Windows 7 (SP1 or higher).
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17
SOLIDWORKS Composer

This chapter includes the following topics:

• Controlling the Display of Hidden Edges
• Highlighting of Invisible Actors
• Delete Empty Groups at Import
• Loading Improvements
• Saving Multiple Configurations to SOLIDWORKS Composer Files
• Sharing (Default) Document Properties
• Other SOLIDWORKS Composer Enhancements

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.
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Video: What's New in SOLIDWORKS 2021 - Composer

Controlling the Display of Hidden Edges

You can control the visibility of hidden edges when you select or highlight elements. You
can define the color and intensity used to display hidden edges.

Available in SOLIDWORKS Composer, SOLIDWORKS Composer Player, and SOLIDWORKS
Composer Sync.

In the (Default) Document Properties > Selection page, the Show hidden edges
check box, and the Color Intensity slider are added in the Selection and Highlight
sections. See Managing (Default) Document Properties > Selection, Composer Player >
Managing Document Properties > Selection, or Sync > Managing Default Document
Properties > Selection in Composer Help.

In the Document Properties > Advanced page, four corresponding properties are
available in the Selection category. See Managing (Default) Document Properties >
Advanced Properties, Composer Player > Managing Document Properties > Advanced
Properties, or Sync > Managing Default Document Properties > Advanced Properties in
Composer Help.

These new properties replace the Show hidden edges option and the Intensity slider
that were available in the Application Preferences > Selection page in previous
versions of SOLIDWORKS Composer.
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Highlighting of Invisible Actors

Invisible actors have their visibility turned off. You can specify to highlight them in the
viewport when you select them in the Assembly tree or elsewhere.

Available in SOLIDWORKS Composer and SOLIDWORKS Composer Player.

See Customizing Application Preferences > Selection or Composer Player > Customizing
Application Preferences > Selection in Composer Help.
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Delete Empty Groups at Import

You can use the IODeleteEmptyGroups advanced document property to specify that
groups that would be empty in the assembly tree after import are removed during the
import process.

Available in SOLIDWORKS Composer and SOLIDWORKS Composer Sync.

See Managing (Default) Document Properties > Advanced Properties or Sync > Managing
Default Document Properties > Advanced Properties in Composer Help.
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Loading Improvements

The loading process is improved for Composer documents such as .smg, .smgXML,
.smgProj, and fully shattered files.

Available in SOLIDWORKS Composer.

• The loading status appears in the left-hand side of the status bar.
• During the loading process, you can press Escape to cancel the operation. This does

not affect already-opened files.

See Importing and Opening Files > Importing and Opening Files in Composer Help.
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Saving Multiple Configurations to SOLIDWORKS Composer Files

You can save multiple or all configurations from SOLIDWORKS files to Composer files.

Available in SOLIDWORKS Composer.

If a SOLIDWORKS part or assembly file has multiple configurations, when you save the
file as a Composer file, you can choose which configurations to save with the Composer
file. See Managing (Default) Document Properties > Input in Composer Help.
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Sharing (Default) Document Properties

You can save (default) document properties settings to a file that you can reuse as a
template. Your colleagues can load this file in Composer to use the same (default)
document properties.

Available in SOLIDWORKS Composer.

This makes it easy to globally harmonize the document properties for all project
stakeholders. See Managing (Default) Document Properties > Sharing (Default) Document
Properties Across Teams in Composer Help.
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Other SOLIDWORKS Composer Enhancements

SOLIDWORKS Composer products have additional user interface and import improvements.

• SOLIDWORKS Composer and SOLIDWORKS Composer Sync support the following
higher versions of import formats:

• ACIS up to R2020 1.0
• Pro/E Creo 1.0 to 6.0
• SOLIDWORKS 2006 to 2021

• In SOLIDWORKS Composer, SOLIDWORKS Composer Player, and SOLIDWORKS
Composer Sync, the Selection Opacity property ((Default) Document Properties
> Selection > PMI Cross-Highlight ) is renamed to Selection Intensity. The
behavior of this property remains unchanged.

• In SOLIDWORKS Composer, SOLIDWORKS Composer Player, and SOLIDWORKS
Composer Sync, performance is improved when loading and saving Composer
documents (*.smg, *.smgXml, *.smgProj, *.smgSce).

• In SOLIDWORKS Composer Player, you can view the configurations in Composer files
in the Configurations pane. You can also control the visibility of the Configurations
pane from View > Configurations Tree.

• The user interface in SOLIDWORKS Composer Player is modernized. You can dock,
undock, move, resize, and auto hide panes. See Composer Player > Interface Concepts
in Composer Help.
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18
SOLIDWORKS Electrical

This chapter includes the following topics:

• Symbols for Terminal Strips
• Excluding a Manufacturer Part from a BOM
• Add-In for Excel Automation
• Managing Wires
• Archiver and Scheduling Process
• SOLIDWORKS Electrical Viewer
• Creating Multiple Drawings Simultaneously
• Generating Separate Routing Assemblies of Cables
• Using Splines in Routings

Video: What's New in SOLIDWORKS Electrical - 2021

SOLIDWORKS® Electrical is a separately purchased product.
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Symbols for Terminal Strips

You can associate a specific terminal symbol used in a terminal drawing either to a
manufacturer part or to a terminal symbol used in a schematic. This allows you to have
a different representation of the terminals in the terminal strip drawing.

Associating a Terminal Symbol with a Manufacturer Part

You can associate a terminal strip symbol and a terminal type with a manufacturer part
stored in the Manager.

To define a Terminal type and a Terminal strip symbol in a manufacturer part
properties:

1. In the Library tab, click Manufacturer part manager .
2. Select the manufacturer part you want to edit.

3. Click Properties .
4. Under Illustration, specify the required values for Terminal type and Terminal

strip symbol.
These values propagate to all the new components that use this manufacturer part
in the project.
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Associating a Terminal Symbol with a Schematic Terminal Symbol

You can associate a terminal strip symbol and a terminal type with a terminal symbol
stored in the Symbols Manager.

To define a Terminal type and a Terminal strip symbol in the properties of a
schematic terminal symbol:

1. In the Library tab, click Symbols manager .
2. Select the symbol you want to edit.

3. Click Properties .
4. Under Characteristics, specify the required values for Terminal type and Terminal

strip symbol.
These values propagate to all new components that use this symbol in the project.

Using Specific Symbols in Configurations of Terminal Strip Drawings

To use specific symbols in terminal strip drawings, in the Terminal Strip Drawing
configuration, you must activate Insert custom symbol and define its parameters.

This feature is not applicable in DIN configurations.

To update the configuration of terminal strip drawings:

1. In the Documents tab, right-click the Project and select Configurations > Terminal
strip drawing.

2. Select the configuration file and click .
3. In the Symbols tab, select Insert custom symbol.
4. Define in a first step the parameters for Priority - Terminal type / Terminal symbol

and in a second step the parameters for Priority - Manufacturer part / symbol.
The changes will be applied for the next update of the terminal strip drawings.
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Excluding a Manufacturer Part from a BOM

You can use the Exclude from bill of materials property in the Manufacturer part
properties dialog box to show or hide components in a BOM. The property propagates
into assemblies and 3D parts.

You can use a filter in the report configuration to hide or show these components.

Excluding from BOM - Manufacturer Part Properties in the Manager

You can exclude a manufacturer part from the BOM by selecting the Exclude from bill
of material parameter in the properties of the manufacturer part.

To exclude manufacturer parts from BOMs in the Manufacturer parts manager:

1. In the Library tab, click Manufacturer part manager .
2. Select the manufacturer part to edit.

3. Click Properties .
4. Select Exclude from bill of material.

Excluding from BOM - Manufacturer Part Properties in the Project

You can exclude a manufacturer part from a BOM by selecting Exclude from bill of
material in the properties of the manufacturer part.

To exclude manufacturer parts from BOMs in the project:

1. In the graphical area, right-click a symbol and select Symbol properties or
Component properties.

2. On the Manufacturer part and circuits tab, click Properties .
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3. Select Exclude from bill of material.
This property propagates only to the manufacturer part associated with the symbol.
It does not modify the properties of the manufacturer parts stored in the Manager.

Excluding from BOM - Using Filter in Report

When you access BOMs in the Report manager, a filter lets you hide references tagged
Exclude from BOM.

You can use a predefined report. To hide the references tagged Exclude from BOM, you
must select a filter.

To generate the BOM using the filter:

1. Click Report manager in the Project tab.
2. Select Bill Of Materials with electrical assemblies sorted by Mark with file

number report.
3. In Filter description, select Display only manufacturer parts which have option

Exclude from bill of materials unchecked.

4. Click Generate drawings .
You can also create your report using a condition with the Exclude from BOM
parameter in the query or a filter.

Add-In for Excel Automation
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You can install an Excel® add-in that helps create data for the Excel Automation feature
(requires Excel 64-bit edition).

To install this add-in, from SOLIDWORKS Electrical Schematic, click and select Install
Excel add-in.

If the installation does not start automatically, in the dialog box, select
EwExcelAddIn.vsto.

Managing Wires

You have more options to manage wires in the project.

These options are available in the General tab of the project configuration.

You can:

• Draw lines without wires (equipotentials).
• Remove the wire when you disconnect it from a symbol.
• Merge the wires when you delete a connected symbol.

To process wires in legacy projects, select all these options.
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Archiver and Scheduling Process

You can archive the SOLIDWORKS Electrical projects and environment by running
EwEnvironmentArchiver.exe.

The EwEnvironmentArchiver.exe file runs on Windows® 10. You can schedule the
archive process using Windows Task Scheduler.

To start the archiver application, do one of the following:

• From SOLIDWORKS Electrical, run the EwEnvironmentArchiver.exe file.
• From the Windows Start menu, search for EwEnvironmentArchiver.exe and run it.

Archiving with the Environment Archiver

To archive the environment:

1. Run the EwEnvironmentArchiver.exe file.
2. In Archive mode, select the objects to archive.
3. In the Output folder, browse and set the output folder path.
4. Click Archive now or Save to save the settings and archive later.

Scheduling the Archiver Using Windows Task Scheduler

To schedule a task:

1. Open Task Scheduler from Windows.
2. Click Action > Create Task.
3. In the General tab, enter the task name.
4. In the Trigger tab, click New, schedule the frequency and time, and click OK.
5. In the Action tab, click New.
6. In the New Action window, in Action, select Start a program.
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7. In Program/script, click Browse and select the path for
EwEnvironmentArchiver.exe.

8. Select the options under the Conditions and Settings tabs.

SOLIDWORKS Electrical Viewer

You can visualize project drawings using SOLIDWORKS Electrical Viewer.

To start the SOLIDWORKS Electrical Viewer, clickWindows Start menu > SOLIDWORKS
2021 program group > SOLIDWORKS Electrical Viewer.
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Creating Multiple Drawings Simultaneously

You can simultaneously create multiple drawings from a book, a folder, or a drawing. You
can select both the quantity and the type of drawings.

Generating Separate Routing Assemblies of Cables
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You can generate a separate routing assembly of cables. Specify the Separate 3D route
assembly option in the cable properties. You can select one, several, or all cables to
route.

Activating the Separate Routing Assembly Parameter for a Cable

To activate the Separate 3D route assembly parameter:

1. In the Project tab, click Cables .
2. Select one or more cables.

3. Click Properties .
4. Select Separate 3D route assembly.

Routing Cables in a Separate Routing Assembly

To route the cables in which the Separate 3D route assembly parameter is
activated:

1. In the SOLIDWORKS Electrical toolbar, click Route Cables ..
2. To open the Cable selector, in Cable to route, click Selected cables > Select

cables.
The Separate route column displays the status of the Separate 3D route assembly.

3. Start the routing.

Using Splines in Routings
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You can route electrical harnesses using splines.

You can use splines and arcs to define the routing path (EW_PATH). If you use splines
in the sketch to define the routing path, the routing is modeled by splines.

142

SOLIDWORKS Electrical



19
SOLIDWORKS Inspection

This chapter includes the following topics:

• SOLIDWORKS Inspection Add-in
• SOLIDWORKS Inspection Standalone

SOLIDWORKS Inspection is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application (see SOLIDWORKS Inspection Standalone).

SOLIDWORKS Inspection Add-in

Template File Locations

You can specify a file location for project templates and report templates. This ensures
that users in multiuser environments use the correct templates, which are critical for
quality control.

In SOLIDWORKS, click Tools > Options > System Options > File Locations and
specify a file location for Inspection Project Template Folder and Inspection Report
Template Folder.
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VDA Balloons

You can rotate VDA balloons while keeping the balloon number vertical. You can also
adjust the font size for VDA balloons.

SOLIDWORKS Inspection Standalone
SOLIDWORKS® Inspection is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as
a completely separate application (see SOLIDWORKS Inspection Standalone).
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Grid Improvements

You can customize grids to help you quickly identify their characteristics.

You can:

• Change the font style and size of zone markers.
• Display dashed gridlines to be less obtrusive and reduce interference with dimensions.
• Adjust column width and row height independently. This helps users create inspection

documents from legacy PDF files that might not have equally spaced columns or rows.

SOLIDWORKS Part Support
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You can open SOLIDWORKS parts with 3D annotations in SOLIDWORKS Inspection
Standalone to create inspection documents.

You can:

• View SOLIDWORKS parts with 3D annotations.
• Use 3D CAD data to quickly create First Article Inspection (FAI) reports.
• Read and extract 3D annotations to build reports using Smart Extract.
• Add quality control to your drawingless manufacturing strategy.
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20
SOLIDWORKS MBD

This chapter includes the following topics:

• Datum Targets
• Bend Tables in 3D PDFs

Video: What's New in SOLIDWORKS 2021 - Model Based
Definition

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Datum Targets
You can add datum target symbols to your DimXpert Dimension Scheme.

You can apply DimXpert location dimensions to datum target points and edit the dimensions
to control the location of the datum targets. DimXpert datum target labels are always
associated with an existing DimXpert datum. You can hide the original DimXpert datum
after you apply DimXpert datum targets for it. Error checking provides feedback to let
you know whether your datum targets fully define the datum.
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Bend Tables in 3D PDFs

For sheet metal parts, you can include a bend table when you publish a 3D PDF.

First, edit a template and insert a placeholder for a bend table.

1. In the 3D PDF Template Editor, click Bend Table , and then click in the template
to insert the table placeholder. You can drag and resize the placeholder.

2. Click outside of the placeholder to release it.

Then use that template when publishing a 3D PDF for a sheet metal part that has a bend
table.

1. Click Publish to 3D PDF (MBD toolbar or 3D Views tab).
2. In the Template Selection dialog box, select the template and click OK.
3. In the Publish to 3D PDF PropertyManager, under Bend Table, select a bend table

and columns to include.
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21
eDrawings

This chapter includes the following topics:

• Annotations in 3D Views
• File Properties
• Measure
• Measure and Move in Save as eDrawings Web HTML

Video: What's New in SOLIDWORKS 2021 - eDrawings

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Annotations in 3D Views
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eDrawings displays annotations in the text scale specified for the 3D View in SOLIDWORKS
part and assembly files.

File Properties

You can view the custom and configuration-specific properties of SOLIDWORKS files in
eDrawings.

Click Tools > File Properties or File Properties to display the names and values
for Custom and Configuration Specific property values.

Configuration-specific data is available for the last-saved configuration and for
configurations where you selected Add Display Data Mark in SOLIDWORKS, for SLDPRT
and SLDASM files only.
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Measure

You can use the Measure tool to measure distances between planar-cylindrical and
cylindrical-cylindrical faces. Different options specify the distance to measure when you
select arcs or circles.

Click Measure , and select:

• A planar face and a cylindrical face. The normal distance is displayed.
• Two cylindrical faces. In the Measure pane, under Arc/Circle Measurements, specify

Distance as Center to Center, Minimum Distance, or Maximum Distance.
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Measure and Move in Save as eDrawings Web HTML

eDrawings Web HTML files support the Move and Measure tools.

Move is available for assembly files (.EASM, .SLDASM). Measure is available for all
eDrawings and SOLIDWORKS file formats.

In eDrawings, click File > Save As. From Save as type, select eDrawings Web HTML
Files (*.html) and select Enable measure. Measure is automatically disabled if you
create the HTML file from a measure-disabled file.
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22
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

• Creating Plots from Scene Template
• Filtering Hidden Bodies in Component Control
• Calculating Minimum and Maximum Values from Plots
• Customizing Visualization Parameters

SOLIDWORKS® Flow Simulation is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Video: What's New in SOLIDWORKS 2021 - Flow
Simulation

Creating Plots from Scene Template
You can create plots from the Scene template so you can share results between different
models.

Filtering Hidden Bodies in Component Control
You can show hidden or duplicated bodies in the Component Control dialog box.

Calculating Minimum and Maximum Values from Plots
The software calculates the minimum and maximum value of cropped plots.

Customizing Visualization Parameters
You can customize visualization parameters for post-processing results.
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23
SOLIDWORKS Plastics

This chapter includes the following topics:

• Redesigned PlasticsManager Tree
• SOLIDWORKS Plastics Enhancements
• Multi-Material Overmolding Injection Process
• Enhanced Modeling of Baffles and Bubblers
• Enhanced Modeling of Sketch-Based Runners
• Delay Time Option for Co-Injection Processes
• A-B-A Sequence of a Co-Injection Process
• Access to Material Databases
• Material Database Plots
• Material Library Updates
• Plastics Tutorials

Video: What's New in SOLIDWORKS 2021 - Plastics

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Redesigned PlasticsManager Tree

The PlasticsManager tree is redesigned to provide a more streamlined and logical workflow
for creating plastics simulation studies. A new node, Injection Units, replaces Injection
System.

The injection unit specifies the material and process parameters. An injection process
can have one or more injection units. For example, a Gas-assisted injection process uses
two injection units, one for the polymer and another for the gas. Similarly, a two-shot
overmolding process uses two injection units for two polymer materials.
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Example of a cavity domain assignment for a two-shot overmolding process. A cavity
is associated with injection unit 1. Two injection units are defined.

SOLIDWORKS Plastics Enhancements
The SOLIDWORKS Plastics solver is enhanced to improve the overall accuracy of simulation
results.

• The Mold-Melt Heat Transfer Coefficient parameter in the Injection Unit Settings
PropertyManager is available for the Shell analysis procedure. Use this parameter to
model the heat transfer between the polymer and the mold walls during the Filling
stage of the injection molding process.

In previous releases, this parameter was available for the Solid analysis procedure
only and for the SOLIDWORKS Plastics Professional and SOLIDWORKS Plastics Premium
products. This parameter is now available for the SOLIDWORKS Plastics standard as
well.

• For the Shell analysis procedure, the Flow and Pack analyses support multipoint material
data and specific heat (C) and thermal conductivity (K) material properties that can
vary with temperature.
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Multi-Material Overmolding Injection Process

You can inject two to six different polymer materials within the same cycle.

In the Study PropertyManager, under Injection Process, select Multi Material
Overmolding. During a multi-material overmolding injection, separate injection nozzles
introduce materials sequentially into the cavities.

This injection process is available only with the Solid analysis procedure and runs with
the Flow+Pack analysis sequence. The Flow+Pack analysis sequence accurately
simulates an actual multi-material overmolding injection process. The first material goes
through a complete Filling, Packing, and Cooling cycle before the start of the injection of
the second material.

For two-shot or multi-shot overmolding designs, you can use the Local Gravity
boundary condition to specify the gravity direction for each cavity. This is useful in
cases where various cavities have different orientations in a mold and the gravity
direction changes for each cavity.
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Enhanced Modeling of Baffles and Bubblers

Modeling is improved for baffles and bubblers that are part of cooling system components.

For baffle cooling components, a blade inserted in a channel splits the flow passage. To
accurately model the flow passage through a baffle cooling component, specify the
diameter (D1), the blade thickness (T), and tip height (H). Previously, only the diameter
(D1) of the baffle was required. The image shows a cross-section of a baffle design (left
side) and the hexahedral mesh of a baffle cross-section (right side).

For bubblers, an inner tube replaces the blade. To accurately model a bubbler cooling
component, specify the outer (D1) and inner tube diameters (D2), the tube thickness
(T), and the tip height (H). Previously, only the outer (D1) and inner tube diameters (D2)
were required.

The enhanced modeling of the baffle and bubbler flow channel enables the creation of an
accurate hexahedral mesh across the cross section. This more-accurate mesh
representation improves the overall accuracy of the coolant flow and the mold cooling
solutions.
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Hexahedral mesh of a bubbler cross-section (2021)Bubbler cross-section (2021)

Enhanced Modeling of Sketch-Based Runners

Two key enhancements to the sketch-based runner design are available in this release.

• The enhanced algorithm for the runner design integrates SOLIDWORKS APIs to create
realistic shapes of runner cross-sections and runner junctions from sketch lines.

• Enhanced meshing algorithms apply tetrahedral elements at the core and prism
elements at the boundary layer when you mesh runners. This element combination
leads to better convergence and results. Previously, a single layer of prism elements
was applied to the core, and the rest of the cross-section, including boundary layers,
was meshed with hexahedral elements.
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Delay Time Option for Co-Injection Processes

You can specify a delay time between injections of the first and second material for
Co-injection, Gas-assist, and Water-assist processes.

The image shows a setting for a Gas-assist injection molding process. The cavity is filled
to 60% capacity with polymer when the switch to nitrogen gas is initialized. The gas
injection begins after a 2-second time delay.

A-B-A Sequence of a Co-Injection Process
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You can simulate an A-B-A sequence of a Co-injection molding process.

During an A-B-A sequence, first a skin material (polymer A) is injected followed by a core
material (polymer B). Toward the end of the process, a small amount of the skin material
is reinjected to ensure the complete encapsulation of the core material.

The image shows settings for an A-B-A sequence where 60% of the cavity fills with
material A. After a time delay of 0.2 seconds, material B is injected to fill 35% of volume.
Injection switches back to material A to fill the last 5% of cavity volume.

Access to Material Databases

You can access the Plastics, Coolant, and Metal material databases before creating a
Plastics study.

In the Plastics CommandManager, click Browse Material Database to research, edit,
or customize materials.

To browse the material databases, the SOLIDWORKS Plastics add-in must be active.
While you can browse and customize materials, you cannot assign them to a Plastics
study.
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Material Database Plots

There are several enhancements to the display of Viscosity and
Pressure-Volume-Temperature (PVT) plots.

PVT Plots EnhancementsViscosity Plots Enhancements

Reduced the default number of isobars from
10 to 6. The 6 isobars display the pressure

Reduced the default number of isotherm
plots from 10 to 5 to reduce visual
clustering of the curves. values at: 0, 50, 100, 150, 200, and 250

MPa.

Increased the number of pressure datasets
for generating PVT curves to 4.

Increased the number of temperature
datasets for generating viscosity curves to
5.

Plot markers are removed. The software
generates the plots from the Modified Tait
model coefficients.

Plot markers are removed. The software
generates the plots from the Cross-WLF
Viscosity model coefficients.

The default range of the shear rate values
on the X-axis is modified to be 1 to 100,000
(the previous range was 0.0001 to 10,000).
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PVT Plots EnhancementsViscosity Plots Enhancements

This range better fits the shear rates during
typical injection molding cycles.

Material Library Updates
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There are several updates to the Plastics Material Library. All updates are according to
the latest data from the material manufacturer.

RemovedMaterialsReclassified
Materials

Updated MaterialsNew Materials

Four grades from
Amoco Chemical
were removed

31 Generic grades
were renamed

Nine grades from
Covestro

252 grades from
Covestro

31 grades from BayerFour grades from
ALBIS

71 grades from
EMS-GRIVORY

86 grades from
EMS-GRIVORY

25 grades from Bayer
Material Science

Two grades from
BASF

Two grades from
SABIC Innovative
Plastics

28 grades from
SABIC Innovative
Plastics

42 grades from
EMS-GRIVORY

122 grades from
INEOS Styrolution

Two grades from
Solvay Specialty
Polymer

23 grades from
Solvay Specialty
Polymers

One grade from
GENERAL ELECTRIC

115 grades from
LANXESS GMBH

Nine grades from
LANXESS

Two grades from
LyondellBasell

62 grades from
MILES

One grade from
SABIC Innovative
Plastics

14 grades from
Monsanto

42 grades from
Solvay Specialty
Polymers

One grade from
Monsanto Europe

One grade from
UNITIKA

Two grades from
Monsanto Japan

12 grades from
PHILLIPS

In addition, you can use a polymer's solid density property to search for a material. For
Search Polymer Database > Options, select Solid Density.
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Plastics Tutorials

A new tutorial, Validating Injection Molding Simulation, is available. In this tutorial, you
simulate the injection molding process, and validate the Flow and Pack results against
experimental data.

The new tutorial is available with the SOLIDWORKS Plastics Professional and SOLIDWORKS
Plastics Premium licenses.

To access the Plastics tutorials, from the SOLIDWORKS Plastics CommandManager, click
Settings and Help > Tutorials.
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24
Routing

This chapter includes the following topics:

• Routing Multiple Wires Through Clips
• Location of Tables in Flattened Routes
• Table Properties in Flattened Routes
• Selecting Several Routes for Electrical Attributes
• Keeping Cable Ends at Correct Pin Locations
• Locking Route Segments
• Hiding Empty Pin Rows
• Propagating Termination Type
• Additional Properties Available in the BOMs
• Splicing Without Components
• Selecting Components to Maintain 3D Orientation in Flatten Routes

Video: What's New in SOLIDWORKS 2021 - Routing

Routing is available in SOLIDWORKS® Premium.
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Routing Multiple Wires Through Clips

When you want to use clips in a routing assembly, you can select multiple routes
simultaneously. You can also define how the cable cores appear inside the clip.

Use the Route/Edit through Clip PropertyManager to:

• Select several routes to pass through the clip.
• Define the alignment mode of the cables inside the clip.

Location of Tables in Flattened Routes
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When you generate a flattened route, the tables are inserted in specific locations.

The location of tables in flattened routes has changed to position the tables more logically
within the overall layout.

Table Properties in Flattened Routes

In a flattened route, when you change the parameters of a table, you can propagate
these parameters to the other tables in the drawing.

You can select the font size and click Fit Text to resize the tables.
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Selecting Several Routes for Electrical Attributes

In the Electrical Attributes PropertyManager you can select one or more route segments
or wires.

In the Property Manager, you have two options to select the route or the wires in the
list. Depending on the selection, you can select the respective electrical attributes.

Keeping Cable Ends at Correct Pin Locations
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On the connector pins, the cable ends of the connector pins have the same position in
the route and in the flattened route.

Also, you can manually edit the individual fan-out in the flattened route, for example, to
assign the cable end to the correct pin.

Locking Route Segments

You can lock a route segment to preserve its properties when you update or modify other
routes.

Right-click the route and select Lock Routes.
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Hiding Empty Pin Rows

You can hide unused pins in flattened routes.

In the Flatten Route Items PropertyManager, select the Hide Empty Pin Rows.

Propagating Termination Type

The termination type of manufacturer parts handled in SOLIDWORKS Electrical propagates
automatically to the connector properties.

You can display this data in the BOM.
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Additional Properties Available in the BOMs

You can display more properties that are assigned to connectors and wires in BOMs.

Splicing Without Components

You can use a splice without component.

To add a splice, you can use the splice library. In the Add Splice PropertyManager, use
Use Splice Library.
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In the Add/Edit Splice PropertyManager, you can add notes that propagate into drawings
of the flattened route. You can select the Add Splice in Circuit Summary to add a splice
without component in the circuit summary table.

Splices without component do not appear in BOMs.

Selecting Components to Maintain 3D Orientation in Flatten Routes

When you apply the flatten route command, you can select portions of the route to not
flatten.

To exclude components from the flattened route, in the Flatten Route PropertyManager,
click Select components to maintain 3D orientation and select components.

In the Edit Flattened Route PropertyManager, you can manage the orientation of the
connectors.
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