
 / Visualize

WHAT'S NEW
SOLIDWORKS 2020



Contents

Legal Notices..........................................................................................................10

1 Welcome to SOLIDWORKS 2020........................................................................13
Top Enhancements......................................................................................................................14
What's New Videos......................................................................................................................15
Performance Improvements.........................................................................................................16
SPR Fixes.....................................................................................................................................17
For More Information....................................................................................................................18

2 User Interface .....................................................................................................20
Markups........................................................................................................................................20

Drawing Markups with a Mouse .............................................................................................22
Exporting Multiple Markups ....................................................................................................22
Markup Previews ....................................................................................................................22

Changes to the CommandManager Menu...................................................................................23
Display Feature Names in a Different Language ........................................................................23
Drag Multiple Contiguous Features to a Folder............................................................................24
Enhanced Large Tooltips for Toolbars ........................................................................................24
File Types List ..............................................................................................................................25
Searching for Materials ................................................................................................................25
Touch Mode .................................................................................................................................26
Troubleshooting Enhancements...................................................................................................26
Updated Help Menu......................................................................................................................27
View Recent Files.........................................................................................................................28
Welcome Dialog Box....................................................................................................................28

3 SOLIDWORKS Fundamentals.............................................................................29
3D Printing....................................................................................................................................29

Checking the 3D Printer Size .................................................................................................29
Slicing Data for 3MF Export ...................................................................................................30

Opening Documents.....................................................................................................................32
Improving Performance When Opening and Saving Files from a Previous Version...............32
Open Modes from File Explorer or PDM Vault View ..............................................................32
Simplified Open Options..........................................................................................................33

Application Programming Interface..............................................................................................33
Changes to System Options and Document Properties...............................................................34
Closing a Document When Saving a Copy..................................................................................36
Selection Sets...............................................................................................................................36

Adding a Selection to a Selection Set ....................................................................................36

2



Updating Entities in a Selection Set .......................................................................................37
Specifying the Up Axis for View Orientation.................................................................................37

4 Installation............................................................................................................38
Improved Installation Manager Download Performance .............................................................38
Installing the 3DEXPERIENCE Marketplace Add-In ...................................................................38
Installing the 3DEXPERIENCE Add-In.........................................................................................39
Installing SOLIDWORKS PCB Viewer .........................................................................................39
Installing Toolbox Software Without Installing Toolbox Data ......................................................40
SOLIDWORKS File Utilities Replaces SOLIDWORKS Explorer .................................................40
Testing a Setup for a Push Deployment ......................................................................................40

5 Administration......................................................................................................42
Selecting a SOLIDWORKS Simulation License with a SolidNetWork License ...........................42
SOLIDWORKS CEF Sub Process................................................................................................43
SOLIDWORKS Rx Supports SOLIDWORKS Composer and SOLIDWORKS Electrical ............43
Specifying Support Information....................................................................................................44

6 Assemblies...........................................................................................................45
Envelope Publisher .................................................................................................................45

Creating Envelopes for a Subassembly..................................................................................46
Viewing Envelopes..................................................................................................................47
Envelope Publisher PropertyManager ....................................................................................47

Flexible Components ..............................................................................................................48
Adding a Flexible Component.................................................................................................49
Editing External References of Flexible Components.............................................................51
Activate Flexible Component PropertyManager......................................................................51

Mates............................................................................................................................................52
Flip Alignment of Width Mates.................................................................................................52
Quick Mates Context Toolbar .................................................................................................52

Patterns ........................................................................................................................................53
Component Pattern with Variable Instances...........................................................................53
Mirror Components PropertyManager.....................................................................................55
Pattern Driven Component Patterns.......................................................................................61

Large Design Review...................................................................................................................63

Create and Edit Component Patterns in Large Design Review .........................................63

Create Mates to Reference Geometry in Large Design Review ........................................64
Exploded Views............................................................................................................................65

Auto-Space Components in Exploded Views..........................................................................65
Reusing a Multibody Part Explode..........................................................................................66

External References Options........................................................................................................67
Isolating Interferences..................................................................................................................67
Modify Configuration for Toolbox Components............................................................................68
Performance Improvements for Assemblies................................................................................68

3

Contents



Save as Copy with a Subset of Configurations ...........................................................................68

7 SOLIDWORKS CAM............................................................................................69
Customization Settings.................................................................................................................69
Probing Routines .........................................................................................................................69
Tab Cutting...................................................................................................................................70
Tapered Multipoint Thread Tool...................................................................................................70
Universal Post Generator.............................................................................................................70

8 SOLIDWORKS Composer...................................................................................71
SOLIDWORKS Composer............................................................................................................71

360 Degree Capture................................................................................................................71
Basic Attach Type for Annotations..........................................................................................71
BOM ID Callouts......................................................................................................................71
Exponent Shape for Callouts...................................................................................................72
Importing Appearances from SOLIDWORKS Files ................................................................72

Importing Exploded, Saved, and Named Views from SOLIDWORKS Files ......................72
Inlaid Text for Linear Arrows...................................................................................................72
Read-Only Mode Enhancement for Animation Library Templates..........................................72

Support of MP4 Format for Animations .............................................................................73
Warning Message Before Breaking External Assembly Links................................................73

SOLIDWORKS Composer Sync...................................................................................................73
Importing Appearances from SOLIDWORKS Files ................................................................73

Importing Exploded, Saved, and Named Views from SOLIDWORKS Files ......................73

9 Detailing and Drawings........................................................................................74
Custom Scales for Drawing Sheets and Views............................................................................74

Setting Custom Scales for Drawing Sheets............................................................................74
Setting Custom Scales for Drawing Views..............................................................................75
Modifying the List of Available Scales.....................................................................................76

Chain Dimensions ...................................................................................................................76
Alternate Position Views...............................................................................................................78

Detailing Mode ........................................................................................................................80
Opening Drawings in Detailing Mode......................................................................................82

Render Pipeline in Drawings ..................................................................................................82
Hole Callouts................................................................................................................................82

Adding Hole Callouts in Section Views ..............................................................................82
Applying All Uppercase to Dimensions and Hole Callouts......................................................84

Annotations...................................................................................................................................84
Flag Notes...............................................................................................................................84
Symbols on Sheet Formats.....................................................................................................84

Cosmetic Threads........................................................................................................................84
Adding Callouts for Non-Hole Wizard Holes...........................................................................84

4

Contents



Adding Callouts for External Threads......................................................................................85
Simplifying Callouts.................................................................................................................86

Creating Markups for Drawings ...................................................................................................87
Design Library..............................................................................................................................88
Dimensions...................................................................................................................................88

Dimensioning Datum Targets..................................................................................................88
Foreshortened Dimensions.....................................................................................................89

Link Child Views to Parent by Default ..........................................................................................89
Location for Saving a New Drawing.............................................................................................89
Performance Improvements in Drawings.....................................................................................89

10 eDrawings..........................................................................................................90
Virtual Reality...............................................................................................................................90
Quality ..........................................................................................................................................93
Manufacturing Models in the 3DEXPERIENCE Marketplace|Make.............................................94
Support for Configuration-Specific $PRPSHEET Properties........................................................94
Text Scale in 3D Views.................................................................................................................95
SOLIDWORKS Drawings Support ................................................................................................95
eDrawings Performance...............................................................................................................95

11 SOLIDWORKS Electrical...................................................................................96
Leader Lines ...........................................................................................................................96

Text Leaders............................................................................................................................97
Block Leaders..........................................................................................................................98
Leader Styles Manager...........................................................................................................99

Minimum Bend Radius and Bend Factor....................................................................................100
Project Viewer............................................................................................................................100

Reimport Electrical Data for Wires, Cables, and Harnesses ................................................102

Report Enhancements for Rows and Columns .....................................................................103
Row Height in Reports..........................................................................................................103
Row Number Column in Reports...........................................................................................103

User Rights Manager ............................................................................................................104
Archive Environment.............................................................................................................104
Feature Grid..........................................................................................................................104
User Profile Customization....................................................................................................104

12 SOLIDWORKS Flow Simulation......................................................................106
Altitude........................................................................................................................................106
Fan Derating...............................................................................................................................106
Logical Expressions in Formula Dependency............................................................................107

13 SOLIDWORKS 3D Interconnect......................................................................108
Importing DXF and DWG Files...................................................................................................108
Importing IFC Files.....................................................................................................................108

5

Contents



Inserting CAD Files into Active SOLIDWORKS Files.................................................................109

14 SOLIDWORKS Manage...................................................................................110
Process Management Enhancements.......................................................................................111

Adding Related Records.......................................................................................................111
Creating a Subprocess..........................................................................................................111

Project Management Enhancements.........................................................................................112
Project Gantt Charts..............................................................................................................112
Capacity and Demand Dashboards......................................................................................112

Dashboard Viewer and Plenary Web Client...............................................................................113
Task Templates..........................................................................................................................114
Integration with Microsoft Outlook..............................................................................................114
Object Notes...............................................................................................................................114

Adding Object Notes ............................................................................................................115
Viewing Object Notes............................................................................................................115

Adding Conditions to a Process Stage.......................................................................................115
BOM Editing...............................................................................................................................116
PDM Options Tab.......................................................................................................................116
Editing the Project Task Subject.................................................................................................117
Export Feature of BOM Compare Tool.......................................................................................118
Send to Process.........................................................................................................................118
Custom Procedures....................................................................................................................118
View Hidden Controls in the Workflow Designer........................................................................118
Inactive Configuration Part Numbering......................................................................................119
Main User Interface Controls for Records..................................................................................119
Customized Affected Item List ....................................................................................................119
Process Task Assignment Controls...........................................................................................119
Copy Manual Quantities of BOM................................................................................................119

15 SOLIDWORKS MBD........................................................................................120
Annotations Folder ................................................................................................................120
3D PMI Compare........................................................................................................................121
DimXpert .....................................................................................................................................121

Annotation Name Format......................................................................................................121
Pipe Threads and Compound Holes.....................................................................................122

16 Model Display..................................................................................................123
Body Compare ......................................................................................................................123
Comparing Bodies......................................................................................................................123
Body Compare PropertyManager ..............................................................................................125

17 Parts and Features..........................................................................................127
Graphics Mesh and Mesh BREP Bodies....................................................................................127

Adding Coordinate Axes, Reference Axes, and Reference Planes .....................................127

6

Contents



Decimating a Graphics Mesh Body .................................................................................129

Expanded Support for Mesh BREP Bodies in Features ..................................................136
Holes ..........................................................................................................................................136

Defining Hole Depth up to Tip or up to Shoulder...................................................................136
Hole Wizard...........................................................................................................................137

Repairing Missing References for Fillets and Chamfers .......................................................137
Surfaces .....................................................................................................................................140

Creating an Offset Surface Without Failed Faces ...........................................................140
Specifying the Thicken Direction ..........................................................................................142

18 SOLIDWORKS PCB........................................................................................146
Duplicate Designators................................................................................................................146
Integration with SOLIDWORKS PDM ........................................................................................146
Rigid-Flex Support in SOLIDWORKS PCB................................................................................147

19 SOLIDWORKS PDM........................................................................................148
Defining Child Reference State Conditions ..........................................................................148

Search User Interface ...........................................................................................................149
Customizable Variables - New Variable List Dialog Box.......................................................150
Using Quick Search...............................................................................................................151

SOLIDWORKS PDM Performance Improvements.....................................................................152

Performance Improvements in Browsing .........................................................................153
Performance Improvements in the SOLIDWORKS PDM Add-in..........................................153

Web2 Enhancements.................................................................................................................154

Bill of Materials Tab in Web2 ...........................................................................................154
History Tab............................................................................................................................157
List of Files to Download in Web2.........................................................................................157

Using AND, OR, and NOT Operators in Search ...................................................................159
Searching in Multiple Variables..................................................................................................163

Creating a Search Card to Search Within Multiple Variables................................................164
Resizable Dialog Boxes..............................................................................................................164
Logging Out from Windows Explorer..........................................................................................165
Reordering Columns in Search Results.....................................................................................165
Scaling the Paper Size in Print Task..........................................................................................165
Warning Users When Transitioning Files...................................................................................165

20 SOLIDWORKS Plastics...................................................................................166
Coolant Input Boundary Condition.............................................................................................166
Create Body from Deformed Shape...........................................................................................166
Domains Node ...........................................................................................................................167

Enhanced Solid Mesh (Auto) Workflow ................................................................................167

7

Contents



Streamlined Mesh Creation ..................................................................................................168
Flow, Pack, and Cool Analyses Enhancements.........................................................................168

Geometry-Based Boundary Conditions ................................................................................168
Legacy Plastics Simulation Studies ...........................................................................................169
Material Library Updates............................................................................................................169
Plastics Material Databases in 3D ContentCentral ....................................................................171
Plastics Tutorials........................................................................................................................172
Study Creation and Management ..............................................................................................172
Virtual Mold Design....................................................................................................................172

21 Routing.............................................................................................................174
3D Route Changes in Flattened Routes.....................................................................................174
Color for Electrical Coverings.....................................................................................................174
Connector Blocks.......................................................................................................................175

Create Multiple Connection Points .......................................................................................175
Length Leaders for Flattened Routes.........................................................................................176
Manufactured-Style Flattened Route..........................................................................................177
Mass and Density of Cables and Wires.....................................................................................177

Minimum Bend Radius ..........................................................................................................177
Pipe Drawings............................................................................................................................178

Reimport Electrical Data .......................................................................................................178
Show/Hide Flatten Route Items..................................................................................................178
Splices Without Components.....................................................................................................179
Transparent Coverings...............................................................................................................180

22 Sheet Metal......................................................................................................181
Convert to Sheet Metal ...............................................................................................................181
Tab and Slot ..............................................................................................................................181

23 SOLIDWORKS Simulation...............................................................................182
Collapse Simulation Tree Folders..............................................................................................182

Distributed Coupling for Pins and Bolts ...............................................................................183

Draft and High-Quality Mesh Definition ................................................................................185

Free Body Forces for Nonlinear Studies ...............................................................................186
Link Between Results and Model Files......................................................................................187
Repair Corrupt Studies...............................................................................................................188

Simulation Evaluator .............................................................................................................188
Simulation Performance Improvements.....................................................................................189
Stress Averaging at Mid-Side Nodes.........................................................................................189

Thermal Loads for Beams ....................................................................................................190

8

Contents



24 Sketching.........................................................................................................193
Applying Torsion Continuity Relations ..................................................................................193
Baseline and Chain Dimensions in Sketches.............................................................................195
Importing 2D DXF or DWG Files as Reference Sketches..........................................................195
Power Modify Tool......................................................................................................................195

Silhouette Entities .................................................................................................................197
Creating Silhouette Entities...................................................................................................198
Silhouette Entities PropertyManager.....................................................................................199

25 SOLIDWORKS Visualize.................................................................................200
AMD ProRender Integration.......................................................................................................200
AxF Measured Materials.............................................................................................................200
glTF Export for AR and VR.........................................................................................................201
IES Light Profiles........................................................................................................................201

Finding IES Light Profiles......................................................................................................201
Adding IES Profile Lights to Scenes......................................................................................202

Inline Rendering.........................................................................................................................203
Instancing...................................................................................................................................203
MDL Support ..............................................................................................................................204
NVIDIA RTX Support ..................................................................................................................205
Scaling for High-Resolution Displays.........................................................................................205
SOLIDWORKS PDM Integration................................................................................................205

26 Structure System and Weldments...................................................................207
Options for Creating Primary Members Based on Points .....................................................207

Specifying the Member Profile..............................................................................................208
Creating Primary Members Based on Point and Length.......................................................208
Creating Primary Members Between Points.........................................................................209
Creating Primary Members Based on Up to Point................................................................209
Creating Primary Members Based on Direction....................................................................210

Creating Curved Beams and Merging Tangent Members .........................................................211

Split Members .......................................................................................................................211

Pattern and Mirror Support ...................................................................................................213
Creating a Linear Pattern of a Structure System Feature.....................................................214
Adding a Structure System Feature to an Existing Feature..................................................215

Member and Corner Trim Enhancements .................................................................................216
Cut List Properties for Weldment and Structure System Features.............................................217

9

Contents



Legal Notices

© 1995-2019, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE
company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without
notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS
SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically
or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used
or copied only in accordance with the terms of the license. All warranties given by DS
SolidWorks as to the software and documentation are set forth in the license agreement,
and nothing stated in, or implied by, this document or its contents shall be considered
or deemed a modification or amendment of any terms, including warranties, in the license
agreement.

Patent Notices
SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S.
Patents 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705;
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patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and
Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks andProduct Names for SOLIDWORKSProducts andServices
SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings
logo are registered trademarks and FeatureManager is a jointly owned registered trademark
of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of HCL Technologies Ltd.

SOLIDWORKS 2020, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS
Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS
Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation
Premium, SOLIDWORKS Flow Simulation, SOLIDWORKS CAM, SOLIDWORKS Manage,
eDrawings Viewer, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS
Plastics, SOLIDWORKS Electrical Schematic Standard, SOLIDWORKS Electrical Schematic
Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS Electrical Professional,
CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection, SOLIDWORKS MBD,
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SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector powered by Altium,
and SOLIDWORKS Visualize are product names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective
holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT
1995), consisting of “commercial computer software” and “commercial software
documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided
to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent
with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units
of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1
(JUN 1995) and 227.7202-4 (JUN 1995)

In the event that you receive a request from any agency of the U.S. Government to
provide Software with rights beyond those set forth above, you will notify DS SolidWorks
of the scope of the request and DS SolidWorks will have five (5) business days to, in its
sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systemes
SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional,
and Education Products
Portions of this software © 1986-2018 Siemens Product Lifecycle Management Software
Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

D-Cubed® 2D DCM © 2019. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® 3D DCM © 2019. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® PGM © 2019. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® CDM © 2019. Siemens Industry Software Limited. All Rights Reserved.

D-Cubed® AEM © 2019. Siemens Industry Software Limited. All Rights Reserved.

Portions of this software © 1998-2019 HCL Technologies Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2019 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2019 DriveWorks Ltd.

© 2012, Microsoft Corporation. All rights reserved.

Includes Adobe® PDF Library technology.

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected
by U.S. Patents 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered
trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.
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reserved.
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1
Welcome to SOLIDWORKS 2020

This chapter includes the following topics:

• Top Enhancements
• What's New Videos
• Performance Improvements
• SPR Fixes
• For More Information

Model courtesy of Matt Lyle, SOLIDWORKS 2019 Beta Splash Screen Prize winner.

SOLIDWORKS® 2020 delivers many enhancements and improvements, most created in direct
response to customer requests.
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These enhancements help you speed up and improve your product development process –
from concept design through manufactured products.

• Workflow. Refinements in design, simulation, manufacturing, and collaboration permit new
workflows that improve time to market and product quality, and reduce manufacturing
costs.

• Performance. Improvements in drawings and assemblies significantly speed up large
assembly design and detailing.

• Direct connection to the 3DEXPERIENCE® Platform. Seamless integration with 3DEXPERIENCE
applications provides scalability and flexibility to dramatically improve the way you develop
concepts, design, and collaborate.

Top Enhancements
The top enhancements for SOLIDWORKS® 2020 provide improvements to existing products
and innovative new functionality.

Throughout this guide, look for the symbol in these areas:

Assemblies • Create and Edit Component Patterns in Large Design
Review on page 63

• Create Mates to Reference Geometry in Large Design
Review on page 64

• Envelope Publisher on page 45
• Flexible Components on page 48

Detailing and
Drawings

• Adding Hole Callouts in Section Views on page 82
• Chain Dimensions on page 76
• Detailing Mode on page 80
• Render Pipeline in Drawings on page 82

Fundamentals • Improved Performance When Opening and Saving Files
from a Previous Version

Model Display • Body Compare on page 123

Parts and Features • Creating an Offset Surface Without Failed Faces on page
140

• Repairing Missing References for Fillets and Chamfers on
page 137

• Expanded Support for Mesh BREP Bodies in Features on
page 136

• Decimating a Graphics Mesh Body on page 129

Routing • Create Multiple Connection Points on page 175
• Minimum Bend Radius on page 177
• Reimport Electrical Data on page 178
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Sketching • Applying Torsion Continuity Relations on page 193
• Silhouette Entities on page 197

SOLIDWORKS
Composer

• Importing Exploded, Saved, and Named Views from
SOLIDWORKS Files on page 72

• Support of MP4 Format for Animations on page 73

SOLIDWORKS
Electrical

• Leader Lines on page 96
• Reimport Electrical Data for Wires, Cables, and Harnesses
on page 102

• Report Enhancements for Rows and Columns on page 103
• User Rights Manager on page 104

SOLIDWORKSPDM • Bill of Materials Tab in Web2 on page 154
• Defining Child Reference State Conditions on page 148
• Performance Improvements in Browsing on page 153
• Search User Interface on page 149
• Using AND, OR, and NOT Operators in Search on page 159

SOLIDWORKS
Plastics

• Geometry-Based Boundary Conditions on page 168
• Mesh Enhancements

SOLIDWORKS
Simulation

• Draft and High-Quality Mesh Definition on page 185
• Distributed Coupling for Pins and Bolts on page 183
• Free Body Forces for Nonlinear Studies on page 186
• Simulation Evaluator on page 188
• Thermal Loads for Beams on page 190

Structure System • Pattern and Mirror Support on page 213
• Options for Creating Primary Members Based on Points
on page 207

• Split Members on page 211

What's New Videos
Some topics in this document include links to videos that provide more insight into the
new functionality. Look for the links next to this image:
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To access all What's New videos online, see
https://www.solidworks.com/product/whats-new.

Performance Improvements
SOLIDWORKS 2020 includes the following performance and workflow improvements:

Assemblies
• Assembly performance is optimized for some tools and workflows so full rebuilds of
assemblies or graphics occur less often.

• Most assemblies and drawings, that were saved in a previous version, open faster
without having to save them in the new version. The improvement is greater for
assemblies that use reference components in several configurations.

You do not have to fully rebuild assemblies and drawings with reference components
in multiple configurations when opening a new version in SOLIDWORKS 2020. Also,
you can make greater use of lightweight components and drawings without needing
to convert them to the current version.

You can improve save performance by clearing the Force referenced documents to
save to current version system option. When you clear the option, documents that
were not modified in the current session are not saved to the current version of
SOLIDWORKS. For an example, see Improving Performance When Opening and
Saving Files from a Previous Version on page 32

This improvement also eliminates the need to run batch conversion tools such as the
PDM File Version Upgrade Utility or the Convert Files task in the Task Scheduler.

Detailing and Drawings
When you create a drawing from an open assembly, the creation of the first view may
be faster than in previous releases.

eDrawings
Performance is improved when you hover over and select entities using the Measure
and Markup Dimensions tools.

SOLIDWORKS PDM
• SOLIDWORKS PDM loads the data in the background, which improves the browsing
responsiveness.

Browsing folders that have a large number of files is faster due to:

• Faster database queries for custom columns.
• Background loading and incremental loading of the data.

When you double-click a folder, SOLIDWORKS PDM loads data in this order:

1. All subfolders synchronously. You can browse subfolders while the remaining data
loads in the folder.
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2. Files with standard columns in the file list.
3. Information in custom columns. You can add more custom columns and maintain

the same browsing speed.

When you select a file and switch between the Bill of Materials, Contains, and Where
Used tabs, SOLIDWORKS PDM loads the data in the tabs in the background. When you
switch to a different file or folder, the background loading stops and loading of the
new file or folder starts.

Performance improves significantly for folders with a large number of files or for
database servers with high latency.

• The SOLIDWORKS PDM task pane tree refreshes faster and the commands in the
SOLIDWORKS PDM toolbar are correctly enabled in the task pane instantaneously
when you select a file.

• Data in the task pane tree loads in the background.
• When you select a file in the task pane tree, calls to the database are eliminated.

In the FeatureManager design tree or in the graphics area, when you right-click a file
and select SOLIDWORKS PDM, the menus are correctly enabled.

When you select a file in the graphics area or in the FeatureManager design tree, the
file listed in task pane tree is selected and the commands in the SOLIDWORKS PDM
toolbar are correctly enabled.

• You can perform the following actions faster:

• Logging into the vault when you set a large number of files or folders for automatic
caching.

• Viewing the System History of a vault that includes a large number of items.
• Opening a file from a folder that includes a large number of files.
• Creating a new file or subfolder in a folder that contains large number of files.

Simulation
• Multiple load cases. You can use an optimized solution for distributed and rigid remote
loads.

• Linear/quadratec tetra. You can replace quadratic elements as linear elements in certain
parts of geometry (especially in bulky areas with fewer surface irregularities) to boost
solver speed and performance.

SOLIDWORKS Visualize
SOLIDWORKS Visualize supports and defaults to Live rendering mode. This can improve
performance and reduce memory consumption for final renders.

SPR Fixes
SOLIDWORKS 2020 focuses on fixing reproducible and difficult to reproduce stability
issues. In addition, we target important SPRs (Software Performance Reports) that improve
your design productivity.

Some of the high-impact SPRs that we fixed:
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ResolutionSPR

Notes with geometric tolerance symbols or surface finish symbols are
saved with the sheet format.

389741

Angular dimensions display properly in broken views.551580

An assembly properly exports as a STEP file even if an assembly's
component has the same name as the assembly.

625475

A circular sketch pattern of a Hole Wizard hole creates accurate
patterns.

634314

Hole and shaft fit appear in diameter dimensions for nominal fit dowel
holes created in the Hole Wizard.

675106

File display is faster.713849

Instant3D works correctly when you drag sketch entities.921300

Dimension arrowheads keep the same styles when you use multi-jog
leaders.

960699

Font sizes display properly when you use Publish to 3D PDF in
SOLIDWORKS MBD.

886991

In the SOLIDWORKS PDM Administration tool, results are filtered as you
type in the Group Members, Add Group Members, and Users dialog
boxes.

1129989,
1129991,
1129992

For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML • Help > What's New > PDF

• Help > What's New > HTML

In SOLIDWORKS, click the symbol to display the section of this
manual that describes an enhancement. The symbol appears next

InteractiveWhat's
New

to new menu items and the titles of new and changed
PropertyManagers.

To enable Interactive What's New, click Help > What's New >
Interactive.

To open sample files for this book, go to
system_dir:\Users\Public\Public

Sample files

Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\chapter_name\file_name.
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For example, C:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\sketching\Block.sldprt.

Contains complete coverage of our products, including details
about the user interface, samples, and examples.

Online Help

Provides information about late changes to our products, including
changes to the What's New book, online help, and other
documentation.

Release Notes

19

Welcome to SOLIDWORKS 2020



2
User Interface

This chapter includes the following topics:

• Markups
• Changes to the CommandManager Menu
• Display Feature Names in a Different Language
• Drag Multiple Contiguous Features to a Folder
• Enhanced Large Tooltips for Toolbars
• File Types List
• Searching for Materials
• Touch Mode
• Troubleshooting Enhancements
• Updated Help Menu
• View Recent Files
• Welcome Dialog Box

Markups

Video: What's New in SOLIDWORKS 2020 - Markup

You can draw markups with a mouse on nontouch devices, display bounding boxes for
markups, create markups in drawings, and use the context toolbar to access markup
options.

To hide or show markups, click Hide All Types > View Markups on the Heads-up
View toolbar. Right-click a markup in the FeatureManager design tree or in the graphics

area and click Hide to hide markups.

Markup Toolbar
The Ink Markup toolbar is renamed to the Markup toolbar. To view the toolbar, click View

> Toolbars > Markup .
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New options:

Specifies a color and thickness for the pen and mouse
strokes.

Color

Uses a mouse to draw ink strokes.Draw

The toolbar displays different options depending on the device. Touch is not available
for nontouch devices.

Markup toolbar for nontouch devicesMarkup toolbar for touch devices

Ink strokes in markups are limited to devices that use Windows 10, version 1703 or
later.

Context Toolbar
The following options are available when you right-click a markup:

Enters edit mode.Edit Markup

Suppress

Zooms to the markup.Orient

Hide

Exports markups as one of the following file types: .pdf,
.bmp, .jpg, .png, and .tif.

Export Markup

Markup Tab for the CommandManager
To view the Markup tab for the CommandManager, right-click in the CommandManager
and click Tabs > Markup.

Markup Creation Information
Markups save the creation date and time stamp, and the creator ID. This information
appears when you preview a markup and export a markup to a file.
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Markups for Drawings
For more information on markups for drawings, see Creating Markups for Drawings
on page 87.

Drawing Markups with a Mouse

1. On a nontouch device, open a part or assembly.

2. Click View > Hide/Show > Markups .
3. Click Tools > Options > System Options > FeatureManager.

4. Under Hide/show tree items, select Show for Markups and click OK.

5. In the FeatureManager design tree, right-clickMarkups and click Insert Markup

.

The Markup toolbar appears.

6. Click Draw to draw with the mouse.

7. Optional: To change the color or the thickness of the line, click Color .

Exporting Multiple Markups

To export multiple markups:

1. In the FeatureManager design tree, under Markups , Ctrl + select multiple
markups.

2. In the context toolbar, click Export Markup .
3. In the Export Markup dialog box, specify the file name and type, and click Save.

When you select .pdf as the file type, one .pdf file is created and each page contains
one markup. When you export multiple markups, the order in which you select the
markups is the order of the pages in the .pdf file.

When you select the other file types, each markup saves to an individual file in the
specified folder. When you export multiple markups, the folder name is the name
specified for File name in the Export Markup dialog box.

Markup Previews

When you hover over a markup in the FeatureManager design tree, a markup preview
appears. In the graphics area, a bounding box with orange edges surrounds the markup.
When you select the markup, the preview closes and a bounding box with blue edges
surrounds the markup.
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Changes to the CommandManager Menu
Many items have changed:

Description of ChangeItem

Renamed to Enable CommandManagerCommandManager

Moved under TabsList of CommandManager
tabs

Moved under ToolbarsList of toolbars

Removed from the menuCustomize Menu

To show toolbars in the CommandManager:

1. Right-click in the CommandManager.
2. Click Toolbars and then click a toolbar.

Display Feature Names in a Different Language
In the FeatureManager® design tree, for features that use the default name, you can view
a feature name translated into a different language. The translation displays in a tooltip
when you hover over the feature.

To display feature names in a different language:

1. In the FeatureManager design tree, right-click a top-level assembly or part and click
Tree Display.

2. Click Show Translated Feature Name in Tooltip and click a language.
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3. In the FeatureManager design tree, hover over a feature that has a default name.

The tooltip displays the feature name and the translated feature name. For example,
the French translation of Shell1 is Coque1:

4. Optional: To hide the tooltips, under Show Translated Feature Name in Tooltip,
click Hide Tooltip.

Drag Multiple Contiguous Features to a Folder
You can select multiple contiguous features and drag the features to a folder in the
FeatureManager design tree. You can drag features to change their order in a folder if
the features do not have parent-child relationships. You can drag folders and features
into another folder.

When dragging a feature out of a folder, you can drag the feature above a contiguous
feature in the FeatureManager design tree.

To drag multiple contiguous features to a folder:

1. Open a part that has multiple features.
2. If the part does not have a folder, in the FeatureManager design tree, right-click a

feature and click Add to New Folder .
3. In the FeatureManager design tree, select one or more contiguous features and drag

the features to Folder .

When the pointer changes to , drop the features to the selected folder.

4. Expand Folder and change the feature order.

When the pointer changes to , you can drag the features to the selected location.

5. Select multiple contiguous features from the Folder and drag the features from
the folder to a location above the folder in the FeatureManager design tree.

Enhanced Large Tooltips for Toolbars
Enhanced large tooltips provide expanded information for tools in a toolbar. Some
enhanced tooltips include images or animations.

For example, the Bounding Box large tooltip provides information about viewing the
bounding box properties and includes an image of a bounding box.
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To use enhanced large tooltips:

1. Click Tools > Customize and under Tooltips, click Show tooltips.
2. Under Show tooltips, select an option:

Displays a brief description with the
tooltip. Some tooltips may include an
image or short animation.

Large tooltips with images

Displays a brief description with the
tooltip.

Large tooltips without images

Displays the tool name.Small tooltips

3. Click OK.
4. Hover over a tool in a toolbar to view the enhanced tooltip.

File Types List
The file types list in the Open dialog box is consolidated and reorganized. The list is wider
to accommodate longer file names.

In the Save As dialog box, the list of files types for Save as type is reorganized.

Searching for Materials
You can find materials by using the Search box in the upper left corner of the Material
dialog box.

To search for materials:

1. From an open document, in the FeatureManager design tree, right-clickMaterial and
click Edit Material.
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2. In the Material dialog box, enter an alphanumeric character or part of a material name
in the search box.

This example searches for plastic. Matching results display materials in the material
tree.

3. Select a material or click X to clear the search box.

Touch Mode

On the Touch toolbar, Undo appears after you perform an action. The Escape icon

changed to . The icon for the active model tab displays at the bottom of the toolbar.

Model tabs:

• Model

• Design Study

• 3D Views

• Motion Study

Troubleshooting Enhancements
The SOLIDWORKS software provides more information about possible causes of crashes
and known solutions you can use to avoid them in the future. It also makes it easier for
you to supply error reports that will help the SOLIDWORKS development team diagnose
and resolve problems for you.

In the Welcome dialog box, the Troubleshooting tab displays messages for known solutions
to problems you have encountered, and how many times those problems have occurred.
The solutions include contacting Technical Support about installing hotfixes, checking for
updates to see if you need to apply service packs, and making sure the machine has a
certified or tested graphics driver.

When the SOLIDWORKS software starts, it scans log files to identify crashes that have
known solutions, and creates messages about those solutions in the
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solutionmessages.xml file. The file updates when it identifies additional problems and
solutions, and when hotfixes and service packs are applied on the machine. The cumulative
list of messages about problems and solutions, minus those solved by hotfixes and service
packs that have already been applied, displays on the Troubleshooting tab.

To find solutions for crash fixes:

1. In the Welcome dialog box, click Alerts > Troubleshooting.
2. If there are crashes for this release of the SOLIDWORKS software on this machine,

error messages display that tell you how many times the problems causing those
crashes have occurred. The error messages also suggest solutions such as:

• Contacting Technical Support about installing hotfixes.
• Checking for updates to see if you need to apply service packs.
• Making sure that the machine has certified or tested graphics drivers.

Optional. Click Close on the right side of the message to delete it.

3. If Check for Updates or System Diagnostics displays, select it and follow
instructions for that option.

A separate tab provides information about recovered documents. To view it from the
Welcome dialog box, click Alerts > Document Recovery.

Updated Help Menu
On the Help menu, options are reorganized and renamed.

To view the menu, click Help.

Activate Licenses, Deactivate Licenses,
and Show Licenses changed to Activate,
Deactivate, and Show, and moved under
Licenses.

Get Support is added to the list of
options.

SOLIDWORKS is removed from some of the
option names. For example, SOLIDWORKS
Tutorials changed to Tutorials.
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View Recent Files
You can view a list of recent files opened in the software in the following locations:

• Windows® Start menu: App list and tiles
• Search Windows: Search results for the SOLIDWORKS® 2020 software
• Windows taskbar

To view recent files:

1. From the Windows Start Menu, click Settings > Personalization > Start.
2. Verify that Show app list in Start menu and Show recently opened items in

Jump Lists on Start or the taskbar are On.
3. Close the Windows Settings dialog box.
4. From the Windows Start Menu, right-click the SOLIDWORKS 2020 icon from the app

list.

A list of files appears under Recent.

Welcome Dialog Box
You can log in to SOLIDWORKS from the Welcome dialog box.

In the upper-right corner, click Log In.
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3
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• 3D Printing
• Opening Documents
• Application Programming Interface
• Changes to System Options and Document Properties
• Closing a Document When Saving a Copy
• Selection Sets
• Specifying the Up Axis for View Orientation

3D Printing

Video:What's New in SOLIDWORKS 2020 - 3D Printing

Checking the 3D Printer Size

You can select a 3D printer from a list to determine if a model fits inside the 3D printer.
You can mark a 3D printer as a favorite to make the 3D printer available as a selection
in the Print3D PropertyManager.

When you add a printer as a favorite, the following read-only information appears:

DescriptionOption

Printer manufacturer.Company

Model number for the printer.Model

Height, Length, and Width of the printer.Bed Size of this 3D
Printer

Printer type. For example, FDM, SLS, or SLA.Technology
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DescriptionOption

3D printer list from the Wohlers Report 2019 provided by Wohlers
Associates, Inc.

Source URL

To check the 3D printer size:

1. Open a part or assembly, and click File > Print3D .

2. On the Settings tab of the Print3D PropertyManager, click 3D Printer Name , and
click Select Printer.

In the 3D Printers dialog box, a folder list alphabetized by company name appears.

3. Expand a folder to view a list of 3D printers, and select a printer.
4. Click Add to Favorites.

The printer is added to the Favorites folder at the top of the folder list.

5. Close the dialog box.

6. In the PropertyManager, under 3D Printer Name , select a printer.
7. For Bottom plane of model, in the graphics area, select a planar face or reference

plane.

The printer appears as a transparent box around the model. Sections of the model
that do not fit in the printer area appear in red.

Slicing Data for 3MF Export

You can generate slices from precise SOLIDWORKS® geometry to export to a 3D
Manufacturing Format (.3mf) file without saving the geometry to a mesh file.

Slices represent the highest fidelity of SOLIDWORKS geometry based on the minimum
segment length, resulting in slices with the highest accuracy that a 3D printer can print.

To slice data for 3MF export:

1. Open a part and click File > Print3D .
2. On the Settings tab, for Bottom plane of model, select a plane.
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3. On the Preview tab, specify options:

DescriptionOption

Specifies the layer height of the striation lines.Layer height

Saves slicing information when you export to a .3mf
file.

Available when you specify a bottom plane on the
Settings tab.

Generate slices
(for 3MF export)

Specifies the smallest edge included in a polyline for a
slice.
This edge corresponds to the smallest linear segment
that a 3D printer can print.

Minimum edge
length

Generates a preview of slices.
Available when you specify a bottom plane on the
Settings tab and a layer height on the Preview tab.

To interrupt the preview generation, close the
PropertyManager.

If you change the bottom plane, layer height, or
minimum edge length, click Preview Slices to
regenerate the slices.

Preview Slices

After you click Preview Slices, the slices appear in yellow on the part.

After previewing slicesBefore previewing slices

4. Click the Settings tab.
5. Expand the Save To File section.
6. For Format, select 3D Manufacturing Format (*.3mf) and click Save File.
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7. In the Save As dialog box:
a) For Save as type, select 3D Manufacturing Format (.3mf).
b) Click Options.
c) In the System Options - STL/3MF/AMF dialog box, select Include slices to

include slicing information in the exported file, and click OK.
d) Click Save.
The .3mf file contains slices generated from precise geometry. Use this file with a
3D printer that can read slice information.

Opening Documents

Improving Performance When Opening and Saving Files from a Previous Version

You can improve save performance by clearing the Force referenced documents to
save to current version system option in the External References tab.

When you clear the option, only documents that are modified in the current session are
saved to the current version of SOLIDWORKS. This reduces save times significantly on
the first save of large assemblies and drawings.

To clear the system option:

1. Click Tools > Options and in System Options, click External References.
2. Clear Force referenced documents to save to current version.
3. In SOLIDWORKS 2020, open a SOLIDWORKS 2019 assembly with SOLIDWORKS

2019 parts.
4. Add a mate in the top-level assembly.
5. Click File > Save.

SOLIDWORKS saves the top-level assembly because you modified it by adding a mate.
However, because you did not enable the system option, the parts that are saved with
SOLIDWORKS 2019 are not converted to SOLIDWORKS 2020.

Open Modes from File Explorer or PDM Vault View

When you open SOLIDWORKS documents from File Explorer in Windows® or the PDM
Vault View, you can access the Open dialog box before the file opens.

For example, you can search for a large assembly in PDM and then access the Open dialog
box directly from the Vault View. The assembly prepopulates the Open dialog box and
lets you change the open mode to Large Design Review.

Previously, to access the open modes, you had to bring up the Open dialog box and
navigate again to the file you already found in File Explorer or PDM.

You can access the Open dialog box from File Explorer by right-clicking a .SLDPRT,
.SLDASM, or .SLDDRW file and clicking SOLIDWORKS > Open. Earlier versions of the
software support this method, however, you must install SOLIDWORKS 2020 to update
the SOLIDWORKS Launcher beforehand.

If the SOLIDWORKS software is already open, you can access the Open dialog box from
the PDM Vault View or File Explorer by holding Alt and dragging a .SLDPRT,.SLDASM, or
.SLDDRW file into the graphics area. Alt and drag are not supported in earlier versions.
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Simplified Open Options

The Open and the Welcome dialog boxes have reorganized and renamed options.

Renamed options:

Previous NameNew Name

Large Assembly ModeUse Large Assembly Settings

Do not load hidden componentsLoad hidden components

Select sheets to openSelect Sheets

Large Assembly Settings

After opening an assembly, click Large Assembly Settings in the Assembly tab of
the CommandManager to enable or disable these settings.

For Assemblies system options, the following large assembly options are renamed:

Previous NameNew Name

Use Large Assembly Mode to improve
performance when the assembly
contains more than this number of
components

Use Lightweight mode and Large
Assembly Settings when the number of
components exceeds

Use Large Design Review when the
assembly contains more than this
number of components

Use Large Design Review mode when
the number of components exceeds

To access these options, click Tools > Options > System Options > Assemblies.

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

SOLIDWORKS® 2020 API includes the ability to:

• Append a new selection list to a previously suspended selection list.
• Create and edit:

• Mirrored components.
• Fillets and chamfers using new methods.
• Multibody part exploded views.

• Find missing references in fillets and chamfers and reassign them to new edges.
• Get or set:

• More properties in derived part and pattern feature data objects.
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• Whether a sketch is editable.
• Whether to convert width polylines to solid fill hatches when importing to part
sketches.

• Slice models into 2D sketch sections.
• Sort a body cut list folder.
• Use 3D Interconnect functionality.
• Use improved mass property reporting.

Changes to System Options and Document Properties
The following options are added, changed, or removed in the software.

System Options
These system options are accessible at Tools > Options > System Options. The Access
column lists which subarea of System Options that the option is located.

AccessDescriptionOption

External
References

Moved to Pack and Go.Include subfolders for
drawings search in Pack
and Go

External
References

Permits the creation of external
references.
Renamed from Do not create
references external to the model.

Allow creation of
references external to
the model

External
References

Specifies the type of reference
component:

Creates an external
reference to any
component.

Any
Component

Creates an external
reference only to
envelope components.

Only
Envelope
Component

Available when you select Allow
creation of references external to
the model.

Reference Component
Type
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AccessDescriptionOption

External
References

Specifies the context of external
references:

Creates an external
reference to components
in the top-level
assembly.

Top level
assembly

Creates external
references only to
components in the same
subassembly.

Same
subassembly

Available when you select Allow
creation of references external to
the model.

In the context of

External
References

For assemblies and drawings that are
not saved in the current version,
selecting this option saves all referenced
documents to the current version of
SOLIDWORKS when you save the
assembly or drawing. Referenced
documents are converted even if they
are not modified in the current session.
When cleared, only modified documents
are saved in the current version. Clear
the option to reduce save times or to
allow users with earlier versions of the
software to continue using the
referenced documents.

Force referenced
documents to save to
current version

Export > 3MFIncludes slicing information for 3D
printing when you export to a .3mf file.

Include slices

Document Properties
These document properties are accessible at Tools > Options > Document Properties.
The Access column lists which subarea of Document Properties that the option is located.

AccessDescriptionOption

Drafting
Standard >
Uppercase

Sets the default case used in new
dimensions and hole callouts to all
uppercase.

All uppercase for
dimensions and hole
callouts

Dimensions >
Linear

Automatically adds an overall dimension
when you create a set of chain
dimensions.

Add overall dimension to
chain dimensions
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AccessDescriptionOption

Dimensions >
Linear

(Available if Add overall dimension to
chain dimensions is selected.)
Automatically adds a final reference
dimension when you create a set of
chain dimensions.

Add last reference
dimension

AnnotationsSets the default to include the thread
Type in cosmetic thread callouts.

Show type in thread
callouts

Closing a Document When Saving a Copy
When you select Save as copy and open in the Save As dialog box, you can close the
original document. If the original document has unsaved changes, the document remains
open.

To close the document when saving a copy:

1. Open a model and click File > Save As.
2. In the Save As dialog box, click Save as copy and open and click Save.
3. When prompted by the Save as copy and openmessage, select Close the original

document.

Selection Sets
You can add and remove selected items to new or existing selection sets. You can add
selected items to multiple selection sets.

In assemblies, only the selection sets for the assembly show when you click Save
Selection. In parts, only the selection sets for the part show. To view selection sets, in

the FeatureManager® design tree, expand Selection Sets .

You can drag a selected item from the FeatureManager design tree or from a selection
set to another selection set. You cannot drag items from an assembly selection set to a
part selection set.

Adding a Selection to a Selection Set

To add a selection to a selection set:

1. Open a model and select multiple items in the FeatureManager design tree or graphics
area.
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2. Right-click the selections and click Save Selection.

• To add an item to a new set, click New Selection Set .
• To add an item to an existing set, click Selection-Set#(##) where # indicates
the order of creation and ## indicates the number of items in the set.

A check next to a selection set indicates that the selected item is a member of the
selection set.

3. Expand Selection Sets to show the selection set.

Updating Entities in a Selection Set

To update entities in a Selection Set:

1. In the FeatureManager design tree, select a selection set under Selection Sets .
2. In the FeatureManager design tree or in the graphics area, CTRL + select or clear

highlighted items.
3. Continue to press CTRL and right-click the selected items, and click Update Selection

Set.
Selected items are added to the selection set.

Specifying the Up Axis for View Orientation
You can specify the y-axis or the z-axis as the default up orientation for views. This option
changes the view orientation for standard orthogonal, named, and child views.

To use this functionality, save the files in SOLIDWORKS 2020 or later.

To specify the up axis for view orientation:

1. Open a model.

2. Click View Orientation (View toolbar).

3. In the Orientation dialog box, click the Up Axis flyout and select an option:

Uses the Y-axis as the up orientation for views.Apply Y-up views

Uses the Z-axis as the up orientation for
views.

Apply Z-up views
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4
Installation

This chapter includes the following topics:

• Improved Installation Manager Download Performance
• Installing the 3DEXPERIENCE Marketplace Add-In
• Installing the 3DEXPERIENCE Add-In
• Installing SOLIDWORKS PCB Viewer
• Installing Toolbox Software Without Installing Toolbox Data
• SOLIDWORKS File Utilities Replaces SOLIDWORKS Explorer
• Testing a Setup for a Push Deployment

Improved Installation Manager Download Performance
The download and extraction processes of the Installation Manager use parallel threading.
The result is faster downloads. Users who are downloading more than one product will
see the greatest benefit.

Installing the 3DEXPERIENCE Marketplace Add-In
The 3DEXPERIENCE Marketplace add-in installs by default with your installation of
SOLIDWORKS 2020 SP01 and later.

3DEXPERIENCE Marketplace contains these services: PartSupply, Make, and Engineering.
You access 3DEXPERIENCE Marketplace from the Task Pane.

The 3DEXPERIENCE Marketplace add-in allows easier interaction between 3DEXPERIENCE
Marketplace and SOLIDWORKS by bringing the tools right into your modeling environment.
It also lets you search and download parts and assemblies from an online catalog populated
with models from component suppliers and individual SOLIDWORKS users. You can insert
these parts and assemblies directly into your active SOLIDWORKS model from the Task
Pane.

For information on PartSupply, Make, or Engineering, see the Frequently Asked Questions
section (FAQs) available on each site.
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Installing the 3DEXPERIENCE Add-In
The 3DEXPERIENCE add-in is a unified add-in that provides access to all the
3DEXPERIENCE services and apps that you are entitled to use based on your roles.

If you are a member of your organization's 3DEXPERIENCE platform, you can download
and install additional add-in components that provide access to 3DEXPERIENCE
collaboration apps, file sharing, and data management, including the 3DEXPERIENCE
Marketplace services.

Prerequisites for installing the 3DEXPERIENCE add-in are:

• 3DEXPERIENCE platform credentials. You can sign in with your SOLIDWORKS ID and
password if it uses the same email address your administrator used to invite you to
3DEXPERIENCE platform.

• A web browser.
• The 64-bit version of the Java 11 JRE component or higher.
• A full product installation of SOLIDWORKS 2018 SP0 or later.

To install the 3DEXPERIENCE add-in:

1. Before you begin, exit SOLIDWORKS.
2. Log in to the 3DEXPERIENCE platform.

If your company has an on-premise installation, contact your administrator to get
the sign in link.

3. At the top bar of the 3DDashboard, click the Compass
4. Under Me, click SOLIDWORKS.
5. Follow the prompts to download and install the 3DEXPERIENCE Launcher and more

add-in components.

The add-in components available to you depend on your platform roles. They download
sequentially, so keep your browser window open and watch for prompts.

6. To use the 3DEXPERIENCE add-in for the first time:
a) Return to the 3DDashboard in your browser.
b) Click the Compass and click SOLIDWORKS.
c) Log in if required.

Installing SOLIDWORKS PCB Viewer
You can download and install SOLIDWORKS® PCB Viewer using the Installation Manager,
making it easier to install concurrently with SOLIDWORKS or other SOLIDWORKS products.
This free PCB viewer is available without a license.

You can use the viewer to access, print, and search through all of your team's design
files created in Altium Designer.

You can also add SOLIDWORKS PCB Viewer to your administrative image deployments.

You cannot install the SOLIDWORKS PCB Viewer on the same computer as SOLIDWORKS
PCB.
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Installing Toolbox Software Without Installing Toolbox Data
If your environment has a PDM or shared Toolbox/Hole Wizard location, you can set client
installations to not install or upgrade Toolbox data in that location.

Do this if:

• You did not yet set up the SOLIDWORKS PDM local view before installing the
SOLIDWORKS software.

• The files in the location are in use and could block SOLIDWORKS installations from
completing.

• The location is unavailable and could block SOLIDWORKS installations from completing.

When you set client installations to not install Toolbox data, the SOLIDWORKS software
and settings point to the Toolbox/Hole Wizard location, but you must install the data in
a central location later.

To install the SOLIDWORKS software without including Toolbox/Hole Wizard data, you
must install SOLIDWORKS from an administrative image.

1. In the Administrative Image Option Editor, click Settings.
2. Expand Toolbox/Hole Wizard Options.
3. When asked if you want this client to install/upgrade the Toolbox files, select No,

install the Toolbox software without including the data files.

At least one person, typically the SOLIDWORKS Administrator, must install or upgrade
the Toolbox/Hole Wizard data in the central location or the software will not function
properly. Anyone in the organization can handle this task with a single manual installation
of the SOLIDWORKS software. If you manage Toolbox inside of SOLIDWORKS PDM, follow
the steps outlined in the Toolbox section of the SOLIDWORKS PDM Administrator Guide
to install or upgrade the Toolbox data.

SOLIDWORKS File Utilities Replaces SOLIDWORKS Explorer
SOLIDWORKS Explorer has been replaced by SOLIDWORKS File Utilities, which lets you
rename, replace, copy, and move SOLIDWORKS files while maintaining file references.

You can install SOLIDWORKS File Utilities from the Installation Manager, the Administrative
Image Options Editor, and its own installation wizard. It is also available from
https://www.solidworks.com/sw/support/downloads.htm.

Testing a Setup for a Push Deployment
The Deploy Automatically tab in the Administrative Image Option Editor contains a test
feature.

You can run a mock installation that exercises the systems used for the deployment, such
as:

• Connecting to the target computer.
• Creating an install task on that computer.
• Completing the install task on that computer.
• Updating the status and logs on the administrative image.
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• Detecting a program to run before or after the installation.

The test checks for file paths, validates permissions, and reports that the installation
ended successfully. It does not install any software or modify the registry on the target
system. If any one of the systems fails on any of the target computers, the test indicates
which system failed.

Tooltips provide more information about failures. You can export the results to an .xml
spreadsheet (or .csv), which is helpful for reviewing multiple failures or sharing results
with other support personnel.

To test a setup for a push deployment:

1. Using the Installation Manager, create an Administrative image.
2. Start the Administrative Image Option Editor.

You can start the option after the Installation Manager completes creating the
administrative image or double-click sldAdminOptionEditor.exe in the
administrative image folder.

3. On the Setup tab, add one or more computers.
4. Click Deploy Automatically:

a) Supply a domain administrator's username and password.
b) Select one or more computers to test.
c) Click Test.

5. When the Setup Test appears, click Run Test.
6. Allow several minutes for the test to complete or click Cancel Test at any time.
7. Review and correct any setup problems.
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5
Administration

This chapter includes the following topics:

• Selecting a SOLIDWORKS Simulation License with a SolidNetWork License
• SOLIDWORKS CEF Sub Process
• SOLIDWORKS Rx Supports SOLIDWORKS Composer and SOLIDWORKS Electrical
• Specifying Support Information

Selecting a SOLIDWORKS Simulation License with a SolidNetWork License
SolidNetWork license users can control which of the SOLIDWORKS® Simulation licenses
in their license pool to use when they add in SOLIDWORKS Simulation. They can also
upgrade the SOLIDWORKS Simulation license without unloading the add-in in case they
need a higher license type for more advanced studies.

1. To use a specific SOLIDWORKS Simulation license:
a) In the SOLIDWORKS, click Tools > Add-Ins and in the Add-in dialog box, select

SOLIDWORKS Simulation.

b) On SOLIDWORKS Simulation (CommandManager), click the Down arrow
to display a list of licenses on your server that can support Simulation.

c) Select the appropriate SOLIDWORKS Simulation license.
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2. To check or change your current SOLIDWORKS Simulation license, click the Down

arrow on SOLIDWORKS Simulation (CommandManager).

The license that is in-use displays a check mark. If more advanced license types are
available, you can upgrade.

You cannot downgrade a SOLIDWORKS Simulation license. Disable the SOLIDWORKS
Simulation add-in and add the license back in at a lower level.

3. Optional: To disable the add-in, click SOLIDWORKS Simulation (CommandManager)
or clear it from Tools > Add-Ins.

The following cases still use license order:

• When SOLIDWORKS Simulation starts running.
• If SOLIDWORKS Simulation is added in Tools > Add-Ins.
• If the you click SOLIDWORKS Simulation without specifying a license from the pull-down
list.

SOLIDWORKS CEF Sub Process
SOLIDWORKS integrates the Chromium Embedded Framework (CEF). In the Microsoft
Windows Task Manager, one or more instances of SOLIDWORKS CEF Sub Process,
swCefSubProc.exe, appear when you use SOLIDWORKS.

SOLIDWORKS Rx Supports SOLIDWORKS Composer and SOLIDWORKS
Electrical

SOLIDWORKS Rx is installed with SOLIDWORKS Electrical and SOLIDWORKS Composer.

The Problem Capture tab in SOLIDWORKS Rx collects files, videos, and settings for
SOLIDWORKS Composer and SOLIDWORKS Electrical. In the Capture section, choose
the application to capture. SOLIDWORKS Composer, SOLIDWORKS Electrical, or
SOLIDWORKS display only if you installed them in the 2020 version of SOLIDWORKS,
SOLIDWORKS Composer, or SOLIDWORKS Electrical.

If you select SOLIDWORKS Electrical or SOLIDWORKS Composer and click Record Video,
SOLIDWORKS Rx:

1. Records the active SOLIDWORKS Electrical or SOLIDWORKS Composer session or
starts a new session to record.

2. Lists the video in the Package section, along with system and other support
information:

• For SOLIDWORKS Electrical, this is the same information currently generated by
the Support Information on the Help menu.

• For SOLIDWORKS Composer, this information also includes logs and settings.

43

Administration



3. Lets you add more files to the Package section.

For example, for SOLIDWORKS Electrical, you can add .tewzip files.

4. Lets you package the files in the Package section into a .ZIP file and send it, along
with a description of the problem, to your technical support contact.

Specifying Support Information
Administrators can provide support information to users by using the Settings Administrator
Tool.

To access the Settings Administrator Tool, you must first create an administrative image.
See SOLIDWORKS Online Help: Creating an Administrative Image from SOLIDWORKS
Installation Manager.

Support information appears when you click Get support in the following locations:

• Help

• Logged in
• Welcome dialog box under Resources
• SOLIDWORKS Error Report dialog box
• In SOLIDWORKS Rx, Help

To specify support information:

1. Start the Settings Administrator Tool from an administrative image.
2. In the SOLIDWORKS Setting Administration dialog box, select an option on the

Welcome page and click Next until you reach the Support Information page.
3. Specify the contact information:

Get Support opens this website if you
do not specify contact information.

Open the SOLIDWORKS Support
website

Specifies contact information to show in
the SOLIDWORKS Support dialog box:

Provide support contact information
in a dialog box

• Organization or person name
• Contact options:

• Email
• Phone number
• Web address
• Web address text

• Note

To view the SOLIDWORKS Support dialog
box, click preview.
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6
Assemblies

This chapter includes the following topics:

• Envelope Publisher
• Flexible Components
• Mates
• Patterns
• Large Design Review
• Exploded Views
• External References Options
• Isolating Interferences
• Modify Configuration for Toolbox Components
• Performance Improvements for Assemblies
• Save as Copy with a Subset of Configurations

Envelope Publisher

Video: What's New in SOLIDWORKS 2020 - Envelope
Publisher

You can use the Envelope Publisher tool to include components from a top-level
assembly as envelopes in a subassembly.

You can work in the subassembly using the published envelopes as reference components
in isolation from the top-level assembly. The envelope components inherit changes from
the top-level assembly.

Multiple subassemblies can have the same envelope. Subassemblies can contain only one
group of envelopes published by Envelope Publisher .

When you select a subassembly as a destination for the envelope, an external reference
is created to the parent assembly. The Published Envelopes folder displays external
reference symbols that indicate the reference state of the envelope.
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Envelope Publisher is available when an assembly contains subassemblies. The tool
is not available in Large Design Review mode.

Creating Envelopes for a Subassembly

To create envelopes for a subassembly:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\envelope_publisher\EnvelopePublisher.SLDASM.

2. Click Tools > Envelope Publisher .

If Envelope Publisher is not available, check the External References system
options:

a) Click Tools > Options > System Options > External References.
b) Under Assemblies, select:

• Allow creation of references external to the model
• Any component for Reference component type
• Top level assembly for In the context of

3. In the Envelope Publisher PropertyManager, for Components to use as envelopes

, select the following components:

a) Under Connectors , select all the connectors.
b) Select Ducting<1>.
c) Under Building<1> subassembly, select DoorSubAssy<1> and

DoorSubAssy<2>.

4. For Destination subassemblies , select PipeSubAssy<1>.
5. Optional: Change the envelope group name from the default name of Envelope

Group1.

6. Click Add group, and click .
7. In the FeatureManager® design tree, right-click PipeSubAssy<1> and click Open

pipesubassy.SLDASM .
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8. Optional: If prompted, click Rebuild.

You can work with the envelope components in the subassembly.

Viewing Envelopes

To view envelopes:

1. Click View > Hide/Show.
2. Select an option:

Displays envelopes that belong to components in the
top-level assembly.

View Component
Envelopes

Displays envelopes that belong to the top-level
assembly.

View Top Level
Envelopes

Envelope Publisher PropertyManager

To open the Envelope Publisher PropertyManager:

In an assembly that contains a subassembly, click Tools > Envelope Publisher .

If Envelope Publisher is not available, check the External References system options:

1. Click Tools > Options > System Options > External References.
2. Under Assemblies, select:

• Allow creation of references external to the model
• Any component for Reference component type
• Top level assembly for In the context of

Add a Group / Edit Group

Lists the group name.Add or Edit
Envelope Group
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Specifies the components to include in the envelope.
Flexible subassemblies cannot be envelope components.

Components to
use as envelopes

Specifies the subassemblies to publish the envelopes.
The published envelope creates external references to the
parent assembly.

You cannot select the following subassemblies as a
destination:

• Subassemblies that are a destination for a different
envelope group.

For assemblies that contain multiple instances of a
subassembly, you can use only one of the instances as
a destination subassembly.

• Subassemblies that are a component in an envelope.

Destination
subassemblies

Adds the envelope group.Add group

Resets the PropertyManager fields.Reset

Saves changes to the envelope group.Done

Envelope Groups

Lists envelope groups.Envelope Groups

Flexible Components

Video: What's New in SOLIDWORKS 2020 - Flexible
Components

You can define a part component as flexible to drive the geometry of flexible components
by the assembly geometry.

For example, you model a spring in the context of an assembly where the length of the
spring is driven by an external reference in the assembly. You insert the spring into a
second assembly where the spring appears with an out-of-context reference. You can

use the Make Part Flexible tool to remap the out-of-context reference to the second
assembly. As a result, the spring is driven by the second assembly without affecting the
nominal length of the spring.
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You can use Make Part Flexible under the following conditions:

• A single part is selected.
• A part is in the top-level of the active assembly.
• A part has external references defined in the context of an assembly that is not the
active assembly.

The external reference must be one of the following entity types:

Sketch arcs or circlesPartial cylindrical facesArc or cylindrical edges

Sketch lines (linear)Planar facesAxes

Sketch pointsPlanesCylindrical faces

VerticesReference pointsLinear edges

The custom and configuration-specific properties of the flexible component are the same
as these properties in the component's nominal state. Properties show the value from
the nominal state. Select Use mass property from rigid state to apply the mass
properties of the component in its rigid state to the activated flexible component.

The flexible component updates dynamically when an external reference changes.

In the FeatureManager design tree, indicates flexible components.

To change a component from flexible to rigid, select the part and click Make Part Rigid

in the context menu. The remapped external references are deleted and the component
returns to its nominal state.

Adding a Flexible Component

To add a flexible component:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\flexible_components\Destination_Assembly.SLDASM.
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2. Click Insert Components (Assembly toolbar) and select
system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\flexible_components\Spring.SLDPRT.

3. Create a coincident mate between Collar<1> and the red face of Spring<1>.

4. Click View > Hide/Show > Axes .
5. Create a concentric mate between the central axis of Spring<1> and the cylindrical

shaft of Shaft<1>.

6. Click .
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7. In the FeatureManager design tree, right-click Spring<1> and click Make Part

Flexible in the context menu.

In the graphics area, a preview of the unattached reference entity appears.

8. To reattach the reference entity, click a planar face on Shaft<1>.

9. Click .
10. In the graphics area, move Collar<1> up and down.

Editing External References of Flexible Components

1. Right-click the component and click Edit Flexible Part References.
2. Modify the references listed in the Activate Flexible Component PropertyManager.

Activate Flexible Component PropertyManager

To open the Activate Flexible Component PropertyManager:

Open an assembly, right-click a part, and click Make Part Flexible in the context
toolbar.
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Flexible References

Lists the flexible references that you need to remap. When you select
a reference, a preview appears in the graphics area. Select an entity
of the same type in the graphics area to specify the reference.

External
References in the
selected
component

Indicates a reference that is not specified.

Indicates a reference that is specified.

Applies the mass properties of the component in its rigid state to
the activated flexible component as overridden mass properties.

Use mass
property from
rigid state

Mates

Video: What's New in SOLIDWORKS 2020 - Assembly
Mates

Flip Alignment of Width Mates

In the Mate PropertyManager, click Aligned and Anti-Aligned to flip the alignment
of width mates. In the Copy with Mates PropertyManager and in the Quick Mates context

toolbar, click Flip Mate Alignment .

To flip the alignment of width mates:

1. Open an assembly that contains a width mate.

2. In the FeatureManager design tree, expand Mates .

3. Right-click Width and click Flip Mate Alignment.

Quick Mates Context Toolbar

You can select the following mates and options from the Quick Mates context toolbar:

Available for concentric mates.Lock rotation

Available for mates that support the flip alignment option.Flip Mate
Alignment
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Available options:

Flip Dimension

Maximum Value

Minimum Value

Arc/Circle Measurements

Limit Distance
Mate

Available options:

Flip Dimension

Maximum Value

Minimum Value

Limit Angle Mate

Available options:
Available for Distance Along
Slot and Percent Along Slot.Flip Dimension

Slot Position

Slot Mate

Available options:
Available for Dimension
and Percent.Flip Dimension

Width Position

Width Mate

Patterns

Video: What's New in SOLIDWORKS 2020 - Assembly
Patterns

Component Pattern with Variable Instances

You can vary the linear or angular spacing of individual instances of linear and circular
component patterns to override the pattern spacing.

You can use these options in a callout to modify the spacing and direction of an instance:
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Specifies the absolute value from the seed component. Use only
positive values.

Available for linear component patterns.

Distance from
seed

Specifies the angle from the seed to the selected instance. Use only
positive values.

Available for circular component patterns.

Angle from seed

Specifies the relative value to the nominal position of the selected
instance.

The nominal position of the instance is the location of the instance
before the modification.

You can specify positive and negative values. For negative values,
the absolute distance to the seed must be positive.

Available for linear and circular component patterns.

Offset from
nominal

In the Linear Component Pattern and Circular Component PropertyManagers, Instances
to Skip is renamed to Instances to Override. You can specify instances to skip in

Skipped instances . Use Modified instances to specify instances to modify.

Modifying an Instance in a Linear Component Pattern

To modify an instance in a linear component pattern:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\patterns\Vary_Pattern.SLDASM.

2. In the FeatureManager design tree, right-click LocalLPattern1 and click Edit

Feature .
3. In the PropertyManager, under Instances to Override, click in Modified instances

. In the graphics area, pink selection orbs display on the pattern instances.

4. Click the selection orb for 4,1 and click Modify Instance.
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5. In the callout, modify the value for Dir 1 offset from nominal to -60mm and click
outside of the callout.

A shadow instance appears in the new position.

6. In the PropertyManager, click .
The bracket is no longer behind the pipe.

Mirror Components PropertyManager

You can position a mirrored component by using the origin of that component. You can
select multiple components in the component orientation field. You have more control
over the orientation of copied components that are not opposite-hand versions.

New and changed options on the Step 2: Set Orientation page of the Mirror Components
PropertyManager:

Mirrors a component instance about the
component origin of the selected
reference plane. This instance is not an
opposite-hand version.

Component
origin

Mirror Type
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These options replace the Reorient components options.Orient
Components

X and Y axes mirror about the plane.X mirrored, Y
mirrored

X and Y axes mirror about the plane
with the X axis direction reversed.

X mirrored and
flipped, Y
mirrored

X and Y axes mirror about the plane
with the Y axis direction reversed.

X mirrored, Y
mirrored and
flipped

X and Y axes mirror about the plane
with the X and Y axes direction
reversed.

X mirrored and
flipped, Y
mirrored and
flipped

Calculates the component orientation
by mirroring and flipping about the X
and Y axes of the component.

Align to
component
origin

Component
Orientation Axis

Calculates the component orientation
by mirroring and flipping the component
about the local X and Y axes. In the
calculation, X is parallel to the mirror
plane and Y is normal to the face or
plane that you select in Alignment
Reference.

A second reference triad appears in the
graphics area and shows the X and Y
rotation axes for the seed and the
mirrored component. The axes change
as you click the orientation icons.

Align to selection

Select an entity to align the up axis of
the orientation axes. Available when you
select Align to selection.

You can select the following items as
references:

• Planes or planar faces that are
perpendicular to the mirror plane.

• Linear edges or linear sketch
segments that are parallel to the
mirror plane.

Click Flip alignment reference

direction to flip the direction of the
reference.

Alignment
Reference
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Changes to the Step 2: Set Orientation page:

• The Mirror Type section moved.
• The Orient Components box as well as the Components to Mirror box on the Step

1: Selections page of the PropertyManager are resizable.
• Multiple components can be selected for Orient Components. Shift + select to select
all items between the first and last selected items. Ctrl + select to select individual
components. Alt + select items to designate an opposite hand component.

• Create opposite hand version moved to the right of the Orient Components
options.

SOLIDWORKS 2020SOLIDWORKS 2019
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Comparing Component Orientation Options

To compare the component orientation options:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\mirror_pattern\TopAssembly.SLDASM.

2. Click Linear Component Pattern > Mirror Components (Assembly toolbar).
3. Select Mirror Plane for Mirror Plane and select Valve assembly<1> for

Component to Mirror.

4. Click Next to Step 2: Set Orientation.
5. Under Mirror Type, select Component origin.
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6. Under Orient Components, select a component orientation option.

X mirrored, Y
mirrored
X and Y axes
mirror about the
plane.

X mirrored and
flipped, Y
mirrored
X and Y axes
mirror about the
plane with the
X-axis direction
reversed.

X mirrored, Y
mirrored and
flipped

X and Y axes
mirror about the
plane with the
Y-axis direction
reversed.

X mirrored and
flipped, Y
mirrored and
flipped

X and Y axes
mirror about the
plane with the X
and Y axes
direction reversed.

Comparing Mirror Type Options

To compare the Mirror Type options:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\mirror_pattern\TopAssembly.SLDASM.

59

Assemblies



2. Click Linear Component Pattern > Mirror Components (Assembly toolbar).
3. Select Mirror Plane for Mirror plane and select Valve assembly<1> for

Component to Mirror.

4. Click Next to Step 2: Set Orientation.

5. Under Orient Components, select X mirrored, Y mirrored .
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6. Under Mirror Type, select an option.
a) Optional: Click View > Hide/Show to view the bounding box, center of mass,

or origins in the graphics area.

Center of bounding box
The distance between the
mirror plane and the center
of the bounding box is
equal for the seed and the
mirrored instance.

Center of mass
The distance between the
mirror plane and the center
of mass is equal for the
seed and the mirrored
instance.

Component origin
The distance between the
mirror plane and the origin
is equal for the seed and
the mirrored instance.

Pattern Driven Component Patterns

When a Pattern Driven Component Pattern uses a Hole Wizard feature as the driving
feature, you can align the patterned instances to each hole axis.

In the Pattern Driven PropertyManager, under Driving Feature or Component, you
can select an alignment method when you select a hole wizard feature as the driving
feature:

Aligns instances to the Hole Wizard feature.
Default alignment method for new pattern features.

Align to holes
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Aligns instances to the seed instance.
Default alignment method for existing pattern features.

Align to seed

Aligning Patterned Instances Using a Hole Wizard Feature

In the example, you pattern a rivet to a hole feature to connect 2 plates.

To align patterned instances using a Hole Wizard feature:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\patterns\RivetedPlates.SLDASM.

Top view of 2 plates

Side view of 2 plates

2. Click Linear Component Pattern > Pattern Driven Component Pattern
(Assembly toolbar).

3. In the PropertyManager, select the following items:
a) For Components to Pattern, select round head rivets gb<2>.

b) For Driving feature or component, select the 04.0 (4) Diameter Hole1
feature.

c) Click Select Seed Position and select the seed component.
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4. Click OK .

The pattern for round head rivets gb<2> matches the hole pattern.

Top view of 2 plates

Side view of 2 plates

Large Design Review

Create and Edit Component Patterns in Large Design Review

You can create and edit linear and circular component patterns when you edit an assembly
in Large Design Review mode. You can edit pattern driven and sketch driven component
patterns. This functionality is available for top-level assemblies only.

You can use the following tools when you right-click a pattern feature in the
FeatureManager design tree:

• Edit Feature
• Suppress
• Unsuppress
• Hide Components
• Show Components
• Isolate Components

For a component pattern that is driven by an unavailable entity,
**LargeDesignReview** shows as a prefix to the entity name in the PropertyManager.

Available Functionality by Component Pattern

Curve Driven
and Chain

Pattern Driven
and Sketch
Driven

Linear and
Circular

Create

Delete
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Curve Driven
and Chain

Pattern Driven
and Sketch
Driven

Linear and
Circular

DefinitionEdit

Patterned
components

Instances to
skip

To use this functionality, save the assembly in SOLIDWORKS® 2020 and later.

To create component patterns in Large Design Review Mode:

1. Click Open .
2. In the dialog box, select an assembly, and then in Mode, select Large Design

Review.
3. Select Edit assembly.
4. Click Open.

5. Click Linear Component Pattern (Assembly toolbar).
6. Specify options in the PropertyManager.

Create Mates to Reference Geometry in Large Design Review

You can create mates to the reference geometry of components when you edit an assembly
in Large Design Review.

In the FeatureManager design tree, you can view the following reference geometry for a
component:

• Standard planes
• Origin
• Reference planes
• Axes - not temporary axes
• Reference points
• Coordinate systems

You can Hide or Show reference geometry in the top-level assembly and components.

You can create standard mates that reference the reference geometry. These mates are
saved in the top-level assembly.

To use this functionality, save the assembly in SOLIDWORKS® 2020 and later.

To create mates to reference geometry in Large Design Review:

1. Click Open.
2. In the dialog box, select an assembly, and then in Mode, select Large Design

Review.
3. Select Edit assembly.
4. Click Open.
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5. Click Mate (Assembly toolbar).
6. Select options in the Mate PropertyManager to create a mate to reference geometry.

7. Click .

8. In the FeatureManager design tree, expand Mates for the top-level assembly to
view the mate.

Exploded Views

Auto-Space Components in Exploded Views

You can enable Auto-space components for existing explode steps. You can select
center, rear, or front of the bounding box for the order of auto-spaced components.

Auto-space components is renamed from Auto-space components on drag.

To use Auto-space components in exploded views:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\assemblies\explode\pillow_block.SLDASM.

2. Click Insert > Exploded View .

3. In the PropertyManager, for Explode Step Components , select these components:

• flatwasher<1>
• lockwasher<2>
• socket head cap screw<2>

4. Drag the Y axis to explode the components.
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5. Under Auto-space components, select a bounding box option:

Bounding box front

Orders auto-spacing by the
front of the bounding box.

Bounding box rear

Orders auto-spacing by the
rear of the bounding box.

Bounding box center

Orders auto-spacing by the
center of the bounding box.

6. Click Add Step.

7. Click .

Reusing a Multibody Part Explode

You can reuse an exploded view from a multibody part in an assembly level exploded
view. This behavior is similar to reusing a subassembly explode in an exploded view.

The reused explode step shows as fully exploded in the graphics area. If a multibody part
has multiple exploded views, you can select the exploded view to use.

You cannot view individual steps reused from a multibody part. The individual steps are
not animated when you use Animate explode or Animate collapse. The reused exploded
view shows as a single step in the Explode PropertyManager.

To reuse a multibody part explode:

1. Open an assembly that contains a multibody part with an exploded view.
2. On ConfigurationManager, right-click an exploded view and click Edit Feature.

3. In the PropertyManager, for Explode Step Components , select the multibody
part.

4. Under Options, click From Part.

The multibody part explodes in the graphics area. The exploded view from the
multibody part is added as a step under Explode Steps.
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5. Click .

External References Options
You can select options for In the context of to allow creation of external references in
a top-level assembly or a subassembly. You can select options for Reference Component
Type to limit external references to any component or only envelope components.

When you edit a part in the context of an assembly, the part turns blue and the assembly
in which the external reference is created turns purple in the FeatureManager design tree.

To set external references options:

1. Click Tools > Options > System Options > External References.
2. Under Assemblies, specify:

Permits the creation of external references.
This option is renamed from Do not create
references external to the model.

Allow creation of references
external to the model

Creates an external
reference to any
component.

Any
Component

Creates an external
reference only to
envelope components.

Only Envelope
Component

Reference Component Type

Creates an external
reference to components in
the top-level assembly.

Top level
assembly

Creates external references
only to components in the
same subassembly.

Same
subassembly

In the context of

3. Click OK.

Isolating Interferences
In the Interference Detection tool for assemblies and multibody parts, you can tag
interference, components, or bodies for isolation after you exit the Interference Detection
PropertyManager.

To isolate interferences:

1. Open an assembly or multibody part, and click Interference Detection (Evaluate
toolbar).

2. In the PropertyManager, click Calculate.
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3. Under Results, right-click an interference and click Isolate when done.

Isolated interferences appear as .

When you select Component View for assemblies or Body View for multibody parts,
you can click Isolate when done for the parent component, the child component,
or the interference.

4. Click .

The tagged interferences appear in the graphics area.

5. Click Exit Isolate on the Isolate pop-up toolbar.

Modify Configuration for Toolbox Components
You can modify the configuration for Toolbox components by using the Modify
Configurations dialog box.

To modify configurations for toolbox components:

• In the FeatureManager design tree, right-click a toolbox component and click Configure

Component .

In the Modify Configurations dialog box, you can create a configuration, switch to a
different configuration, or suppress a component.

Performance Improvements for Assemblies
Assembly performance is optimized for some tools and workflows so full rebuilds of an
assembly or graphics occur less often.

Save as Copy with a Subset of Configurations
You can save a copy of a part or assembly with a subset of configurations.

When selecting configurations to save, the active configuration is selected by default. The
parent configuration of a derived configuration is selected with the derived configuration.
You cannot clear the check box for the active configuration or the parent configuration.

Linked display states remain in the copied model.

To save as a copy with a subset of configuration:

1. Open a model, right-click a configuration in the ConfigurationManager, and click Save
Configurations.

2. In the Save Configurations as a new Assembly/Part dialog box, select a configuration.

To select all configurations, click .
3. Click Save Selected.
4. In the Save As dialog box, click Save.
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7
SOLIDWORKS CAM

This chapter includes the following topics:

• Customization Settings
• Probing Routines
• Tab Cutting
• Tapered Multipoint Thread Tool
• Universal Post Generator

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Customization Settings
You can save and restore customization settings for a SOLIDWORKS CAM Technology
Database.

The Customization Settings options are available in the Settings tab. Make sure the
SOLIDWORKS software is not running when you save or restore settings.

Probing Routines

Video: What's New in SOLIDWORKS 2020 - CAM
PROBING

You can use a Probe tool to speed up the setup and manufacturing process.

The defined routines area includes:

• Single Point
• Pocket
• Boss
• 3 Point Boss
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• 3 Point Hole

The Probe tool is only available in SOLIDWORKS CAM Professional.

Previously, the probing cycles were controlled through a custom post processor using
drilling cycles in SOLIDWORKS® CAM.

Tab Cutting

Video: What's New in SOLIDWORKS 2020 - CAM Tab
Cutting

You can create multiple tabs or micro-joints in parts for various fabrication workflows.
The settings are available in the Contour tab.

The tabs or micro-joints are helpful when cutting parts in machines like a plasma, water
jet, or laser. They keep small parts from tipping or falling through the cut process.

Previously, the Avoid Area options handled this functionality in SOLIDWORKS CAM.

Tapered Multipoint Thread Tool
A multipoint tapered threading tool is available in the library. The tool lets the thread
angle align with tapered pockets. You can define tapered threads as single point, user
defined, or automatic.

Previously, you could only use straight threading tools in either single or multipoint
configurations.

Universal Post Generator
A free post editor is available. The editor adds template posts for turning that extend
beyond milling.
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8
SOLIDWORKS Composer

This chapter includes the following topics:

• SOLIDWORKS Composer
• SOLIDWORKS Composer Sync

Video: What's New in SOLIDWORKS Composer 2020

SOLIDWORKS Composer
SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical
contents for product communication and technical illustrations.

360 Degree Capture

When you create technical illustrations and high resolution images, you can capture a
defined number of images of the model along a vertical axis performing a 360° clockwise
rotation.

See Composer Help: Working in Workshops > Technical Illustration Workshop > Multiple
Tab and Working in Workshops > High Resolution Image Workshop > Multiple Tab.

Basic Attach Type for Annotations

A basic attach type is available for annotations.

See Composer Help: Editing Actor Properties > Annotation Properties > Attach.

BOM ID Callouts

A BOM table property lets you display BOM table entries only for geometry actors with
visible callouts that display the BOM ID.

See Composer Help: Editing Actor Properties > BOM Table Properties > Filter.
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Exponent Shape for Callouts

A callout property, Exponent Shape, displays a callout's quantity exponent with a colored
circular background.

See Composer Help: Editing Actor Properties > Annotation Properties > Callout exponent.

Importing Appearances from SOLIDWORKS Files

You have the option to import appearances from SOLIDWORKS files.

Previously, Composer silently imported all appearances whether you wanted them or not.
See Composer Help: Composer Help: Managing (Default) Document Properties > Advanced
Properties > Properties > Input - Import.

Importing Exploded, Saved, and Named Views from SOLIDWORKS Files

You can import exploded, saved, and named views from SOLIDWORKS files.

See Composer Help: Managing (Default) Document Properties > Advanced Properties >
Properties > Input - Import.

Inlaid Text for Linear Arrows

An Inlaid Text property displays text inside linear arrows.

See Composer Help: Editing Actor Properties > Markup Properties.

Read-Only Mode Enhancement for Animation Library Templates

You can make edits when property values are read-only.

With the MakeAngleAxisDistPtEditable parameter for Animation Library XML templates,
you can make the angle, axis, and distance properties of animated actors editable in the
Animation Library workshop when property values are read-only. See Composer Help >
Creating Animations > Custom Animation XML Example.
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Support of MP4 Format for Animations

You can save videos in FLV, MKV, and MP4 formats as well as AVI.

See Composer Help: Working in Workshops > Video Workshop and Working with the
Ribbon > File Menu.

Warning Message Before Breaking External Assembly Links

A warning message appears if you start an operation that will break external assembly
links.

The warning message appears in a Composer project (.SmgProj file) or in a fully shattered
product structure (.SmgXml file). It prompts you to confirm the operation. See Composer
Help: Importing and Opening Files > About Composer File Types > Breaking of External
Assembly Links.

SOLIDWORKS Composer Sync

Importing Appearances from SOLIDWORKS Files

You have the option to import appearances from SOLIDWORKS files.

Previously, Composer silently imported all appearances whether you wanted them or not.
See Composer Help: Composer Help: Managing (Default) Document Properties > Advanced
Properties > Properties > Input - Import.

Importing Exploded, Saved, and Named Views from SOLIDWORKS Files

You can import exploded, saved, and named views from SOLIDWORKS files.

See Composer Help: Managing (Default) Document Properties > Advanced Properties >
Properties > Input - Import.
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9
Detailing and Drawings

This chapter includes the following topics:

• Custom Scales for Drawing Sheets and Views
• Chain Dimensions
• Alternate Position Views
• Detailing Mode
• Render Pipeline in Drawings
• Hole Callouts
• Annotations
• Cosmetic Threads
• Creating Markups for Drawings
• Design Library
• Dimensions
• Link Child Views to Parent by Default
• Location for Saving a New Drawing
• Performance Improvements in Drawings

Video: What's New in SOLIDWORKS 2020 - Drawings

Custom Scales for Drawing Sheets and Views
Workflow is improved for setting custom scales for drawing sheets and views.

Setting Custom Scales for Drawing Sheets

The scale list on the status bar includes an option to specify a custom scale for drawing
sheets.

To specify custom scales for drawing sheets:

1. In the status bar, click the scale.
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2. In the list, click User Defined.

3. In the dialog box, enter a scale in the format x:x or x/x.
4. Click OK.

Setting Custom Scales for Drawing Views

In the Drawing View PropertyManager, you can select Use custom scale and immediately
enter a custom scale.

Previously, after selecting Use custom scale, you had to click in the box, scroll up, select
User Defined, and then enter the scale in another box.

To set custom scales for drawing views:

1. In a drawing, select an existing view or insert a new view.
2. In the PropertyManager, under Scale, select Use custom scale.
3. In the box, enter a scale in the format x:x or x/x.

You can also click and select a predefined scale from the list.
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Modifying the List of Available Scales

You can control which scales appear in the list that you access from the status bar and
Drawing View PropertyManager. The same list is used for both drawing sheets and drawing
views.

The list is defined in a file named drawingscales.txt, which you can edit to add and
remove scales. The file contains instructions for editing the list.

The default file location is:

install_dir\SOLIDWORKS\lang\language.

To specify a different location for the file:

1. Click Tools > Options > File Locations.
2. Under Show folders for, select Drawing Scale Standards.
3. Set the file location and click OK.

Chain Dimensions
You can create a chain of associated dimensions measuring from one feature to the next.

You can create chain dimensions in drawings and in sketches in parts and assemblies.
Chain dimensions are reference dimensions driven by the geometry. You cannot change
their values or use the values to drive the model.

When you create chain dimensions, your first selection defines the starting edge of the
chain. Subsequent selections are measured from one selection to the next. You can select
items such as edges, vertices, circles, and midpoints.

Creating Chain Dimensions

To create chain dimensions:

1. Click Chain Dimension (Dimension/Relations toolbar) or Tools > Dimensions
> Chain.

2. Select the starting edge.
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3. Click features to add to the chain set.

Adding Dimensions to Existing Chain Dimensions

To manually add an overall dimension to a set of chain dimensions:

• Right-click any dimension in the set and click Add Overall.

To add more dimensions to a set of chain dimensions:

• Right-click any dimension in the set, click Add to Chain, and then select other items
to add to the chain.

You can delete a dimension from a set of chain dimensions. The surrounding dimensions
automatically adjust to prevent gaps in the chain.

To automate some common chain dimension actions:

1. Click Tools > Options > Document Properties > Dimensions > Linear.
2. Under Chain Dimension, select options:

DescriptionOption

Automatically adds an overall dimension
when you create a set of chain
dimensions.

Add overall dimension to chain
dimensions

(Available if Add overall dimension to
chain dimensions is selected.)
Automatically adds a final reference
dimension when you create a set of chain
dimensions.

Add last reference dimension

Converting Between Baseline and Chain Dimensions

You can convert baseline dimensions to chain dimensions and vice versa.

To convert a chain dimension to a baseline dimension:

• Right-click any dimension in the set and click Convert to Base.

The dimensions change to a baseline:
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To convert a baseline dimension to a chain dimension:

• Right-click any dimension in the set and click Convert to Chain.

The dimensions change to a chain:

Alternate Position Views
In part drawings, you can use Alternate Position View to overlay two configurations
of a part in a single view. In assembly and part drawings, you can use Edit Feature to
open a PropertyManager and define changes to the view.

Creating Alternate Position Views - Parts

In part drawings, you can use Alternate Position View to overlay two configurations
of a part in a single view. The two configurations must already exist in the part model
before you create the alternate position view.

This is useful for showing one part that you make from another. For example, you might
purchase standard junction boxes that have mounting tabs, and then machine the tabs
off. You can create a drawing view of the as-machined configuration, and then add an
alternate position view to show the as-purchased configuration.

In this example, the part model has two configurations:
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• Buy_01 for the as-purchased junction box (with tabs).
• Mod_99 for the as-machined junction box (without tabs).

To create alternate position views for parts:

1. Create a view of the as-machined junction box (Mod_99).

2. Select the view and click Alternate Position View (Drawing toolbar).
3. In the PropertyManager, for Existing configuration, select the configuration for the

as-purchased junction box (Buy_01).

4. Click .

Phantom lines show the tabs of the Buy_01 configuration.

Editing Alternate Position Views

In part drawings, you can replace the alternate position configuration with an existing
configuration from the part model.

In assembly drawings, you can replace an alternate position configuration with an existing
configuration from the assembly model, or you can define a new configuration on the fly.

In assembly and part drawings, you can use Edit Feature to open a PropertyManager
and make changes to the view.

In this example, the alternate position view shows the two tabs from the as-purchased
configuration (Buy_01).

You replace it with an as-purchased configuration that has different tab geometry
(Buy_02).
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To edit alternate position views for parts:

1. In the FeatureManager® design tree:

a) Expand Sheet , and then expand the Drawing View that contains the
alternate position view.

b) Right-click Alternate Position and click Edit Feature.

2. In the PropertyManager, for Existing configuration, select a different configuration
(Buy_02) to use as the alternate view.

3. Click .

Phantom lines show the tabs of the Buy_02 configuration.

Detailing Mode

Video: What's New in SOLIDWORKS 2020 - Detailing
Mode

You can use Detailing mode to open large drawings quickly. The model data is not loaded,
but you can add and edit annotations within the drawing.

Detailing mode is useful if you need to make minor edits to drawings of large assemblies
or drawings with many sheets, configurations, or resource-intensive views.

Detailing mode is available for drawings saved in SOLIDWORKS 2020 and later.

Creating Dimensions and Annotations
In Detailing mode, you create dimensions and annotations just as you would in Resolved
mode.

Exception: You cannot create dimensions or annotations that require model information,
such as hole callouts, cosmetic threads, or links to model properties.

If a drawing is open in Detailing mode and you change and save an associated part or
assembly, then an out-of-date message appears.
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The Resolve Drawing tool always appears in the CommandManager so you can resolve
the drawing at any time.

Saving
You can save your changes to the existing drawing file without exiting Detailing mode.
Saving in Detailing mode does not require a special save format.

• If you save the drawing in Detailing mode, and then close it and reopen it, you can
continue to edit the items you created in Detailing mode.

• If you save the drawing in Resolved mode, the dimensions and annotations you created
in Detailing mode are resolved and saved. Then if you close the drawing and reopen
it in Detailing mode, the ability to edit the resolved dimensions and annotations is
limited. You can only change their position or delete them.

Capabilities Available in Detailing Mode
You can create the following dimensions and annotations:

• Weld callouts• Notes, including notes with leaders
• •Linear and circular note patterns Geometric tolerances

•• Datum feature symbolsSurface finish symbols
• •Revision symbols Datum target symbols

•• Radial and linear dimensions, including
use of the Smart Dimension tool

Revision clouds
• Locations labels

• Ordinate dimensions• Balloons
• Angular running dimensions• Magnetic lines

In addition, you can do the following:

• Change the position, rotation, and labels of drawing views.
• Copy or cut drawing views and paste them onto the same or other sheets within the
same drawing.

• Within annotations, add links to the displayed values of dimensions and other linkable
annotations.

• Insert sketch blocks.
• Add general and revision tables. You cannot add other table types.
• Select displayed geometry, such as model edges and sketches. Use Select Other to
find other selectable items. You cannot select model faces in any drawing views.

• Save the file as a PDF/DXF file, or print as a PDF.

Limitations
• You cannot create new drawing views.
• You cannot create centerlines, center marks, or hatching.
• You cannot use the Undo tool.
• Draft quality section views cannot be selected or exported to DXF/DWG.
• Detailing mode is not available for detached drawings.
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Opening Drawings in Detailing Mode

You can use the Open tool to open drawings in Detailing mode.

In Detailing mode, you can add and edit dimensions and annotations within the drawing,
but the model data is not loaded.

Detailing mode is available for drawings saved in SOLIDWORKS 2020 and later.

To open drawings in Detailing mode:

1. Click Open (Standard toolbar) or File > Open, or press Ctrl+O.
2. In the dialog box, in Files of type, select SOLIDWORKS Drawing (*.drw;

*slddrw).
3. Browse to select a drawing.

4. In the dialog box, for Mode, select Detailing .
5. Click Open.

When a drawing is in Detailing mode:

• appears on the top node of the FeatureManager design tree.
• [Detailing] is appended to the file name in the top bar of the SOLIDWORKS
window.

Render Pipeline in Drawings
Drawings and drawing annotations benefit from the graphics architecture introduced in
SOLIDWORKS 2019, which implemented graphics acceleration and image quality scaling
across graphics cards.

This architecture provides a more responsive, real-time display especially for large models.
It takes advantage of modern OpenGL (4.5) and hardware-accelerated rendering to
maintain a high level of detail and frame rate when you pan, zoom, or rotate large models.
These performance improvements scale up with the higher-end graphics cards not fully
supported in previous versions of the SOLIDWORKS software.

Hole Callouts

Adding Hole Callouts in Section Views

You can apply hole callouts to cross-sectioned holes and slots.

You can apply the callouts in section views, broken-out section views, and detail views.
You can apply the callouts to these features:

• Hole Wizard holes and slots
• Advanced Holes
• Holes created with Cut-Revolve
• Holes and slots created with Cut-Extrude
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To add hole callouts in section views:

1. Click Hole Callout (Annotation toolbar) or Insert > Annotations > Hole Callout.

The pointer changes to .

2. Select any line segment of the cross-sectioned hole.

• Click to select a side edge:

• Shift + click to select a top or bottom edge:

3. Click to place the callout.
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Applying All Uppercase to Dimensions and Hole Callouts

You can set dimensions and hole callouts to display characters in all uppercase in the
graphics area.

You can apply all uppercase to selected dimensions and hole callouts. In any dimension
or hole callout PropertyManager, under Dimension Text, select All uppercase.

You can set the default as all uppercase for all new dimensions and hole callouts in a
document. In any part, assembly, or drawing, click Tools > Options > Document
Properties > Drafting Standard. Under Uppercase, select All uppercase for
dimensions and hole callouts.

Annotations

Flag Notes

Flag Note Bank
The Flag Note Bank appears only on drawings that have flag notes.

Sorting Flag Notes
To sort a stack of flag notes, right-click and select Sort Stack. For a stack of balloons
that includes flag notes, the software sorts flag notes separately after it sorts the other
balloons.

Symbols on Sheet Formats

You can include geometric tolerance and surface finish annotations on sheet formats. The
annotations cannot include leaders.

Cosmetic Threads

Adding Callouts for Non-Hole Wizard Holes

You can add cosmetic thread callouts to holes not created with the Hole Wizard.

In a side view of a hole, use the Smart Dimension tool to add the thread callout as
defined in the Cosmetic Thread feature in the source part or assembly.

1. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions
> Smart.
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2. Select the two silhouette edges of the cosmetic thread.

3. Click to place the dimension.

The hole callout appears.

Adding Callouts for External Threads

In drawings, you can add cosmetic thread callouts to external cosmetic threads.

The thread callout is defined in the Cosmetic Thread feature of the source part or assembly.
You use the Smart Dimension tool to add the callout in a side view or section view of
the external thread.

To add the callout:

1. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions
> Smart.
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2. Select the two silhouette edges of the cosmetic thread.

The pointer changes to when it is over a silhouette edge of a cosmetic thread.

3. Click to place the dimension.

The thread callout attaches to the outer geometry of the cylinder.

Simplifying Callouts

In parts, assemblies, and drawings, you can exclude the thread Type (such as Machine
Threads or Straight Pipe Tapped Thread) from callouts for cosmetic threads.

To simplify callouts:

In the Cosmetic Thread PropertyManager, under Thread Callout, clear Show type.
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Show type selected

Show type cleared

To specify the default for Show type:

Click Tools > Options > Document Properties > Annotations and select or clear
Show type in thread callouts.

Creating Markups for Drawings
You can add markups to drawings on touch and nontouch devices.

All markups show under Markups in the FeatureManager® design tree.

These options are available for an active sheet when you right-click Markup in the
FeatureManager design tree:

Edit Markup

Zooms to the markup.Orient

Hide

Exports markups as one of the following file types: .pdf,
.bmp, .jpg, .png, and .tif.

Export Markup

For more information on markup changes, see Markups on page 20.

To create markups in drawings:

1. On a nontouch device, open a drawing, and click the Markup tab in the
CommandManager.

If the Markup tab is not available, right-click in the CommandManager and click Tabs
> Markup.
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2. Click Markup on the Markup tab.

In the FeatureManager design tree, a new markup shows under Markups .

3. Click Draw (Markup toolbar) to add markup content using the mouse.

4. Click Exit Markup to save the markup.

5. To export the markup, right-click Markup and click Export Markup .
6. In the dialog box, click Save.

Design Library
When you save a note that contains symbols and linked values to the Design Library, the
software stores those symbols and values within the note. When you insert the note from
the Design Library into another drawing, the stored symbols and values display correctly.

The stored symbols and values are not linked to the original note from the original
document.

Previously, the software did not store the symbols and linked values in the Design Library
note and they displayed an error when inserted into another drawing.

This functionality is supported for notes added to the Design Library in SOLIDWORKS®

2020 or later. Notes added to the Design Library in earlier releases still show errors.

Dimensions

Dimensioning Datum Targets

In part and assembly models, you can use dimensions to control the position and shape
of datum targets.

Positioning Datum Targets Without Using Sketches

You can use the Smart Dimension tool, without a sketch, to place driving and driven
dimensions on datum targets. You can use driving dimensions to control the position of
the attachment point of the datum target’s leader.

Datum Target Shape Dimensions
You can add dimensions directly to the datum target shape. You can drag to modify the
position of these dimensions.

In the Datum Target PropertyManager, select Show dimensions.
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Foreshortened Dimensions

Arrow Styles
Two new arrow styles are available for foreshortened dimensions.

Click Tools > Options > Document Properties > Drafting Standard > Dimensions
> Linear. Under Foreshortened, the new options are:

Straight

Single arrow

Drafting Standards
Foreshortened dimensions are available for all drafting standards. Previously, they were
only available for the ANSI drafting standard.

Link Child Views to Parent by Default
When you create a projected view, the drawing view property Use named configuration
is set to <Link to parent> by default. Previously, the property was set to Default.

This behavior applies only to projected views created in SOLIDWORKS 2020 or later.

Location for Saving a New Drawing
When you save a new drawing, the default folder location in the Save or Save As dialog
box is the folder where the model in the drawing's first view is saved.

You can override this behavior by specifying a default folder in Tools > Options > File
Locations > Show folders for > Default Save Folder.

Performance Improvements in Drawings
When you create a drawing from an open assembly, the creation of the first view may
be faster than in previous releases.
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10
eDrawings

This chapter includes the following topics:

• Virtual Reality
• Quality
• Manufacturing Models in the 3DEXPERIENCE Marketplace|Make
• Support for Configuration-Specific $PRPSHEET Properties
• Text Scale in 3D Views
• SOLIDWORKS Drawings Support
• eDrawings Performance

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Virtual Reality

Video:What's New in SOLIDWORKS 2020 - eDrawings
VR

With Virtual Reality (VR), you can explore models at a 1:1 scale.

Using HTC VIVE™ and VIVE Pro™ VR headsets, you can walk around and through your
model in VR. You can examine each part in assemblies and take apart assemblies one
part at a time.

Computers with Microsoft Windows® 10 1709 and later using Valve SteamVR™ support
VR in eDrawings.

Controller Interaction
The controller supports additional functionality when you interact with models.
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FunctionalityButton

Creates an exploded view of the model from the nondominant hand controller.

Resets the view and model.

Scales/rotates the component. When you select the component (button 4)
and hold down button 3, the scale or rotation is continuous. Previously you
had to click multiple times to scale or rotate.

• Places the component.

• Changes the scale.

• Rotates the component.

When the component is not selected, button 3 teleports you to the location
that you are pointing to with the dominant hand controller.

Selects the component with a single click. You can focus on manipulating the
component with button 3 without holding down button 4 simultaneously. If
you click button 4 again, the component returns to its original position.
Previously you had to hold down button 4 to keep the component selected.

Custom Floor and Sky Environments
You can add image files to create custom floor and sky environments in VR. Requirements
include:

• Floor. Must be .png or .jpg files.
• Sky. Equirectangular .png or .jpg files. Skies must be equirectangular. Images must
have an aspect ratio of 2:1. Cube maps are not supported.
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To add image files for custom floors and skies, click VR Options (if you have a VR
model open) or Tools > VR Options. In the dialog box, browse to a folder that includes
the image files and click OK.

SkyFloor

Environment Pane

You can change the Floor Scale in the Environment pane.

Image Quality
Image quality in VR has improved with:

• Full screen anti-aliasing
• Larger draw distances
• Realistic reflections and transparencies on models

2019
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2020

Model Display
You can display models with:

• Ambient occlusion
• Dynamic shadows
• Non-RealView appearances

Opening Models
You can open multiple models in VR in eDrawings. Although you can view only one model
at a time in the VR headset, you can switch between models on the desktop. eDrawings
can have either VR or non-VR documents open, but not both at the same time. To switch
between VR and non-VR documents, close all current documents in eDrawings.

Warning Messages
Warning messages help you use VR properly. They appear when:

• A laptop is not plugged into a charger when you click Play to view the model in
a VR headset.

• The VR headset is not plugged in.

Quality
When you open a SOLIDWORKS or eDrawings part or assembly in eDrawings:

• 2D annotations, general tables, and BOMs in the Notes folder of the
FeatureManager® design tree:

• Behave the same as in the SOLIDWORKS software, with the same orientation and
positioning.

• Remain parallel to the screen when you rotate or zoom models.
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• You can move tables anywhere in the graphics area.
• Cosmetic threads remain visible. (Only for SOLIDWORKS part/assembly files when you
set Graphics boost to Fastest speed.)

Improvements in 2D notes include:

• Surface finish symbols. Corrected symbol
lines, text position, angle, and display.

• Ability to zoom and turn notes on/off
• BOM display. Corrected background
paper alignment, sizing, and highlighting
plane.

• Text. Corrected mirrored notes, italics,
angle, font, and note positioning.

• Color
• Geometric tolerance symbols. Corrected
position, rotation, box lines, and specific
angles for general tolerances.

Improvements in Unassigned Items and annotations:

• BOMs. Rotation with model and corrected background paper size.
• Notes. Corrected angle and positioning, notes move with model, zooming, and ability
to turn notes on/off.

Improvements to general tables:

• Table lines and text are synced.
• Text is properly aligned.
• Tables move when you rotate models.
• Ability to show/hide tables.
• Background paper is properly sized.

These improvements apply to .SLDPRT, .SLDASM, .EPRT, and .EASM files.

Manufacturing Models in the 3DEXPERIENCE Marketplace|Make
You can upload .stl files from eDrawings to the 3DEXPERIENCE Marketplace|Make for
manufacturing. This helps you find vendors to provide you manufacturing quotes.

To manufacture models in 3DEXPERIENCE Marketplace|Make:

1. In eDrawings, open an .stl file.

2. Click Upload model for manufacturing to Marketplace .
3. Click OK to accept the warning that the document will be uploaded to the DS server.
4. In the 3DEXPERIENCE Marketplace|Make dialog box, click Get a quote and follow

the instructions.

Support for Configuration-Specific $PRPSHEET Properties
When you change a configuration-specific property in a source file (.SLDPRT or .SLDASM),
the $PRPSHEET property in the linked drawing displays the updated value. You do not
need to open and save the drawing in the SOLIDWORKS software.

94

eDrawings



This improvement applies to the following:

• SOLIDWORKS Quick View
• eDrawings Desktop including the integration in SOLIDWORKS PDM Desktop client
• eDrawings Web Viewer embedded in SOLIDWORKS PDM Web2 client

Text Scale in 3D Views
When you publish a SOLIDWORKS model with 3D views to eDrawings, text remains at
the same scale.

In SOLIDWORKS, clear Always display text as the same size in the Annotation
Properties dialog box and set the Text scale for the 3D views. All 3D views in the
eDrawings file retain the same text scale as in the SOLIDWORKS file.

This applies to .eprt and .easm files.

SOLIDWORKS Drawings Support
When you open SOLIDWORKS drawings from hyperlinks (even if the links have spaces
in the path or file name), the drawings open properly in eDrawings.

eDrawings Performance
Performance is improved when you hover over and select entities using the Measure
and Markup Dimensions tools.
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11
SOLIDWORKS Electrical

This chapter includes the following topics:

• Leader Lines
• Minimum Bend Radius and Bend Factor
• Project Viewer
• Reimport Electrical Data for Wires, Cables, and Harnesses
• Report Enhancements for Rows and Columns
• User Rights Manager

SOLIDWORKS® Electrical is a separately purchased product.

Leader Lines

Video: What's New in SOLIDWORKS Electrical 2020 -
Leader Lines

You can create leader lines with blocks and notes in 2D panel layouts and harness
drawings.

To create a leader line, on the Draw tab, under Annotation, click Block leader or

Text leader .

Annotation

Opens the Text leader section under the Command
panel.

Text leader

Opens the Block leader section under the Command
panel.

Block leader

Sets the leader style.Leader styles
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Text Leaders

To create text leaders:

• On the Draw tab, under Annotation, click Text leader .

• On the Cabinet layout tab, under Annotation, click Text leader .

Text Leader
You can draw leader lines freehand or by defining the coordinates in the Text leader
section.

Closes the section.

Prompts you to create a text leader.Message

Defines the starting point of the leader line.Enter coordinates

Validates the input.

Graphical Properties
When you select a text leader in the graphics area, the Properties panel displays the text
leader line properties under the General, Overall, Leaders, and Text sections. You can
set the following properties:

Specifies the arrowhead type such as closed, dot, and oblique.Arrowhead

Specifies the text alignment.Justify

Specifies the text attachment direction as horizontal or vertical.Attachment type

Shows the horizontal landing line of the leader.
With
horizontal
landing

Without
horizontal
landing

Horizontal landing
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Grips
When you select a leader, four grips appear at the following positions:

DescriptionCallout

Arrowhead1

Start point of the landing line2

End point of the landing line3

Text position4

Block Leaders

To create block leaders:

• On the Draw tab, under Annotation, click Block leader .

• On the Cabinet layout tab, under Annotation, click Block leader .

Block Leader

Closes the section.

Prompts you to create a block leader.Message

Defines the starting point of the leader line.Enter coordinates

Validates the input.

Graphical Properties
When you select a block leader in the graphics area, the Properties panel displays the
block leader properties under the General, Overall, Leaders, and Block sections. You
can set the following properties:

Sets the block source such as slot, circle, and box.Block Source
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Shows the horizontal landing line of the leader.
With
horizontal
landing

Without
horizontal
landing

Horizontal landing

Grips
When you select a leader, four grips appear at the following positions:

DescriptionCallout

Arrowhead1

Start point of the landing line2

End point of the landing line3

Text position4

Leader Styles Manager

You use Leader styles to create, delete, edit, and set the current leader.

To use the Leader Styles:

• On the Tools tab, under Drawing styles, click Leader styles .

Leader Styles Manager

Creates a new leader style.New
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Opens the Rename dialog box to rename the leader
style.

Rename

Deletes multiple leader styles. You cannot delete the
current style or the leader style used in the open
document.

Delete

Displays the leader style properties.Properties

Sets the selected leader style as current for the open
document.

Set as current

Minimum Bend Radius and Bend Factor
You can create a route part if the bend radius of the cable, core, or wire is less than the
minimum bend radius.

You can define the minimum bend radius and the bend factor for cables and wires in
SOLIDWORKS Electrical Schematics. The Bend Radius (Diameter x Bend Radius
Factor) defines the minimum bend radius. The Bend radius (x Diameter) field is
renamed to Bend Radius Factor.

In an electrical segment, the software considers the individual minimum bend radius for
the cable and core.

To define the bend radius and bend factor:

• For wires, right-click a wire in schematic view, click Wire style > Properties, and
enter a value for Bend Radius Factor and Bend Radius (Diameter x Bend Radius
Factor).

• For cables, right-click a cable in schematic view, click Cable properties, click the
cable name, and enter a value for Bend Radius Factor and Bend Radius (Diameter
x Bend Radius Factor).

The Bend Radius Factor and Bend Radius (Diameter x Bend Radius Factor) are
interdependent. If you enter the value in one field, the value in the other field updates
correspondingly.

Project Viewer
You can view SOLIDWORKS Electrical projects in the Project Viewer window.

To open Project Viewer, click Projects manager > Preview . The software displays
the selected SOLIDWORKS Electrical project in read-only format.

View

Opens the projects manager window.Projects manager
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Displays the previous page.Previous

Displays the next page.Next

Opens the properties dialog box of the selected
record.

Properties

Opens the reports manager window.Reports

Zooms to display the drawing extents.Zoom Extents

Zooms to display an area specified by the rectangular
window.

Rectangular Zoom

Real-time zoom.Dynamic Zoom

Moves the view when you click and move the mouse.Real-time Pan

Opens the print manage window.Print

Exports the drawings in DWG format.Export DWG files

Exports the drawings in PDF format.Export PDF file

Filters
You can filter a specific document or component. When you open Documents tab, the
software displays the Document Search and when you open Components tab, the
software displays the Component Search.

Side Panel

Lists the project documents.Documents

Lists the components, which are sorted by location.Components

Preview Zone
Displays the drawings present in the selected Documents or Components tab. Click a
drawing to open it in the viewer zone.
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Viewer Zone
Displays the selected drawing. The software displays one drawing at a time. The drawings
are read-only and you can only use zoom commands.

Reimport Electrical Data for Wires, Cables, and Harnesses
You can remove unused sketch segments from wires, cables, and harnesses.

If you remove a wire or core from electrical routes, cables or harnesses in SOLIDWORKS
Electrical Schematics, when you reimport that model, the software removes the wire or
core from the model in SOLIDWORKS Electrical 3D.

If you delete a wire style from a route assembly in SOLIDWORKS Electrical Schematics,
when you reimport that model, the software deletes that particular route assembly from
SOLIDWORKS Electrical 3D.

Routing Parameters
You can set the routing parameters to create electrical harnesses from the Route harnesses
PropertyManager.

Suppresses all the 3D parts of large assemblies to enhance
performance.

Enhanced large
assembly
performance

Adds the components to the harness and creates guidelines.
Select this to manually finish the harness.

Manual harness

Creates fan-outs for multipin connectors. This option is enabled
when you select Manual harness.

Generate fan-outs
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Report Enhancements for Rows and Columns

Video: What's New in SOLIDWORKS Electrical 2020 -
Reports

You can add a column that specifies the row number and controls the row height in reports.

Row Height in Reports

You can set the row height. The software ensures that the row height is not less than the
font size.

To control the row height, on the Project tab, click Reports > Properties >
Report configuration edition > Styles and set the Row height.

This functionality applies to Header, Content, and Total.

Row Style

Applies the default value for the row height.Automatic

Applies the minimum height entered in Row height. Applicable
for multiple lines in a row.

Minimum height

Applies the fixed height entered in Row height. Applicable for
a single line in a row.

Fixed height

Row Height
Enter the row height.

Row Number Column in Reports

You can add a column in a report that specifies the row number of the report entity.

You can configure the row number and define a base number in the report template. The
row numbers are consecutive and auto assigned in the report manager and report
drawings.

The row numbers are still consecutive when you apply the following operations:

• Filter
• Sort
• Merge
• Break
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Use the following variables to keep row numbers consecutive after a break:

• REPORT_ROW_GLOBAL. Applies consecutive row numbers to the entire row.
• REPORT_ROW. Applies consecutive row numbers to each report table that has breaks.

User Rights Manager

Video: What's New in SOLIDWORKS Electrical 2020 -
User Rights

You can archive custom user profiles, customize the feature grid, control the deletion
rights of user profiles, and create a user-defined profile from the User rights manager.

Archive Environment

You can archive and unarchive the environment, user-defined profiles, and linked features.

A notification appears when there is a mismatch between the number of profiles during
archiving and unarchiving.

Feature Grid

Administrators can export the feature grid list to a .csv file.

User Profile Customization

Administrators can create new custom profiles and user groups from system profiles, edit
custom profiles, and manage user rights in the Feature grid.

User Profile

Opens the Create profile dialog box, where you enter
the profile name. This option is enabled when you
select an existing system profile. The new profile
copies the feature list of the selected profile.

New Profile

Edits the rights of system and custom profiles.Edit Profile

Sets the rights of the custom profile to the default
rights of the system profile from which it was
referenced.

Reset to Default

Apply Changes
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Displays the profiles without groups and users.Show empty profiles

Lets you organize the custom profiles.
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12
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

• Altitude
• Fan Derating
• Logical Expressions in Formula Dependency

SOLIDWORKS® Flow Simulation is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Altitude
You can use Altitude to set the atmospheric pressure and temperature.

Altitude makes it easier to conduct what-if or optimization analyses.

Fan Derating
Fans are often set to run below their maximum capacity to reduce noise and increase
their lifetime, but still achieve their thermal cooling requirements. Fans run at less than
maximum capacity by reducing their RPMs, which derates the fan curve. The Derating
factor simulates this reduction of the fan curve.
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Logical Expressions in Formula Dependency
Boundary conditions depend on coordinates, time, and monitor parameters, such as goals.
You can define sophisticated dependencies using conditional and Boolean expressions
such as IF, AND, OR, XOR, NOT, >, <, and =.

For example, you can set the value of a heat source dependent on two different
temperature sensors, defined as temperature goals, so that the dissipated power is
downgraded depending on the temperature at the sensors.
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13
SOLIDWORKS 3D Interconnect

This chapter includes the following topics:

• Importing DXF and DWG Files
• Importing IFC Files
• Inserting CAD Files into Active SOLIDWORKS Files

Video: What's New in SOLIDWORKS 2020 - 3D
Interconnect

Importing DXF and DWG Files
SOLIDWORKS 3D Interconnect supports importing BREP data from DXF or DWG files.

In the DXF/DWG Import dialog box, under Import to a new part as, click 3D curves
or model and click Finish. The software imports the BREP data from the DXF or DWG
file. You can do the following on the imported body:

• Edit feature
• Update model
• Break link

Importing IFC Files
SOLIDWORKS 3D Interconnect can import IFC files.

Imported IFC files have a hybrid body-mode feature that quickly converts complex faceted
shapes to mesh bodies. This includes shapes such as humans, trees, and furniture. IFC
files convert simple shapes like walls, roofs, beams, and columns into precise solid and
surface bodies that you can directly use for modeling references. This functionality
improves performance and reliability for large, imported IFC files and lets you model
directly against major structural elements of buildings in the SOLIDWORKS software.
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Inserting CAD Files into Active SOLIDWORKS Files
You can insert non-native (*.catpart, *.ipt, *.par, *.prt) or neutral (*.iges,
*.igs, *.jt, *.sat, *.step, *.stp) CAD files into an active SOLIDWORKS part or
assembly file. You can also drag a non-native or neutral CAD file into an active
SOLIDWORKS part or assembly file.

SOLIDWORKS Part Files
To insert a non-native or neutral CAD file into an active SOLIDWORKS part, click Insert
> Part.

When you drag the CAD files into the active SOLIDWORKS part file, a prompt appears:
Are you trying to make a derived part?

• Click Yes to insert the part as a derived part feature.
• Click No to open the part in a new window as a new document.

SOLIDWORKS Assembly Files
To insert a non-native or neutral CAD file into an active SOLIDWORKS assembly, click
Insert > Component > Existing Part/Assembly.
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14
SOLIDWORKS Manage

This chapter includes the following topics:

• Process Management Enhancements
• Project Management Enhancements
• Dashboard Viewer and Plenary Web Client
• Task Templates
• Integration with Microsoft Outlook
• Object Notes
• Adding Conditions to a Process Stage
• BOM Editing
• PDM Options Tab
• Editing the Project Task Subject
• Export Feature of BOM Compare Tool
• Send to Process
• Custom Procedures
• View Hidden Controls in the Workflow Designer
• Inactive Configuration Part Numbering
• Main User Interface Controls for Records
• Customized Affected Item List
• Process Task Assignment Controls
• Copy Manual Quantities of BOM

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Process Management Enhancements

Video: What's New in SOLIDWORKS Manage 2020 -
Process Management Enhancements

When you start a process, you can add affected items and the related references. You
can add multiple records at once even from different objects such as libraries and Bills
Of Material.

You can associate special objects such as risks, project issues, and product requirements
to a process. SOLIDWORKS Manage maintains parent and child relationships for processes.

Adding Related Records

You can add related records to the existing affected items, including assembly child
records, parent records, and references.

To add related records:

1. Create a new process or edit an existing process.
2. Add one or more affected items.
3. Right-click an affected item and click Add related records.
4. Click BOMs, Where Used, or References icons.
5. Select the check box for each line item.

Use the search and filter features to accelerate the process.

6. Optional: Click Add to add records.
7. Close the dialog box.

The restriction for adding records from a single object still applies.

Creating a Subprocess

When you send multiple items through a process, you can split the selected items into a
connected subprocess.

You can create a subprocess only if you enable it in the process object. The subprocess
retains the history of the parent process. You can view all the subprocesses that are part
of a parent process. You can keep some items in the parent process and send others to
the subprocess.

To create a subprocess:

1. Select items in a process.
2. Right-click and click Create sub-process.

A new process is created that includes the affected items.
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3. Optional: To view affected items that are split into a subprocess, select Show
sub-process.

4. Optional: To view the subprocesses and hierarchy of the processes, click the
Sub-process tab.

Project Management Enhancements

Video: What's New in SOLIDWORKS Manage 2020 -
Project Management Enhancements

You can import projects as XML from other tools like Microsoft Project, visualize the life
of a project, and plan the capacity of your resources.

Project Gantt Charts

You can use the improved Gantt chart tools and functionality to display and visualize your
project data in formats such as PERT charts, Network diagrams, and Load and Schedule
charts.

The functionality is also available in the Plenary Web Client.

Capacity and Demand Dashboards

You can automatically calculate availability of your resources and effort requirements for
projects.

The dashboard of the Project Planning tool has two role-based user interfaces.

DescriptionDashboard

Provides an overall view of the available capacity of resources
in your team.
Calculates capacity based on absences and on personal and
public holidays. You can highlight the availability of your
resources by color coding capacity levels.

Capacity

Displays the work assigned to each resource. You can view the
demand for resources either based on their projects or through
their assigned tasks.

Demand
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Dashboard Viewer and Plenary Web Client

Video: What's New in SOLIDWORKS Manage 2020 -
Dashboard Viewer and Plenary Web Client

Dashboard Viewer
The Dashboard Viewer lets organizations display a dashboard on a community monitor
that updates periodically.

The application:

• Is available in the SOLIDWORKS Manage program group.
• Provides access to configured dashboards only.
• Can display dashboards in full-screen mode.
• Can refresh at regular intervals.
• Always keeps available data up-to-date.
• Requires a login credential.
• Requires at least one Viewer license.

Plenary Web Client
You can use the plenary web client from your internet browser to access the data remotely.

The SOLIDWORKS Installation Manager includes the Plenary Web Client. The enhancements
made in the Plenary Web Client facilitate integration with a connected SOLIDWORKS PDM
vault.

You can review your tasks and update projects without installing any software. You can
check in, check out, and send SOLIDWORKS PDM data to processes that have PDM outputs.

DescriptionUI Elements

Provides preview and advanced search tools and is available
in the right pane.

Search all pane

Lets you interact with project records.Projects module
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Task Templates

Video: What's New in SOLIDWORKS Manage 2020 -
Task Templates

You can use task templates to quickly create and assign common tasks with predefined
parameters.

Create a task template to predefine Subject, Priority, Assign To, Time allocated, and
Notes of your repeatable activities.

Integration with Microsoft Outlook

Video: What's New in SOLIDWORKS Manage 2020 -
Outlook and PDM Integration

The integration of SOLIDWORKS Manage with Microsoft® Outlook and the expanded
integration with SOLIDWORKS PDM helps to streamline and access important information.

With the integration, you can:

• Link incoming emails directly to records to provide a complete history and improved
visibility.

• Access emails from the Emails tab in the Property Card.
• Create records based on a message. For example, an organization can convert a
customer request into a process or a case for evaluation.

• Access emails and other information saved in SOLIDWORKS Manage through the
Manage tab in SOLIDWORKS PDM File Explorer.

Object Notes
The Object Notes feature lets administrators provide users with conceptual information
about an object and steps to perform a task. The Object Notes feature is similar to Process
Notes.

Highlights:

• Administrators can add different notes for individual field groups.
• Administrators must enable Object Notes before adding the notes.
• After administrators add information in Object Notes, it appears in every record within
that particular object.
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• The data of notes is available in rich text format. Administrators can copy and paste
notes from other applications such as Microsoft® Word.

• Object Notes are not available for Process and Project objects.

The data of Object Notes is specific to a field group. Adding notes to one field group
does not copy it to another field.

Adding Object Notes

Administrators can add notes from the Administration tool.

To add Object Notes:

1. In the Administration tool, edit an object.
2. To add notes to the SOLIDWORKS PDM objects, go to the Fields wizard page and click

Object Notes.
3. To add notes to the Document and Records objects:

a) On the Options tab, select Enable Object Notes.
b) Click Save to enable the object notes.

4. In the Field Group dialog box, click the Object Notes tab.
5. Add notes and click Save.

Viewing Object Notes

After Administrators add Object Notes, users can view them from a Field Group.

To view Object Notes:

1. Open a record for which the Administrator has enabled Object Notes and loaded data
into the Field Group.

2. Click at the upper-right corner of the Property Card window to view the notes.

Adding Conditions to a Process Stage
You can add conditions to a process stage. This helps SW Manage to evaluate the field
values of affected items and prevents the Send to Next Stage action, if any of the
defined conditions is true.

Adding conditions in SOLIDWORKS Manage is similar to defining conditions for
SOLIDWORKS PDM transitions. You can use the same Conditions node for stage conditions
that you use for Decision controls.

To add conditions to a process stage:

1. In the Process configuration administration tool, go to the Workflow Properties page.
2. Select a process stage where you want to add a condition.
3. Select the Condition node.
4. Click New.
5. Create the required condition.
6. Click Save and close.
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BOM Editing
In the dialog box called Open BOM in new window, enhancements include check out and
editing controls.

The controls let you edit the lower-level BOMs faster.

The Open BOM icon added to the BOM tab controls lets you edit the BOM of a record
without opening the property card.

PDM Options Tab
The PDM Options tab provides options that affect files in a SOLIDWORKS PDM vault.

To view the PDM Options tab:

1. In the Process Configuration wizard, on the Workflow Properties page, select the
Output node.

2. Click the PDM Options tab.

The tab includes the following options:

DescriptionOption

Prevents the creation of a new version each time an output
updates SOLIDWORKS PDM variables or changes the status
in SOLIDWORKS Manage.
It is similar to the SOLIDWORKS PDM transition option to
Overwrite Latest Version.

• This setting applies to the SOLIDWORKS Manage output
only.

• UseOverwrite Latest Version to prevent SOLIDWORKS
PDM from creating a new version if:

• SOLIDWORKS Manage changes the state of the
SOLIDWORKS PDM workflow.

• The SOLIDWORKS PDM transition updates a variable.

• If you include a large number of affected items in the
process, it takes a longer time to complete.

Do not increment
version of PDM files

Uses permissions granted to the logged-in user.Permissions: Use
permissions from the
logged in user
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DescriptionOption

Allows a user logged in to the PDM vault to use permissions
granted to the user whose credentials are available in the
User Name and Password fields.

If you use permissions granted to another user:

• You have these permissions only until you change the
state.

• You do not require transition permission in the
SOLIDWORKS PDM workflow.

• Your name appears in the history and in the data card
variables.

Permissions: Use
permissions from the
following user

Editing the Project Task Subject
You can edit the subject of multiple project tasks to provide additional information.

You can add project-specific information, such as a project number, to the subject line
to help users search and view the tasks related to a project. This information can appear
before or after the original text.

To edit the project task subject:

1. Open a project record.
2. Optional: Go to the Planning tab and select the Tasks tab.
3. Go to the Tasks tab, if enabled.
4. Select and right-click a task or group of tasks to update.
5. Click Subject.
6. In the dialog box, select one or more options.
The following table describes the options available in the dialog box.

DescriptionArea

Add amends the subject text.

Remove removes previously added text.

Add/Remove

Before places the text before the existing text.

After places the text after the existing text.

Position

Part Number adds a part number.

Text adds text to the subject.

Text

7. Click Apply.
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• Subject labels indicate the position of the original text.
• The position of the labels does not change if you change your selection in the Position
area.

Export Feature of BOM Compare Tool
The BOM Compare tool has an Export button that lets you export the comparison
information to a Microsoft® Excel file.

The spreadsheet contains:

• Information on all records that are compared.
• A comparison of the two sides of the formatted output.

When you export the comparison information, the Microsoft® Excel file automatically
creates the right and left sides of the comparison on a single sheet.

Send to Process
The Send to Process functionality lets you select a process for the selected record.

You can perform the following functions with Send to Process:

• Click to view the Send to Process dialog box.

• Click to the view a list of available processes and select a process.

Custom Procedures
An option on the Search tool lets specific users or groups run administrator-defined queries
of the database without accessing the database management applications.

Users can define customized procedures, which can include input parameters.

View Hidden Controls in the Workflow Designer

The icon on the Process Wizard page of the Workflow Designer displays hidden
controls.

If administrators hide controls on the workflow in the Advanced tab by mistake, they can
click the icon to view the controls.

118

SOLIDWORKS Manage



Inactive Configuration Part Numbering
Administrators can assign part numbers to inactive configurations.

Administrators can use the root file’s name with the name of the configuration. This makes
it less confusing for users because they can see the configuration name.

Main User Interface Controls for Records
You can use the Back and Forward buttons to navigate between records.

Customized Affected Item List
You can customize the grid where you view the affected items. You can add fields and
apply conditional highlighting.

The enhancement provides similar customization capabilities available in the Bill of
Materials (BOM) variants. You can add detailed information for each affected item.

Process Task Assignment Controls
When you create processes with predefined tasks, you can control the ownership and
assignment of the tasks.

You can configure the ownership and assignments in the process object to make
reassigning easier.

Copy Manual Quantities of BOM
When you edit a BOM using the Copy From dialog box, you can copy manual quantities
by selecting Copy Manual Quantities.
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15
SOLIDWORKS MBD

This chapter includes the following topics:

• Annotations Folder
• 3D PMI Compare
• DimXpert

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Annotations Folder

Video: What's New in SOLIDWORKS MBD 2020 -
Annotation Folders

In assemblies and parts, annotations appear in subfolders under the Annotations
folder in the FeatureManager® design tree.

From the folder, you can sort the annotations and highlight them in the graphics area.

When you select an annotation in the FeatureManager design tree, it is highlighted in the
graphics area.
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Sorting by Annotation View
By default, annotations appear in subfolders that correspond to the view they belong to,
such as Unassigned, Front, Right, and Top.

Sorting by Annotation Type
You can sort annotations by type, such as Smart Dimensions, Weld Symbols, and

Balloons. Right-click Annotations or a view subfolder and select Sort by Annotation

Type. If you sort the Annotations folder, all annotations are sorted into annotation
type subfolders.

If you sort a view subfolder, only the annotations within that subfolder are sorted. To
return to the original order, right-click the same folder and clear Sort by Annotation
Type.

3D PMI Compare
The 3D PMI Compare tool performs a more thorough analysis of reference dimensions
to identify more similarity scenarios based on geometry. It also checks annotation notes,
reference dimensions, and geometric tolerances.

DimXpert

Annotation Name Format

Names of DimXpert annotations follow a new format.

The new format adds @feature_name(value) to the previous format.

Examples

Previous FormatNew Format

DistanceBetween3DistanceBetween3@Plane6(7.5)

121

SOLIDWORKS MBD



Previous FormatNew Format

Radius3Radius3@Fillet Pattern1(5)

CounterBore1CounterBore1@Hole Pattern1(8)

Pipe Threads and Compound Holes

You can create DimXpert hole callouts for pipe threads and many types of compound
holes.

The DimXpert hole callout file has new elements to support new hole types. See
system_dir:\Program Files\SOLIDWORKS
Corp\SOLIDWORKS\lang\language\txcalloutformat.txt.
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16
Model Display

This chapter includes the following topics:

• Body Compare
• Comparing Bodies
• Body Compare PropertyManager

Body Compare

Video:What's New in SOLIDWORKS 2020 - Decimation
and Body Compare

You can use Body Compare to compare two groups of bodies that are colocated in the
same part or assembly. For example, you can compare a CAD model against a scan file,
mesh file, or another CAD model.

For models that you reverse engineer, use Body Compare to compare these models to
the original scan to find differences. For manufactured parts, you can scan the part and
compare the scan to the source CAD model.

The deviations display on the source body to indicate where the two bodies do not match.
When creating a body, select Unmatched color in the Body Compare PropertyManager
to show where the source and the compare bodies do not match.

Comparing Bodies
To compare bodies:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\model_display\Gear.SLDPRT.

2. In the FeatureManager design tree, expand the Solid Bodies folder.
If you do not see the folder, take the following steps:
a) Click Tools > Options > System Options > FeatureManager.

b) Under Hide/show tree items, select Show for Solid Bodies and click OK.
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3. Compare the edges of the gear teeth for Gear1 and Gear2.

a) After viewing the filleted edges of Gear1, right-click Gear1 and click Hide .

b) Right-click Gear2 and click Show to view the nonfilleted edges.

Gear2: Nonfilleted EdgesGear1: Filleted Edges

4. Click View > Display > Body Compare .
5. In the PropertyManager, set the following options:

a) For Source Bodies, select Gear1
b) For Compare Bodies, select Gear2
c) Move the Legend Threshold slider so the top and bottom numbers in the legend

are approximately 1.00mm.

In the graphics area, the red and yellow colors indicate where Gear1 and Gear2 do
not match.

6. Click .
7. To clear the Compare Body Legend, in the graphics area, right-click the legend and

click Body Compare .

To open the Body Compare PropertyManager, right-click the legend and click Body
Compare Properties.
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Body Compare PropertyManager
To open the Body Compare PropertyManager:

Click View > Display > Body Compare . You can also select Body Compare from
the Evaluate and Mesh Modeling tabs in the CommandManager.

Body Compare is not available if the part is a single body or if the assembly contains
only one body component.

Specify options to compare bodies:

Bodies to Compare

Displays detailed help when you hover over the controls.Dynamic Help

Specifies the source bodies from a scan, a mesh file, or a
CAD model. Bodies can be any type: classic BREP bodies,
mesh BREP bodies, or graphics bodies. Classic BREP and
mesh BREP can be solid or surface bodies.
Specify the display of the source bodies:

Current View

Hidden Display

Transparent Display

Wireframe Display

Source Bodies

Specifies the CAD model bodies to compare. Bodies can be
any type: classic BREP bodies, mesh BREP bodies, or
graphics bodies. Classic BREP and mesh BREP can be solid
or surface bodies.

Compare Bodies

Color Settings

Specifies the absolute value of deviation allowed by the
scale. Move the slider to change the distances.

Legend
Threshold

Displays the legend after closing the Body Compare
PropertyManager.

Show Legend on
Screen
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Improves the accuracy of the body compare.

Higher accuracy might impact performance.

This slider is disabled when the compare bodies are graphics
mesh bodies.

Accuracy

Identifies areas on the compare bodies that do not match
the source bodies.
For example, you compare bodies where the compare body
is not a complete reproduction of the source body. The
unmatched color appears in areas where there is no
corresponding geometry on the source bodies. Either the
geometry is missing or is too far away.

Click Edit Color to select a color.

Unmatched color

After you create a body compare analysis, the analysis remains on display in the graphics

area. To close the analysis, right-click in the graphics area and click Body Compare .
To modify the analysis options, right-click in the graphics area and click Body Compare
Properties.
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17
Parts and Features

This chapter includes the following topics:

• Graphics Mesh and Mesh BREP Bodies
• Holes
• Repairing Missing References for Fillets and Chamfers
• Surfaces

Graphics Mesh and Mesh BREP Bodies

Adding Coordinate Axes, Reference Axes, and Reference Planes

You can add coordinate axes, references axes, and reference planes to a graphics mesh
body or a mesh BREP body by selecting facets, fins, or vertices. You use facets as planar
references, facet fins as linear edge references, and facet vertices as point references.

Coordinate axes, reference axes, and reference planes are useful when you create a
model based on a graphics mesh body or a mesh BREP body and you want to add
geometry. This functionality is available for parts and assemblies.

Before adding coordinate axes, reference axes, and reference planes, turn on the Selection
Filter toolbar to select facets, facet fins (edges), and facet vertices in the graphics area.
For Cylindrical/Conical Faces in the Reference Axis PropertyManager, use Paint Select
Facet or Tangent Select Facet to select groups of facets.
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To add a reference plane between two facets:

1. With a graphics body open, click Plane (Reference Geometry toolbar) or Insert
> Reference Geometry > Plane.

2. Click Toggle Selection Filter Toolbar (Standard toolbar) or press F5.

3. Click Filter Mesh Facets to select only triangular facets.
4. In the graphics area:

a) Select a facet for the First Reference as shown.

b) Select another facet for the Second Reference as shown.

The Mid Plane option is automatically selected for the first and second references in
the PropertyManager.

5. Click .

128

Parts and Features



Decimating a Graphics Mesh Body

Video:What's New in SOLIDWORKS 2020 - Decimation
and Body Compare

The Decimate Mesh tool reduces the facet count in graphics mesh bodies. A lower
facet count makes it easier to modify a graphics mesh body.

You can reduce the facet count for an entire body or a group of facets in the body. To
select a group of facets, you can use the Paint Select Facets tool or the Tangent
Select Facets tool.

This tool does not support mesh BREP bodies.

To decimate a graphics mesh body:

1. Before you open a graphics mesh file, specify these system options in Tools > Options
> Import:
a) For File Format, select STL/OBJ/OFF/PLY/PLY2 and click Import as Graphics

Body.
b) For Unit, select Millimeters.
c) Click OK.
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2. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\parts\piggy_bank.STL.

3. Click Insert > Mesh > Decimate Mesh.
4. Hover over the body.

A tooltip displays the total number of facets and vertices in the body.

5. In the graphics area, select the graphics mesh body.

The PropertyManager lists the graphics mesh body in Selections and displays the
total facet count in the body.
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6. In the PropertyManager:

a) Under Facet Reduction, for Percentage Reduced By , enter 80.

When you enter a percentage value, the tool automatically calculates the number
of facets that the graphics mesh body is reduced to in Reduced Facet Count
. This number is 12140.

b) Click Calculate.

A progress dialog reports decimation status. When the process is complete, a
preview of the decimated body generates. The body does not decimate much.

a) Click Reset to remove the preview and restore the body to its previous state.

b) For Maximum Error Tolerance , enter 25mm.

This option sets the maximum deviation tolerance between the original and
resulting mesh. Increasing this value allows for more notable decimation.

c) Click Calculate.

d) Click .
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The facets in the graphics mesh body are substantially less dense than the original
body.

7. Click Undo on the Standard toolbar to restore the graphics mesh body to its
previous state.

Keep the model open to continue with the next task where you use Paint Select Facets
to decimate a group of facets.

Using Paint Select Facets to Decimate a Facet Group

You can use the Paint Select Facets tool to select a wide or narrow area of facets in
the body.

To use Paint Select Facets to decimate a facet group:

1. Using the same graphics mesh body, piggy_bank.STL, zoom to the left ear of the
model.

2. Click Insert > Mesh > Decimate Mesh.
3. In the Decimate Mesh Body PropertyManager, under Selections, click Paint Select

Facets .
4. In the Paint Select Facets dialog box, adjust the radius of the selection circle to .60.

You can adjust the radius by clicking the Up and Down arrows.
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5. Drag the pointer to select all facets in that ear.

6. Click to close the Paint Select Facets dialog box.

The Decimate Mesh Body PropertyManager displays a total facet count for Facet
Group <1>.

7. Reduce this facet count by half in the PropertyManager:

a) For Percentage Reduced By , enter 50.

b) For Maximum Distance Deviation , enter 25mm.

This option sets the maximum deviation tolerance between the original and
resulting mesh. Increasing this value allows for more notable decimation.

c) Click Calculate.

A progress dialog reports decimation status. When the process is complete, a
preview of the decimated body generates.

d) Click .

Keep the model open to continue with the next task where you use Tangent Select
Facets to decimate a group of facets that are tangent to a seed facet.
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Using Tangent Select Facets to Decimate a Facet Group

You can use the Tangent Select Facets tool to select facets that are tangent from
a seed facet.

To use Tangent Select Facets to decimate a facet group:

1. Using the same graphics mesh body, piggy_bank.STL, zoom to the right ear of the
model.

2. Click Insert > Mesh > Decimate Mesh.
3. In the graphics area:

a) Right-click and click Tangent Select Facets.
b) Select one or more facets in an area where you want to reduce the facets in the

ear. These facets are the seed facets.
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4. In the Tangent Select Facets dialog box:
a) Leave Angle Tolerance at its default value.

A facet is included in a facet group only if the angle between its normal and the
normal of a seed facet is less than or equal to the angle tolerance. You can adjust
the Angle Tolerance by moving the slider or clicking the Up and Down arrows.

b) Click Adjacency Limit and enter 10.

Only facets within the specified number from a seed facet are included in the
facet group. For example, in this case, the tool only selects facets within 10 facets
of the seed facet. You can click the Up or Down arrow to adjust how far to
propagate adjacent facets to the seed facet.

c) Click to close the Tangent Select Facets dialog box.

The Decimation PropertyManager displays a total facet count for Facet Group <1>.

5. Reduce this facet count by half in the PropertyManager:

a) For Percentage Reduced By , enter 50.

b) Set Maximum Distance Deviation to 25mm.

This option sets the maximum deviation tolerance between the original and
resulting mesh. Increasing this value allows for more notable decimation.

c) Click Calculate.

A progress dialog reports decimation status. When the process is complete, a
preview of the decimated body generates.

d) Click .
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Expanded Support for Mesh BREP Bodies in Features

Video: What's New in SOLIDWORKS 2020 - Direct
Mesh Editing

The following features now support mesh BREP bodies:

• Shell
• Fillet
• Draft
• Chamfer
• Delete Face
• Fill Face
• Mutual Trim
• Surface Knit
• Delete Hole

Fillet and Chamfer meshShell mesh

The Insert menu includes a submenu for Mesh specific tools:

• Convert to Mesh Body
• Segment Imported Mesh Body
• Surface from Mesh
• 3D Texture
• Decimate Mesh

Holes

Defining Hole Depth up to Tip or up to Shoulder

You can define the end condition of a hole to the depth up to the tip or to the shoulder.
The options are available for all Hole Wizard features (including the Hole Wizard
Assembly feature) and Advanced Hole types with the following end conditions:

• Blind
• Up to Vertex
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• Up to Surface
• Offset from Surface

For legacy holes, the options are only available for holes with drill types such as simple,
tapered, counterbore, countersunk, and counter drilled holes.

After creating the hole feature, you can switch between the two options. Hole callouts in
drawings display dimensions based on the depth of the end condition.

Previously, the end condition of a hole was calculated only up to the full diameter of the
shoulder.

Hole Wizard

Continuing improvements are available in the Hole Wizard.

For example:

• Thread depths are recalculated. Threads cannot be deeper than the hole, regardless
of whether Automatically calculate blind hole depth is selected or cleared.

• Show custom sizing does not switch between selected and cleared in unexpected
ways.

• Changes to Head Clearance are correctly reflected in the PropertyManager and
Toolbox.

Additional improvements have been made in areas such as updating the tolerance of the
fit between holes and shafts, and handling the Near side countersink option.

Repairing Missing References for Fillets and Chamfers

Video: What's New in SOLIDWORKS 2020 - Fillet
Repair

You can repair fillet and chamfer features that are missing edges.

When you edit fillet or chamfer features that have errors, all missing references display
at the top of the Items to Fillet or Items to Chamfer box in the PropertyManager. You
can right-click missing references to zoom to their location, repair individual or all missing
references, or clear the list of missing references.
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To repair, the software attempts to reattach missing references when the missing reference
location in the model contains a valid physical edge, face, or loop. If it only repairs a
subset of the missing references, the number of repaired edges display.

To repair missing references:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\parts\repair_references.SLDPRT.

2. When prompted to rebuild, click Don't Rebuild.
3. Close the What's Wrong dialog box.

4. In the FeatureManager design tree, right-click Fillet 1 and click Edit Feature .
5. In the PropertyManager, right-click in Items to Fillet and click Repair All Missing

References.

All missing references are repaired except for **Missing**Edge<8>.

At the base of the model, the missing reference ghost is highlighted.

6. Under Items to Fillet, right-click **MissingEdge**<8> and click Clear All Missing
References.

7. Click .
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8. Right-click Fillet 2 and click Edit Feature .
9. Under Items to Fillet, right-click **MissingEdge**<1> and click Zoom to

Selection.

10. Right-click in Items to Fillet and click Repair All Missing References.

11. Click .

The tool repairs all fillet references at the base of the model.
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Surfaces

Creating an Offset Surface Without Failed Faces

Video: What's New in SOLIDWORKS 2020 - Surface
Offset

The Offset Surface tool identifies faces on a surface it cannot offset, and lets you
create an offset surface without them.

When the tool starts to create an offset surface and encounters failure, it lists faces it
cannot include in the offset surface. Those faces might fail because of one or more of the
following:

• Their offset surface includes an area with a radius of curvature that is less than the
offset distance.

• They self-intersect.
• They conflict or interfere with nearby faces.
• The offset surfaces are not connected, for example, because the offset has broken
references or is based on faces from multiple parts.

If you click Remove All Failing Faces in the PropertyManager, the tool creates an offset
surface with gaps caused by removing the failed faces. You can repair the gaps by manually
adjusting the offsets of the failed faces and adding them back individually into the offset
surface. An alternative if the tool fails is to reduce the offset distance, and run the tool
again.

Previously, the Offset Surface tool failed when it could not create an offset for one or
more faces of a surface. The tool did not identify which faces caused the failure, which
made the offset surface difficult to complete.
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To create an offset surface without failed faces:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\parts\tree_gate.SLDPRT.

2. Click Offset Surface (Surface toolbar) or Insert > Surface > Offset.
3. Select the model by clicking Edit > Select All.
4. In the PropertyManager, for Offset Distance, enter 10mm.

Flip Offset Direction toggles the offset direction of the surface between outward
to inward. This example uses the outward direction, which increases the thickness of
the model and is the default direction.

5. Click .

A message displays that it is unable to offset the selected surfaces. When the tool
completes the analysis, the PropertyManager lists and highlights the failing faces in
Offset Parameters.

6. Click Remove All Failing Faces.

The PropertyManager removes the failing faces from Offset Parameters and the
model updates in the graphics area.
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7. Click .

The tool creates a Surface-Offset feature with missing faces, as noted in red.

8. In the graphics area, zoom to the missing faces.

You can use other surfacing techniques to repair these gaps and then use the feature to
create additional surfaces.

Specifying the Thicken Direction

You can thicken a surface by specifying a direction other than normal to a face. This
option is available for Thicken and Thicken-Cut features.

In the Thicken PropertyManager and Thicken Cut PropertyManager, you can specify the
following entities as a Direction from the graphics area:

• Pair of vertices• Linear sketch entities
• •Sketch points Cylindrical faces

•• Conical facesReference planes
• •Reference axis Points in reference geometry

•• Planar facesLinear edges
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To specify the thicken direction:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\parts\thicken_surface.SLDPRT.

2. Click Thicken (Features toolbar), or Insert > Boss/Base > Thicken.
3. In the PropertyManager:

a) For Surface to Thicken, select Surface-Trim 2 in the flyout FeatureManager
tree.

b) For Thickness, type 50mm.
c) Click in Direction of Thicken.
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4. In the graphics area, select an entity to use as a direction and click .

Examples of direction of thicken:

The thicken surface is parallel to the linear sketch entity.

The thicken surface is parallel to a line drawn between the two sketch points.

The thicken surface is normal to the reference plane.
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The thicken surface is normal to the reference axis.

The thicken surface thickens on both sides of the selected entity.
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18
SOLIDWORKS PCB

This chapter includes the following topics:

• Duplicate Designators
• Integration with SOLIDWORKS PDM
• Rigid-Flex Support in SOLIDWORKS PCB

SOLIDWORKS PCB is a separately purchased product.

Duplicate Designators
ECAD-MCAD collaboration supports the use of duplicate pad designators in the footprint
library and free pads in the PCB Editor in SOLIDWORKS PCB and Altium Designer.

Integration with SOLIDWORKS PDM
The SOLIDWORKS PDM-based design and data management workflow for electronic
design uses SOLIDWORKS PDM Professional.

You can:

• Create SOLIDWORKS PCB projects and design files using SOLIDWORKS PDM.
• Design file check-in, check-out, and automated versioning of all electronic files through
the SOLIDWORKS PDM File Explorer.

• Create data cards and Where Used items for design files.
• Centralize the storage of electronic design data under the control of the SOLIDWORKS
PDM vault.

• Notify the workflow processes at specific milestones.
• Use a formal release process with electronic approvals and sign offs.

SOLIDWORKS PCB-PDM Connector
The SOLIDWORKS PCB-PDM Connector integrates SOLIDWORKS PCB and SOLIDWORKS
PDM to extend SOLIDWORKS PDM-based design methodology.

The integration lets you:

• Synchronize SOLIDWORKS PCB/PDM variables and parameters.
• Create a SOLIDWORKS PDM-based Bill of Materials.
• Integrate projects and documentation check-in, check-out, and archive.
• Generate virtual data cards and Where Used items for electronics parts.
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Rigid-Flex Support in SOLIDWORKS PCB
The Rigid-Flex support enables you to design rigid and flex portions of the board. The
ECAD-MCAD collaboration enables you to modify the flex entities and create new bends
in mechanical designs to suit the enclosure.

You can:

• Define advance layer stack-ups using Layer Stack Manager.
• Use board planning mode.
• Insert Split Lines.
• Insert Bending Lines.
• Create Layer Stack Legend tables.
• Remove routing obstacles.
• Enable 3D folded view.
• Enable 3D folded clearance.
• Support ECAD-MCAD Collaboration.
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19
SOLIDWORKS PDM

This chapter includes the following topics:

• Defining Child Reference State Conditions
• Search User Interface
• SOLIDWORKS PDM Performance Improvements
• Web2 Enhancements
• Using AND, OR, and NOT Operators in Search
• Searching in Multiple Variables
• Resizable Dialog Boxes
• Logging Out from Windows Explorer
• Reordering Columns in Search Results
• Scaling the Paper Size in Print Task
• Warning Users When Transitioning Files

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased product.

Defining Child Reference State Conditions

Video: What's New in SOLIDWORKS PDM 2020 -
Workflows

You can define conditions on the state of immediate child references to control the parent
file transition.

When you define conditions, you can transition the parent file if:

• Its child references are not selected for transitioning with the parent file and are already
in a state that meets the defined condition.
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• Its child references are selected for transitioning with the parent file and, after
transition, are in a state that meets the defined condition.

• The warning, Child references do not meet the state conditions, is not set to
blocking.

By default, when this warning is not set to blocking, only those parent files that fulfill
the child reference state condition are selected for transition.

To change the state of the parent file, in the Do Transition dialog box, select Change
state.

The warning is set to blocking by default for new and upgraded users.

This helps avoid situations such as approving an assembly when the referenced parts are
not approved or when the assembly uses obsolete parts.

To define child reference state conditions:

1. In the Administration tool, click a workflow transition.
2. In the transition's Properties dialog box, in the Conditions tab:

a) Select <Click here to add a condition>.
b) In the conditions list, select Child Reference State.
c) Expand Comparison and select a comparison operator.
d) Under Value, select the state if you selected the Text Equal To or Text Not

Equal To comparison operator.

For the Text Compare operator, enter the value in the workflow name.state
name format. You can also use wildcard characters to specify the pattern.

e) Under Configuration / Path, enter the wildcard characters to specify the file
name or file path pattern.
Leave Configuration / Path blank to apply the condition to all immediate child
reference files.

3. Click OK and save the workflow.

Search User Interface

Video: What's New in SOLIDWORKS PDM 2020 -
Search

You can perform a search with the quick search box in the SOLIDWORKS PDM File Explorer
without setting up a search card.

The quick search box is available in the SOLIDWORKS PDM File Explorer as a part of the
SOLIDWORKS PDM menu bar.

With the quick search box, you can:
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• Define your search string using sample text.
• Select a string from a list of the previous five searches when you click in the quick
search box.

• Use AND, OR, and NOT operators in the search string.
• Click in the quick search box, type, and select any string from the list of previously
matching searches.

• Use the following keys:

Selects the search fieldCtrl + F

Selects the search stringArrow keys + Enter

Starts the searchEnter

Closes the searchEsc

Customizable Variables - New Variable List Dialog Box

You can use this dialog box to specify the variables that you can search from the quick
search for specific users or groups.

To display Customizable Variables dialog box:

1. In the Administration tool, expand Lists.
2. Right-click Quick Search Variable List and click New List.

Name
Enter the name of the new variable list.

Variables

Adds the administrator-defined variables.

You can add up to five variables.

Add

Deletes the selected variable.Delete

Moves the listed variables up and down.Up and down arrows

Selected Variable

Displays a selected variable and lets you select a variable to
replace the selected variable.

Variable

Displays the name of the selected variable.Name
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Users
Lists users and lets you select the users who can select the variables in quick search.

Groups
Lists groups and lets you select the groups whose members can select the variables in
quick search.

Using Quick Search

You can search faster using the quick search. The quick search box is available in the
SOLIDWORKS PDM menu bar.

To use quick search:

1. In the SOLIDWORKS PDM File Explorer, navigate to the vault or folder to search.
2. Press Ctrl + F to access the quick search box.
3. Click the list arrow in the quick search box to specify the search settings.

151

SOLIDWORKS PDM



4. From Search for, Search in, and Search variables in, select the appropriate search
categories.

You can select multiple options to search for.

Searches for the names of files or folders
that match the search string.

File/Folder nameSearch for

A list of administrator-defined variables.
Searches for the value of selected variables
in the data card fields.

Administrator-defined
variables

Searches for the string in the current folder.Current FolderSearch in

Searches for the string in the current folder
and its subfolders.

Current Folder &
Subfolders

Searches for the string in all folders.All Folders

Limits the search to the latest version.Latest versionSearch
variables in

Searches for the string in all versions.

The Latest version and All versions
options are available based on the
following settings in the Administration
tool:

All versions

• Whether variables are selected in the
Quick Search Variable Lists or not.

• Selection of Always work with latest
version of files.

5. In the quick search box, enter the search strings and press Enter.

The search results appear in the same window.

6. Click Close Search to clear the search results and to return the file list.

SOLIDWORKS PDM Performance Improvements

Video: What's New in SOLIDWORKS PDM 2020 -
Performance

You can perform the following actions faster:
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• Logging into the vault when you set a large number of files or folders for automatic
caching.

• Viewing the System History of a vault that includes a large number of items.
• Opening a file from a folder that includes a large number of files.
• Creating a new file or subfolder in a folder that contains large number of files.

Performance Improvements in Browsing

SOLIDWORKS PDM loads the data in the background, which improves the browsing
responsiveness.

Browsing folders that have a large number of files is faster due to:

• Faster database queries for custom columns.
• Background loading and incremental loading of the data.

When you double-click a folder, SOLIDWORKS PDM loads data in this order:

1. All subfolders synchronously. You can browse subfolders while the remaining data
loads in the folder.

2. Files with standard columns in the file list.
3. Information in custom columns. You can add more custom columns and maintain the

same browsing speed.

When you select a file and switch between the Bill of Materials, Contains, and Where Used
tabs, SOLIDWORKS PDM loads the data in the tabs in the background. When you switch
to a different file or folder, the background loading stops and loading of the new file or
folder starts.

Performance improves significantly for folders with a large number of files or for database
servers with high latency.

Performance Improvements in the SOLIDWORKS PDM Add-in

The SOLIDWORKS PDM task pane tree refreshes faster and the commands in the
SOLIDWORKS PDM toolbar are correctly enabled in the task pane instantaneously when
you select a file.

• Data in the task pane tree loads in the background.
• When you select a file in the task pane tree, calls to the database are eliminated.

In the FeatureManager design tree or in the graphics area, when you right-click a file and
select SOLIDWORKS PDM, the menus are correctly enabled.

When you select a file in the graphics area or in the FeatureManager design tree, the file
listed in task pane tree is selected and the commands in the SOLIDWORKS PDM toolbar
are correctly enabled.
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Web2 Enhancements

Video:What's New in SOLIDWORKS PDM 2020 -Web2

When you drag a folder to the file list, the Check In File Structure dialog box opens
automatically.

In the Details section of the data card, in Comment, you can see version comments.

Bill of Materials Tab in Web2

SOLIDWORKS PDM Web2 lets you see a read-only view of the Bill of Materials.

In the large screen layout, the Bill of Materials tab is available in the file detail view. The
supported BOM types are:

• Computed BOMs
• Weldment BOMs
• Weldment cut lists
• SOLIDWORKS BOMs

In the small screen layout, the Bill of Materials tab is available from the ellipsis menu.
The tab contains two customizable columns.

Bill of Materials Tab in Web2

The Bill Of Materials tab displays the bill of materials of SOLIDWORKS PDM items or of a
SOLIDWORKS assembly, drawing, part, or weldment part.

To display the Bill of Materials tab:

In the large screen layout, click the file name and click the Bill Of Materials tab.
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Bill of Materials Tab

Expands or collapses the indented BOMs.Expand or
collapse

1

Displays the selected item for Indented or Top
Level Only.

BOMTable view2

Displays the name of the selected BOM at the top with the list of
other BOMs and options based on the selected BOM.

View option and
reference version

List of BOMsSelected BOM

Indented, Parts
Only, Top Level
Only, As Built,
Latest

Computed BOM,
Weldment BOM,
Weldment cut list,
SOLIDWORKS BOM

BOM

-Computed BOM,
Weldment BOM,
Weldment cut list

Weldment BOM or
Weldment cut list

-Computed BOM,
SOLIDWORKS BOM

SOLIDWORKS BOM

BOM type and
options

3

Displays the name of the selected configuration or sheet for
Computed BOM, Weldment cut list, and Weldment BOM.

Configurations
or sheets

4
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Lets you select options and perform actions based on user
permissions:
• Change State
• Check Out
• Download
• Delete

Actions5

Bill of Materials Tab - Small Screen Layout

The Bill of Materials tab contains two columns.

To display the Bill of Materials tab:

In the file detail view, click the ellipsis, and click Bill Of Materials.

Displays the file name, selected BOM name, and
configuration or sheet name.

File name header1

Displays the values of two columns and comma-separated
values of remaining columns.

Row details2

Displays the selected BOM, view option, reference version,
and configuration or sheet.

Settings control3

Lets you select the left and right columns to display.Columns control4

Expands or collapses the row to display values of other
columns.

Expand/collapse control
for row

5
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Expands or collapses the indented, multilevel computed
BOMs.

Expand/collapse control6

History Tab

SOLIDWORKS PDM Web2 lets you see a read-only view of the history.

In the large screen layout, the History tab is available in the file detail view. It displays
the table view that includes the Event column and customizable columns:

• Version
• User
• Date
• Comment

Click and select or clear the columns to display.

In the small screen layout, to access the History tab, in the file detail view, click the
ellipsis. The History tab has:

• A list of events in descending order of date and time.
• A separate row for each event.
• Information such as Version, User, Date, and Comment in each row for each event.
• A common control to expand or collapse all rows.
• Individual controls for each row.

List of Files to Download in Web2

SOLIDWORKS PDM Web2 displays the list of files to download.

In the large screen layout, the Download with References dialog box displays the collapsible
Settings option and the list of files to download.

157

SOLIDWORKS PDM



The file list displays the files based on these settings:

• Version

• Latest
• Referenced

• Preserve relative paths
• Include subfolders
• Include drawing
• Include simulation

The file list includes customizable columns such as State, Version, Size, and Path. Click

and select or clear the columns to display.
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In the small screen layout, the Download with References dialog box displays the list of
files to download in one column.

Click Settings to select the appropriate options. Click Cancel to access the file list.

Using AND, OR, and NOT Operators in Search
SOLIDWORKS PDM supports AND, OR, and NOT operators in input search criteria in
edit-box type fields on search cards.

You can use these search operators in any search card, Web2 search, the SOLIDWORKS
PDM Search tool, and quick search.

Rules:

• Search strings are case-insensitive.
• Operators are case-sensitive and must be capitalized.
• For variable values, the valid operators are: =, !=, <, <=, >, >=, and <>.
• Rules for using escape symbol:
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Input StringSearch for String with

String with an escape symbol \.

For example, to search for "speaker",
enter the string as \"speaker\"

Double quotation marks

String with an escape symbol \.

For example, to search for 3" pipe, enter
the string as "3\" pipe".

The use of the escape symbol \ is
optional in cases where you use a
double quotation mark " as an inch
constant.

For example, to search for 3", you may
enter the string as 3".Double quotation marks that are a part of

an explicit search

• In case of multiple operators used in a search, SOLIDWORKS PDM evaluates the search
operators in this order: (), NOT, AND, and OR.

• You can use AND, OR, and NOT search operators or their equivalent symbols&, |, !
respectively.

• You can search for TEXT, INT, FLOAT, and DATE type data.

If you do not specify the data type explicitly and the multi-variable field has:

• TEXT and non-TEXT variables, the applied data type is TEXT.
• DATE and non-DATE variables, the applied data type is TEXT.
• FLOAT and INT variables, the applied data type is FLOAT.

• You can use the AND and OR operators with or without the :. For example, for AND
operator, use AND, AND:.

• Use the single colon specifier, :, when you want to search for values across multiple
configurations or variables.

For example, when you enter the input string as:

• :part1 part2 part3 part4, SOLIDWORKS PDM returns the matches that may
be present in different configurations.

• :!part1, SOLIDWORKS PDM returns the matches that do not have part1 in any
of the configurations.

• Along with :, you can nest search strings within {}.

For example, for the input string :{part1 part2} part3, SOLIDWORKS PDM returns
only those matches where part1 part2 are found in the same configuration.

• The search field supports * and ? as wildcard characters.
• You can use = to search for an exact string. For example, to search for a Tools string,
enter the search string as =Tools.
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• If a string contains more than one word, you can use "" to search for the exact string.
For example, to search for pipe tools, enter "pipe tools".

When you upgrade to SOLIDWORKS PDM 2020, the previously saved searches are
upgraded to follow the new search rules while maintaining the previous behavior and
search results.

AND (&) Operator
Searches for results that include both the term before and the term after the operator.

DescriptionSearch String Examples

Returns the match that includes term1 and term2. Terms
may appear in any order in the results.

Examples of valid search results:

• term1 term2
• term2 term1
• term3 term1 term2

term1 AND term2
TERM1 & TERM2

AND: term1 term2

&: term1 term2

AND is the implicit operator for the SPACE character.

Returns the match that is enclosed in the parentheses
and that contains term1 and term2.

Examples of valid search results:

• (term1 term2)
• (term2 term1 term3)

"(*" term1 term2 "*)" OR
"(*)" term1 term2

AND is the implicit operator for the SPACE character.

Returns the match that is enclosed in the parentheses
and that contains the string term1 term2.

Examples of valid search results:

• (term1 term2)
• (term3 term1 term2 term4)Searches for

results that include the term before or
after the operator or both.

"(*" "term1 term2" "*)"
or "(*)" "term1 term2"
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OR (|) Operator

DescriptionSearch String Examples

Returns the match that includes either or both term1
and term2.

Examples of valid search results:

• term1
• term2
• term2 term1

term1 OR term2
Searches for results that
include the term before
or after theTERM1 | TERM2

OR: term1 term2

|: term1 term2

Returns the match that is enclosed in the parentheses
and that includes either term1 or term2 or both.

Examples of valid search results:

• (term1)
• (term3 term2)
• (term2 term1 term4)

"(*" term1 OR term2 "*)"
or "(*)" (term1 OR term2)

NOT (!) Operator
Searches for results that do not include the term after the operator.

DescriptionSearch String Examples

Returns values other than term1.

Examples of valid search results:

• term2
• term3 term4

NOT TERM1

Returns values other than string term1 term2.

Examples of valid search results:

• term3
• term2 term1

!="term1 term2"

Returns dates other than 2019-01-11.

Examples of valid search results:

• 2019-02-12
• 2017-03-11

!(2019-01-11)
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Searching in Multiple Variables
You can search for a value in multiple selected variables using the Edit-box control in a
search card.

In the File Explorer, when you search for a value, SOLIDWORKS PDM considers OR as
the implicit operator, and returns a match if it exists in any variable value.

To specify a multiple-variable edit-box control on the search card:

In the Card Editor, click Edit (Controls toolbar), and click in the card to place the edit
box.

Lets you select multiple variables from the existing variables defined
in the vault.

When you select the variables, the edit box displays the variables
separated by | in alphanumeric order.

Multi-variable
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Lets you define the variable values.
By default, SOLIDWORKS PDM considers the OR condition for the
default values. The values can be the same or unique.

At run time, when you edit default values with
Multi-variable selected, the default values in the single
variable edit box (for example, in the Cards tab) are not
updated automatically.

Default Values

Creating a Search Card to Search Within Multiple Variables

You can create a search card that lets you search for values in multiple variables when
you open it in the File Explorer.

To create a search card to search within multiple variables:

1. Create a search card.
2. Add controls to the card.
3. In the Card Editor, click Edit (Controls toolbar).
4. Click in the card to place the edit box.
5. Select Multi-variable.
6. From the list, select the variables to include.
7. Select the appropriate flags.
8. Click Default Values and select the variables you selected in step 6.
9. Assign values to the variables.

The default values appear in the card controls.

10. Save the card.

Resizable Dialog Boxes
The following dialog boxes are now resizable:

• Edit Variable
• Serial Number - New Serial Number
• Indexing Settings
• Cold Storage Schema
• Dialog boxes in Data Import/Export node such as XML Variable Alias Sets, Export
Rule, and Import Rule

• File Type Properties
• Customizable Columns
• Dialog boxes in Bill of Materials node such as BOM, Item BOM, Weldment BOM, and
Weldment Cut List

• Edit Template
• Dialog boxes in Dispatch such as Administrate Actions and Properties
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Logging Out from Windows Explorer
You can see the name of the logged in user in the File Explorer and log out from Windows®
Explorer.

To see the name of the logged in user, hover over .

To log out from Windows Explorer:

1. Click .
2. Click Log Out.

Reordering Columns in Search Results
You can reorder the columns in the search results of the embedded search and the Search
tool. SOLIDWORKS PDM saves the changes to the column ordering.

Scaling the Paper Size in Print Task
When configuring the Print task, you can select Scale to fit or Scale. When you select
Scale, you can select Allow the user to change the scale to let users change the scale
at run time.

Warning Users When Transitioning Files
For transitions that include dynamic notifications, you get a warning if you do not select
any user or group to receive a notification.
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20
SOLIDWORKS Plastics

This chapter includes the following topics:

• Coolant Input Boundary Condition
• Create Body from Deformed Shape
• Domains Node
• Enhanced Solid Mesh (Auto) Workflow
• Streamlined Mesh Creation
• Flow, Pack, and Cool Analyses Enhancements
• Geometry-Based Boundary Conditions
• Legacy Plastics Simulation Studies
• Material Library Updates
• Plastics Material Databases in 3D ContentCentral
• Plastics Tutorials
• Study Creation and Management
• Virtual Mold Design

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Coolant Input Boundary Condition
The Coolant Input boundary condition replaces the Cooling System boundary conditions
of Cool Pipe, Coolant Flow Field, and Coolant Entrance.

The Coolant Input boundary condition is more intuitive and easier to use than the
previous boundary conditions. Assign the Coolant Input boundary condition directly on
geometry entities. This boundary condition supports both solid body and sketch-based
cooling channel designs.

Create Body from Deformed Shape
After running a warpage analysis, you can export the deformed shape as a SOLIDWORKS®

part body.

To open the Body from Deformed Shape PropertyManager:

In the PlasticsManager, under Results, right-clickWarp Results, and click Create Body
from Deformed Shape.
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Save the deformed body as a new configuration or a new part file. Use the Advanced
Export to access alternative export formats, such as Surfaces and Tessellated body,
to recreate geometry from a deformed shape.

Product designers can use this functionality to evaluate a part’s deformed shape and
assembly fit requirements, while mold designers can size the mold accurately.

Designers of plastic optical lenses can use Body from Deformed Shape in their optical
simulations to evaluate the effect of manufacturing-induced deformation on the
performance of the lens.

Domains Node
The Domains node in the PlasticsManager tree lists the part bodies participating in the
analysis and their domain classification.

The domain classification choices available for a study depend on the type of Injection
Process and Analysis Procedure defined when creating a new study. For a Shell
analysis procedure, the domain choice is limited to Cavity. For a Solid analysis procedure,
the domain choices are: Cavity, Runner, Cooling Channel, Mold, and Insert.

The available domain choices depend on the installed SOLIDWORKS Plastics license.

Notes:

• You can select multiple part bodies to assign the same domain type, which is useful
for models with a large number of bodies.

• You can access the Runner Design, Cooling Channel, and Virtual Mold PropertyManagers
to create these features.

• You can assign the Order in which the cavities are injected for two-shot overmolding
or multishot overmolding designs.

• You can exclude bodies from the analysis.

Before generating the mesh, every part body listed in the Domains node requires a
domain assignment. You can exclude bodies that do not participate in the Plastics
simulation by selecting Exclude from Analysis.

Enhanced Solid Mesh (Auto) Workflow
The Solid Mesh (Auto) workflow is enhanced to create hybrid meshes for single and
multi-material models.

Hybrid meshes, which are composed of a mixture of prism elements at the surface and
tetrahedral elements to fill the volume of a part, are best suited for analyses. In previous
releases, the Solid Mesh (Auto) algorithm created marching hexahedral meshes.

A good-quality watertight surface mesh is a prerequisite for the successful creation of a
hybrid mesh. If the hybrid mesh creation fails, the Solid Mesh (Auto) algorithm reverts
to creating a marching hexahedral mesh.
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Streamlined Mesh Creation
The Mesh PropertyManager is redesigned to simplify the mesh creation workflow.

The number of steps in the mesh creation workflow is reduced.

To access the Mesh PropertyManager, right-click Solid Mesh, or Shell Mesh.

To create a solid mesh with the automatic mesh process, click OK in the Mesh
PropertyManager.

Follow a manual mesh creation workflow to specify the mesh type (Tetrahedral Hybrid
or Hexahedral), mesh size, and curvature controls.

Flow, Pack, and Cool Analyses Enhancements
Analyses solvers are improved.

• For the Shell and Solid mesh procedures, the Flow and Pack analyses account for
multipoint, variable specific heat (C), and thermal conductivity (k) material data.
Specific heat (C) and thermal conductivity (K) material properties can vary as a function
of temperature. You can now incorporate multi-point data provided by material suppliers
into analyses.

• Prediction of pressure decay is more accurate with improved pressure calculations in
the pure cooling phase.

• A new turbulence (k-ω) model calculates the flow of coolant in the cooling circuits.
Cool simulations are more accurate using the new model.

Geometry-Based Boundary Conditions

Video: What's New in SOLIDWORKS Plastics 2020 -
Geometry Based Conditions

You can assign more boundary conditions directly on geometric entities than you previously
could.

The boundary conditions that you can apply on geometric entities are the following:

• Injection Location
• Control Valves
• Mold Wall Temperature
• Clamp Force
• Symmetry Face
• Insert Properties (previously, Insert Boundary)
• Air Vents
• Exclude from Warp (previously, Runner Element)
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• Filled Hot Runner
• Coolant Input

Although the majority of the boundary conditions are geometry-based, the following
boundary conditions remain mesh-based:

• Warp Boundary
• Flow Injection Factor
• Modify Local Thickness

The mesh-based boundary conditions are available after generating a mesh. To access

the mesh-based boundary conditions, right-click Mesh .

Legacy Plastics Simulation Studies
Legacy studies created in SOLIDWORKS Plastics 2019 and earlier are read-only in the
2020 release due to an architectural redesign.

You can open legacy studies in SOLIDWORKS Plastics 2020, but you can only edit
post-processing features such as results export and report creation.

Material Library Updates
The SOLIDWORKS Plastics material library features new polymer grades provided by
material suppliers.

Sixteen polymer grades are added from the Chevron Phillips Chemical and thirteen polymer
grades from the RadiciGroup material databases.

169

SOLIDWORKS Plastics



RadiciGroup High Performance PolymersChevron Phillips Chemical

PA / Radistrong A RV500W 333BKHDPE / Marlex 9005

PA6 / Radilon S CW300LW 339 E BKHDPE / Marlex 9006

PA6 / Radilon S RV300W 333 BKHDPE / Marlex 9012

PA6 / Radilon S RV350W 333BKHDPE / Marlex 9018

PA610 / Radilon D RV300W 333 BKHDPE / Marlex 9035

PA610 / Radilon D HSKC 106NTHDPE / Marlex 9708

PA610 / Radilon D RV600RKC 306BKHDPE / Marlex H525

PA612 / Radilon DT RV300RKC2 106 NTHDPE / Marlex HHM 4903

PA66 / Radilon A CF200 316 BKHDPE / Marlex HHM 5502BN

PA66 / Radilon A RV300W 333BKHDPE / Marlex HMN 6060UV

PA66 / Radilon A RV350W 333 BKHDPE / Marlex HMN TR-938

PA66 / Radistrong A RV600W 333 BKHDPE / Marlex HMN TR-942

PPS / Raditeck P RV400K 1700NTDPE / Marlex HXM 50100

HDPE / Marlex TRB-432

LDPE / Marlex 1007

LDPE / Marlex KN226

The following obsolete material grades are removed from the database based on the
supplier’s recommendation.
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EMS-GRIVORY

Grilamid DAM55 COND

Grilamid DAM55 LX COND

Grilamid DAM55 LY COND

Grilamid TR XE 3657

Grilamid TR70

Grilamid XE3050 GRAU

Grilamid XE3732

Grilamid TR70 LX

Grilamid ELY 20 NZ

Grilon A28DZ

Grilon A28GM

Grilon A28NZ

Grilon A28V0

Plastics Material Databases in 3D ContentCentral
SOLIDWORKS partnered with the world’s largest plastics material suppliers to provide
access to the most up-to-date and accurate plastics material databases.

To access the plastics material databases in 3D ContentCentral:

1. Go to http://www.3dcontentcentral.com/.
2. Click FIND > INJECTION MOLDING MATERIALS.

The complete catalog of plastics materials appears with information about the material
supplier, material family, tradename, grade, and a short description (if available).

To download an individual material grade, click Download Plastics Material Data. Unzip
the compressed binary file .bin to a local folder.

To add a material file from 3D ContentCentral to the SOLIDWORKS Plastics
User-defined database:

1. In the PlasticsManager, under Material, right-click Polymer and click Open
Database.

2. In the dialog box, click User-defined Database.
3. Click Import Plastic Material > File.
4. Browse to the location of the unzipped material data file and select it.
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The new material is added under the Plastics Database

When new material grades become available, the material suppliers upload the data in
3D ContentCentral. New materials uploaded to 3D ContentCentral by material suppliers
are included in subsequent service packs or future major releases of SOLIDWORKS Plastics.

Plastics Tutorials
Seven tutorials covering a range of SOLIDWORKS Plastics workflows are available.

To access the tutorials:

From the SOLIDWORKS Plastics CommandManager, click Settings and Help > Tutorials.

Study Creation and Management
You can create a new Plastics study based on the current SOLIDWORKS configuration.
Study management features for editing, deleting, and clearing a study are available.

In the SOLIDWORKS Plastics CommandManager, click New Study.

In the Study PropertyManager, type a name for the study, set the appropriate Injection
Process parameters, and select a Solid or Shell mesh for the Analysis Procedure.
The new study is based on the active SOLIDWORKS configuration.

After creating a new study, right-click the top study node in the PlasticsManager tree to
access the study management features.

Edits the study parameters.Edit Study

Deletes the study.Delete Study

Resets the study to its default state. Deletes all boundary
conditions, mesh, materials, process parameters, and results
associated with the active configuration.

Clear Study

Virtual Mold Design
You can define the position of a virtual mold relative to the cavity with a bounding box
or by setting global coordinates.

To open the Virtual Mold PropertyManager:

• In the PlasticsManager, right-click Domains , and click Virtual Mold Design.

Specification Method

Centers the rectangular volume in space representing the mold on
the approximate centroid of the part.

Bounding Box
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Specifies the location and dimensions of the rectangular volume in
space representing the mold using the global coordinate system.

Global
coordinate

Parameters

Specifies the extents of the X coordinates of the volume in space.+X, -X

Specifies the extents of the Y coordinates of the volume in space.+Y, -Y

Specifies the extents of the Z coordinates of the volume in space.+Z, -Z

Links the positive and negative coordinate extents, such that the
negative extent varies simultaneously with the positive extent.

Specifies the positive and negative coordinate extents independently.
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21
Routing

This chapter includes the following topics:

• 3D Route Changes in Flattened Routes
• Color for Electrical Coverings
• Connector Blocks
• Create Multiple Connection Points
• Length Leaders for Flattened Routes
• Manufactured-Style Flattened Route
• Mass and Density of Cables and Wires
• Minimum Bend Radius
• Pipe Drawings
• Reimport Electrical Data
• Show/Hide Flatten Route Items
• Splices Without Components
• Transparent Coverings

Routing is available in SOLIDWORKS® Premium.

3D Route Changes in Flattened Routes
You can update a 3D route by adding or deleting items such as connectors, clips, branches,
and splices. When you flatten the 3D route, the software updates the flattened route with
the 3D route changes.

Color for Electrical Coverings
You can set the color for electrical coverings through the Routing Library Manager and
view the colors in the Coverings PropertyManager, under Layer Properties.

Covering Library Wizard
You can set the color for electrical coverings from the Covering list.

Specifies the color for electrical coverings. Double-click the
color to set it.

SWColor
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Connector Blocks
You can create connector blocks for parts and assembly connectors with the Create
Connector Block PropertyManager and the Routing Library Manager.

The End View Creation PropertyManager is now the Create Connector Block
PropertyManager. In this PropertyManager you can:

• Preview and select the view for connectors using standard views.
• Provide the pin information for the connector block. The pin information is visible on
the flattened drawing view.

To create connector blocks:

• For parts and assembly connectors, click Create Connector Block (Electrical

toolbar) or Tools > Routing > Electrical > Create Connector Block .
• For routing assemblies, in the FeatureManager design tree, expand Components,

right-click any component, and click Create Connector Block or in the graphics

area, right-click the connector and click Create Connector Block .

Insert Pin Information

Displays the selected entities.Selected Entities

Displays the pin information, which you can edit.Pin Information

Contains additional pin information that you enter.Pin Text

Create Multiple Connection Points
You can create multiple connection points in parts.

Select the following parameters to create multiple connection points in parts:

• A sketch that has sketch points. The number of connection points is equal to the number
of sketch points in a sketch.

• Multiple circular edges.
• Multiple circular and cylindrical faces.

Assign Port ID Information
You can assign port ID or pin information to the connection points through the Connection
Point PropertyManager.

For the route type as Electrical, the software displays the Assign Pin Information
section. For the route types as Tube and Fabricated Pipe, the software displays the
Assign Port ID Information section.
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Displays the entities from the Selections section.Selected Entities

Displays the connection point name, which you can edit.CPoint Name

Displays the port ID or pin number, which you can edit.Port ID or Pin Number

To create the connection points for the Selected Entities, select the check box for each
row.

View/Edit Connection Point Parameters
You can use this dialog box to view and edit connection point parameters. The software
highlights the CPoint or ACPoint in the graphics area and FeatureManager design tree
when you select or edit any parameter.

To access this dialog box:

1. Open a part that has connection points or an assembly that has assembly connection
points.

2. In the FeatureManager design tree, right-click CPoint and click View/Edit
Connection Point Parameters.

Displays the connection point name.CPoint Name

Displays the pin number or port number, which you can edit.Pin Number/Port ID

Displays the stub length, which you define when you create
connection points. You can edit the stub length.

Stub Length

Reverses the direction of the route.Reverse Direction

For assembly connection points, you can edit only the Pin Number/Port ID.

Length Leaders for Flattened Routes
You can show length leaders when you flatten routes with the Flatten Route
PropertyManager.

To access the PropertyManager in the route assembly, click Tools > Routing > Electrical

> Flatten Route .

Flatten Options

Displays length leaders in the flattened route and on flattened
drawings.

Show Length Leaders
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Manufactured-Style Flattened Route
You can adjust the angle of a line or an arc from the X-axis when you edit the
manufactured-style flattened route.

To access the PropertyManager, right-click a manufacture-style flattened route in the
FeatureManager design tree and click Edit Flattened Route .

Edit Tools

Adjusts the angle of a line or an arc from the X-axis.Adjust angle from
X-axis

Mass and Density of Cables and Wires

Video: What's New in SOLIDWORKS Electrical 2020 -
Mass Properties

You can set the mass of cables, cores, and wires in the Cable Wire Library Wizard

and the density for coverings in the Covering Library Wizard using the Routing
Library Manager.

The cable wire library and the covering library define the mass properties of an electrical
route that has cables, cores, wires, and coverings. The software calculates and applies
these properties to the solid bodies based on the values set in the libraries. You can view
the mass by using SOLIDWORKS Mass Properties.

You can also view the Mass per Unit Length and Density attributes in the following
PropertyManagers. These values are read-only.

• Edit Wires PropertyManager under Properties.
• Covering PropertyManager under Layer Properties.
• Fixed Length Covering PropertyManager under Layer Properties.

Minimum Bend Radius
You can create a route part if the bend radius of the cable, core, or wire is less than the
minimum.

Click Tools > Options > System Options > Routing and select Create route part
for segments if bend radius is less than the minimum.
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In a route part for segments, the software considers the individual minimum bend radius
for the cable and core.

You can view the unit of measure for Minimum Bend Radius and Outer Diameter in

the Cable Wire Library Wizard using the Routing Library manager.

When you save the XML file using the Routing Library manager, the XML file and the
Routing Library manager use the same unit of measure.

Pipe Drawings
You can specify the drawing template and the sheet format for pipe drawings with the
Pipe Drawing PropertyManager.

To access the PropertyManager, click Pipe Drawing (Piping toolbar) or Tools >

Routing > Piping > Pipe Drawing .

Drawing Options

Uses the selected template for the pipe drawing.Drawing template

Reimport Electrical Data
You can remove unused sketch segments and connectors from the route assembly when
you update and reimport the From-To Excel or XML file using the Import Electrical Data
PropertyManager.

Update Options

Deletes unused sketch segments.Delete segments with no data

Deletes unused connectors.Delete connector

Show/Hide Flatten Route Items
You can create 3D connectors and connector blocks simultaneously when you create
flattened route drawings for route assemblies.

When you flatten a route from the Flatten Route PropertyManager, in Flatten Options,
you can select Display 3D connectors or Use drawing connector blocks. The software
creates 3D connectors and connector blocks for flattened route drawings. You can select
one or both types.

178

Routing



Connectors

Visible in the drawing view if you select Display 3D
connectors when you flatten the route.

3D Connectors

Visible in the drawing view if you select Use drawing
connector blocks when you flatten the route.

Connector Blocks

Enabled if you provide pin text when you define connector
blocks.

Pin Text

Enabled if you provide a pin color when you define connector
blocks.

Pin Color

Annotations

Displays the connector name and reference in the drawing
view. When you select Display 3D connectors, the connector
and component name are highlighted when you click the
connector table. When you select Use drawing connector
blocks, the connector name is highlighted when you click the
connector table in the drawing view.

Component Reference

Accessory Components
• Splices
• Inline Components

Splices Without Components
You can add splices without components to electrical routes. A spherical image appears
on a junction point without a CPoint or an RPoint when you add splices without
components.

When you add splices to the route, the software adds a Splices folder to the
FeatureManager design tree.

You can delete splices without components from the FeatureManager design tree or from
the graphics area by deleting the splice junction point.
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Add Splice PropertyManager
When you pin the Add Splice PropertyManager and selectWithout Component in Splice
Options, you can assign properties to the splice and add multiple splices with the same
properties.

Splice Options

Adds splices with components.With component

Adds splices without components and displays Additional
Properties. You can create and modify properties.

Enter a name for a new property.Name

Enter a value or text expression for a new
property.

Value

Adds the new name and value to the
Additional Properties list.

Create/Edit

Without Component

Transparent Coverings
You can create transparent coverings for wires and cables.

Click Tools > Options > System Options > Routing and select Create transparent
coverings.
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22
Sheet Metal

This chapter includes the following topics:

• Convert to Sheet Metal
• Tab and Slot

Convert to Sheet Metal
With the Convert to Sheet Metal tool:

• There are improved flat pattern results.
• For sheet metal parts created in SOLIDWORKS® 2020 and later, you can:

• Convert multiple disjoint tabs that share a common bend face.
• Use relief cuts that:

• Use improved logic to determine where to include relief cuts.
• Behave similarly to relief cuts created with the Edge Flange tool.
• Reflect the selected auto relief, type, and gap values more accurately.

Tab and Slot
When creating a Tab and Slot feature in a sheet metal part, you can set negative values.

In the Tab and Slot PropertyManager, under Slot, click Slot Length Offset or Slot

Width Offset to set the values as negative. This does not create a negative offset in
cases of a single body tab and slot or if the resulting tab and slot bodies are merged.
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23
SOLIDWORKS Simulation

This chapter includes the following topics:

• Collapse Simulation Tree Folders
• Distributed Coupling for Pins and Bolts
• Draft and High-Quality Mesh Definition
• Free Body Forces for Nonlinear Studies
• Link Between Results and Model Files
• Repair Corrupt Studies
• Simulation Evaluator
• Simulation Performance Improvements
• Stress Averaging at Mid-Side Nodes
• Thermal Loads for Beams

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Collapse Simulation Tree Folders
In a simulation study tree, you can collapse all folders and subfolders with a single
command.

To collapse all folders and subfolders in a simulation study tree:

• Right-click a simulation folder or subfolder, and click Collapse Tree Items . You
can also right-click an empty area next to a simulation folder to access Collapse Tree
Items.
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Distributed Coupling for Pins and Bolts

Video: What's New in SOLIDWORKS Simulation 2020
- Distributed Coupling

The introduction of distributed coupling enhances the formulation of pin and bolt
connectors.

Distributed coupling allows the faces attached to pin and bolt connectors to deform, which
delivers a more realistic representation of a connector’s behavior. Distributed coupling
for pins and bolts is available for linear static studies only.

In the Connectors PropertyManager, under Connection Type, select Distributed.

For new pin and bolt connector definitions, the default Connection Type is Distributed.
For legacy connector definitions, Connection Type is Rigid.

When you set Connection Type to Distributed, a distributed coupling formulation
connects a reference node (beam element node of a bolt shank) to a group of coupling
nodes inside the imprint regions of a bolt's head and nut. Distributing coupling constrains
the motion of the coupling nodes to the translation and rotation of the reference node.
Nodes located inside the head and nut imprint areas can deform relative to each other.

This constraint is enforced in an average sense in a way that enables control of the
transmission of loads through weight factors at the coupling nodes. For example, the
constraint distributes a bolt's pre-load such that the sum of the forces at the coupling
nodes is equivalent to the total pre-load at the reference node. Uniform weight factors
are applied in this case.

The distributed connection produces more realistic stress and displacement fields at a
bolt's head and nut contact areas.

A rigid connection produces stress hot spot areas inside the head and nut regions of the
connected components, because rigid bars introduce high stiffnesses. A distributed
connection eliminates these high stresses.

The image shows two cylindrical components connected by a bolt with a prestress load
of 1,000 N. No-penetration contact exists between the two components.
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Results of a static analysis using rigid and distributed connection for this bolt.

Distributed Bolt ConnectionRigid Bolt Connection

von Mises stress plot with smoother gradients
at the head imprint region.

von Mises stress plot with hot spot at the
head imprint region.

184

SOLIDWORKS Simulation



Distributed Bolt ConnectionRigid Bolt Connection

Resultant displacement plot showing smoother
distribution at the head imprint region.

Resultant displacement plot showing
uniform deformation at the head imprint
region.

Draft and High-Quality Mesh Definition
An improved mesh formulation for linear static studies allows both draft and high-quality
solid elements to coexist in a single mesh definition.

You can select which solid bodies to mesh with high-quality mesh or draft-quality mesh.
The simulation runs with a hybrid mesh definition that has draft and high-quality
tetrahedral elements. The hybrid mesh is available only for linear static studies with solid
bodies.

• To assign a draft-quality mesh to a solid body:

Right-click the body in a Simulation static study, and click Apply Draft Quality Mesh
. An icon of a blue tetrahedron element with straight lines next to a body indicates

a draft-quality mesh assignment.
• To assign a high-quality mesh to a solid body:

Right-click the body, and click Apply High Quality Mesh . An icon of a blue
tetrahedron element with curved lines next to a body indicates a high-quality mesh
assignment.
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• To assign a draft or high-quality mesh to all solid bodies in a study:

Right-click the Parts folder , and click Apply Draft Quality Mesh to All , or
Apply High Quality Mesh to All .

You can also assign a draft or high-quality mesh quality to selected solid bodies from the
Mesh Quality tab of the Mesh PropertyManager.

The image shows an assembly with draft and high-quality mesh assignments.

Results from Linear static studies with hybrid meshes are valid as input for dependent
study types such as: Fatigue, Pressure Vessel, Design, and Submodeling studies.

Free Body Forces for Nonlinear Studies

Video: What's New in SOLIDWORKS Simulation 2020
- Free Body Forces in NL Studies

After running a nonlinear static or nonlinear dynamic study, you can list the free body
forces on select geometry entities at each solution step.

In the Nonlinear-Static dialog box, click Compute free body forces.

When the analysis completes, right-click Results, and click List Result Force. Under
Options select Free Body Force.
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Select geometry entities (face, edge, or vertex) or a body to list the free body forces that
act on the selected entities for a defined solution step.

The free body forces can come from contact, external loads, restraints, or connectors.

Free body calculations are not available for 2D simplification studies.

Table 1: Listing of Free Body Forces on Selected Faces

Link Between Results and Model Files
The algorithm that links the results file (*.cwr) to the model file that generated the
results is improved.

You can upload and view result plots from data saved in the most recent *.cwr file, even
in cases where the software terminated before completing the analysis of all simulation
studies. For example, during a batch analysis of multiple studies, if the program terminates
before running the last study, the software validates the links to the completed *.cwr
files for post-processing.

It is important to save the model after meshing. The same mesh data exist in both files
for the software to establish the link between the results file and the model that generated
the results.

The software checks for the results file in this order:

1. The results folder specified on the study's Properties dialog box.
2. The folder of the model file that generated the results.
3. The results folder specified on the Default Options > Results tab.
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To re-establish a link between a valid *.cwr file and a model file, and be able to create
result plots, start the Simulation Evaluator.

Simulation Evaluator lists the location of the model file and results folder. If a results
file (*.cwr) exists, click the link provided to validate the results file and link it to the
current study. In the event that the software cannot establish a link between the active
model and the results file in the designated results folder, a warning message lists the
reasons of failure.

Renaming a model file or a simulation study after saving the results can invalidate the
link to the results file. The software cannot reconstruct the link between the new file
and the results saved in the original file <model name-study name.cwr>.

Repair Corrupt Studies
The software identifies simulation studies with corrupt data, and issues a warning to
delete the corrupted studies before saving the model.

When the software detects a simulation study with corrupt data, it flags the study tab
with an error icon. When you save a model that has corrupt studies, the software issues
a warning to delete the corrupt studies before proceeding.

Simulation Evaluator

Video: What's New in SOLIDWORKS Simulation 2020
- Simulation Evaluator

Simulation Evaluator checks a study's setup to determine if the setup is optimal for a
successful simulation.

To run the Simulation Evaluator, do one of the following:

• In the Simulation CommandManager, click Simulation Evaluator .
• In a Simulation study tree, right-click the top study icon, and click Simulation

Evaluator .

Simulation Evaluator checks conditions related to the results folder, storage capacity
of the results drive, materials used in the simulation, and the mesh volume. If conditions
in the study prevent a successful simulation run, the Simulation Evaluator dialog box
provides information for corrective actions.

In the Simulation Evaluator dialog box, click Save to save the content of the dialog box
in a .txt document.
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Simulation Performance Improvements
Performance improvements are implemented for linear static studies with multiple load
cases and studies with contacts set to incompatible bonding.

Linear Static Studies with Multiple Load Cases
You see performance benefits while solving a simulation for linear static studies with
multiple load cases defined with remote loads. The force and moment components of
remote loads support the optimized solver performance. Translation, rotation, and mass
components of remote loads remain unchanged for all load cases.

Performance is not improved when no-penetration contact or virtual wall contact are
present in any load case.

The Intel Direct Sparse solver performs the global stiffness matrix factorization (which
consumes the majority of the total solution time) only once, because the stiffness matrix
remains the same for each load case.

The optimized reconfiguration of the Intel Direct Sparse solver was introduced in
SOLIDWORKS Simulation 2019, and it was realized for pressure, force, and torque load
types.

Incompatible Bonding
The algorithm of the surface-to-surface incompatible bonding is improved. The solver
calculates correctly the zero-stress state and zero frequencies for rigid body modes.

The calculation of stresses at bonded interfaces with unmatched (incompatible) meshes
is also improved.

The default option for bonded component contact is now set to Incompatible mesh.
You can change the mesh setting for the Component contact (including the Global
Contact option) to Compatible mesh or Incompatible mesh for a bonded contact
type from Simulation Options > Default Options > Contact.

Stress Averaging at Mid-Side Nodes
The improved stress averaging algorithm applies to linear dynamic studies.

Before you run a linear dynamic study, in the Results Options PropertyManager, click
Average stresses at mid-nodes (high-quality solid mesh only).

For a high-quality solid element, the stresses at the mid-side nodes are calculated by
averaging the stress values at the adjacent corner nodes. This stress averaging method
improves the calculation of stresses at mid-side notes for tetrahedral elements with high
aspect ratios.

Example:
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• Stresses at corner nodes (1, 2, 3, and 4) globally
averaged over the shared elements.

• Stresses at mid-side nodes (5, 6, 7, 8, 9, and 10)
averaged over the associated corner nodes. For
example, stress (node 5) = (stress (node 1) + stress
(node 2)) / 2

Thermal Loads for Beams
You can apply thermal loads on beam joints and beam bodies. After running thermal
analysis on a model with beams, you can import the temperatures into a Linear Static,
Nonlinear Static, Frequency, Buckling, or Nonlinear Dynamic study to perform stress
analysis.

The table lists the type of thermal loads you can apply on beam and truss elements. Apply
concentrated thermal loads on beam and truss joints and distributed thermal loads along
the length of beam and truss bodies.

Beam or Truss

BodyJointThermal Loads

YesYesTemperature

YesNoConvection

YesNoHeat Flux

YesYesHeat Power

YesNoRadiation to Ambient only

Only heat flux supports non-uniform distribution of thermal load.

For example, to apply temperature to a joint or beam body, in the Temperature

PropertyManager click Joints or Beams . In the graphics area, select the joints or
beam bodies to apply the temperature loads.
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After running a thermal study, you can view thermal plot results on beam models. The
temperature result plot of a truss is shown.

To perform stress analysis based on temperatures from a thermal study:

1. Create a static study.
2. Open the static study Properties dialog box.
3. On the Flow/Thermal Effects tab, select Temperatures from thermal study.

The resultant displacement plot of a truss model with temperature loads imported into a
static study is shown.
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24
Sketching

This chapter includes the following topics:

• Applying Torsion Continuity Relations
• Baseline and Chain Dimensions in Sketches
• Importing 2D DXF or DWG Files as Reference Sketches
• Power Modify Tool
• Silhouette Entities

Video: What's New in SOLIDWORKS 2020 - Sketching

Applying Torsion Continuity Relations
You can apply torsion continuity relations between splines and any other sketch entity in
2D sketches. The sketch entities must share an end point. These relations create a smooth
continuity at the end point and apply equal curvature and an equal rate of curvature to
the sketch entities.

You can apply torsion continuity relations to a spline and one of these sketch entities:

• Spline
• Arc
• Conic or elliptical arc
• Model edges that are linear, circular, conic, parabolic, elliptical, or spline-based

To apply torsion continuity relations:

1. Select a plane and open a sketch.

2. Click Style Spline (Sketch toolbar) or Tools > Sketch Entities > Style Spline

.
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3. Sketch a spline.

4. Right-click the spline and click Show Curvature Combs.

5. Click 3 Point Arc (Sketch toolbar) or Tools > Sketch Entities > 3 Point Arc

.
6. Sketch an arc that shares common end point with the spline.

7. Right-click the arc and click Show Curvature Combs.
8. Ctrl + select the spline and arc.

The Add Relations/Properties PropertyManager appears.

9. In the Add Relations/Properties PropertyManager, under Add Relations, click Torsion

Continuity .

10. Click .

The result is a smooth continuity with equal curvature and equal rate of curvature at
the shared end point between the spline and arc.
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Baseline and Chain Dimensions in Sketches
In assemblies and parts, Baseline and Chain dimension tools are available in Sketch
mode.

• Baseline dimensions can be driving or driven.
• Chain dimensions can only be driven.

Importing 2D DXF or DWG Files as Reference Sketches
You can import 2D DXF or DWG files as reference sketches.

To import 2D DXF or DWG files as reference sketches:

1. Click Open (Standard toolbar) or File > Open.
2. In the Open dialog box, set File of type to Autodesk AutoCAD Files (*.dwg;

*.dxf), browse to the file, and click Open.
3. In the DXF/DWG Import dialog box, under Import to a new part as, select 2D

sketch and Import as reference.
4. Click Finish.

The software imports the DXF or DWG file as a reference sketch.

You cannot edit a reference sketch. In the FeatureManager® design tree, right-click
the reference sketch and click Make Edit Sketch. The software converts the
reference sketch to a regular sketch and you can edit it.

Power Modify Tool
Power Modify is a pen sketch mode that uses pen gestures to modify sketch geometry.
Power Modify adds pink strokes that indicate where you want modifications such as
adding fillets or trimming to take place.

You can only use the Power Modify tool with a touch device. On the touch device, you
can use the tool with pen sketch mode, your finger, or a mouse.

Click or touch Power Modify (Sketch Ink toolbar).

Modifies the sketch geometry when you use ink strokes
as gestures to trim, extend, split, offset, and add fillets
and chamfers to sketch geometry.

Power Modify

After using Power Modify, you can further update the sketch geometry by using the
following tools on the context toolbar:

Undoes the last Power Modify stroke.Edit Power Modify
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Converts lines into chamfers.Convert to sketch
chamfer

Converts arcs into fillets.Convert to sketch
fillet

Extends lines or arcs up to the nearest sketch entity.Convert to sketch
extend

You can use the Power Modify ink strokes to do the following:

• Add fillets by drawing an arc that intersects sketch geometry.

When you add multiple fillets quickly, the software converts all the pink strokes into
fillets at the same time. The software considers them as consecutive fillets with the
same radius and creates an automatic relation with the first fillet in the series.

• Add chamfers by drawing a line that intersects sketch geometry.

• Power trim sketch entities by drawing a scribble gesture on sketch geometry.
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• Extend sketch entities along their natural paths by drawing a line or arc that partially
overlaps the sketch geometry to which you want to extend.

• Split sketch entities by drawing two intersecting lines or arcs on sketch geometry.

• Offset sketch entities by drawing two parallel lines that intersect sketch geometry. You
can offset the following sketch geometries:

• Multiple lines, arcs, or splines
• Multiple shaded sketch contours

Silhouette Entities
You can create multiple sketch entities by projecting the outline of the bodies in a part
or components in an assembly onto a parallel sketch plane.

Silhouette entities create parametric sketch constraints on the model. You can use

silhouette entities when you use Sketch and 3D Sketch On Plane .
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In Section View mode:

• The Silhouette Entities tool is available only when you clear the Graphics-only
section option.

• Silhouette entities do not contain sketch constraints.
• You can silhouette a component that has only a single instance in an assembly.

To use silhouette entities, click Silhouette Entities (Sketch toolbar) or Tools >

Sketch Tools > Silhouette Entities .

Creating Silhouette Entities

To create silhouette entities:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\sketching\food_processor_silhouette.SLDASM.

2. In the FeatureManager design tree, select Plane4.

3. Click Sketch (Sketch toolbar).

4. Click Silhouette Entities (Sketch toolbar) or Tools > Sketch Tools > Silhouette

Entities .
5. In the PropertyManager, for Entities to Silhouette, select base plate<1> from the

FeatureManager design tree.
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6. Clear External silhouette to create sketch entities of the outer body and the internal
entities of the model.

7. Click .

To create entities of the external silhouette only, select External silhouette.
Silhouette entities appear on the sketch.

Silhouette Entities PropertyManager

To open the Silhouette Entities PropertyManager:

1. In a part or assembly, open a sketch on a plane.

2. Click Silhouette Entities (Sketch toolbar) or Tools > Sketch Tools > Silhouette

Entities .

Entities to Silhouette

Lists the selected bodies in parts or
components in assemblies.

Select bodies or components to create
silhouette sketch entities

Creates the sketch entity from the silhouette
of the outer boundary of the model. Clear
this option to project the inner loops in the
model.

External silhouette
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25
SOLIDWORKS Visualize

This chapter includes the following topics:

• AMD ProRender Integration
• AxF Measured Materials
• glTF Export for AR and VR
• IES Light Profiles
• Inline Rendering
• Instancing
• MDL Support
• NVIDIA RTX Support
• Scaling for High-Resolution Displays
• SOLIDWORKS PDM Integration

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.

AMD ProRender Integration
SOLIDWORKS Visualize supports AMD Radeon™ ProRender, a raytracing engine that is
designed to run on AMD’s high-performance graphics cards.

To use ProRender, click Tools > Options > 3D Viewport and, under Render Engine,
select AMD Radeon ProRender.

AxF Measured Materials
SOLIDWORKS Visualize supports AxF™ measured materials.

The .axf file format from X-Rite stores digital material representations, most notably
measured materials, from their BTF scanning technology. To add .axf files to a project,
drag from Windows Explorer into your scene or click Palette > Appearances > Add >
Import Appearances.
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glTF Export for AR and VR
You can use .gltf and .glb file formats to export your SOLIDWORKS Visualize project
data for use in augmented and virtual reality viewers.

IES Light Profiles
You can use IES light profiles to modify light sources to mimic real-world lights. The
profiles are generally used for interior and architectural scenes where the light is cast
and readily seen on nearby objects like walls, ceilings, and floors.

Specifications from the Illuminating Engineering Society (IES) define the standards for
describing light profiles in the form of .ies files. Lighting manufacturers provide .ies
files that define the unique way in which each product emits light; for example, how it
casts light rays and shadows.

Finding IES Light Profiles

From the internet, you can download IES light profiles from lighting manufacturers such
as Philips and Lithonia, and add them to the Lights folder of the library in SOLIDWORKS
Visualize.

The Lights folder contains samples of IES profiles. These profiles do not represent
specific profiles from light manufacturers. However, you can use a sample profile if,
for example, you have not yet decided on or obtained a specific IES profile to use. Also,
you can use a sample profile if you want a unique look for a light source but do not
need a specific profile.

To find IES light profiles:

1. Search the internet using a string such as “ies light profiles download” to find
sources.

2. Download the files and copy them to the Lights folder in your SOLIDWORKS Visualize
Content folder.
By default, the content folder is located in your Documents folder.
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Adding IES Profile Lights to Scenes

You can drag existing IES profile lights into scenes. You can also create IES profile lights
by adding area lights to scenes and then editing parameters to make them IES profile
lights.

Dragging IES Profile Lights into Scenes

You can drag IES profile lights from the File Libraries tab into your scenes.

1. In the Palette, on the File Libraries tab, select Lights from the list.
2. Drag an .ies file from the Palette into the scene and drop it in the location for the

light.

The profile is placed using the Pick Positionmethod and normal to the surface under
the pointer.

You can also drag .ies files directly from File Explorer into the scene.

3. Optional: To make adjustments to the light, on the Scenes tab, select the light
in the tree. Then you can:

• Adjust the parameters of the light, such as Brightness and Color.
• Use the Object Manipulation Tools (main toolbar) to adjust the position and
direction of the light.

To move the position and the target simultaneously, right-drag the arrow handles.

In Preview render mode, IES profile lights are represented as standard area lights.
This provides enough information to adjust placement of the light, but does not represent
the light profile accurately. Use Fast or Accurate modes for accurate representation
of the light profile.

Creating IES Profile Lights from Area Lights

You can create IES profile lights by adding area lights to scenes and then editing
parameters to make them IES profile lights.

You can use these lights as placeholders if, for example, you have not yet decided on or
obtained a specific IES profile to use.

1. In the Palette, on the Scenes tab, click Add > New Light > Pick Position.
2. In the viewport, click a location for the light.
3. In the Palette, for Type, select IES Profile.

A default IES profile is used. Now or later, you can change to a specific IES profile.

4. To change to a specific IES profile:

a) On the Scenes tab, select the light in the tree.

b) For IES Profile, click , browse to an .ies file, and click Open.
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Inline Rendering
SOLIDWORKS® Visualize supports and defaults to the Live rendering mode for renders
that you run from the Output Tools dialog box. The Live rendering mode blocks access
to the application during the rendering process.

Previously, all renders that you ran from the Output Tools dialog box ran in the background
so that you could continue working in the application. To continue this behavior, you can
switch to the Background rendering mode.

To switch render modes:

1. Click Tools > Options.
2. On the 3D Viewport tab, under Render Mode, select one of the following:

Provides faster rendering by blocking
access to the application during the
rendering process. This option can be
useful when you use computers with
minimum recommended configurations.

Live

Lets you continue working in the
application during the rendering process.
Performance might slow down, especially
on computers with minimum
recommended configurations.

Background

Instancing
For SOLIDWORKS part and assembly models, SOLIDWORKS Visualize can handle duplicated
geometry, such as patterned components from SOLIDWORKS assemblies, more efficiently.

Typically, for larger SOLIDWORKS assemblies, the use of duplicated geometry requires
less GPU memory and reduces the likelihood of running out of GPU memory.

Appearance part-grouping mode does not support this functionality.
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MDL Support
SOLIDWORKS Visualize supports full editing capabilities of NVIDIA® Material Definition
Language (MDL) materials.

You can modulate textures and edit color fields and parameters.

Also, these materials are supported in Preview mode.

The creator of an MDL material defines its look and behavior. The creator specifies which
parameters to show, and specifies the parameter names, value ranges, and whether the
parameter can be textured.

Parameter names in MDL material are not localized.

Using MDL Materials

The NVIDIA vMaterials catalog provides access to a collection of MDL materials.

Before you begin, download and install the vMaterials catalog from the NVIDIA website:

1. Go to the NVIDIA VMATERIALS web page.
2. Click DOWNLOAD and follow the instructions.

To use MDL materials:

1. In SOLIDWORKS Visualize, open a new or existing project.
2. In Microsoft® File Explorer, browse to the folder where you installed the NVIDIA

vMaterials catalog.
3. To assign a material to a part, drag any .mdl file and drop it on the part in

SOLIDWORKS Visualize.
One .mdl file can include definitions for multiple materials. SOLIDWORKS Visualize
creates one appearance for each material.

4. To edit the material, select it in the viewport or in the Appearances tab, and then edit
parameters in the Appearances tab.

If the creator of an MDL material specifies that a parameter can be textured,
appears next to the parameter.
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5. To add a texture to the parameter, click , browse to a texture, and click Open.

The texture appears on the model, and the texture's parameters appear in the Texture
subtab.

The changes you make affect only the copies of the appearance in the project. They do
not affect the source appearance.

NVIDIA RTX Support
SOLIDWORKS Visualize has RT Core support for full RTX hardware acceleration for
Accurate and Fast render modes on NVIDIA Turing™ TU10x GPUs.

Scaling for High-Resolution Displays
SOLIDWORKS Visualize supports displays with 4K and higher resolution.

Icons and buttons scale so that their appearance does not degrade or become blurry on
high-resolution and high-pixel density displays.

Except for the viewport, all aspects of the user interface respond to the Microsoft Windows®
display scaling setting. In dialog boxes and the Palette, the software uses the display
scaling setting to display icons and buttons at an appropriate size. Icons associated with
text are scaled to a size appropriate for the text.

The viewport, which includes the preview of ongoing renders, does not scale. It always
appears in the actual device pixels of the screen. Therefore, when you use a 4K monitor,
the viewport appears smaller compared to other user interface elements. To change the
resolution of the viewport, click Tools > Options > 3D Viewport and change the value
for Maximum Resolution.

SOLIDWORKS PDM Integration
You can use the integrated SOLIDWORKS PDM menu to access vault tools and view file
information for files you open in SOLIDWORKS Visualize.

You must have SOLIDWORKS PDM Professional installed.

Most tools on the menu are available only if you open a project from the PDM vault.

Exceptions:

• Search is always available.
• Select in Windows Explorer is available if you open a project, whether from the
PDM vault or another location.

To access these tools:

• On the menu bar, click SOLIDWORKS PDM.
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Changes the workflow state. Workflow states represent where
the file is in the design and approval process, such as Under
Editing, Waiting for Approval, or Approved.

Change State

Checks in files after editing to make them available to users
with appropriate rights. Until you check in a file, changes are
saved in your local version only.

Check In

Checks out a file to give you the exclusive right to edit it until
you check it back in. Other users can open the file for viewing
and copying but cannot change it.

Check Out

Cancels a checkout without saving changes.Undo Check Out

Changes the version of a file in your local cache to the latest
available version.

Get Latest Version

Changes the version of a file in your local cache to another
version you select.

Get Version

(Always available, even if no files are open in SOLIDWORKS
Visualize.) Searches for files and folders and for other data
such as users and items.

Search

(Available if you open a project, whether from the PDM vault
or another location.) Opens Windows Explorer to the folder
that contains the file and selects the file.

Select in Windows
Explorer

Opens the SOLIDWORKS PDM data card for the document you
are viewing.

Show Card

Displays version information for the document in the local
cache.

Local Version

Displays revision information for the document in the local
cache.

Local Revision

Displays the name of the user who has checked out the file.Checked Out By

Displays the location (system name and path) where the user
checked out the file.

Checked Out In

Displays the current state of the document as defined in the
SOLIDWORKS PDM workflow.

Workflow State
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26
Structure System and Weldments

This chapter includes the following topics:

• Options for Creating Primary Members Based on Points
• Creating Curved Beams and Merging Tangent Members
• Split Members
• Pattern and Mirror Support
• Member and Corner Trim Enhancements
• Cut List Properties for Weldment and Structure System Features

Video: What's New in SOLIDWORKS 2020 - Structure
System

Options for Creating Primary Members Based on Points
When specifying Point and Length, you can set a direction for a primary member by
selecting a sketch entity as a reference. The member extrudes in its direction. You can
also reverse its direction.

Additional end condition types:

Extends a primary member from the start point to the end
point. Click Chain Link to add members along a chain of points.

Point

Extends a primary member up to the selected point.Up to Point

Extends a primary member from a point to a plane. The
member extrudes in the direction of the reference plane.

Up to Plane
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Specifying the Member Profile

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\structure_system\point_length.SLDPRT.

2. Click Insert > Structure System > Structure System to enter Structure System
mode.

3. Click Insert > Structure System > Primary Member to add primary members.

4. Click Pin at the top of the PropertyManager.
5. In the Profile tab, set the following:

a) For Standard, select Iso.
b) For Type, select pipe.
c) For Size, select 21.3 x 2.3.

Creating Primary Members Based on Point and Length

To create primary members based on point and length:

1. In the Member tab, under Primary Member Type, click Point Length Member .
2. Under End Condition, select Length and enter 200.00mm.

The PropertyManager displays the following members:

• Point11@Point and point
• Point5@Point and point
• Point9@Point and point
• Point7@Point and point

3. In the graphics area, select the four sketch points on the Point and point plane.

4. Click .

208

Structure System and Weldments



Creating Primary Members Between Points

To create primary members between points:

1. In the Member tab, under End Condition, select Point.

2. Under Points And Length, click Chain Link .

The end point of one member is used as the beginning of the next pair in the chain.

3. In the graphics area, click each point at the corners of the rectangle on the Top plane.

The PropertyManager lists the following pairs:

• Point8@Base Point, Point6@Base Point
• Point6@Base Point, Point7@Base Point
• Point7@Base Point, Point5@Base Point
• Point5@Base Point, Point8@Base Point

4. Click .

Creating Primary Members Based on Up to Point

To create primary members based on up to point:

1. In the Member tab, under End Condition, select Up to Point.

2. Under End Condition, click in the End Condition box .
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3. In the graphics area, select the point on the plane labeled Up to point.

Point1@Uptopoint displays in the PropertyManager.

4. In the Member tab, click in the Points And Length box .
5. In the graphics area, select points 8, 5, and 7 as shown.

6. Click .

Creating Primary Members Based on Direction

To create primary members based on direction:

1. In the Member tab, under End Condition, select Length.

2. Under End Condition, click in the Direction of Member box .
3. In the graphics area, select the sketch line that appears in a magenta color.

When you select the sketch line, the color changes to orange.

The PropertyManager displays Line1@For direction control.

4. In the graphics area, click the remaining corner on the rectangle on the Top plane.
5. In the Member tab, enter 280.00mm for Length.

6. Unpin the PropertyManager and click .

7. Click Structure System in the Confirmation Corner to exit Structure System
mode.

8. In the Corner Management PropertyManager, click .
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Creating Curved Beams and Merging Tangent Members
You can create curved beams from primary and secondary members in a structure system.
Curved members behave the same way as linear members where you can add secondary
members between them.

If you select a 3D curve or spline as a reference, the member can only pierce through
the center of the profile. Also, in some scenarios, you cannot sweep members with 2D
or 3D splines because of their curvature and radius.

You can also merge multiple members that are tangent to each other into a single member
with theMerge Tangent Members option and add secondary members between merged
members.

Split Members
You can split primary and secondary members by specifying references or dimensions.

For Reference type, you can select faces, reference planes, or members. For Dimension
type, you can specify a dimension for length, direction vector, and the number of split
member instances to create.

Splitting Members by Reference

To split members by reference:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\structure_system\split.SLDPRT.
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2. In the FeatureManager design tree, right-click Structure System2 and click Edit

Feature .
3. In the graphics area, select this member as shown.

The Member Properties PropertyManager lists Member8 in Selected Members.

4. Optional: Ctrl + select the two members above Member8 as shown in the graphics
area.

Member20 and Member16 are added to Selected Members.

5. In the PropertyManager, click Split Member and select Based On Reference.
6. In the graphics area, select the vertical member that intersects the horizontal

members, as shown.

7. Click .

Members 8, 20, and 16 split at their intersection of Member 15.

Do not exit Structure System mode. Keep the model open to continue with the next
step.
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Splitting Members by Dimension

To split members by dimension:

1. In the graphics area, select the longest horizontal member as shown.

The PropertyManager lists Member21 in Selected Members.

2. In the PropertyManager, click Split Member and select Based On Dimension.
3. Click Instance and enter 6.

4. Click .
5. In the FeatureManager design tree, expand Structure System2 and expand

<iso><square tube><20 x 20 x 2>(3).

Member21 lists the split instances from Member21_1 to Member21_6.

Pattern and Mirror Support
You can pattern and mirror structure system members using the Linear Pattern, Circular
Pattern, or Mirror tools.

In the Pattern PropertyManager, under Bodies, you can specify structure system features
or individual members to pattern. You can also mirror members by specifying structure
system features or individual members under Bodies to Mirror in the Mirror
PropertyManager.

You can add secondary members as a separate structure system feature between patterned
and mirrored members.

You can also create secondary members as part of a new structure system by selecting
members from existing structure system features.
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Creating a Linear Pattern of a Structure System Feature

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2020\samples\whatsnew\structure_system\shed.SLDPRT.

2. Click Insert > Pattern/Mirror > Linear Pattern.
3. In the PropertyManager, for Direction 1:

a) For Pattern Direction , select the edge shown in the graphics area.

b) Select Up to reference.

c) Click in Reference Geometry , and in the graphics area, rotate the model
and select the face shown.

d) For Spacing , enter 10mm.

e) Click Number of Instances and enter 6.

4.

5. In the PropertyManager, click Bodies and click in Structure System to Pattern .
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6. In the flyout FeatureManager design tree, click Structure System1.

7. Click .

The model adds six instances of the frame.

Adding a Structure System Feature to an Existing Feature

1. Click Insert > Structure System > Structure System .

2. Click Insert > Structure System > Secondary Member .

3. Click Pin at the top of the PropertyManager.
4. Click the Profile tab and set the following:

a) For Standard, select Iso.
b) For Type, select square tube.
c) For Size, select 80 x 80 x 5.

5. Click the Member tab, and for Secondary Member Type, click Support Plane

Member .
6. Click in Support Plane, and in the flyout FeatureManager design tree, select Plane2.

7. Click in Member Parameters and click Chain Link .
8. In the graphics area, click Right Orientation (Heads-up View toolbar).
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9. Click each of the vertical members and click .

A row of secondary members displays along the right side of the model.

10. Right-click in Member Parameters and click Clear Selections.
11. In the graphics area, click Left Orientation (Heads-up View toolbar) and repeat

steps 6 to 9 to generate another row of secondary members.

12. Unpin the PropertyManager and click .

13. Click Structure System in the Confirmation Corner to exit Structure System
mode.

14. In the Corner Management PropertyManager, click .

Member and Corner Trim Enhancements
Enhancements and quality improvements for structure system features include:

• When creating Ref Plane and Face Plane intersection primary members, you can
select faces in addition to reference planes.

• When creating Support Plane secondary members, you can select faces in addition
to reference planes.

• You can delete input sketches and planes for individual members without deleting the
Structure System feature.

• Issues with corner treatment, especially with creating complex corners, are resolved.
• You can define individual gap values for trimming corners.
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• Original corner features are retained even after adding or deleting new members at
the corner location.

Cut List Properties for Weldment and Structure System Features
Two cut list properties are available for structural members created by weldment as well
as structure system features.

The Angle Direction property indicates whether the two ends face of the body are along
the same direction or not. You can specify:

• Same
• Opposite
• Out of Plane
• None

The Angle Twist property indicates the angle between the normals of two end cut planes
for out of plane trimming. You can set the angle 0–180 degrees.
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