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Legal Notices

© 1995-2017, Dassault Systemes SolidWorks Corporation, a Dassault Systemes SE company,
175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without
notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or
manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or
copied only in accordance with the terms of the license. All warranties given by DS SolidWorks
as to the software and documentation are set forth in the license agreement, and nothing
stated in, or implied by, this document or its contents shall be considered or deemed a
modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents
6,611,725; 6,844,877, 6,898,560; 6,906,712; 7,079,990, 7,477,262; 7,558,705; 7,571,079;
7,590,497; 7,643,027, 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902;
8,817,028; 8,910,078; 9,129,083; 9,153,072; 9,262,863; 9,465,894, 9,646,412 and foreign
patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and
Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo
are registered trademarks and FeatureManager is a jointly owned registered trademark of DS
SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.
FeatureWorks is a registered trademark of HCL Technologies Ltd.

SOLIDWORKS 2018, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS
Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS
Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium,
SOLIDWORKS Flow Simulation, eDrawings Viewer, eDrawings Professional, SOLIDWORKS
Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical Schematic Standard,
SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS
Electrical Professional, CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection,
SOLIDWORKS MBD, SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector
powered by Altium, and SOLIDWORKS Visualization are product names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective
holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY
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The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995),
consisting of “commercial computer software” and “commercial software documentation” as
such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government
(a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in
48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense,
consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN
1995)

In the event that you receive a request from any agency of the U.S. Government to provide
Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope
of the request and DS SolidWorks will have five (5) business days to, in its sole discretion,
accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks
Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education
Products

Portions of this software © 1986-2017 Siemens Product Lifecycle Management Software Inc.
All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:
D-Cubed® 2D DCM © 2017. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® 3D DCM © 2017. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® PGM © 2017. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® CDM © 2017. Siemens Industry Software Limited. All Rights Reserved.
D-Cubed® AEM © 2017. Siemens Industry Software Limited. All Rights Reserved.
Portions of this software © 1998-2016 HCL Technologies Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2017 Luxology, LLC. All rights reserved, patents pending.
Portions of this software © 2007-2016 DriveWorks Ltd.

© 2011, Microsoft Corporation. All rights reserved.

Includes Adobe® PDF Library technology

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected by
U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents
Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered
trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. All rights
reserved.
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Copyright Notices for SOLIDWORKS PDM Professional Product
Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2012 Spatial Corporation.

The eDrawings® for Windows® software is based in part on the work of the Independent JPEG
Group.

Portions of eDrawings® for iPad® copyright © 1996-1999 Silicon Graphics Systems, Inc.
Portions of eDrawings® for iPad® copyright © 2003 - 2005 Apple Computer Inc.

Copyright Notices for SOLIDWORKS PCB Products
Portions of this software © 2017 Altium Limited.
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Welcome to SOLIDWORKS 2018

This chapter includes the following topics:

e Top Enhancements
e For More Information

Image courtesy of S.C. ASTRA RAIL Industries S.R.L.

SOLIDWORKS® 2018 delivers many enhancements and improvements, most created in direct
response to customer requests.

This release provides four new end-to-end process solutions that simplify the interactions
between disciplines across product development to improve your business outcomes. Accelerate
innovation and grow your business with the following new processes:

e Design to Manufacturing Process. A complete solution to bring your ideas to market.

e Distributed Data Management Process. The right data, at the right time, for the right people.
e Designer to Analyst Process. Analysis tools for every step of the design process.

e Electrical Design and Internet of Things (IOT) Process. Connect your smart devices to your
customers.

Top Enhancements

The top enhancements for SOLIDWORKS 2018 provide improvements to existing products
and innovative new functionality.

Throughout this guide, look for the symbol in these areas:
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User Interface

SOLIDWORKS 3D
Interconnect

Model Display

Parts and Features

Sheet Metal

Sketching

SOLIDWORKS PDM

SOLIDWORKS
Simulation

Weldments

Mouse Gestures Enhancements on page 20
Touch-based Interactions on page 23
Welcome Dialog Box on page 24

Additional File Formats Supported on page 109

Additional Information Supported for Reading from
Third-Party Native CAD Files on page 109

STEP, IGES, and ACIS Files on page 109

Offloaded Rendering on page 129

Creating a Bounding Box on page 133

Extracting Geometry from a Corrupted Solid Body on page
135

Creating Normal Cuts on page 187
Tab and Slot on page 188
Three Bend Corner Reliefs on page 191

Creating Mirrored Entities in 3D Sketch on page 206
Pen, Touch, and Gesture-based Sketching on page 208

Automated Drawing PDF Creation in SOLIDWORKS PDM
Standard on page 153

Data Card Editor Undo on page 155

Design Branching and Merging on page 155
Detailed Warning Messages on page 170
Revision Table Integration on page 173

SOLIDWORKS PDM Support for Non-SOLIDWORKS CAD
File References on page 179

Mesh Refinement for Stress Singularities on page 203
Displacement Control for Nonlinear Contact on page 202
Email Notification for Completed Analysis on page 202

Factor of Safety Plot for Nonlinear Static Studies on page
202

Topology Study on page 194
Improved Pin Connector on page 203

Import Simulation Study Features into Assemblies on page
202

Sensor for Simulation Mass Properties on page 204

Customizing Description for Bounding Box Properties on
page 228
Linking a Cut List Folder to a Cut List Property on page 228
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e More Control Over Custom Properties on page 150

All features are available in SOLIDWORKS Standard, SOLIDWORKS Professional, and
SOLIDWORKS Premium unless otherwise noted.

For More Information

Use the following resources to learn about SOLIDWORKS:
What's New in PDF This guide is available in PDF and HTML formats. Click:

and HTML « Help > What's New > PDF
e Help > What's New > HTML

II“r:atvt\a,ractlve What's In SOLIDWORKS, click the & symbol to display the section of this
manual that describes an enhancement. The symbol appears next
to new menu items and the titles of new and changed
PropertyManagers.

To enable Interactive What's New, click Help > What's New >
Interactive.

What's New What's New Examples are updated at every major release to
Examples provide examples of how to use most top enhancements in the
release.

To open What's New Examples click Help > What's New >
What's New Examples.

Sample files To open sample files for this book, go to
system dir:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\chapter name\file name.

For example, C:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\sketching\Block.sldprt.

Online Help Contains complete coverage of our products, including details
about the user interface, samples, and examples.

Release Notes Provides information about late changes to our products, including
changes to the What's New book, online help, and other
documentation.

16



User Interface

This chapter includes the following topics:

e Auto-Rotate View on Sketch Edit

e Folders in the FeatureManager Design Tree

e Measure Tool Enhancements

e Mouse Gestures Enhancements

e Scaling of Entities on High Resolution Monitors

e Show File Names and Descriptions in Design Library
e Task Pane Changes

e Touch-based Interactions

e Welcome Dialog Box

Auto-Rotate View on Sketch Edit

The system option, Auto-rotate view normal to sketch plane on sketch creation,
has been renamed. It is now available when you edit an existing sketch, as well as when
you create a new one.

In Options > System Options > Sketch, the option is renamed.

New Name Auto-rotate view normal to sketch plane on sketch
creation and sketch edit

Previous Name Auto-rotate view normal to sketch plane on sketch
creation

The view rotation behavior is now consistent, regardless of how you open the sketch. If
the option is selected, the following behavior occurs:

e When you open a new or existing sketch, the view rotates to be normal to the sketch
plane.

e When you exit a sketch:

e If you keep your changes, the view remains normal to the sketch plane. For example,

click q’ in Confirmation Corner or Insert > Exit Sketch.
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e If you discard your changes, the view reverts to the orientation it was before you

opened the sketch. For example, click x in Confirmation Corner or Edit > Exit
Sketch without Saving Changes.

Folders in the FeatureManager Design Tree

The folder icons in the FeatureManager design tree indicate the state of items in the
folders.
Assemblies

In assemblies, the icons indicate if the folder contains shown, hidden, or suppressed
items, or various combinations.

Icon Shown Hidden Suppressed
B3 X
[ X
0 X
P X X
3 X X
| X X
B X X X
Parts
In parts, the icons indicate if the folder contains unsuppressed or suppressed items, or
both.
Icon Unsuppressed Suppressed
i3 X
m X
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Measure Tool Enhancements

The Measure B tool supports the following additional features:
e Input box. The input box that lists selections now includes six items.

J8 Measure - cover plate.sldprt 7 |[=] S8l Measure - cover plate,sldprt @
s - e H-B8M G 56 - im oo R - B * [A]

Farce<1= - Face<1=
Face< 2= Face=2=
Face< 3= - Face=3=
Total area: 453569 millimeters®2 Face<d=
cover plate SLOPRT Face=5»
File: cover plate.sldprt Config: Default Face=f=

Total area: 5253.859 millimeters ™2
cover plate, SLDPRT
File: cover plate.sldprt Config: Default

SOLIDWORKS 2017 SOLIDWORKS 2018

e Quick Copy. When you hover over a numeric value, the numeric value gets highlighted

in the dialog box and Copy B is displayed. Click I to copy the value to the clipboard.
You can paste the value at the required location.

J8 Measure - cover plate,sldprt 7 =2
o- e 8@ *B&

Face=1x>
Face<2=

Distance: £5*mm -

Delta ¥ 1.5 @ i

Delta ¥ 3.750mm

m

Total area: 357117 millimeters~2

File: cowver nlate. SLDPRT Ta: cower nlate SLDPRT

e Font Size. You can adjust the font size of the text in the Measure dialog box. ClickAA

to increase the font size. Click A to decrease the font size.

You cannot decrease the font size below the default size.
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e Pin. Click ™ to pin the Measure dialog box to the graphics area. Click * to close the
dialog box.

Click * to unpin the Measure dialog box. Press Esc to close the dialog box only if the
dialog box is unpinned.

Mouse Gestures Enhancements

Mouse gestures are easier to customize.

You can set the number of mouse gestures to 2, 3, 4, 8, or 12 gestures. If you set the
number to 2 gestures, you can orient them vertically or horizontally.

To set the number of mouse gestures, click Tools > Customize > Mouse Gestures.
From the drop-down list, select the desired humber of mouse gestures.

You can also customize the mouse gesture assignments through a visual drag-and-drop
user interface. Drag tools from the list of commands to any of the mouse gestures guides.
If you drag a tool to an empty position, the tool is added to the gesture guide. If you
drag a tool to an occupied position, it replaces the tool on the gesture guide. If you Ctrl
+ drag a tool from one gesture guide position to another, it is copied to the second
position. You can copy a tool within one gesture guide, as well as across gesture guides.

Icons are added for the following tools:

FH Shortcut Bar

@. Escape

i=h Expand/ Collapse Tree

Bt Collapse all Items

G Exit Sketch without Saving Changes
) Repeat Last Command

@ Browse Open Documents

e Browse Recent Folders

1) Browse Recent Documents

i, Pack and Go
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O Hide All Types
E,% Edit Linear Pattern
@ Edit Circular Pattern

The following options have changed:

e The four columns showing mouse gesture assignments for Part, Assembly, Drawing,
and Sketch are removed. They are replaced by the Mouse Gesture Guide window.

e Show only commands with mouse gestures assigned is removed.
e Print List is changed to Print Gesture Guides.

Scaling of Entities on High Resolution Monitors

Entities such as 3D arrows and sketch relations scale well on high resolution monitors.
These entities scale properly according to the screen size, resolution, and display setting.
Improved scaling increases the visibility of these entities and makes it easier to work on
high resolution monitors.

Enhancements include:

e The bitmap size increases based on the display scaling.

e The size of the entities in the graphics area increases proportionately according to the
scaling factor.

e Scaling of selection changes based on the resolution or DPI setting of the screen.

e 3D arrows in the graphic area scale well on high resolution monitors. You can easily
grab and drag them on a touch screen using your fingers or stylus.

Show File Names and Descriptions in Design Library

You can display file names or descriptions of reusable elements (such as features, sketches,
parts or assemblies) in the lower panel of the Design Library.

To show file names and descriptions:

e Right-click in the lower panel of the Design Library, and click Show File Name or
Show Description.

Previously, commands in this shortcut menu were limited to displaying Large Icons,
Small Icons or Adding New Folders.
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Task Pane Changes

Some items from the Task Pane have been moved to the new Welcome dialog box.

The following sections have been removed from the SOLIDWORKS Resources tab in the
Task Pane:

e Getting Started

e Community

e Tip of the Day

The following table summarizes the moved items, their new names (if changed), and
their new locations within the Welcome dialog box.

Removed New Name New Location
Task Pane Item (if changed) (Tab in Welcome
dialog box)

New Document New Home
Open a Document Open Home
Tutorials Learn
Online Training MySolidWorks Training Learn
What's New Home
Introducing SOLIDWORKS Learn
General Information Get Support Home
Customer Portal Home
User Groups Home
Discussion Forum SOLIDWORKS Forum Home
Technical Alerts and News  Technical Alerts Alerts

Tip of the Day Home

To access the items in their new location:
In the Task Pane, at the top of the SOLIDWORKS Resources tab, click Welcome to
SOLIDWORKS fot.

For more information, see Welcome Dialog Box on page 24.
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Touch-based Interactions

Touch-based interactions are easier and more intuitive.

Magnified Selection

The Magnified Selection tool is available in touch devices.
If you press the screen for two seconds or more, then drag your finger, the Magnified

Selection G magnifying glass appears. If you press the screen for less than two seconds,
then drag your finger, the mouse gesture guide appears.

Touch Mode

Touch mode makes the user interface easier to interact with when you use a touch-enabled

device. It optimizes the size of on-screen manipulators, context toolbars, breadcrumbs,
and selection.

When you turn on touch mode, a toolbar of commonly used tools appears on the left or
right side of the SOLIDWORKS window, including:

o Escape Exits the current mode or selection.
FH Shortcut (s) Key Opens the shortcut bar.
am Multi-select Lets you:

e Select more than one item at a time.
It is equivalent to Ctrl + select with

a mouse.
e Drag your finger to box select or lasso
entities.
x Delete Deletes the selected item.
+(=y Zoom Up and Zoom Down Changes the zoom scale for the

magnifying glass.

G Lock 3D Rotate (Sketch mode only) Locks the ability to
rotate the model so you do not
accidentally rotate the model while
sketching.

To turn on touch mode, click View > Touch Mode \@5.

Touch mode is optimized for left- or right-handed users based on your Windows settings.
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Custom Numeric Keypad

Touch gestures improve the user experience. The custom numeric keypad for a
touch-enabled device makes it faster and easier to input values. The keypad is
proportionate to the tool to maximize the visible area.

Previously you used the default operating system keypad that covered a large portion of
the screen.

You can turn on touch mode by clicking View > Touch Mode. When you touch the
numeric input field with your finger or stylus, the custom numeric keypad appears.

The numeric keypad has the following features:

e The keypad gives you more screen space to view and proofread your work.
e You can trigger the numeric keypad for all numeric input fields with spinner controls.
e When you click the More Options button, it shows all the parameters associated with
the field. For example, the Equation input fields have the following parameters:
¢ Global Variables
e Functions
o File Properties
e Units

e Tapping anywhere outside the numeric keypad dismisses the keypad and accepts the
new value.

From the taskbar, you can turn on the built-in keypad to enter non-numeric values.

Welcome Dialog Box

When you open the SOLIDWORKS software, the Welcome dialog box provides a convenient
means to open documents, view folders, access SOLIDWORKS resources, and stay updated
on SOLIDWORKS news.

You can also click Welcome to SOLIDWORKS 2 (Standard toolbar), Help > Welcome

to SOLIDWORKS, or Welcome to SOLIDWORKS on the SOLIDWORKS Resources ‘ﬁ'
tab in the Task Pane to open the Welcome dialog box.

The Welcome dialog box has tabs for: Home, Recent, Learn, and Alerts.

Some of the content from the Task Pane has moved to the Welcome dialog box to avoid
duplication.

Home Tab

The Home tab lets you open new and existing documents, view recent documents and
folders, and access SOLIDWORKS resources.

Sections in the Home tab include New, Recent Documents, Recent Folders, and
Resources.
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New

The New section includes:

7. Part Opens a new document. The document is based on a
template from the Default Templates page of the System
Options dialog box.

@ Assembly

Drawing
| |

Advanced Opens the New SOLIDWORKS Document dialog box, where
you can open a new document based on an alternate
template.

Open Opens the Open dialog box, where you can select an existing

¥

document to open.

Recent Documents

The Recent Documents section includes thumbnails of documents that you have opened
recently. Click View all to open the Recent tab to see a longer list of recent documents.

Functionality in the Recent Documents section is identical to previous versions of the
SOLIDWORKS software. The Welcome dialog box replaces the Recent Documents window.

Recent Folders

The Recent Folders section includes a list of folders from which you have opened
documents recently. Click View all to open the Recent tab to see a longer list of recent
folders.

When you hover over a folder, you can click ™ to keep the folder at the top of the Recent
Folders list until you unpin it.

To access the Recent Folders list after you close the Welcome dialog box, click File >
Open Recent > Browse Recent Folders.

Resources

The Resources section includes links to:

@ What's New

) MySolidWorks

) SOLIDWORKS Forum

Customer Portal

&
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& User Groups

i3 Get Support

)
Tip of the Day ¥

Shows a new tip each time that you open the Welcome dialog box. Click < or » to see
other tips.

Recent Tab

The Recent tab lets you view a longer list of recent documents and folders.

Sections in the Recent tab include Documents and Folders.

Documents

The Documents section includes thumbnails of documents that you have opened recently.
You can do the following:

e C(Click a thumbnail to open the document.

e Drag a thumbnail and drop it in the empty graphics area, an open part, assembly, or
drawing, or Windows Explorer.

e Hover over a thumbnail to see document information such as full path and last saved
date, and click 4 to see more options and information.

e Right-click a thumbnail and click Remove, Pin, or Clear unpinned items.

e Click Browse to open the Open dialog box for the current folder.

If the Welcome dialog box is closed, you can open the Recent tab by clicking one of the
following:

e Open 37 > Browse Recent Documents
¢ File > Open Recent > Browse Recent Documents

Folders

The Recent Folders section includes a list of folders from which you have opened
documents recently.

You can do the following:
e Click a folder to open the folder in the Open dialog box.

e Hover over a folder and click ™ to keep the folder at the top of the list.
¢ Right-click a folder and click Remove, Pin, or Clear unpinned items.
e Click Browse to open the Open dialog box for the current folder.

If the Welcome dialog box is closed, you can open the Recent tab by clicking File > Open
Recent > Browse Recent Folders.
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Learn Tab

The Learn tab lets you access instructional resources to help you learn more about the
SOLIDWORKS software.

Sections in the Learn tab include:

Introducing Opens the Introducing SOLIDWORKS book.
SOLIDWORKS
Tutorials Opens the step-by-step tutorials in the software.

MySolidWorks Opens the Training section at MySolidWorks.com.
Training

Samples Opens local folders containing sample models.

3DContentCentral Opens 3DContentCentral.com.

& Online Tutorials Opens the SOLIDWORKS Tutorials (videos) section at
solidworks.com.

pay My Training Opens the My Training section at MySolidWorks.com.

a Certification Opens the SOLIDWORKS Certification Program section
at solidworks.com.

-4 Curriculum Opens the Curriculum section at solidworks.com.

When you install the software, if you do not install the Help Files or Example Files, the
Tutorials and Samples links are unavailable.

Alerts Tab

The Alerts tab keeps you updated with SOLIDWORKS news.

Sections in the Alerts tab include Critical, Troubleshooting, and Technical Alerts.

Critical

The Critical section includes important messages that used to appear in a dialog box.

The Critical section appears if there are critical alerts to display. If a critical alert exists,
the Welcome dialog box opens to the Critical section automatically on startup, even if
you selected Do not show on startup in the dialog box. Alerts are displayed until you
select Do not show this message again.

Troubleshooting

The Troubleshooting section includes troubleshooting messages and recovered
documents that used to be on the SOLIDWORKS Recovery tab in the Task Pane.
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The Troubleshooting section appears if there are crash diagnostic messages or recovered
documents to display. If the software has a technical problem and an associated
troubleshooting message exists, the Welcome dialog box opens to the Troubleshooting

section automatically on startup, even if you selected Do not show on startup in the
dialog box.

Technical Alerts

The Technical Alerts section opens the contents of the SOLIDWORKS Support Bulletins
RSS feed at solidworks.com.
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SOLIDWORKS Fundamentals

This chapter includes the following topics:

e Adobe Illustrator Creative Cloud Files

e Application Programming Interface

e Default Templates for New Documents

e Include or Exclude Suppressed Components in Pack and Go

e Rebuild Tools

e Select Over Geometry

e Support for 3D Printing Models Containing Surface Bodies and Graphics Bodies

Adobe lllustrator Creative Cloud Files

SOLIDWORKS supports the Adobe Illustrator Creative Cloud platform. You can import
Creative Cloud files using the SOLIDWORKS application.

Application Programming Interface

See SOLIDWORKS API Help: Release Notes for late-breaking updates.
SOLIDWORKS 2018 API includes the ability to:

Access general tolerance table annotations and features.
Access hidden content in tables.
Add a distance mate between cylindrical components of an assembly.

Add and edit pairs of concentric mates (hole sets) between the same two components,
allowing for misalignment of concentric mates.

Add rebuild and save marks to multiple configurations and remove them from all
configurations.

Add specific display dimensions by type.

Create a spline constrained to a surface.

Create a trimmed sheet body with a specified tolerance.

Create advanced assembly mates and sweeps using improved API architecture.
Create advanced holes in parts.

Create and upgrade VB.NET and C# macros using Microsoft Visual Studio® Tools for
Applications (VSTA) 2015.

Create bidirectional twist and thin-walled sweep features.
Create internal and external threads.
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e Edit third-party native CAD components in assemblies.

e Expand and collapse indented items in BOMs.

e Get corresponding objects between drawing views and parts or assemblies.
o Get, edit, insert, or delete the below frame text of geometric tolerances.

e Get layer items by type.

e Get or set a custom property builder template for parts or weldments.

o Get or set component display state-specific properties in multiple assembly display
states.

e Get or set geometric tolerance leader options, All Over This Side and All Around
This Side.

e Get or set the balloon padding for existing notes in drawings.

o Get or set whether a configuration node is expanded in the ConfigurationManager.
e Get or set whether table text is all upper case.

e Get or set whether to automatically rebuild equations.

e Get or set whether to automatically repair files on opening.

e Get or set whether to display configuration names and descriptions in the
ConfigurationManager.

¢ Get or set whether to import DimXpert annotations when inserting or mirroring parts.
e Get or set whether to lock a magnetic mate.

e Get or set whether to show a slit in the corner relief of Flat-Pattern features.
e Get whether a custom property is editable in a configuration.

e Handle pre- and post-notify events when converting bodies.

e Import and export Hole Wizard and Toolbox data.

e Modify control points and interior knots in sketch splines.

e Offload PhotoView 360 rendering to other networked machines.

e Optionally rebuild a model after adding configurations.

e Override default part or assembly templates when creating a Split feature.

e Quickly check whether an interference exists between components.

e Save and restore the current SOLIDWORKS software settings.

e Select exploded views, create a regular explode step with rotation parameters, create
a radial explode step, and edit explode steps.

e Set table anchors at selected sketch points on drawing sheets.

e Set whether to expand all configurations in a specified pane of the
ConfigurationManager.

e Show the preview of a configuration selected in the ConfigurationManager.

Default Templates for New Documents

The templates specified in System Options > Default Templates are always used when
you create new documents directly from the Novice page of the New SOLIDWORKS
Document dialog box or from the Welcome dialog box.

Previously, if you created multiple templates, then depending on the template names and
folder locations, those templates might have been used instead of those specified in
Default Templates. You can still use alternate templates by clicking Advanced in the
New SOLIDWORKS Document dialog box or the Welcome dialog box.
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Include or Exclude Suppressed Components in Pack
and Go

This new option makes it easier for you to package a simplified copy of an assembly for
analysis, rendering, or other purposes, and to exclude proprietary components that you
do not want to share.

Suppressed components appear in the grid with the [Suppressed] notation. Clear Include
suppressed components to remove these from the grid and the target Pack and Go
file or folder. The suppressed components will still appear in the FeatureManager of the
packaged assembly, but their corresponding files will be excluded.

You can also include or exclude any components suppressed in the active configuration,
along with decals, drawings, and simulation results associated with those components.

This option is only available when you launch Pack and Go from the SOLIDWORKS File
menu.

Rebuild Tools

The Force Regen and Force Regen the Top Level Assembly tools have been renamed
to use the word Rebuild instead of Regen so that all rebuild tools use consistent
terminology.

The tools include:

;] Rebuild Rebuilds changed features.

8 Rebuild All Configurations Rebuilds changed features in all
configurations.

8! Force Rebuild Rebuilds all features.

] Force Rebuild All Configurations Rebuilds all features in all configurations.

Rl Force Rebuild Top Level Assembly Rebuilds all features in the top level
assembly.

Forced rebuilds can take significantly more time, depending on model complexity.

The Force Rebuild toolbar buttons are located on the Standard toolbar. You can add the
tools to the CommandManager, shortcut bars, and mouse gestures.

Keyboard shortcuts for Ctrl + Q and Ctrl + Shift + Q remain unchanged. This table
shows the various keyboard shortcuts:

Part Assembly Drawing Sketch

Rebuild Ctrl + B Ctrl + B Ctrl + B Ctrl + B
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Part Assembly Drawing Sketch

Rebuild All Ctrl + Shift + B Ctrl + Shift+ B Ctrl + Shift + B
Configurations

Force Rebuild Ctrl + Q Ctrl + Q Ctrl + Q

Force Rebuild Ctrl + Shift + Q Ctrl + Shift + Q Ctrl + Shift + Q
All
Configurations

Force Rebuild Ctrl + Q
Top Level
Assembly

Select Over Geometry

The Select Over Geometry tool lets you drag a box or lasso over a model without
starting the drag from an empty space in the graphics area.

This is helpful when you drag a box or lasso in a model that is zoomed in and you do not
have space in the graphics area to start dragging. Previously, if you tried to drag a box
or lasso on top of geometry, it selected the geometry and you could not create a selection.

To use Select Over Geometry:

1. PressT.
Select Over Geometry is also available in mouse gestures.
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2. Drag a box or lasso around the geometry to select.

Support for 3D Printing Models Containing Surface
Bodies and Graphics Bodies

SOLIDWORKS supports 3D printing of models that contain surface bodies and graphics
bodies only if they form a watertight manifold volume.

Previously, 3D printing of surface and graphics bodies was not supported and you could
only 3D print solid bodies. Now, you can 3D print surfaces or graphics bodies provided

they form a watertight manifold volume. Bodies that do not form a watertight manifold
volume are temporarily hidden and bodies that form a watertight manifold volume get

3D printed.

To 3D print a model, click File > Print3D @
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This chapter includes the following topics:

e Installing SOLIDWORKS CAM

Installing SOLIDWORKS CAM

SOLIDWORKS CAM is a manufacturing application that creates CNC programs to machine
your SOLIDWORKS parts and assemblies. It supports mill, turn, and mill assembly
machining. It is installed by SOLIDWORKS Installation Manager as part of the Individual
installation.

SOLIDWORKS CAM converts the design view of parts created by the SOLIDWORKS software
to a manufacturing view. It uses the part or assembly file to create machinable features
and generate toolpaths. When you update the model, those changes are automatically
reflected in the toolpaths.
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This chapter includes the following topics:

e Controlling Dismissed Messages

e Logging into SOLIDWORKS

e Show Document Open Times

e Specifying a Template for General Tables

e Task Scheduler Supports Additional File Formats

Controlling Dismissed Messages

The Settings Administrator Tool lets you manage common dismissed messages by users.

When you run the Settings Administrator Tool, you can block users from dismissing
messages by applying controls for Messages/Errors/Warnings. You can ensure that
some error messages and warnings always display or never display. These settings are
saved in the *.sldSettings file.

The Settings Administrator Tool was introduced in the previous release. Administrators
can use the tool to set system options when deploying the SOLIDWORKS software. It
is available when you install an Administrative Image and is stored in the following
default location: C:\SolidWorksAdmin\SOLIDWORKS
<version>\64bit\SOLIDWORKS\Program Files
64\SOLIDWORKS\sldSettingsAdmin.exe.

To enable control of dismissed messages:

1. Launch the Settings Administrator Tool and in the System Options tab, click
Messages/Errors/Warnings.

2. Check Apply and optionally check Lock@ for the messages you want to manage.

35



Administration

3. Set the message to Show or Don't Show.

If you select Show, the message is removed from a user's dismissed message list,
and displays to the user at the appropriate time. If you select Don't Show, the
message is automatically added to a user's dismissed messages list, and does not
display when the user is working on a model.

This table describes the behavior in the software:

Apply Lock Show Don't Behavior
Show

X X Force the message to show.

Dismisses the message and adds the
message to the dismissed message list.

Forces the message to show and disables
X X X the option to Don't show again in the
message box.

Dismisses the message and bars user
X X X from enabling it in Tools > Options >
Messages/Errors/Warnings.

4. When you choose Don't Show, you must also select a response to the silenced
prompt. The response to a message might be OK, Yes, No, or a short text string.

Users can override locked settings if you supply them with a password. When users hover
over a lock icon in Messages/Errors/Warnings, a dialog box prompts for a password.
With this password, users can unlock a message, and remove or add a message from
their dismissed messages list.

Logging into SOLIDWORKS

This release introduces a new login feature.

If you have a SOLIDWORKS online license, you must log in through the Login dialog box,
and you must be online when you log in. You use the same SOLIDWORKS ID to access
the Customer Portal, MySolidWorks, and the SOLIDWORKS Forums.

Additional benefits to logging in with the SOLIDWORKS ID are:

e Hyperlinks to web content within the SOLIDWORKS software will automatically log you
into SOLIDWORKS websites. These sites include the Customer Portal, MySolidWorks,
and forum links from the Task Pane and the new Welcome dialog box.

e Settings synchronization on all 2018 installations where you log in. By default,
customization and system options (excluding file locations) are synchronized. You can
opt to include the following settings to synchronize:

e System Options. All options in Tools > Options except file locations.
e File Locations. File locations listed in Tools > Optionsand Toolbox/Hole Wizard.
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e Customizations. These settings include toolbar layouts, menu customizations,
mouse gestures, and keyboard shortcuts.

If you have a SOLIDWORKS standalone or network license, you can use the Login dialog
box, but can also continue to start SOLIDWORKS as you currently do.

To log into the SOLIDWORKS software:

1. In the SOLIDWORKS title bar, click the Login icon .
In Email, type your SOLIDWORKS ID.

The SOLIDWORKS ID can be your email address.

3. In Password, type your password.
4. Click Log in.

The Login icon changes color to indicate that you are logged in.

You remain logged in until you click the Login icon© and click Log Out. Closing
SOLIDWORKS does not log you out.

Synchronizing Settings and Options Across Multiple Machines

If you use the SOLIDWORKS software with multiple machines, you can update your
settings on any of the machines and synchronize those settings across all machines. This
functionality is available only if you have online licensing and are implementing the new
Login feature in this release.

To synchronize settings and options across multiple machines:

1. In Tools > Options, click Synchronize Settings.
2. Choose between a manual or an automatic method:

e Synchronize Now

Download Settings and Upload Settings allow you to manually download settings
from other machines on demand, and to upload settings from the current machine
to a file in the cloud, where they are available when you log into one of your
machines.

e Automatic Synchronization

Settings and customizations created on other machines will automatically apply
to the machine when you log in, and changes you make on the current machine
are applied to other machines when you log into them.

Synchronization settings can vary on different machines. For example, you can set

one machine to automatically synchronize system options and file locations, but not
customizations, while another machine is set for manual downloads and uploads of

all types of option settings.

Administrator settings which are locked for each start-up of SOLIDWORKS cannot
be overwritten by the synchronization process.

3. Click OK.
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Show Document Open Times

When you hover over a SOLIDWORKS part, assembly, or drawing document in Windows
Explorer, a tooltip displays how long it took to open the document the last time it was
opened.

This feature helps you effectively manage your time when you work with larger assemblies
and drawings.

Last Open Time displays in minutes and seconds, and is available for models which are
opened directly from disk saved in SOLIDWORKS 2018.

For assemblies opened in Lightweight mode, the tooltip displays Last Open Time and
also, Last LW Open Time.

Last Open Time does not update in reference files when they are saved while open in
memory, but does update when the reference files are saved while open in their own
window.

You can also add a column in Windows Explorer to see SW Open Time for all files, and
you can identify files saved in earlier versions of SOLIDWORKS by adding a column for
SW Last Save with. This column is not new in 2018, but is helpful in combination with
SW Open Time. To add these columns, right-click on any of the column headers, and
select More... Then in the Choose Details dialog box, scroll to and select SW Last Saved
with and SW Open Time, and click OK.

Last Open Time can be influenced by factors such network bandwidth, hard drive
speed, SOLIDWORKS options, and the state of the computer and models when the file
was last opened.

Specifying a Template for General Tables

You can specify a file path for a general tables template in Systems Options > File
Locations. This template helps users to consolidate styles and formatting.

Previously, users could not specify a file location for a general tables template.

Task Scheduler Supports Additional File Formats

The Task Scheduler imports and exports additional file formats.

The following tables list the different types of files you can import and export using the
SOLIDWORKS software:

Parasolid X_E .xCb; oxmt_txt; .xmt_bin
IGES .igs; .iges
STEP .stp, .step
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ACIS .sat
VDAFS .vda
SLDXML .sldlm
Rhino .3dm

For IGES, STEP, ACIS and SLDXML files, you have an option to run import diagnostics
and to import multiple bodies as parts

Parasolid X_t, .x_b
ACIS .sat
VDAFS .vda
VRML wrl

STL .stl

3D Manufacturing Format .3mf
Microsoft XAML .XAML
CATIA Graphics File .cgr
HOOPS HSF hsf

HCG .hcg

Certain file types have their own tab in the Task Scheduler where you can select more
options for export.
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This chapter includes the following topics:

e Asset Publisher and Magnetic Mates Enhancements
e Changing the Transparency of an Assembly or Multibody Part
e Check Entity Enhancements

e Mates

e Misaligned Mates

e Motion Study Menu Enhancements

e Pattern Enhancements

e Performance Evaluation Enhancements

e Smart Explode Lines

e SpeedPak

e Treehouse Enhancements

Asset Publisher and Magnetic Mates Enhancements

¢ You can define multiple ground planes 9 in an assembly. You can have only one active
ground plane at a time. Components with magnetic mates and a defined ground plane
are placed on the active ground plane.

e When inserting a component with a magnetic mate, you can cycle through the
connection points by using keyboard shortcuts. Use the left bracket [ to cycle through
connection points on the moving component. Use the right bracket ] to cycle through
connection points on the static component.

e After inserting a component with a magnetic mate, you can enable the magnetic mate
lock by clicking the Lock mate @ icon near the cursor.

Defining Multiple Ground Planes in an Assembly

An arrow indicates the active ground plane. You can add a ground plane or activate a
different ground plane.

To add a ground plane:

1. Click Insert > Reference Geometry > Ground Plane.
For assemblies that have an existing ground plane, right-click the Ground Planes
folder in the FeatureManager design tree, and click Insert Ground Plane.

2. Select a ground plane.
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3. Click ¥.

To activate a ground plane:

1. In the FeatureManager design tree, expand the Ground Planes folder 3,

2. Double-click the ground plane 9 that you want to activate, or right-click the ground
plane and click Activate.

Using the Keyboard Shortcuts

To use the keyboard shortcuts to cycle through connection points:

Select the component to use in @ magnetic mate. With the component selected, use [ or
] to cycle through the connection points.

To customize the keyboard shortcuts:

1. Click Tools > Customize > Keyboard.
2. In Category, select Others.

3. Under Command, select Cycle connection point (moving component) or Cycle
connection point (static component) to change the keyboard shortcut.

Changing the Transparency of an Assembly or
Multibody Part

You can change the transparency of all components in an assembly or in a multibody
part. Multibody parts and components that display in Shaded ¥* or Shaded with Edges
@ modes change from opaque to transparent.

To change the transparency, right-click the assembly and click Top Level Transparency
&9 on the context toolbar.

For components that are transparent when you change the assembly to transparent:

e If you do not change the transparency of the component, the component remains
transparent when you change the assembly to opaque.

e If you change the transparency of the component, the component becomes opaque
when you change the assembly to opaque.

Check Entity Enhancements

For assembly documents, the Check Entity dialog box returns information about the
component name if an assembly contains components that have undesirable geometry.
Examples of undesirable geometry include invalid faces, invalid edges, short edges,
minimum radius of curvature, edge gaps, and vertex gaps.

To exclude checks for open surfaces in an assembly, clear the Open surface(s) option.
Use the Isolate command to isolate the components that have undesirable geometry.
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To isolate a component:

1. With an open assembly, click Check @ (Tools toolbar) or Tools > Evaluate > Check.

2. Click Check to check for components that have undesirable geometry.

3. Select a component from the Result list to highlight the component in the graphics
area. Information about the component appears in the message area.

4. Click Isolate to isolate the component.

5. Click Exit Isolate (Isolate pop-up toolbar) to return to the Check Entity dialog box.

6. Click Close and Isolate faults to isolate all components that have undesirable
geometry when you close the Check Entity dialog box.

Mates

Perpendicular Mates

You can apply a perpendicular mate between a complex, non-analytic surface and a linear
entity like a line, an edge, an axis, or an axial entity.

To create a perpendicular mate:

H oW

Click Mate (Assembly toolbar) or Insert > Mate.
In the Mate PropertyManager, under Standard Mates, click Perpendicular.
For Entities to mate, select a linear entity and a non-analytic surface.

Click ¥ twice to close the PropertyManager.

Temporarily Hiding Faces when Selecting Mates

Use the Alt key to temporarily hide a face when you need to select an obscured face for
mates.

You can use this keyboard shortcut only with the following Mate commands:

Insert Mates
Edit Mates

Copy with Mates
Mated Entities

The components must be displayed in Shaded ¥ or Shaded with Edges @ modes.
After you select a mate, the hidden faces become visible.

To temporarily hide a face:

1.

Click Mate N (Assembly toolbar) or Insert > Mate.

With focus in the graphics area, hover over a face and press Alt. The face is
temporarily hidden.

To show the temporarily hidden face, press Shift + Alt.

To show all temporarily hidden faces in a semi-transparent state, press Ctrl + Shift
+ Alt.
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5. To restore visibility to all temporarily hidden faces, press ESC.

Misaligned Mates

Allowing Misaligned Concentric Mates

If you have components with two holes, you can mate those components even when the
holes are not the same distance apart.

You can align the mate to resolve exactly with either the first or the second concentric
mate and apply the offset to the concentric mate that is not aligned. Or you can apply
the offset equally to both sets of mated holes. You can also specify an allowed tolerance,
beyond which the misaligned mates over define the assembly and display an error.

To allow misaligned mates:
1. In an assembly, add a concentric mate between the first pair of holes.

LB =]v)

|:| Lock rotation

2. Add a concentric mate between the second pair of holes.

S Lo EiaH a7 [=][v]
Align Linked mate

43



Assemblies

3. In the dialog box, click Create this mate using misalignment options.

If you do not see Create this mate using misalignment options in the dialog
box, go to Tools > Options > System Options > Assemblies and select the
Allow creation of misaligned mates option.

4. 1In the PropertyManager, select Align Linked mate for the misalignment type.
5. Click ¥
In the graphics area, you can click Section View o (Heads-up View toolbar) and

zoom to view the edges of each mate. Notice the gap between the surface and edge
in the second mate.

First mate solves
exactly

Second mate displays
misalignment distance

In the FeatureManager design tree, the two concentric mates show in a Misaligned folder
% under the Mates folder.

Assemblies System Option for Misaligned Mates

You can enable or disable the creation of misalignhed mates in System Options.
To allow creation of misaligned mates:

1. Click Tools > Options > System Options > Assemblies.
2. Select Allow creation of misaligned mates.

Document Properties - Mates

You can specify document properties for misaligned mates.

With an assembly open, click Tools > Options > Document Properties > Mates.
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Misaligned mates

Maximum deviation Specify the maximum deviation allowed for misaligned
mates.

Default misalignment Select a default misalignment type:
Align first concentric Solves the first concentric
mate mate exactly, and applies

all the misalignment to the
second concentric mate.

Align second concentric Solves the second

mate concentric mate exactly,
and applies all the
misalignment to the first
concentric mate.

Symmetric Applies half of the
misalignment to each
concentric mate.

Motion Study Menu Enhancements

Motion symbols automatically appear when you export animations of motion studies.
You can hide or show motion symbols for motion studies by selecting View >
Hide/Show > Motion Symbols &.

Pattern Enhancements

Including Material and Visual Properties in a Mirrored Part

When you mirror a part from a part environment or an assembly context, you can select
the material and the visual appearance of the part to include in the derived part.

In the Mirror Components PropertyManager, the Material option is selected by default.
To change the material of the derived part, clear the Material option.

The Propagate from original part option in the Visual Properties section mirrors color
assignments from the parent part to the derived part. Mirrored colors include colors
assigned to the part, bodies, features, and faces.

The Material and Propagate from original part options are available only when you
mirror a part or when you insert a part into another part for the first time. These options
are not available when you edit the mirror feature or the inserted part.
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Select material and visual appearance to include in a derived part:

1. Click Mirror Components [ak] (Assembly toolbar) or Insert > Mirror Components.
In the PropertyManager, follow the steps to create a mirror pattern.

Click Create opposite hand version in Step 2: Set Orientation to continue
through the PropertyManager.

3. In Step 4: Import Features, under Transfer, select Material. Under Visual
Properties, select Propagate from original part.

4. Click ¥ to create the mirrored component.

Linear Pattern Enhancements

Use linear patterns to rotate pattern instances along a pattern direction.
You can rotate instances as follows:

¢ Rotate instances based on an input value.
e Rotate instances about a selected axis.
e Align rotated instances to the seed instance.

To rotate a linear pattern along pattern Direction 1:

1. Click Linear Component Pattern BE (Assembly toolbar) or Insert > Component
Pattern > Linear Pattern.

2. In the Components to Pattern section, add a component to pattern.
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3. In the PropertyManager, select options under Direction 1:

Pattern Direction

Defines the direction to extend the pattern.
Select a linear edge or a linear dimension.

e Number of Instances

Specifies the total number of instances including
the seed components.

Rotate instances

Rotates the instances based on an input value
around a selected axis.

Axis of rotation

Specifies the axis that the pattern rotates
around.

's" Reverse Direction

Reverses the direction of the rotation.

|4  Angle

Specifies the angular increment for each pattern
instance.

Align to seed

Aligns each instance to match the original
alignment of the seed feature.

Reference point

Select a reference point:

e Bounding box center
e Component origin

These options appear when you select Align to
seed.

4. Click ¥.
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Performance Evaluation Enhancements

Assembly Open Progress Indicator

The Assembly Open Progress indicator provides information on the status of operations

while you open an assembly.

*

Opened 3016 Assembly
Components Updated

Graphics
Generated

This file took & minutes and 24 seconds to open

Far more information, view: &? Performance Evaluation

This file was last opened in 2 minutes and 49 seconds

|:| Do not show again

For assemblies that take longer than 60 seconds to open, the indicator remains open

after the assembly opens.

The indicator provides information on the following operations:

Open Components

Loads the top-level assembly and reference documents.
Shows the number of components opened and the total
number of files in the assembly.

Update Assembly

Updates models including mates, assembly features,
patterns, and in-context models.

Update Graphics

Generates graphics.

Elapsed time

Shows the amount of time required to open the assembly.

Previous time to open

Shows the amount time required to open the assembly
the last time the assembly was opened.

The Previous time to open operation is specific to the
assembly mode. This information is saved for Large
Assembly mode, Lightweight mode, and Resolved mode.

After opening the assembly, click Performance Evaluation in the indicator dialog box
to view performance information specific to opening the assembly. To view the performance
information at a later time, click Tools > Evaluate > Performance Evaluation.

You can suppress the Assembly Open Progress indicator by selecting Do not show again.
To restore the progress indicator, click Tools > Options > System Options >
Messages/Errors/Warnings, and select Assembly Open Progress Indicator.

48



Assemblies

If you enable the No preview during open (faster) option, the Do not show again
option does not appear. To disable the No preview during open (faster) option, click
Tools > Options > System Options > Performance to clear the option.

Assembly Visualization Enhancements

The Assembly Visualization tool includes a set of predefined columns to help troubleshoot
assembly performance. You can view the open and rebuild times for the components,
and the total number of graphics triangles for all instances of components.

Other enhancements include the addition of a Performance Analysis & button, and

moving the buttons to the same line as the Filter field \:J,. An updated user interface
improves the usability by using more readable text and icons.

To view Performance Analysis information:

1. Click Assembly Visualization 49 (Tools toolbar or Evaluate tab on the
CommandManager) or Tools > Evaluate > Assembly Visualization.

2. On the Assembly Visualization tab @, click the Performance Analysis button.
You can also click the arrow » to the right of the column headers and click
Performance Analysis.

The following columns appear:

e File Name

e Quantity

¢ Total Graphics-Triangles
¢ SW-Open Time

e SW-Rebuild Time

Performance Evaluation Tool Enhancements

Performance Evaluation provides more information on the open, display, and rebuild
performance of models in an assembly.

To open the Performance Evaluation [} tool:

¢ Click Performance Evaluation in the Assembly Open Progress Indicator dialog box.
¢ Click Tools > Evaluate > Performance Evaluation.

New Performance Evaluation checks that are available:

Document Open File Lists files by the amount of time required to open the file.
Details
Modified on Open Indicates the number of files that are updated while the

assembly opens. Click Show These Files B to view the
list of updated files.
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Graphics Triangles

Lists files by the number of graphic triangles contained in
a part.

Files with less than 5,000 graphic triangles are not listed.

Shaded Image Quality

Lists the files where image quality is medium-high or very

high. Click % Show These Files to view a list of affected
files.

For image quality, click Tools > Options > Document
Properties > Image Quality. In the Shaded and draft
quality HLR/HLV resolution section, move the Low
(faster) - High (slower) slider to change the image
resolution.

Parts with very high image quality have the slider set
at 80% or greater. Parts with medium-high image
quality have the slider set at 60% - 80%.

If the list of files does not appear, go to Tools >
Options > Document Properties > Image Quality and
clear the Apply to all referenced part documents
option. A message about assembly image quality appears
when you have the Apply to all referenced part
documents option selected and meet the following
conditions:

¢ Shaded and draft quality HLR/HLYV resolution slider
is set above sixty percent.

e Number of components in the assembly is equal or
above the Large Assembly Mode threshold.

Appearance

Displays a warning if a file contains over 100 appearances

applied to faces. Click Show These Files % to view the
list of affected files.

Performance Evaluation checks are organized in the following categories:

Open Performance

e Open Summary

e Document Open File Details
e Previous Version References
e Modified on Open
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Display Performance

Graphics Triangles

Shaded Image Quality
Display Speed

Appearance

Components Far From Origin

Rebuild Performance

Rebuild Data Unavailable

Rebuild Report

Mate

In-Context Part Performance
In-Context Relationship Performance
In-Context Relationship Conflict
Assembly Rebuild Report

In SOLIDWORKS 2018, the In-Context Circular
References check is renamed to Assembly Rebuild
Report.

Settings Performance

Verification on Rebuild
Large Assembly Mode

Statistics

Parts
Subassemblies
Components
Assembly

Click Assembly Visualization to open the Assembly Visualization tool.

Smart Explode Lines

Creating and Dissolving Smart Explode Lines

You can create smart explode lines automatically for components in an exploded view.

You can view the associated explode steps for a selected component in the Smart Explode
Lines PropertyManager. Smart explode lines use the bounding box center as a reference

point by default.

You can use smart explode lines along with manually created explode lines. To use a

different path for an explode line, you must manually create the explode line or dissolve
the smart explode line. You cannot add a component to the explode steps using the Smart
Explode Lines PropertyManager.

When you change the explode steps, the smart explode lines update automatically.
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To create smart explode lines:

1. Open an assembly that contains an exploded view.

2. On the ConfigurationManager 2 tab, expand the active configuration.
Right-click the ExplView @ feature and click Smart Explode Lines &,
4. 1In the Smart Explode Lines PropertyManager, click ¥ .

The exploded view contains the smart explode lines.

To edit smart explode lines:

1. On the ConfigurationManager 2 tab, expand the active configuration.

2. Right-click the ExplView @ feature and click Edit Smart Explode Lines @:.

3. Inthe Smart Explode Lines PropertyManager, modify the settings for the smart explode
lines.

4. Click ¥.

Dissolving Smart Explode Lines

To change a line created by using the Smart Explode Lines option, you must dissolve
the smart explode line.

To dissolve a smart explode line:

1. On the ConfigurationManager 2 tab, expand the active configuration.

2. Expand the ExplView @ feature.
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3. Right-click the 3DExplode a” sketch and click Edit Sketch.

When you edit the sketch, the smart explode lines appear in the color selected for
the Highlight setting. To change this color, click Tools > System Options >
Colors. In the Color scheme settings section, select Highlight.

4. Right-click the smart explode line and click Dissolve Entities 5-"*13.

In the following image, the route line on the right side is dissolved. The route line on
the left side remains a smart explode line.

To dissolve all smart explode lines:

1. On the ConfigurationManager 2 tab, expand the active configuration.
2. Expand the ExplView @ feature.

LR

3. Right-click the 3DExplode @" sketch and click Dissolve Smart Explode Lines ',
To edit the lines, you must edit the sketch.

Smart Explode Lines PropertyManager

In an assembly exploded view, you can create explode route lines automatically for
selected components by using the Smart Explode Lines PropertyManager.

To open the Smart Explode Lines PropertyManager:

1. On the ConfigurationManager 2 tab, expand the configuration.

2. Right-click the ExplView @ feature and click Smart Explode Lines @?.
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If smart explode lines already exist, click Edit Smart Explode Lines.

Components

Components

Select the components that have an associated explode
step.

Apply to all component
instances

Copies the explode line options from one component to
the other instances of the same component.

This functionality is available when:

¢ The Component origin option in the Component Route
Line section is selected.

e The Components section contains at least one other
instance of the selected component. The configuration
and display state of the other component instance must
match the configuration and display state of the
selected component.

e The explode steps of the other instances match the
explode steps of the selected component.

The comparison of the explode steps occurs in the
parent explode view. The comparison does not occur
in the Explode Step check boxes.

Select the subassembly
parts

When selected, enables you to select individual
components of a subassembly. When cleared, enables you
to select an entire subassembly.

Component Route Line

Bounding box center

Locates the explode line relative to the bounding box
center of the selected component.

Component origin

Locates the explode line relative to the origin of the
selected component.

Selected point

Locates the explode line relative to the selected point.

Select reference point

Select a point to use for the Selected point. The selected
point can be a point, a vertex, a sketch arc, an edge arc,
a sketch line, or an edge line.
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Explode Steps

Explode Step Lists the explode steps in order.

Route line Select the explode steps to include in the route line.

SpeedPak

Setting a Rebuild on Save Mark on SpeedPak Configurations

You can set a Rebuild on Save mark sl on a SpeedPak Configuration in multiple ways.

Setting a Mark in the ConfigurationManager

1. On the ConfigurationManager 2 tab, right-click the assembly and click Rebuild on
Save Mark.

2. Select Add Mark for SpeedPak Configurations.

Setting a Mark in the SpeedPak PropertyManager

1. On the ConfigurationManager 2 tab, under the active configuration, right-click an
existing SpeedPak configuration and click Edit SpeedPak.

2. Inthe SpeedPak PropertyManager, select Add Rebuild on Save Mark in the Options
section.

Updating SpeedPak Configurations Automatically

You can use the Update out-of-date SpeedPak configurations when saving files
option to automatically update SpeedPak configurations. You can lock this option in the
Settings Administrator Tool.

To specify the Update out-of-date SpeedPak configurations when saving files
option:
1. Click Tools > Options > System Options > Assemblies.

2. For Update out-of-date SpeedPak configurations when saving files, select one
of these options:

All Update all out-of-date SpeedPak configurations.

None Do not update any out-of-date SpeedPak
configurations.

With Rebuild on Save Update out-of-date SpeedPak configurations that have

mark the Rebuild on Save mark [&.
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Treehouse Enhancements

Display Files in a List View

You can perform many of the same tasks in the list view that you perform when viewing
the Treehouse structure in the graphical user interface:
e To open a file, right-click the icon in the Type column and click Open.

e To hide a column, right-click a column heading and clear the column entry. To reorder
columns, drag the column.

e To save an existing document as a new copy, double-click the document name and
change the name.

The document name turns green to indicate that the document is saved as a new
document.

When saving an existing document as a new copy, you must work from the top
down. For example, if you have an existing assembly document in the hierarchy and

you want to save a component of that assembly as a new document, you must first
save the assembly as a new document.

e For new documents, to change the file path in the Destination Folder Path column,
click Select the Save to Folder (= and select the destination folder.

A new document can have the same name as an existing document when the
Destination Folder Path is different.

e To open the Treehouse structure in Microsoft Excel, click Open in Excel .
To display files in a list view:

1. Click Display in a List view "E to open the list view.
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§E faucet_assembly EI@
Type Document Name Quantity Active Configuration

(@] (=) faucet_assembly.sldasm Default

@ auce 1

& aucet_ste 2 .
i Suce - 2 -
L cE

k

[ OK |[ Cancel |[ Apply |

In the List view, suppressed files are not shown and you cannot change the active
configuration.

To change the active configuration:

In the graphical user interface, hover over an assembly and click Q.
In the configuration list, select the configuration to switch from.

In the drop-down list, select a configuration to switch to.
Click Switch.

s =

Hiding Suppressed Documents

You can hide suppressed documents to simplify the assembly structure that appears in
Treehouse.

To hide suppressed documents:

9
1. Click aﬂ

2. Clear Display the suppressed documents in the View section.
3. Click Apply and then OK.
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Print Options

Click Print & to view these options:

&  Print Extents Prints to the extents of the structure.

&  Print Display Prints the part of the extents that are displayed. Use
Zoom to Area oO“ to print a specific part of an extent.

@ Print Preview Shows a preview of the current print selection. The
preview is based on the paper size, scale, and
orientation.

User Interface

User interface enhancements include:

e To view a specified area of the Treehouse structure, click Zoom to Area joly
e Double-click the middle mouse button to zoom extents.
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This chapter includes the following topics:

e Documentation

e Rebranding

e Setting Subroutines for Parts

e Setting the Toolpath Output Folder
e Technology Database

e User Interface Improvements

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Documentation

All documentation, including the installation guide, online help, and tutorials, is available
for SOLIDWORKS CAM.

Rebranding

Geometric Ltd. and HCL have merged. All rebranding changes have been completed in
the installer, software, registry, and related documents.

Geometric Ltd. is now HCL Technologies Ltd.

Setting Subroutines for Parts

You can set the subroutines to specify whether parts are output in subprogram format
or long code.

To set subroutines for parts:
1. In the SOLIDWORKS CAM tree, in the Machine dialog box, click the Posting tab.
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2. Under Subroutines, select an option:

Option Description

Output subroutines for patterned (Mill module only.) Sets subprograms for
Features mill parts to work for pattern Features.
Output subroutines (Assembly module only.) Sets

subprograms for similar parts in
assemblies that are managed in the
PartManager.

3. Click OK.

Setting the Toolpath Output Folder

You can set the toolpath output folder by tool, feature, and part for multiple parts in
assemblies.

To set the toolpath output folder:

1. In the SOLIDWORKS CAM tree, in the Machine dialog box, click the Setup tab.
2. Under Output multiple parts by, select an option:

Option Description

Tool Processes (posts/simulates) all toolpaths
machined by the tool on one part, then
repeats the sequence for other part
instances. This process starts with the
first feature and continues for consecutive
operations that use the same tool.

Feature Processes the toolpath on each instance
of a feature before moving to the next
feature.

Part Processes all of the toolpaths on a part,

then processes the next part.

3. Click OK.
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Technology Database

Non-supported operations and conditions have been removed from the Technology
Database.

User Interface Improvements

Several improvements have been made to the user interface.

CommandManager

For readability, icons of 64, 98, and 128 DPI are available in the CommandManager. In
addition, the icons are stacked with horizontal text.

Display Colors

The default display colors have been modified for Stock, Features, Operations, and
Simulation.

Save Operation Plan

For ease of use, the Save Operation Plan tool is available on the CommandManager.

Previously, the Save Operation Plan EB tool was only available when you right-clicked
a feature.
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This chapter includes the following topics:

e Building Model as a Part in CircuitWorks
e Usability Improvements
e Ability to Recognize SOLIDWORKS Features in CircuitWorks

CircuitWorks is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Building Model as a Part in CircuitWorks

You can open ECAD files directly in CircuitWorks using an option in the SOLIDWORKS
software.

You can open an IDF file directly in CircuitWorks by clicking File > Open in SOLIDWORKS.
Previously, with this option, you could only build a CircuitWorks file as an assembly in
SOLIDWORKS. A new option in CircuitWorks allows you to build a CircuitWorks file as a
part in SOLIDWORKS.

To build a model as a part in CircuitWorks:

1.
2.

Click Tools > Add-Ins to load the CircuitWorks add-in.

Click CircuitWorks Options (CircuitWorks toolbar) or Tools > CircuitWorks >
CircuitWorks Options.

In the CircuitWorks Options dialog box, on the General tab, under General options,
clear Open files in CircuitWorks Lite.

Click File > Open and navigate to system dir:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\CircuitWorks\BasicBoard.emn.

The file opens in CircuitWorks.

You can edit any of the board entity properties by right-clicking Components,
clicking Properties, and modifying the Component Instance Properties.

In the CircuitWorks menu, click Tools > Build Model as Part.
If a dialog box prompting a warning appears, click OK.

The CircuitWorks file is built as a part in SOLIDWORKS.

You can edit the part in SOLIDWORKS and export it back to CircuitWorks by clicking
Tools > CircuitWorks > Export to CircuitWorks.
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Usability Improvements

Controlling CircuitWorks User Options from an Administrator
Location Using Windows User Permissions

You can control the CircuitWorks options by setting up the Administrator Options file
location in the CircuitWorks Setup Wizard.

To control CircuitWorks user options from an administrator location using
Windows User Permissions:

1. Set up CircuitWorks options for users.

An administrator location can be any shared folder where the Options XML file is
present. A user can be an administrator or a client depending on his Windows user
rights on the shared folder.

2. In SOLIDWORKS, click CircuitWorks Options (CircuitWorks toolbar) or Tools >
CircuitWorks > CircuitWorks Options.

3. In CircuitWorks Options, on the General tab, under CircuitWorks Setup Wizard,
click Show Wizard.

4. In CircuitWorks Setup Wizard, do the following:
a) Click Next.
b) On the Set Library Location pane, for Select Admin XML File, click Browse
to specify the location.
5. In the Browse For Folder dialog:
a) Navigate to the folder specified in step 4.

b) Double-click the file with the name ecadopt.xml/ecadoptAdmin.xml or any
valid xml options file.

Editing Reference Designators of Multiple Components

You can edit Reference Designators of multiple components simultaneously in
SOLIDWORKS.

To edit multiple reference designators:

1. In the SOLIDWORKS software, click File > Open and open a CircuitWorks file.

2. On the Circuitworks tab, right-click a component and click Edit Reference
Designators.

3. In the Edit Reference Designators dialog box, under New Reference Designators
column, type the new reference designators for components.

4. Click Update.
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Setting Up Administrator Rights

You can set up the administrator rights or user rights for CircuitWorks options. You can
enable or disable the rights of other users to edit files by providing access to folders for
a fully-editable or read-only mode.

To set up administrator rights:

1. In SOLIDWORKS, click CircuitWorks Options (CircuitWorks toolbar) or Tools
CircuitWorks CircuitWorks Options.

2. In CircuitWorks Options, in the General tab, do one of the following:

e Under Specify Admin file to set CircuitWorks options, click B to specify the
XML file.

e Under CircuitWorks Setup Wizard, click Show Wizard and do the following:
1. In CircuitWorks Setup Wizard, navigate to Set Library Location pane, for
Select Admin XML File.
2. Click Browse to specify the location.

3. In the Browse For Folder dialog box:
a) Navigate to the file specified in step 3.

b) Right-click the file and click Share with > Specific people to provide Read or
Read/Write access.

Ability to Recognize SOLIDWORKS Features in
CircuitWorks

When you export SOLIDWORKS board files to CircuitWorks using the CircuitWorks Export
Wizard, the Wizard recognizes and translates the SOLIDWORKS features into CircuitWorks
terms.

Supported features:

¢ Fillet

e Chamfer

e Cut Extrude Holes/ Simple Holes/ Advanced Holes/ Hole Wizard
e Linear Pattern

o Sketch Driven Pattern

e Curve Driven Pattern

e Circular Pattern

e Blocks in sketches.
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Exporting SOLIDWORKS Features Using the CircuitWorks Export
Wizard

You can export selected features from SOLIDWORKS parts into CircuitWorks using the
CircuitWorks Export Wizard Task Pane.

To export SOLIDWORKS features using the CircuitWorks Export Wizard:

1.

Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\circuitworks\BoardFeaturesl.sldprt.

In the SOLIDWORKS software, click Export to CircuitWorks iy (CircuitWorks toolbar)
or CircuitWorks > Export to CircuitWorks.

In the CircuitWorks Export Wizard Task Pane, Select Top of Board and click Next
until you reach Select the Board Outline.

For Select the Board Outline:
a) Click Use the following SOLIDWORKS feature.

b) | When you click on the feature, the software converts the feature name to
CircuitWorks-specific name. The old name appears under Selected Feature and
the new name appears under New Name in the CircuitWorks Task Pane.

In the FeatureManager design tree, select the Board and Chamferl features.
c) Click Next.
For Select the Nonplated Hole Features:
a) In the FeatureManager Design Tree, select Holel.
b) Click Next.
For Select the Plated Hole Features:

a) In the FeatureManager Design Tree, select Hole2.

b) Continue to click Next in the CircuitWorks Export Wizard Task Pane, until you
reach Finish.

Click Finish.

The software exports the part into CircuitWorks and opens it in the CircuitWorks
application.

Editing Hole Features in the CircuitWorks Export Wizard

You can edit individual hole features in the CircuitWorks Export Wizard Task Pane by
clearing individual hole selections or renaming instances..

To edit hole features in CircuitWorks:

1.

Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\circuitworks\BoardFeatures2.sldprt.

In the SOLIDWORKS software, click Export to CircuitWorks iy (CircuitWorks toolbar)
or CircuitWorks > Export to CircuitWorks.

In the Circuitworks Export Wizard Task Pane, click Next until you reach Select the
Board Outline.
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4. For Select the Board Outline:
a) Click Use the following SOLIDWORKS feature.

b) | When you click on the feature, the software converts the feature name to
CircuitWorks-specific name. The old name appears under Selected Feature
and the new name appears under New Name in the CircuitWorks Task Pane.

In the FeatureManager design tree, select Board @l and Fillet1 ®.

c)
d) Click Next.

5. For Select the Nonplated Hole Features:
a) In the FeatureManager design tree, click Holel @,

b)
c) Click Next.
6. For Select the Plated Hole Features:
o
a) In the FeatureManager design tree, click CirPattern2 F=7,
b)
¢) Inthe Task Pane, under Feature Name, clear PTH 2 and PTH 3.

d) For PTH, under New Name, type Seed Hole.
e) Click Next until you reach Finish.

7. Click Finish.

The software exports the board, containing only the selected holes using the renamed
instances, into CircuitWorks. The board opens in the CircuitWorks application.
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This chapter includes the following topics:

e SOLIDWORKS Composer
e SOLIDWORKS Composer Sync
e SOLIDWORKS Composer Player

SOLIDWORKS Composer

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical
contents for product communication and technical illustrations.

Label Orientation and Label Position for Measurements

A new section, Label, has been created in the Properties pane for measurements, to
manage the display of measurement labels. It contains two new properties, Label
orientation and Label position.

A few existing properties have been moved to this new Label section: Center value,
Shape, Color, and Opacity. See Measurement Properties in the Composer help.

Support of Favorite Context

When importing 3DXML files that contain 3D Tolerancing & Annotation captures, favorite
context is now supported.

The visibility of geometrical elements is properly managed, provided that the favorite
context is defined on the annotation set that contains the capture.

Support of Pro/E Creo 3.0

Pro/E Creo 3.0 is now supported.
See About Supported Import Formats in the Composer help.
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Padding for Measurements
In certain cases, the software applies padding around measurement values to improve
legibility.

When the label orientation is set to Auto, if a measurement value overlaps the leader
line and you set its label's shape to None, some padding will be applied around the
measurement value to ensure that it remains easy to read.

Write Outlines

A new document property is available to configure SMG outputs.

It saves outlines along with the 3D model. Thus, whenever the model is opened, or
whenever you change to a render mode that uses outlines, outlines are loaded immediately
(as it is no longer required to compute them each time they must be loaded).

See SMG, SMGXML, SMGPROJ Output in the Composer help.

Composer files in SMG, SMGXML, and SMGPROJ formats for which outlines are saved now
contain a .smgOutlines file.

SOLIDWORKS Composer Sync

Support of Favorite Context
When importing 3DXML files that contain 3D Tolerancing & Annotation captures, favorite
context is now supported.

The visibility of geometrical elements is properly managed, provided that the favorite
context is defined on the annotation set that contains the capture.

Support of Pro/E Creo 3.0

Pro/E Creo 3.0 is now supported.

See About Supported Import Formats in the Composer help.

Write Outlines

A new document property is available to configure SMG outputs.

It saves outlines along with the 3D model. Thus, whenever the model is opened, or
whenever you change to a render mode that uses outlines, outlines are loaded immediately
(as it is no longer required to compute them each time they must be loaded).

See SMG, SMGXML, SMGPROJ Output in the Composer help.

Composer files in SMG, SMGXML, and SMGPROJ] formats for which outlines are saved now
contain a .smgOutlines file.
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SOLIDWORKS Composer Player

Label Orientation and Label Position for Measurements

A new section, Label, has been created in the Properties pane for measurements, to
manage the display of measurement labels. It contains two new properties, Label
orientation and Label position.

A few existing properties have been moved to this new Label section: Center value,
Shape, Color, and Opacity. See Measurement Properties in the Composer help.

Padding for Measurements
In certain cases, the software applies padding around measurement values to improve
legibility.

When the label orientation is set to Auto, if a measurement value overlaps the leader
line and you set its label's shape to None, some padding will be applied around the
measurement value to ensure that it remains easy to read.
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SOLIDWORKS Costing

This chapter includes the following topics:

Calculating the Cost of Custom Operations for Selected Materials
Costing Template Enhancements

Evaluating the Cost of Assembly Operations

Organizing and Saving Costing Data Locally

SOLIDWORKS Costing is available in SOLIDWORKS Professional and SOLIDWORKS Premium.
Costing for assemblies is available in SOLIDWORKS Premium only.

Calculating the Cost of Custom Operations for Selected
Materials

You can define Material class for custom operations for selected materials or all materials
in the Custom tab of the Costing Template Editor.

To calculate the cost of custom operations for selected materials:

1.
2.

3.

B

Open a sheet metal or machined part.

Click Costing & (Evaluate tab on the CommandManager) or Tools > SOLIDWORKS
Applications > Costing.

Click Begin Cost Estimation.

In the Costing Task Pane, click Launch Template Editor.

On the Custom tab of the Costing Template Editor, for the Painting custom operation:
a) Click All to display the drop-down list.

b) Click Selected.

c) In the dialog box, under Available Material class, select Steel.

d) Click Add.

e) Click OK.

Click Save As &,
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7. In the dialog box:

a) Navigate to system dir:\Program Files\SOLIDWORKS
Corp\SOLIDWORKS\lang\english\Costing templates if it is not your default
location.

b) For File name, type SteelTemplate.

c) For Save as type, select Template database files(*.sldctm) for machined
parts, and Template database files(*.sldcts) for sheet metal parts.

d) Click Save.
e) Click *.
8. In the Costing Task Pane:

a) Under Template, select SteelTemplate.
b) Under Material, select Steel for Class.

When you select Always Include, the calculated cost for the Painting custom
operation is always included in the CostingManager for SteelTemplate.

Costing Template Enhancements

Machining and Sheet Metal Template Enhancements

On the Milling tab of machining templates, you can input values for TER: Tool
engagement ratio under TER (%). On the Cut tab of sheet metal templates, you can
input values in Unit for the Cut Type of Length.

You can assign three types of Unit, for the Cut Type of Length:

e USD/mm
e USD/cm
e USD/m

These options allow you to choose the area and cost per unit for Costing.

Limited-Access Multibody and Assembly Templates

You can create limited-access templates for multibody parts and assemblies that limit
the visibility of certain elements.

In the Costing Template Editor, when you click Save As Limited Access Copy, an
information message prompts you to click Yes or No. When you click Yes, the template
is saved as a limited-access template with the costs visible. When you click No, the
template is saved as a limited-access template with costs of the following elements hidden:
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Element Sub-Element

Costing DisplayManager &
Show Cost

Show Time

Tooltips

Template costs

Costing Task Pane

Material > Material Cost

Markup/Discount

Shop Rate

Estimated Cost Per Part > Breakdown

The above parameters are also hidden in the Costing report.

Evaluating the Cost of Assembly Operations

You can assign assembly operation costs in the template. You can override template
costs, and add assembly operation time in the PropertyManager.

To evaluate the cost of assembly operations:

1. Click Costing & (Evaluate tab on the CommandManager) or Tools > SOLIDWORKS
Applications > Costing.

2. In the CostingManager, right-click Assembly Operations and click Add Assembly
Operation.

3. In the Assembly Operations PropertyManager, under Name, type Fastening.

4. 1In the PropertyManager, click Each selected component, and Ctrl + select four
fasteners of a corner in the graphics area.

5. In the PropertyManager, do the following:
a) Under Operation Time, type 10.

b) | The default value is 60 USD/hr.

Under Assembly Operation Cost, type 20.
c) Click ¥.
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6.

In the CostingManager, right-click Assembly Operations and click Add Assembly
Operation.

In the Assembly Operations PropertyManager, under Name, type Inspection.

In the PropertyManager, click Entire selection, and select the entire assembly in
the graphics area.

In the PropertyManager, do the following:
a) Under Operation Time, type 3600.
b) Under Assembly Operation Cost, type 100.

c) Click ¥ .

10. In the Costing Task Pane, click Begin Cost Estimation.

Organizing and Saving Costing Data Locally

You can save Costing data. Such data includes CAD files, Costing templates, and Costing
reports locally as a package, with the Costing Pack and Go tool.

To organize and save Costing data locally:

1.
2.

o s W

Open an assembly.

Click Costing & (Evaluate tab on the CommandManager) or Tools > SOLIDWORKS
Applications > Costing.

Click Begin Cost Estimation.

In the Costing Task Pane, click Generate Report g.
In the Report Options dialog box, choose the report options and click Publish.

In the Costing Task Pane, click Costing Pack and Go .

If a warning message prompts you to save the assembly, click OK and save the
assembly.

In the Costing Pack and Go dialog box:

a) | The default file name is the same as the CAD file name. You can rename the
file name.

For File name, type a name.

b) For Save to, click |—| and browse to the location where you want to save the

report.

c) Select Include Costing report and click |—| to browse to the location of the
report to include.

d) Click Save.
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This chapter includes the following topics:

e 3D PMI Compare for DimXpert Annotations Is Enhanced
e Automatic Generation of DimXpert Annotations for Fastener Assemblies
e Customizable General Tolerances for DimXpert

e Displaying Component-level DimXpert Annotations in Assemblies
e General Profile Tolerance
e Patterned Datums

3D PMI Compare for DimXpert Annotations Is
Enhanced

When using the 3D PMI Compare tool, the restriction that the modified part starts as
a copy of the reference part is removed. You can apply DimXpert to each model
independently. There is an assumption that the face IDs of the parts are consistent.

Automatic Generation of DimXpert Annotations for
Fastener Assemblies

You can use DimXpert to automatically annotate one of the two components of a fixed
or floating fastener assembly.

Starting with the source component, its annotations are used to create the annotations
on the target component using the fixed and floating fastener formulas, as outlined in
ASME Y14.5, to compute the necessary tolerances.

To use DimXpert to automatically annotate one of the two components of a fixed
or floating fastener assembly:

1. Click Tools > DimXpert > Auto Pair Tolerance.
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2. In Source, select the source component (red arrow).
3. In Target, select the target component (black arrow).

4. Click ¥.
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Customizable General Tolerances for DimXpert

You can view the general tolerance file used in DimXpert and TolAnalyst and customize
it to conform to your specific design requirements.

Linear
from over over over over over over over over
Desiznation Deseription 0 2 & 20 120 400 1000 2000 4000
up to up to upto up to up to up to up to up to up to
3 6 30 120 400 1000 2000 4000 ==
o | Customl 0.1 0.1 0.2 0.3 0.5 0.8 1.2 2 El
c2 Custom2 0.05 0.1 0.3 0.5 0.8 1 1.5 3 4
Broken Edge
from over over
Designation Description 2 = £
up to up to upto
3 6 ==
o | Customl 0.1 0.5 1
c2 Custom2 0.2 0.8 2
Angular
from over over over over
Designation Description 2 = = = =2
up to up to upto up to up to
10 50 120 400 ==
o | Customl 0.1 0.1 0.2 0.3 0.4
c2 Custom2 0.05 0.1 0.3 0.5 0.7
Units
Linear mm
Angular Degrees

To specify the folder for DimXpert general tolerance file, click Tools > Options >
System Options > File Locations. Under Show folder for, select DimXpert General
Tolerance File and click OK.

Customizing the General Tolerance File

To customize the general tolerance file:

1. In the folder specified in System Options > File Locations > DimXpert General
Tolerance File, use Excel to open the file general tolerances.xlsx.

The file contains sections for linear dimension, broken edges (chamfers and fillets),
and angular dimensions. You can switch units from mm to inch and the table values
update automatically.
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2. To modify Custom1 for linear dimensions, locate the Linear section.

Linear :{

from over aver over | <

N L 0 3 6 30 |

Designation Description })
up to up to up to upto ¥

3 6 30 120 N

Cl Customl 0.1 0.1 0.2 0.3 §

c2 Custom?2 0.05 0.1 0.3 05 |y

3. Change the values in the Custom1 row.
For example, to change the tolerance from 0.2 to 0.3 for linear dimensions that are

in the range over 6 and up to 30, you change the corresponding Custom1 value from
0.2 (mm) to 0.3.

over over
5] 6

up to up to
30 30
0.2 |4— —p| 023
0.3 0.3

4. Save the Excel file.

Inserting a General Tolerance Table

You can insert a general tolerance table in a model to display the current tolerances in
use.
To insert a general tolerance table:
1. Click Insert > Tables > General Tolerance.
In the PropertyManager, set the options.

2
3. Click ¥.
4. Click in the graphics area to place the table.

Displaying Component-level DimXpert Annotations in
Assemblies

To display component-level DimXpert annotations in an assembly, click Tools > Options
> Document Properties > Detailing and select Show DimXpert when viewing

component annotations.
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General Profile Tolerance

General all over profile tolerance is available to let you fully define models using a single

profile tolerance feature control frame. You can insert a general profile tolerance in a note
or table cell.

G E R ¢ @

GEmon L,

% aw_spider <Scheme2 >
* Annotations
+ ERlparty

£ Surface Profilel k

Inserting a General Profile Tolerance in a Note

To insert a general profile tolerance in a note:

1. Click Insert > Annotations > Note.

2. In the graphics area, click to place the note.

3. In the PropertyManager, under Text Format, select Insert DimXpert General
Profile Tolerance .

4. Set the options.

5. Click ¥.
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Editing a Geometric Profile Tolerance

After creating a geometric profile tolerance, you can modify it using the Geometric
Tolerance Properties dialog box.
To edit a geometric profile tolerance:

1. In the DimXpertManager, right-click the geometric profile tolerance feature and click
Edit General Profile Tolerance. In this example, right-click Surface Profile 1.

G E R & &

e ool o =

{\% aw_spider <Scheme2 >
4 Annotations
~ EH part1

£ Surface Profile1 k

2. In the Properties dialog box, select the geometric tolerance options.
3. Click OK.

Patterned Datums

You can assign datums to hole patterns, concentric holes with gaps between them, width
patterns, and concentric bosses. You can create datums as individual features or patterns
using counterbores and countersinks.
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Four-hole pattern used as secondary datum

Two concentric hole pattern used as secondary datum
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Two boss features used to define datum A
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Two width features used to define datum B

Two counterbore holes used to define datum C

Two countersink holes used to define datum B
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Detailing and Drawings

This chapter includes the following topics:

e Annotations
e Dimensions
e Drawing Views

e Output
e Tables
Annotations

Auto Hatching in Section Views

Auto hatching in section views and broken-out section views has a new option.

Randomize scale Randomizes the hatch scale for the same material in the drawing
view. Clear this setting to keep the scale identical for all hatches
of multiple parts of the same material.

In a drawing, click Insert > Drawing View > Section.

In the Section View Assist PropertyManager, set the options.

Click ¥

In the Section View PropertyManager, under Section View, select Auto hatching.

Select or clear Randomize scale.
Set the options.

Click ¥ .

N ounhw NE=

Custom Property Improvement

In annotations and tables, you can create or reference a File property or Cut list property
with the correct evaluated value when it contains quotes in its expression name.

Movable Datum Target

You can create movable datum targets with the Datum Target tool.

The options include:
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e Horizontal movable
e Rotational movable

Horizontal Movable

Horizontal Movable = creates a movable datum target where the movable symbol is
always pointing either left or right with an arrow that can extend in any direction.
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Rotational Movable
Rotational Movable B creates a movable datum target where the movable symbol

always points directly at the datum target center. You can choose Up, Down, Left, Right,
Free Drag, or By Selection.
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Creating a Horizontal Movable Datum Target

To create a horizontal movable datum target:

1.

Click Datum Target @ (Annotation toolbar), or click Insert > Annotations >
Datum Target.

In the PropertyManager, under Settings, select Horizontal Movable <,

Click in the graphics area to place the target. You can drag the pointer left or right
to change the direction of the symbol before clicking again to place the symbol.

Click to place the symbol.

You cannot select other options in the PropertyManager until you place the symbol.
To set other options, such as Lock Leader Angle to drag the circle along the angle
specified in Angle only, you must reselect the datum target and set the options in
the PropertyManager.

Click ¥ .

Creating a Rotational Movable Datum Target

To create a rotational movable datum target:

1.

Click Datum Target @ (Annotation toolbar), or click Insert > Annotations >
Datum Target.

In the PropertyManager, under Settings, select Rotational Movable k=)

Click in the graphics area to place the target. You can freely drag the pointer to any
angle before clicking again to place the symbol.
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4. Click to place the symbol.

You cannot select other options in the PropertyManager until you place the symbol.
To set other options, such as Left, Right, Up, Down, Free Drag, or By Selection,
you must reselect the datum target and set the options in the PropertyManager.

5. Click .

New Draft Symbols

Draft is a new category in the Symbol Library.

The draft symbols include:

Symbol Description

Plus Draft
+DFI
Minus Draft
-DFT
\/_; Parting Line Diamond
Fi_ Parting Line
Tolerance Draft
DFTINCL

New Geometric Tolerance Options
Per ASME Y14.8 requirements, two new geometric tolerance options are available, All
Over This Side and All Around This Side.

To access the options, click Insert > Annotations > Geometric Tolerance. In the

PropertyManager, under Leader, select All Over This Side ‘N or All Around This Side
Y
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/%QLM A /ﬁ@m A

All over this side All around this side

These options are available in drawings, parts, and assemblies, but not in DimXpert.

Dimensions

Hole Callouts Supported in Advanced Hole Tool

You can create hole callouts for holes created with the Advanced Hole tool.

You can reverse the callout order. In the Dimension PropertyManager, under Dimension

Text, select Reverse Callout Order. You may need to reverse the callout order when
you place a callout on the far side face.

D053 K820 T 0.5, FARSIDE
@ 027 F 017, FAR SIDE
@ 020
1/4-20 T 0.25
L | 044 T 0.25

L-—-/Neorside foice

Reverse Callout Order selected
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L | @044 F 025
@ 0.20
1/4-20 ¥ 0.25
@027 ¥ 0.17, FAR SIDE
, N D053 %820 T 0.5 FARSIDE

-/Neorside face

Reverse Callout Order cleared

Text Below.

You can define the callout in the feature by including additional text. In the Dimension
PropertyManager, under Dimension Text, type the text to include in Text Above, and

Text A oyve  of—
L | @044 3 0.25
@020
1420 0.25
@027 F 0.7, FAR SIDE
SO 0sr 827 018, FARSIDE

Text Beloyy  af—

Trailing Zeroes

New options in the Options dialog box let you control individual values for trailing zeroes
in dimensions, tolerances, and property values.

The legacy options Smart and Standard for trailing zeroes are no longer available for

documents created in SOLIDWORKS 2018 and later. Documents created in SOLIDWORKS
2017 and earlier retain these settings with legacy behavior if they are used.
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Setting Trailing Zeroes in Dimensions

To set trailing zeroes in dimensions:

1. Click Tools > Options > Document Properties > Dimensions.
2. In Zeroes, under Trailing zeroes, in Dimensions, select:

Smart

To maintain trailing zero behavior from
SOLIDWORKS 2017 for dimensions,
tolerances, and properties.

When Smart is selected, Tolerances
and Properties are not available for
selection.

Show

To display trailing zeroes up to the
number of decimal places applied to each
dimension.

When Show is selected, Tolerances
and Properties are available for
selection.

Remove

To remove trailing zeroes from each
dimension.

When Remove is selected, Tolerances
and Properties are not available for
selection.

Standard

When Standard is selected, trailing zeros
behavior for dimensions, tolerances, and
properties appear according to the overall
drafting standard. This selection is
available for parts, assemblies, and
drawings created prior to SOLIDWORKS
2018.

When Standard is selected,
Tolerances and Properties are not
available for selection.

3. Click OK.
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Setting Trailing Zeroes in Properties

This setting applies to each numeric property value on the Units page of Document
Properties such as Mass, Density, Volume, Surface Area, Cost, Center of Mass, and
Block Tolerance.

This setting also applies to numeric property values that are displayed in the graphics
area or are evaluated in custom properties or other annotations such as notes and tables.

To set trailing zeroes in properties:

1. Click Tools > Options > Document Properties > Dimensions.
2. In Zeroes, under Trailing zeroes in Dimensions, select Show.
3. In Properties, select:

Show To display trailing zeroes up to the
number of decimal places applied to each
numeric property from the Units page of
Document Properties as well as
displayed numeric properties in the
graphics area or are evaluated in custom
properties or other annotations such as
notes and tables.

Remove To remove trailing zeroes from each
numeric property value.

4. Click OK.

Setting Trailing Zeroes in Tolerances

This setting applies to tolerance values for Arc Length, Chamfer, Diameter, Hole Callout,
Linear, Ordinate, Radius, as well as the display of tolerance values that appear within
other annotations such as notes and tables.

To set trailing zeroes in tolerances:

1. Click Tools > Options > Document Properties > Dimensions.
2. In Zeroes, under Trailing zeroes in Dimensions, select Show.

90




Detailing and Drawings

3. In Tolerances, select:

Show To display trailing zeroes up to the
number of decimal places applied to each
tolerance within the dimension (Bilateral,
Limit, and symmetric).

Remove To remove trailing zeroes from each
tolerance (Bilateral, Limit, and
symmetric).

Remove only on zero To remove trailing zeroes from each

tolerance when the displayed value is
zero. Also, when the value of the
displayed tolerance is not equal to zero,
trailing zeroes are displayed up to the
number of decimal places that apply to
each tolerance in the dimension.

4. Click OK.

Drawing Views

Applying Layers and Colors to Hatches

You can apply hatches to specific layers. When you apply a hatch to a specific layer, the
hatch inherits the show/hide, print on/off, and color properties of the layer.

A -

7T 7 TN

0

0O o W

(| L/ .

To apply a hatch to a specific layer:

1. In the graphics area, select the hatch.
2. In the Area Hatch/Fill PropertyManager, under Layer, select the layer.

3. Click v.
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Blocks in Break Views

You can choose whether or not to clip sketch blocks in break views.

In a break view, in the Break View PropertyManager under Break View Settings:

e Select Break sketch blocks to clip the sketch blocks.
e Clear Break sketch blocks to display the sketch blocks with no clipping.
For example:

ABCDEFGI-E ERSTUVXXYZ ABCDEFGHIJKL OPQRSTUY XXYR
Break sketch blocks selected Break sketch blocks cleared

Broken-Out Section Views

Broken-Out Section View on Alternate Position View

You can add broken-out section views to alternate position views.

N/

Broken out section view on alternate
Alternate position view position view

To add a broken-out section view to an alternate position view:

1. In an alternate position view, click Insert > Drawing View > Broken-out Section
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Broken-out sections can only cut the reference configuration of the drawing view,
not the alternate positions.

2. Sketch a closed profile such as a spline.
3. In the PropertyManager, set options.

4. Click ¥.

Broken-Out Section View on Detail View

You can add broken-out section views to detail views.

T

[Broken-out Sections of machined_part-SectionPart-6

DETAIL &
SCALE4 1

To add a broken-out section view to a detail view:

1. In a detail view, click Insert > Drawing View > Broken-out Section.
Sketch a closed profile such as a spline.
In the PropertyManager, set options.

Click ¥ .

> Wb
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Broken-Out Section View on Section View

You can add broken-out section views to section views.

SECTION A-A

Broken out section view on section view |Enlarged image of broken-out section view

To add a broken-out section view to a section view:

1. In a section view, click Insert > Drawing View > Broken-out Section.
2. Sketch a closed profile such as a spline.

3. In the PropertyManager, set options.
4

Click ¥.

Inserting a 3D View in a Drawing

If you create 3D views in SOLIDWORKS MBD, you can insert them in drawing views. In
addition, you can insert any annotations that you create in the 3D view if they are
orthogonal to the drawing view.

To insert a 3D view in a drawing:

1. In SOLIDWORKS MBD, create a 3D view.

2. In the drawing view, on the View Palette, select the 3D view.
3. Drag the 3D view to the drawing sheet and release.
4

Optionally, in the Drawing View PropertyManager, under Import options, select
Import annotations and 3D View annotations.

5. Click .
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Output

Bookmarks in PDF Output

You can choose to include or exclude bookmarks when you save a drawing as PDF.

Click Tools > Options > System Options > Export. In File Format, select PDF.
Select Include bookmarks to include bookmarks in the PDF output. Clear Include
bookmarks to exclude bookmarks in the PDF output.

Tables

All Uppercase Characters

You can specify all characters in a table to be uppercase.

Click Tools > Options > Document Properties > Drafting Standard. Under

Uppercase, select All uppercase for tables to apply uppercase characters to all table
entries in any table type.

In SOLIDWORKS 2018, the option All uppercase is renamed to All uppercase for
notes, which continues to control uppercase characters for all notes.

To specify all characters in a table cell to be uppercase, select a cell and on the table

editing toolbar, click All uppercase A Optionally, in the Table PropertyManager, under
Text Format, select or clear All uppercase.

Revision Table Driven By SOLIDWORKS PDM

You can use SOLIDWORKS PDM to drive a revision table.

When you manage a revision table from SOLIDWORKS PDM, in Options > Document
Properties > Tables > Revisions:

e Alpha/numerical control is disabled and Revision driven from SOLIDWORKS
PDM is displayed.

e Under Multiple sheet style, Independent is disabled and Independent type
Revision Table is not supported while revision is driven from SOLIDWORKS
PDM is displayed.

For more information, see the SOLIDWORKS PDM chapter in this document.
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This chapter includes the following topics:

e 3D Views

e Decals in eDrawings Files

e Setting Options and Passwords for eDrawings Files
e STEP Files in eDrawings Files

e User Interface Enhancements

e Zooming In and Out

eDrawings® Professional is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

3D Views

You can display all of the 3D Views associated with a model.

In the 3D Views pane, click Show All to display all of the 3D Views associated with the
model. Otherwise, only the 3D Views associated with the active configuration are displayed.

The Show All functionality is available for models saved in SOLIDWORKS 2018 and later.

Decals in eDrawings Files

You can include decals in published eDrawings files.

Previously, eDrawings only displayed stock decals and decals whose image data was in
a separate file, such as .png or . jpg, on your computer.

To include decals in published eDrawings files, in the SOLIDWORKS software, click Tools >
Options > Document Properties > Model Display and select Store appearance,
decal, and scene data in model file.

Setting Options and Passwords for eDrawings Files

When you save or publish a file as an eDrawings file, the options and password settings
are streamlined.

When you save or publish an eDrawings file, the Options and Password buttons are no
longer in the Save As dialog box. Instead, the Save Configurations to eDrawings file or
Save Sheets to eDrawings file dialog box appears with the Options and Password
buttons.
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To set options and passwords for eDrawings files:

1. In the SOLIDWORKS software, click Save As & or File > Save As.
In the Save As dialog box, in Save as type, select eDrawings and click Save.

3. In the Save Configurations to eDrawings file or Save Sheets to eDrawings file dialog
box, click Options or Password to access settings.

You can also click Publish to eDrawings @ or File > Publish to eDrawings to
access these dialog boxes.

STEP Files in eDrawings Files

When you save or publish an eDrawings file, you can attach STEP files to each configuration
of the eDrawings file. By attaching STEP files, you include the model geometry associated
with the eDrawings file.

Attaching STEP Files to eDrawings Files

You can attach STEP files to parts and assembilies.
To attach STEP files to eDrawings files:

1. In the SOLIDWORKS software, click Save As (Standard toolbar) or File > Save
As.

You can also click Publish eDrawings File @ (Standard toolbar) or File > Publish
to eDrawings.

2. In the Save As dialog box, in Save as type, select eDrawings and click Save.

3. In the Save Configurations to eDrawings file dialog box:
a) Inthe =] column, select at least one configuration to save.

b) Inthe % column, select the STEP files to save.

You can include a STEP attachment for any of the available configurations in the
file. Including a STEP attachment is independent of including the eDrawings data
for each configuration as long as you select at least one configuration for publishing
the eDrawings data.

c) In Create and attach STEP file of type, select the type of STEP file to attach.

Supported STEP formats are STEP AP203 and STEP AP214. If you have a
SOLIDWORKS MBD license, you can also attach STEP AP242 files, which support
Product and Manufacturing Information (PMI).

d) Click OK.

Opening STEP Files in eDrawings

To open STEP files in eDrawings:

1. In eDrawings, open a part or assembly document that has a STEP attachment.
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2. Click Attachments .

3. In the Attachments pane:
a) Select an attachment to open.
b) Click one of the following:

View Attachment
®

Opens the STEP file in
eDrawings. An attachment

icon appears in the
tab with the file name.

Extract Attachment

Saves the STEP file to a
location you choose.

Delete Attachment

Removes the STEP file
from the eDrawings
document. When you
close the eDrawings
document, the software
prompts you to save
changes. If you do not
save the changes, the
STEP file remains attached
to the eDrawings file.
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User Interface Enhancements

User interface updates streamline your overall workflow.
—|@ DRAWINGS' PRO |File View Tools Help | B [ ime

: @ pocket knife.SLDASM X
r b S A Q@ E-T-

i

ba \JE Erf.ﬁ "L=_—‘ Default

Move  Measure| Section | Stamps Markup Components

Enhancement Description

Quick access toolbar Contains the Open, Save, Print, and
Options tools.

S ELE

Units for Feet and Inches Available when using the Move Component

tool.

Lets you open a new document.

Open il button next to tabs of other open
documents
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Enhancement Description

Configuration names Appear in the bottom of the window to
indicate the active configuration.
(SOLIDWORKS files only.)

Drawing sheet names Appear in the bottom of the window to
indicate the active sheet. (SOLIDWORKS
files only.)

Markups Graphical indicators notify you if the file

contains a markup and if a comment
is associated to a markup

Recent Documents Higher up in the File menu for easier
access.

Zooming In and Out

You can change the direction of the mouse wheel for zooming in and out.

To change the zoom direction of the mouse wheel:

1. Click Options E or Tools > Options.
2. Inthe dialog box, on the General tab, select Reverse mouse wheel zoom direction.
3. Click OK.
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This chapter includes the following topics:

e Connection Point Display

e Distributed Mode

e Global Project Drawing Styles

e Global Wire Mark Display

e Multi-level Terminals

e Natural Sort Option for Marks

e Other Enhancements for SOLIDWORKS Electrical
e Project Level Attribute Styles

e SOLIDWORKS Electrical and SOLIDWORKS Routing Integration
e Symbol Editor

e Terminal Strips

e Unused Wires

e User Data for Manufacturer Parts

e Wire Numbering Group

SOLIDWORKS Electrical is available as a separately purchased product.

Connection Point Display

You can display connection points when symbols are not connected.
On the Graphic tab, set Display to When not connected.

Distributed Mode

Distributed mode minimizes network traffic and large data operations during electrical
schematics development.

o
When the work finishes, click Update connections @
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Global Project Drawing Styles

You can define global settings that apply to all schematic drawings of the project. The
settings ensure that every document has the same characteristics without you performing
manual updates, to achieve consistency.

The drawing settings are saved in a template file that manages different sets of drawing
styles.

To set the drawing styles, on the Project tab, click Project > Configurations > Drawing
styles.

Global Wire Mark Display

In the Wire style manager dialog box, you can globally hide or show wire labels, wire
marks, equipotential marks, and equipotential labels for all wires.

Multi-level Terminals

You can independently mark each level of multi-level terminals and set specific rules for
renumbering multi-level marks.

Level definition dialog box

You can set:

Use terminal and level mark (1.1, Appliesthe terminalmark.levelmark
1.2, 2.1, 2.2) numbering format.

Use level marks (1, 2, 3, 4) Applies a unique mark to each level of

multi-level terminals.

To access this dialog box, in the schematic, component tree, or Terminal strip manager,
right-click and click Terminals > Define levels.

Renumber terminal strip terminals dialog box

You can set renumber order options to:

e Vertical or Horizontal
e Bottom to Top or Top to Bottom

To access this dialog box, in the Terminal strip manager, click Advanced > Renumber.

Component properties dialog box

On the Mark and data tab, after you set the levels, you can set individual component
properties to use Automatic, Manual, or Use level marks.

To access this dialog box, in the schematic, right-click and click Terminals > Component
properties or right-click the component tree and click Select properties.
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Natural Sort Option for Marks

You can set the sort method of marks throughout the project by root and number sort

or natural sort.

To set the natural sort for marks:

1. On the Project tab, click Configurations > Project > Mark.
2. Under Sort by mark, click one of the following for Sort by mark mode:

¢ Order by root and number, first automatic, manual after
e Order by tag alphabetically natural, mixing automatic and manual marks

Other Enhancements for SOLIDWORKS Electrical

For additional information about these enhancements, see SOLIDWORKS Electrical Help.
SOLIDWORKS Electrical enhancements include:

Library

Added fields for prefabricated cable lengths and manufacturer part data
file link.

Marks

You can set the Manual mark mode as the default when using insert
symbol.

You can edit the Automatic/Manual mark mode when you select
multiple objects.

Renumber marks include harnesses.

Import/export

In the file selector for outputs, you can filter on Opened drawings
only to keep only the drawing opened by the current user.

Import DWG files can reconnect lines that are close to each other
according to the offset distance you specify.

User interface

In Cross reference settings, you can set whether to use the cross
reference limit defined in the title block.

When you update or replace a title block in a drawing, the Display
Task dialog box lets you apply the changed title block to only the
selected drawing or to all project schematics in the project that use
the same title block.

More formulas are available on the Font tab for cable core and cable
text to customize text displayed on drawings for Origin-Destination
and Function/Location Outline.

Open and
archive

The software retains the most recent file from each project. It reopens
the last 2D or 3D file when you open a project.

In the archive environment, you can set an option to archive All
projects.
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Project Level Attribute Styles

You can define a common style for attributes that applies everywhere the attribute is
used in the project. For example, you can use the same attributes format in a symbol or
title block without performing manual updates.

In the Project configuration dialog box, on the Attribute tab, you can create custom
attributes or use predefined attributes.

SOLIDWORKS Electrical and SOLIDWORKS Routing
Integration

You can create C-points and define mate references for electrical components from the
Routing Library Manager instead of the Electrical Component Wizard.

To access the Routing Library Manager from the SOLIDWORKS Electrical 3D tab, on the
SOLIDWORKS Electrical 3D CommandManager, click Electrical Component Wizard.

SOLIDWORKS Electrical 3D enhancements in the Routing Component Wizard tab of the
Routing Library Manager let you:

e Define C-points, mate references, and component alignment using the same options
as in the Electrical Component Wizard.

e Set Select Component Type to DIN Rail Component.

Symbol Editor

Enhancements to the Symbol editor are available when you modify attributes and work
with passive symbols.

When you modify attributes, you can use the:

e Multiple attribute and Replace attribute commands to quickly modify the index
and language of one or more attributes when you edit a symbol or title block. These
commands are available in Edit Symbol on the contextual menu.

¢ Modify Revision Index command when you edit a title block.

When you use passive symbols, the following options are unavailable in the Symbol
properties dialog box:

e Manufacturer part
o Characteristics
e Options
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Terminal Strips

Accessory components You can add accessory components to
terminal strips, including end brackets, end
covers, and separators. These are
represented in terminal strip drawings.

Component properties dialog box You can add Manufacturer parts and
circuits for terminal strips.

Reorder terminals dialog box You can set the sort criteria using

Destination cable mark or Origin cable
mark.

Terminal strip drawings You can set the Distance between cables
in terminal strip drawings.

Unused Wires

You can use project configurations to number wires and equipotentials, cables, and
components with unused wire marks.

In the Wire and component numbering dialog box, for Assign unused mark, select
Wires and equipotentials, Cables, or Components. If you select any of these options,
the software reuses unused numbers when numbering new wires, otherwise it uses the
current highest mark +1.

User Data for Manufacturer Parts

If you do not use the ERP data connection, user data fields are available for manufacturer
parts.

Wire Numbering Group

You can start the wire and equipotential numbering at each project location.

In the Numbering group dialog box, set Start numbering at to Project, Book, File, or
Location.
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SOLIDWORKS Flow Simulation

This chapter includes the following topics:

e Color Bar

e Component Explorer
¢ Free Surface

¢ Full Template

¢ Noise Prediction

e Plot Callouts

e Sector Periodicity

SOLIDWORKS Flow Simulation is available as a separately purchased product that can be used
with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Color Bar

On the Color Bar, you can change the value axis to logarithmic and orient the palette bar
horizontally or vertically.

THO0 3093 JIH 3705 4704 4610 50,35 $4 8 SR04 63 J0 77T 7270 TE.T4 81 34 6 00
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Component Explorer

In the Component Explorer, you can create and edit sources and materials from the table,
and display total power.

Free Surface

Free surface lets you simulate flows with a freely moving interface between two immiscible
fluids.

You can use the volume of fluid method (VOF) for tracking and locating the free surface
(or fluid-fluid) interface.

The following pairs of fluids are available: gas-liquid and liquid-liquid. Any phase change
transition, rotation, porous media, or fans are not allowed.

Full Template

You can save all project data to a template, such as boundary conditions, sources, and
goals. This makes it easier to copy projects from model to model.

Noise Prediction

The Fast Fourier Transformation (FFT) algorithm converts a time signal to the complex
frequency domain for transient analysis.

The FFT plot analyzes time-dependent pressure data using the FFT algorithm.

Plot Callouts

You can show the minimum and maximum values in callouts for cut and surface plots.

ut Pt i
Tamparatung

.
'

/
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Sector Periodicity

You can simulate sector periodicity problems, including rotation and heat conduction in
solids.

Phase transitions (including isothermal cavitation), high Mach number flows, and mixing
plane rotation regions are not allowed. When performing the simulation, the rotation axis
should be parallel to one of the global coordinate system axes.

108



SOLIDWORKS 3D Interconnect

This chapter includes the following topics:

e Additional File Formats Supported
e Additional Information Supported for Reading from Third-Party Native CAD Files

Additional File Formats Supported

SOLIDWORKS 3D Interconnect now supports STEP, IGES, and ACIS file formats.

STEP, IGES, and ACIS Files

SOLIDWORKS 3D Interconnect supports STEP, IGES, and ACIS file formats.

SOLIDWORKS 3D Interconnect can read Reference Planes and User Defined Attributes
or Custom Properties from these neutral formats.

When you import custom properties from files, the translator reads user-defined attributes,
if present, and writes them into SOLIDWORKS custom properties.

You can read STEP, IGES, and ACIS assembly files as a multibody files. From the System
Options dialog box, you can choose to map and import the assembly structure as a part
with multiple imported bodies or as a multibody part.

Additional Information Supported for Reading from
Third-Party Native CAD Files

SOLIDWORKS 3D Interconnect reads the following additional information from third-party
native CAD files:

e Assembly cut features

e Custom properties

e Material properties

e Unconsumed sketches and curves

e Reference axes from CATIA® V5 files only.
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Assembly Cut Features

SOLIDWORKS 3D Interconnect can read assembly cut features from PTC® Creo and UG
files.

You can optionally import the material properties, custom properties, and unconsumed
sketches and curves from these files. To import these entities, in the System Options
dialog box, click Import and select the required entity.

Custom Properties

SOLIDWORKS 3D Interconnect can read custom properties, metadata, or user-defined
attributes from third-party native CAD files and map them to the custom properties of
SOLIDWORKS.

SOLIDWORKS 3D Interconnect can read custom properties from these formats:

o ACIS

e Autodesk® Inventor
e CATIA® V5

o IGES

e PTC® Creo

e Solid Edge®

e STEP

e UG

The custom properties are locked when the third-party CAD file and the
SOLIDWORKS file are linked. To overwrite these properties, you must break
the link.

Material Properties

SOLIDWORKS 3D Interconnect can read the material properties from third-party native
CAD files. SOLIDWORKS 3D Interconnect reads only the material name and density
attributes.

Unconsumed Sketches and Curves

SOLIDWORKS 3D Interconnect can read unconsumed sketches or curve data from
third-party native CAD files. Unconsumed sketches are sketches that are not consumed
by any feature. These sketches read the curve data from third-party native CAD files and
form single 2D or 3D sketches.
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SOLIDWORKS Inspection

This chapter includes the following topics:

e SOLIDWORKS Inspection Add-in
e SOLIDWORKS Inspection Standalone

SOLIDWORKS Inspection is available as a separately purchased product that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium or as a
completely separate application (see SOLIDWORKS Inspection Standalone).

SOLIDWORKS Inspection Add-in

SOLIDWORKS Part and Assembly Support

You can create complete inspection reports using existing SOLIDWORKS part and assembly
files (*.sldprt and *.sldasm).
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When you open a SOLIDWORKS part or assembly that contains 3D annotations or Product
and Manufacturing Information (PMI), you can create a new inspection project and extract
all the information for the inspection checklist.

To create an inspection report from a SOLIDWORKS part or assembly:

1. Click New Inspection Project (CommandManager).
2. Select project settings and extraction settings.

Use the checkboxes to set up the project. For example, you can include or exclude
Dimensions, Notes, GD&Ts, and Hole Callouts, SOLIDWORKS Inspection then adds
the balloons to the PMI. Quality inspectors can then refer to the inspection spreadsheet
and the 3D model to understand which characteristics to inspect.

You can use either Automatic or Manual extraction mode.

The Inspection characteristics are listed in the Characteristic Tree. You can modify the
properties of a characteristic to include additional information such as Operation,
Classification, and Method of Inspection. Additionally, you can reorder them.
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When the project is complete, you can generate:

e Microsoft® Excel report

e 2D PDF

e 3D PDF (if SOLIDWORKS MBD is available)
e eDrawings file

SOLIDWORKS PDM Integration

SOLIDWORKS PDM integration is included in the SOLIDWORKS Inspection add-in.

SOLIDWORKS PDM integration helps you manage and centralize the storage of your
inspection projects as well as the files and reports related to them.

SOLIDWORKS Inspection Standalone

2D File Support

You can open and import 2D files from other CAD systems directly into an inspection
project.

SOLIDWORKS Inspection 2018 supports these formats:

e AutoCAD® DWG files
e PTC® Drawing files
e CATIA® V5 CATDrawing files
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You can use the Smart Extract feature to extract one or more characteristics based on
predefined settings.

After completing the inspection project, you can generate a Microsoft Excel file or a 2D
PDF.

3D File Support

You can open and import 3D files from other CAD systems directly into an inspection
project.

R = -
i L

SOLIDWORKS Inspection 2018 supports these formats:

e 3D XML files
e PTC® and Creo Parametric files
e CATIA® V5 CATPart and CATProduct files

You can navigate between the different views of the 3D file using the navigation tree in
the top right corner.

== gt ftc 09_asmal_ctS240 rd CATPart
= Captures

MED_A
MED_B
MBD._C

MED_A_NOTES_Front View.1

The characteristics are ballooned and added to the Bill of Characteristics.

After completing the inspection project, you can generate a Microsoft Excel file, a 2D PDF,
or a 3D PDF.

114



SOLIDWORKS Inspection
Balloon Sequences

You can create balloon sequences in options and assign them to project characteristics.
You can do the following:

e To access balloon options, on the Home tab, click Options > Project Options >
Ballooning.

e To add a balloon sequence, click d;:'
. =
e To remove a balloon sequence, click .

e Under Balloon Sequence, you can customize the Sequence Name and Starting
Value.

Characteristics that you balloon are numbered based on the sequence selected in the
CommandManager or in the characteristic window. When you select a sequence, all new
characteristics start at the Starting Value and increment by 1. If a sequence already
has characteristics, any new characteristic begins at the end of the list.

If you modify a sequence in the options, balloon humbers update accordingly.

Balloon sequencing, incrementing, and customizable numbering must be used
independently of one another in a project.

CMM Data Management Import

There are new filters that help identify assigned and unassigned items.

Create and Place Sub-Balloons
When a characteristic refers to multiple instances of a feature, you can add multiple
balloons to the drawing to identify each instance.

For example, this radius refers to two fillets:

ﬂ?x R.125

To add multiple balloons:

1. In the Table Manager:
a) Create a line for each instance.
b) Right-click an instance and click Create and Place Sub balloons.
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2. Click anywhere in the document to place additional balloons.

In this example, you add balloon 2.2. Balloon 2 automatically changes to 2.1.

_— | |.010

Y_
C

2.875+.020 —=

Customizable Balloon Numbering

You can renumber characteristics in the Bill of Characteristics and include gaps.

To renumber characteristics, on the Characteristics tab, double-click the Characteristics
Number field (#Char) and type the new number. All subsequent characteristics are
renumbered accordingly.

Table Manager

Bill Of Material  Specifications | Characteristics |

2D | 2Char Type SubType Value v Uit Plus Tolerance | Mainus Toles

- 1Mot Mete  OREACALSWAPCORMRSTO OSWOHES
Hote Note INTERPRET PER ASME Y14 52003
3 Hate Mot HEAT TREAT PER GWS 1-08

4 4 Dimension Linear Dimen.. 889 n +0.05 0.10
5 5 Dimension Linear Dimen... 6.4 /63 n
G & Dimension Linear Dimen... 69.85 n +0.5 0.5
7 ! Dimension Linear Dimen... 25.4 n +0.5 0.5
B B Dimension Linear Dimen 15,88 n +0.5 0.5
9 9 Dimension Lingar Dimen,.. 7.47 n +0.5 0.5
4 »

Bill Of Material  Specifications | Characteristics |

S0 | #Char SubType Value Uinit Plus Tolerance | Minws Toles
--———-_-
Hote Hote INTERPRET PER ASME Y14 52003
27 27 Hote HNote HEAT TREAT PER GWS 1-08
28 28 Dimension Lingar Dimen... 88.9 n +0.05 0.10
29 |29 Dimension Linear Dimen... 6.4 /63 n
ki ] Ei ] Dimension Linear Dimen._. 6985 n +0.5 05
31 31 Dimension Linear Dimen 25.4 n +0.5 0.5
2 2 Dimension Linear Dimen,.. 1588 n +0.5 0.5
33 EE Dimension Lingar Dimen,., 747 n +0.5 0.5
4 »

Balloon sequencing, incrementing, and customizable humbering must be used
independently of one another in a project.
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Customizable Tolerance Type
You can customize default tolerances if an explicit tolerance is not specified in the 2D or
3D file for one or multiple characteristics.
In addition to the Linear and Angular default tolerances, you can add new tolerances.
You can do the following:

e To access the tolerance options, on the Home tab, click Options > Project Options >
General.

e To add a new tolerance, under Default Tolerances, click + at the top of the table.
e To rename a tab, double-click it and type the new name.

o Use EE:' and = to add and remove lines in the tolerance table.
¢ You can select tolerance values By Precision or By Range.

After completing the tolerance table, you can select it in the characteristic window.

Explode Note
If a drawing note contains multiple characteristics to inspect, you can explode the note
into multiple instances.
To explode a note:

1. In the Table Manager, right-click the note and select Explode Note.
2. Select each characteristic and create a new instance or use Auto-Explode.

You can also add, remove, copy, and combine rows.

Export to CAMS XML and Verisurf

You can export your inspection projects to CAMS XML and Verisurf.

Export to QualityXpert Improvements

In QualityXpert, you can use a mobile device to publish your inspection plans to the web
for inspection on the shop floor.

ExtractionXpert

The ExtractionXpert™ tool improves Optical Character Recognition (OCR) readings.

ExtractionXpert automatically tries different OCR settings such as Sharpen, Dilate, and
Edge Enhancement. The tool uses more than 200 combinations to recommend the best
settings based on the entered values.

ExtractionXpert accounts for scaling, so you no longer need to manually rescale .pdf
and .tiff drawings. Therefore, in Options > Project Options, the Drawings tab has
been eliminated.
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Full Specification
When extracting characteristics from a 2D or 3D file, the full specification is calculated in

the characteristic window. Some companies require their users to have the full specification
(for example, tolerances, degree, diameter symbols) displayed in the inspection report.

Ignore Basic Dimensions

You can ignore basic dimensions from measurements input so they are not flagged.

Improved Optical Character Recognition

An enhanced Optical Character Recognition (OCR) engine improves the recognition of
documents and fonts, and requires less user input.

Improved User Interface

The user interface is improved for added clarity.

e Menus, dialogs, and buttons are updated to be more consistent.
e Options and settings are reorganized.

o In the Bill of Characteristics, the status for items such as Key and Basic characteristics
is now shown as True or False instead of a check mark.
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Merge Characteristics

You can merge multiple characteristics into one.

For example, this hole dimension is listed as three separate characteristics. You want it
to be listed as a single characteristic.
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» 28THRU
O ¢ |® 020|A|B|C

To merge characteristics:

1. In the Table Manager, select the characteristics to merge.
2. Right-click and select Merge Characteristics.

The characteristics are combined into one.

Net-Inspect Options
Net-Inspect is a web-based quality management system used by many large companies
to manage their inspection processes both internally and with suppliers worldwide.
To set Net-Inspect options, click Home > Options > Net-Inspect Options.

Predefining Balloon Appearances

In Ballooning Project Options, you can use the Characteristic Identification feature to
predefine unique balloon appearances for special characteristics for easy identification
when performing an inspection.

The Characteristic Identification feature can be applied to Key Characteristics. Therefore,
the Key Characteristics options Identified and Placement have been eliminated.

Characteristics Identification

Classification Prefix = Suwffix Balkson shape Fill color Border color . Font color Font Size Fit Identification Criteria
1 Critical = Triangie - | = - . ~ | .. |12

2 | Major K J' VD Balloon ~ | I - I - 1l = |12

g =

Publish Reports with Document Snapshots

You can include captures, views, and drawing sheets in Microsoft Excel inspection reports.

You can select views and sheets to include in published reports. Also, you can manually
create and include snapshots. You can reorder the snapshots before exporting to Excel.

Publish | Name/Sheet 8 Type File: Nam«

N E i s POF-Smanba

Sheet
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Revision Management

You can use the Revision Management tool to analyze changes between two CAD files
and view a summary of all added, removed, or modified annotations.

SOLIDWORKS Inspection can automatically process all of the changes between revisions
or highlight changed items in the project, allowing you to review each item individually.

The manual revision mode provides a summary of the changes as well as instruction to
make the changes. The automatic mode displays a summary with options and user
preferences for automatic processing.

Sampling

Acceptance Quality Limit (AQL) is a method of sampling that is used by many companies
as the standard tool for choosing sample size for product inspection. You can define
sampling and AQL in the SOLIDWORKS Inspection Standalone application for an entire
project or for each individual characteristic.

Smart Extract

The Smart Extract tool lets you extract multiple characteristics when the PDF document
contains a searchable text layer that supports Smart Extract.

To extract characteristics, click Smart Extract (CommandManager) or right-click and
click Smart Extract. You can extract a single characteristic or multiple characteristics.

#ID | #Char Type SubType Value

This is useful for extracting GD&T without manually recognizing each element.

Using predefined settings, you can extract multiple characteristics at once. The quality
of the extraction depends on the software that was used to create the 2D drawing.
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SOLIDWORKS PDM Integration

SOLIDWORKS PDM integration is included in SOLIDWORKS Inspection Standalone.

You can access SOLIDWORKS PDM features such as Check Out, Check In, Search, and
Version using the PDM tab in the CommandManager. This integration helps you manage
and centralize the storage of inspection projects as well as the files and reports related
to them. Additionally, version control helps prevent data loss and the search feature
reduces the time spent searching for inspection projects.
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Undo and Redo

Undo and Redo are available to cancel or redo the last action.
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This chapter includes the following topics:

e 3D PDF Templates

e 3D PMI Compare Versions

e 3D Views Slideshow

e Bill of Materials

e Configuration-specific Properties in 3D PDF
e Import PMI

e Insert a Note in a 3D PDF Field

e MBD Templates

SOLIDWORKS MBD is available as a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

3D PDF Templates

New 3D PDF templates are available for parts and assemblies.

In addition, there are custom versions that you can use as a basis for your specific needs.
To access the 3D PDF templates:

1. Click 3D PDF Template Editor @ (SOLIDWORKS MBD toolbar).

2. Click Open .
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3D PMI Compare Versions
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Using the 3D PMI Compare tool, you can compare PDM revisions of the same document.
To compare PDM revisions of the same document:

1. Click Tools > Compare > 3D PMI.

2. In the Task Pane, select the Reference document.
3. Select Within SOLIDWORKS PDM.
4

Under Within SOLIDWORKS PDM, select the PDM revisions in Version 1 and
Version 2.

5. Click Run Comparison.

3D Views Slideshow

You can watch 3D Views as a slideshow from the 3D PDF.

In a 3D PDF, click Play ™ in the preview pane to automatically sequence through the
model views. To stop or pause the presentation, click Pause i,

Bill of Materials

When you publish a model containing a bill of materials to 3D PDF, you can determine
which columns to include.

To specify the columns in a bill of materials:

1. In a model that contains a BOM, in the Publish to 3D PDF PropertyManager, click ®),
2. Under Output BOM Table, in Column List, select the columns to include.

3. To specify the number of columns to display in the 3D PDF, under Columns in grid,
select the number of columns.

For example, if you select 2 for Columns in grid and you select more than two in
Column List, the 3D PDF displays the values of 2 columns in the BOM. When you
select a BOM row, the remaining column values appear in the BOM.

4. To display all of the BOM columns in the 3D PDF, select Show all columns in PDF.
5. Set other options.

6. Click .
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Configuration-specific Properties in 3D PDF

You can insert configuration-specific properties in text fields and tables when you publish
a model to 3D PDF. For notes, there is a 3D PDF Template Editor option that assigns the
property as configuration-specific.

Inserting Configuration-specific Properties in a Text Field

To insert configuration-specific properties in a text field:

1. In the SOLIDWORKS 3D PDF Template Editor, click Text .4@1.
2. Click to place the text block on the page.

In the PropertyManager, click Custom Property Field “
Under Custom Property Field, select Configuration Specific.
Set the options.

Click ¥ .

o kAW

Inserting Configuration-specific Properties in a Table

To insert configuration-specific properties in a table:

In the SOLIDWORKS 3D PDF Template Editor, click Generic Table @
In the Open dialog box, select a table and click Open.

Optionally, drag and resize the placeholder on the template.

Click outside of the table to release it.

W=

Import PMI

You can import PMI (Product Manufacturing Information) with NX, Creo, and STEP AP242
formats as semantic graphical annotations.

You can assign color to graphical annotations. Click Tools > Options > System Options
> Colors. Under Color scheme settings, select Graphical Annotations.

Insert a Note in a 3D PDF Field

You can select and insert notes, such as a GTOL, from a part or assembly into their own
fields in a published 3D PDF.

To insert a note in a 3D PDF field:

1. 1In the 3D PDF Editor, click Imported Notes A .
2. Click to place the Imported Note Placeholder on the template page.
3. Set the properties.
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4.
5.

Click ¥
Save the template.

MBD Templates

MBD templates for parts and assemblies are included with all versions of SOLIDWORKS
2018 where the text sizes scale properly to the component and assembly sizes.

The new MBD templates have predefined settings based on your model size. When you
use these templates, you will automatically get the proper scaling for your model and
text. For example, select Part 0001 mm to 0010 mm if the model you are designing
will be in the range of one to ten mm. This template is designed for this part size, which
helps simplify your work.

The new templates are installed with your SOLIDWORKS installation.

To use a template:

1.

2.
3.
4

Click File > New.

In the New SOLIDWORKS Document dialog box, click the MBD tab.
Select a template.

Click OK.
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This chapter includes the following topics:

e Offloaded Rendering

Offloaded Rendering

Offloaded rendering lets you send a rendering to another machine that uses the PhotoView
360 Net Render Client. Offloaded rendering frees up your computer while the rendering
is calculated on another machine.

When you use offloaded rendering, two machines are required:

Coordinator The machine running the SOLIDWORKS software and PhotoView 360.
The coordinator must have a license of SOLIDWORKS Professional or
higher and an active subscription service license.

Client The machine running the PhotoView 360 Net Render Client. The client
does not need a SOLIDWORKS license.

There are two types of offloaded rendering:
Single offloaded rendering Sends a single static image to render on the client.

Scheduled offloaded rendering Sends a single static image to the SOLIDWORKS Task
Scheduler to start the task at a later time.

Using Single Offloaded Rendering

To use single offloaded rendering:

1. Click Options @ (Render Tools toolbar) or PhotoView 360 > Options.
2. In the PropertyManager:
a) Select Network Rendering and Offload Rendering.

b) Click ¥ .

When you render the model, it renders on the client that uses the PhotoView 360 Net
Render Client. If the client is busy or unavailable, you are asked if you want to render
on the coordinator or cancel the rendering. On the coordinator machine, you have
full access to the SOLIDWORKS software while the offloaded rendering takes place.
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Using Scheduled Offloaded Rendering

Use scheduled offloaded rendering to start the task in the SOLIDWORKS Task Scheduler
at a later time, such as after business hours.

To use scheduled offloaded rendering:

1. Click Schedule Render @ (Render Tools toolbar) or PhotoView 360 > Schedule
Render.
2. In the dialog box:
a) Select Start Offloaded Rendering Now.
Start Offloaded Rendering Now is not available if the SOLIDWORKS Task

Scheduler is performing tasks, a rendering is already scheduled, or if a rendering
is currently taking place.

b) If there is already a task scheduled in the SOLIDWORKS Task Scheduler, select
Start after Previous Task to put the task into the queue.

c) Click Finish.
SOLIDWORKS Task Scheduler schedules the rendering. If the client is busy or

unavailable when the render task is scheduled to start, the coordinator machine
performs the render.
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This chapter includes the following topics:

e Advanced Hole

e Block Editing of Linked Custom Properties in Derived Parts
e Cosmetic Threads Improvements

e Creating a Bounding Box

e Defeature Tool Improvements

e Extracting Geometry from a Corrupted Solid Body

e Feature Freeze Bar Works with All Folders

e Hole Wizard Options to Match Size or Preserve Settings

e Mesh BREP Bodies

e More Control Over Custom Properties

Advanced Hole

Defining Hole Elements with Baseline Dimensions

You can use baseline dimensions to define advanced holes.

When you select this option in the Advanced Hole PropertyManager, the SOLIDWORKS
software measures near and far side elements from the same initial baseline dimension.
This option also sets the end condition automatically to Offset from Surface for each
element in the hole stack.

The same hole stack can chain elements, defined with baseline dimensions, with other
neighboring hole elements.

Other changes related to using baseline dimensions include:

e For a counterbore, countersink, or taper threaded element, you can select Use
standard depth to ensure that the depth of the element is the same depth defined
in the Hole Wizard data table.

e For a straight threaded element, you can select a formula from a drop-down list to
calculate its depth.

To access this option, click Insert > Features > Advanced Hole. In the Advanced Hole
PropertyManager, under Near And Far Side Faces, select a face and click Use baseline
dimensions.
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Customizing Advanced Hole Callouts

You can customize hole callouts for advanced holes, which is useful for manufacturing
processes.

The manufacturing processes for holes do not always match the order shown in the
advanced hole flyout. You can customize hole callouts that match the order and variables
needed for manufacturing, then use the callouts in manufacturing drawings.

For example, the advanced hole flyout might show this order:

(1) Nearside Mear Side <
Counterbore =T
(2) Straight Rl Y

(3) Straight Threaded Q

% i

Far Side

However, this is the order in which manufacturing creates the holes:

(3) Straight Threaded
(2) Straight
(1) Nearside Counterbore

To customize advanced hole callouts:

1.
2.

3.

4.

In the Advanced Hole PropertyManager, under Hole Callout, click Customize callout.

To reorder the callouts, select the Callout String and click Move Up and Move
Down.

Hole Callout ~
Default callout

@ Customize callout

Callout String
3
2 <MOD-DIAM = <ah-stridias <
1 [«HOLE-5POT> < MOD-DIAM> <

To customize a callout string, double-click it in the Callout String list and select
variables. You can also select Callout Variables to display a list of all variables.

Modified strings are marked with an asterisk in the list.

To restore the default settings for individual Callout String items, right-click a string
and click Restore Default String.
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5. To remove all customizations, under Hole Callout, click Default callout.

Default callout removes all customizations you made to all hole callouts
in the PropertyManager.

Block Editing of Linked Custom Properties in Derived
Parts

On the Custom Properties tab in the Task Pane, you cannot edit or delete file properties
and cut list properties which are linked to parent parts. These options will appear
unavailable (grayed out).

Cosmetic Threads Improvements

When you mirror a feature, the geometry for cosmetic threads generates more reliably.

There are also improvements related to patterns, the hole wizard, and line representation
for depth.

Creating a Bounding Box

With the Bounding Box tool in Reference Geometry, you can create a box that
completely encloses a model within a minimum volume. You can create a bounding box
for a multibody, single body, or sheet metal part.

In the Bounding Box PropertyManager, you can orient a bounding box by selecting a
planar face of the part or a reference plane. When the part updates, the bounding box
automatically resizes.

You can include hidden bodies and surfaces in the bounding box. You can also hide, show,
suppress, and unsuppress a bounding box from a shortcut menu.

Four bounding box properties are available in the Configuration Specific tab of the
Summary Information dialog box. The dimensions in these properties can help you
determine the space required to ship and package product. You can reference these
properties in BOMs and other tables.

Previously, you could only create a bounding box for a cut list item in weldments.
To create a bounding box and view its properties:

1. In a part document, click Bounding Box i@ (Reference Geometry toolbar) or
Insert > Reference Geometry > Bounding Box.
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2. In the Bounding Box PropertyManager, leave Best Fit selected and click ¥ .

The software automatically calculates the bounding box for the part as shown. In the
FeatureManager design tree, Bounding Box is added after Origin.

“

3. To view bounding box properties, click File > Properties > Configuration Specific
tab.

Values for thickness, width, length, and volume of the bounding box are listed.

4. If you hide a body in the part, the bounding box automatically updates and only
encloses the visible bodies in the model.

5. To edit the bounding box, in the Feature Manager, right-click Bounding Box, and
click Edit Feature @. Then in the PropertyManager, click Include hidden bodies
and click ¥

Defeature Tool Improvements

The Defeature tool is more reliable in displaying features that have been selected to
keep, and in selecting and keeping holes, especially in spherical bodies.

When you save the results from the Defeature tool and select the option to save the
model as a separate file, the file is saved as Document Name Defeature.sldprt.

In a part or assembly, click Defeature %o (Tools toolbar) or click Tools > Defeature.
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Extracting Geometry from a Corrupted Solid Body

When the SOLIDWORKS software attempts to repair a corrupt file and cannot resolve the
problem, the software prompts you with an option to extract geometry if the body data
of the file is still intact.

If you accept this option, the software imports the geometry from the corrupted file into
a new file. You can use the geometry and add features to create a new model. However,
the new file will not have the feature history associated with the imported geometry.

Feature Freeze Bar Works with All Folders

The Feature Freeze bar freezes all features above the bar in the FeatureManager design
tree even when the features in a folder were not created in chronological order.

Previously, the freeze bar could not freeze features in a folder if it contained sketches or
features that had been created later than entities below the freeze bar. For example,
suppose your part document contains Sketchl and Sketch2, and you create Boss-Extrudel
feature from Sketch2 and Boss-Extrude?2 feature from Sketchl. Then you add
Boss-Extrudel feature into Folderl. If you moved the freeze bar below Folderl, the
software would not let you position it there, because Folderl contains Sketch2, which is
listed before Sketchl, in the design tree.

* [l Folderl
v ﬁ_l Boss-Extrudel
[ (-) Sketch2
- tﬁj Boss-Extrude?
[ () Sketchl

Now when you drag the freeze bar to Folderl, the software prompts you with a warning
and temporarily unabsorbs Sketch1, so that it can freeze Folder1, Boss-Extrudel, and
Sketch2. This behavior is consistent with how the rollback bar works with absorbed
features.

B () Sket
-Be
=Y
L &
@) Boss-Extrude?

Another enhancement is that the Feature command displays when you right-click any
feature in the FeatureManager design tree. It displays after the Delete command in the
shortcut menu.
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Hole Wizard Options to Match Size or Preserve
Settings

The sizing matching functionality for Hole Wizard, Hole Series, and Advanced Hole has
improved to match hole sizes when changing from one hole type to another.

In Tools > Options > Hole Wizard/ToolboXx, you can choose between two options for
size matching:

e Preserve settings for each Hole Wizard hole type uses legacy behavior to save
settings for each hole type. For example, if the size setting for tapped holes is M6, that
setting is not affected by the size settings of other hole types. This behavior was used
by SOLIDWORKS version 2015 and earlier releases.

e Transfer settings when changing Hole Wizard Hole type attempts to match the
size settings of the last hole type used and the size settings available for the new hole
type. Matching is done based on string comparison. This behavior is set by default for
all new and upgrade installations to preserve the existing SOLIDWORKS version 2017
behavior.

e Example 1: If you create a counterbore hole and set the size at M6, and then create
a countersink hole, the M6 setting carries over to the new hole type.

e Example 2: If you create a counterbore hole and set the size at M6, and then change
it to a tapped hole, the M6 setting carries over to the new hole type setting it to
Mé6x1.0. If multiple M6 tapped holes are listed (for example, M6x0.75 and M6x1.0),
the first one listed (M6x0.75) will be matched.

In SOLIDWORKS Tools > Toolbox Settings, you can also customize size matching

using the Name to Match column. For example, suppose the last hole you created was
a ¥4” ANSI inch counterbore hole, and in the Name to Match field you entered %" or Mé.
If you then switch to creating DIN counterbore holes, and there is a DIN counterbore hole
with M6 in the Name to Match field, the hole size for DIN counterbore holes is set to M6.

The Preserve settings for each Hole Wizard hole type option is only available when
using the Hole Wizard. Advanced Hole and Hole Series use the Transfer settings when
changing Hole Wizard Hole type option at all times.

String matching is based on the following order of precedence:

IHT is an acronym for Initial Hole Type and FHT is an acronym for Final Hole Type.
Special characters are ignored when performing a string in string match.
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String 1 String 2 Matching Method

Name to Match column |Name to Match column |Exact match, for example % or M6

(IHT) (FHT) matched to *%” or M6

Name to Match column |Size Column (FHT) Exact match, for example M6x1.0

(IHT) matched to M6x1.0

Name to Match column |Size Column (FHT) String in string match, for example

(IHT) M6x0 .75 matched to M6

Name to Match column |Size Column (IHT) String in string match, for example

(FHT) M6x0.75 matched to M6

Size column (IHT) Size Column (FHT) Exact match, for example M6 matched
to M6

Size column (IHT) Size Column (FHT) String in string match, for example
M6 matched to M6x1

Size column (FHT) Size Column (IHT) String in string match, for example
M6x1 to M6

Size column (IHT) Size Column (IHT) Default to initial value, for example
1/8-27 NPSM matched to #0-80

Mesh BREP Bodies

Mesh BREP (boundary representation) bodies are made up of triangular polygons, called
facets. Each facet has three vertices and three edges, referred to as fins.

The facets of a mesh BREP body can be collected into faces. These faces are similar to
the faces in standard SOLIDWORKS BREP bodies, except that mesh faces do not have a
geometric description. For example, the facets of a mesh face can make up a rectangle,
but that face is defined simply as a collection of facets, not as rectangle with a height
and width.

Body Types Created from Mesh

You can convert mesh files into three types of bodies:

e Standard SOLIDWORKS BREP bodies

e Mesh BREP bodies

e Graphics bodies

SOLIDWORKS BREP bodies are the standard bodies used in the SOLIDWORKS software.

They can be solid or surface bodies. They do not include mesh surfaces. Every point on
a face of these bodies can be determined with a mathematical equation.

Mesh BREP bodies can be solid or surface bodies. The bodies are made up of mesh facets.
The facets can be grouped into faces. Facets can form a geometric shape such as a
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rectangle, and the rectangle can have a BREP face associated with it, but not every point
on every face can be determined with a mathematical equation.

Graphics bodies are defined entirely by their facets, without reference to equations. For
example, what appears to be a circle in a graphics body is actually a large number of
triangles, some of whose edges approximate the circumference of a circle. These mesh

edges do not actually form a mathematical curve.

Geometry Elements

Mesh body types can include six geometric elements:

Facets the triangular faces of each
unit of the mesh

Facet Edges the edges or fins of the mesh
facets

Facet Vertices the vertices of mesh facets
BREP Faces faces comprised of mesh
facets
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Edges the boundaries of mesh

BREP Vertices the vertices of the edges of

mesh BREP faces

The edges of mesh BREP bodies may approximate mathematical curves, but do not have
any geometric attributes.

Workflows for Working with Mesh BREP Bodies

There are three typical methods for working with mesh bodies:

Workflow #1

Import a mesh file (*.st1, *.obj, *.ply, *.ply2, or *.3MF) from a 3-D scanner, a
mesh-based modeling software application or another CAD product, and convert it into
a mesh BREP body.

Workflow #2

Import a mesh file (*.st1, *.obj, *.ply, *.ply2, or *.3MF) and convert it into a
SOLIDWORKS graphics mesh body.

Use the graphics mesh body as a physical or visual reference to design a model. You
cannot modify or undo any revisions to a graphics mesh body.

Workflow #3

Select a standard SOLIDWORKS BREP body, or a graphics closed or open body, and
convert it to a mesh body. It is recommended that you complete all modifications to
the SOLIDWORKS body first and convert it to mesh as the last step in the modeling
process.

Working with Mesh

You can manipulate mesh geometry in a similar way as to how you work with SOLIDWORKS
geometry and tools such as:

Determine mass properties.
Create reference planes for mesh BREP bodies (not graphics bodies).
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e Select mesh vertices when sketching. Create sketch relations to a mesh facet vertex
of a graphics body or a mesh BREP body.

e Measure distances between mesh elements, using the Measure tool.

You cannot create sensors for mesh bodies.

e Create section views.

e Trim surfaces.

e Shell, offset, and thicken mesh elements.
e Apply appearances and render.

e Detect interference.

Perform Boolean Operations

To combine, intersect, split, move, copy, and cut surfaces, you need to perform these
tasks as Boolean operations; that is, create a solid volume before removing geometry.

You cannot combine or perform other Boolean operations on bodies with different
geometry types. If you have standard SOLIDWORKS solid or surface bodies, you must
convert them to BREP solid or surface bodies with mesh surfaces before performing
Boolean operations with other mesh BREP bodies.

Options for Importing Mesh Files

Several system options are available for importing mesh files and converting them to

mesh BREP bodies.

To import mesh files:

1. In Tools > Options > Import, under File Format, select one of the following:
e STL/OBJ/OFF/PLY/PLY2
e 3MF

2. Under Import as, select one of the following.

e Solid Body
e Surface Body
¢ Graphics Body

3. Under Mesh body options, select one or both of the following for a solid body or
surface body:

¢ Create mesh bodies bounded by single faces
e Group facets into faces

4. Click OK.

If you select Group facets into faces, the software will attempt to group the mesh
facets into selectable faces.
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Converting Solid, Surface or Graphics Bodies to Mesh

You can convert a standard SOLIDWORKS body or graphics body to a mesh BREP body
using the Convert to Mesh Body tool.

Because the tools for editing mesh BREP bodies are limited, you should do as much
modeling as possible with the standard SOLIDWORKS BREP body before converting it to
a mesh BREP body. After the conversion, you are limited to modifying the mesh BREP
bodies using Boolean operations.

To use the Convert to Mesh Body tool:

1. With the standard SOLIDWORKS BREP body or graphic body open, click Insert >
Feature > Convert to Mesh Body =Y

2. For Selected Bodies @, select solid, surface, graphics closed, or open bodies.

You cannot select mixed body types. You can only convert one body type at a time.

3. Make sure Keep original body is selected if you want to maintain a reference copy
of the original solid or surface body in the model.

4. For graphics bodies, select Group facets into faces to group facets into multiple
faces. The faces will match the faces of the original standard SOLIDWORKS BREP
body. Clear the option if you want to convert the mesh into a single face.
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5.

7.

Move the Mesh Refinement slider toward Coarse for fewer, larger facets on the
mesh, and toward Fine, for more, smaller facets.

A preview of the mesh displays in the graphics area for the selected bodies.

Coarse

Fine

This option is useful if you have two standard SOLIDWORKS BREP bodies of significant
different sizes. After you convert the first body to a mesh BREP body with facets of
a certain size, you could convert the second standard SOLIDWORKS BREP body to a
mesh BREP body, and adjust the mesh refinement, so that the mesh size of the second
converted body is close to the mesh size of the first.

Instead of using the slider, you can adjust the facets in the mesh by:

a) Selecting Advanced Mesh Refinement and specifying the Maximum Distance
Deviation and Maximum Angle Deviation of the facets.

b) Selecting Define Maximum Element Size and specifying the maximum length
of the fins.

Click ¥ .

The Body-Convert to Mesh Body feature is added to the FeatureManager design tree.

Selection Filters for Mesh Bodies

The Selection Filter Toolbar lets you select and view the following geometric elements on
mesh bodies:

&

Mesh facets
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4, Mesh facet edges

& Mesh facet vertices

Example of filtering mesh facets:

Creating a Surface From Mesh Feature

The Surface From Mesh tool lets you manipulate a mesh object that you imported from
an *.stl, *.obj, *.off, *.ply, *.ply2 or *.3MF file to create surfaces and solids.

The Surface From Mesh tool works best on mesh files with regular prismatic geometry
such as planes, cylinders, cones, and spheres. The tool may not be appropriate for highly
irregular meshes such as those created from a 3D scan of an organic shape. Because the
feature only creates surfaces, the recommended workflow is to trim the surfaces to form
a solid.

To create a surface from mesh feature:

1. InTools > Options > Import, under File Format, select STL/OBJ/OFF/PLY/PLY2
and click Import as Graphics Body. Then click OK.
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2. Open a file of the format you just selected.

3. Click Insert > Surface > Surface From Mesh 9.
4. Under Facets, do the following:
a) Clear Dynamic Help if you do not want to display detailed help.
b) For surface type, select the type of surface you want to create. You can select
either a Planar @, Spherical @, Cylindrical @, or Conical & surface.
c) In the graphics area, select a group of facets to define the area of the surface
you want to create. You can select these facets by:

e Selecting a few seed facets.

------

¢ Using the Box Select i... or Lasso Selectc}’ tools.
¢ Painting adjacent facets with the Paint Select tool.
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5. Adjust the Facet tolerance slider to include fewer mesh facets in the surface you
are creating. .

Moving the slider left loosens the tolerance for the facets, while moving the slider
right tightens the tolerance. For example, if you are attempting to create a plane,
and there are three facets, one of which is at a slight angle to the other two, then
a loose tolerance will include the angled facet in the plane, while a tight tolerance
will exclude it.

6. Use the Extend surface size, setting to specify the extension distance of the surface
body that fits the selected facets and geometric shape.

7. In the PropertyManager, click Calculate.

A preview of the surface body displays in the graphics area.
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8. Click ¥.

The Surface-From-Mesh feature is added to the FeatureManager design tree.

You can continue to trim and knit the surfaces together to form a model.

Selecting Facets Using Paint Select

You can select groups of facets in the graphics area with the Paint Select Tool.
To select facets using paint select:

1. In the graphics area, select a mesh BREP body, right-click Selection Tools and click
Paint Select Facets.
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2. Press the left mouse button and hold while you drag the pointer and select the facets.
The facts that intersect with the Selection Circle are highlighted.

3. Adjust the radius of the Selection Circle by moving the slider or clicking the Up or
Down arrow.

4. To deselect facets, click ALT + left mouse button and drag the pointer over the
facets you want to remove.

5. Click ¥.

List of Features Supporting Mesh BREP Bodies

The following tables list the functionality that support solid, surface, and graphics mesh
BREP bodies.

Solid and Surface Mesh Type

Function Type Functionality Notes

Display Apply an Appearance Can apply appearance to the
face, body, and part.

Apply a Decal

Render in PhotoView

Section View

Supports all display modes Facets display shaded in
(HLR, HLV, wireframe, edges mode.
shaded, shaded with edges)
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Function Type

Functionality

Notes

Evaluate Clearance Detection Mesh BREP bodies are
included in clearance
detection for an assembly

Interference Detection Mesh BREP bodies are
included in interference
detection for an assembly.

Mass Properties Facets may change mass
properties.

Geometry Cavity

Center of Mass

Combine

Convert to Mesh

Split Line Curve and Project
curve

Cut with Surface

Applies to solid bodies only.

Delete Body

Delete Face Only Face option available.
Patch and Fill options are not
available.

Intersect

Isolate in shortcut menu

Join

Move and Copy Body

Can only use translate.
Cannot use constraints to
move and copy body.

Offset Surface

Resulting surface is mesh
BREP.

Reference Plane

Supports mesh facets, facet
vertices, and facet fins.

Save Bodies

Scale
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Function Type

Functionality

Shell

Notes

Split

Split Line

Surface From Mesh

Thicken

Applies to surface only.

Trim Surface

Applies to surface only.

Sketch

Reference mesh BREP vertex
in sketch

Sketch Relations

Ability to create coincident
constraints for a sketch point
by selecting a mesh edge or
vertex. Mesh edges
represent a sharp edge
(created from groups of fins)
and mesh vertex is a sharp
vertex; that is, corner
vertices from a combination
of sharp edges. You cannot
inference mesh facet faces
and mesh fins in sketch
commands. Also, you cannot
use them to add sketch
relations.

Graphics Mesh Type

Function Type

Display

Functionality

Apply an Appearance

) [o) { =15

Can only apply appearance
to the body or part.

Render in PhotoView

Renders only in HLR/Wire
frame in draft quality.

Section View

Can only use a graphics
section.

Supports all display modes
(HLR, HLV, wireframe,
shaded, and shaded with
edges)
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Function Type Functionality Notes
Geometry Convert to Mesh
Delete Delete Body is not
supported.
Move and Copy Body Can only use translate.

Cannot use constraints to
move and copy body.

Surface From Mesh

Sketch Reference graphics mesh

vertices in a sketch

Enhancements to Importing Mesh Files as Graphics Bodies

When you import mesh files as graphics bodies, the SOLIDWORKS software now supports
additional features.

You can apply texture and appearances to mesh files that you import into SOLIDWORKS
as graphics bodies.

The imported graphics bodies are visible when you view them in HLR, HLV, and
wireframe modes.

The SOLIDWORKS software can render the imported graphics bodies along with solid
and surface bodies.

The imported graphics bodies can appear behind other geometry. Previously, they
always appeared in the foreground even if the other geometry should have been
displayed in front of the graphics bodies.

Imported . 3MF files that contain meshes with textures and appearances display the
texture and appearances on the imported graphics bodies.

More Control Over Custom Properties

You have more control over custom properties and cut list properties.

When you add a user-defined file property or cut list property, if the Value/Test
Expression includes a quotation mark or inches character, type an @ sign in front of the
quotation mark or inches character. The @ sign insures that the expression evaluates
correctly. It also allows you to specify an inch symbol in a cut list folder name.

A new Link column also allows you to select properties where the text in Value/Test
Expression can link to a parent part or a cut list folder. If the box in the Link column is
clear, you can override the value in Value/Test Expression.

This functionality is available only when the part is created in SOLIDWORKS 2018.

Previously, a quotation mark or inches character in Value/Test Expression led to
Evaluated Values that were unexpected or inconsistent.
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This chapter includes the following topics:

e Adding Hardware

e CST Integration

e IPC Compliant Footprint Wizard

e ODBC Library Data

e Positioning Embedded Components
e Symbol Wizard

SOLIDWORKS PCB is available as a separately purchased product.

Adding Hardware

You can add hardware (heat sinks, rails, and stiffeners) in the SOLIDWORKS software
and push the hardware to SOLIDWORKS PCB using the SOLIDWORKS PCB Connector.

CST Integration

There is support to enable CST Integration through odb++ output.

IPC Compliant Footprint Wizard

You can create IPC compliant PCB footprints in a wizard.

With the wizard, you can automatically generate footprints from dimension information
according to IPC package standards. The wizard is based on formulas from the IPC-7351
standard.

ODBC Library Data

You can create a database link in SOLIDWORKS PCB to access ODBC Library Data.

You can connect SOLIDWORKS PCB schematic parts to engineering or corporate databases
of component and parametric data, such as:

e Approved components and libraries
e Procurement data
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e Electrical parameters
e Device documentation

You can also transfer mapped information from database records to design component
parameters and manage component data.

Positioning Embedded Components

SOLIDWORKS PCB supports the correct positioning of embedded components when pushed
from Altium Designer to the SOLIDWORKS software through the SOLIDWORKS PCB
Connector.

Symbol Wizard

The symbol wizard helps you create symbols for components.
The symbol wizard:

e Simplifies and quickens the symbol creation process, especially for large schematic
devices.
e Is configured using grid-based, tabular data.

¢ Allows for copy, paste, and smart paste operations.
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This chapter includes the following topics:

e Automated Drawing PDF Creation in SOLIDWORKS PDM Standard
e Data Card Editor Undo

e Design Branching and Merging

e Detailed Warning Messages

e Enhanced Assignment of Explicit Folder Permission

e Enhanced File Version Upgrade Tool

e Enhanced Permission Control

e Quality Enhancements in SOLIDWORKS PDM

e Revision Table Integration

e Setting Dynamic Variable Values in Copy Tree

e SOLIDWORKS Inspection Integration

e SOLIDWORKS PDM Application Programming Interface

e SOLIDWORKS PDM Support for Non-SOLIDWORKS CAD File References

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full featured data management solution for a small and
large numbers of users, and is available as a separately purchased product.

Automated Drawing PDF Creation in SOLIDWORKS
PDM Standard

SOLIDWORKS PDM Standard can convert a SOLIDWORKS Drawing file to PDF during a
workflow transition using the same task technology used in SOLIDWORKS PDM
Professional.

To provide access to the Convert task, you must add it to the vault by:

e Selecting the task when you create a new vault.
e Importing the task into an existing vault.
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Configuring the Convert Task (For SOLIDWORKS PDM Standard

only)

Administrators can configure the Drawing to PDF Convert task provided by the
SOLIDWORKS Task Add-in to convert a SOLIDWORKS Drawing file to PDF. The task can
map data card variables, and set the naming convention and destination for converted
files.

To configure the Drawing to PDF Convert task:

1.
2.
3.

In the Administration tool, expand Tasks and double-click Convert.
In the dialog box, in the left pane, click Execution Method.

Select the client computers that can be used to execute the task and how task
execution is initiated.

You must configure each client computer as a task host to appear in the list and run
the Drawing to PDF Convert task on the computer where you initiate the workflow
transition.

Each client computer must have a licensed version of SOLIDWORKS to initiate the
task.

Click Conversion Settings > Conversion Options to display the output file format's
Advanced Conversion Options (Adobe PDF) dialog box.

The only output file format available is Adobe PDF (default).

Under Source file references, specify the version of referenced files to convert.

Click File Card to map variables from the source file's data card to the output file's
data card.

Click Output File Details to specify the output file name format and destination.
You can specify only the output paths that are inside the vault.

Click OK.

Converting a SOLIDWORKS Drawing File to PDF

To convert a SOLIDWORKS Drawing file to PDF:

1.
2.

In the Administration tool, configure the Convert task.

Edit a workflow transition to add an action to execute the Drawing to PDF Convert
task.

When you change the state of a SOLIDWORKS Drawing file using a transition on which
the Drawing to PDF Convert task is set, SOLIDWORKS PDM runs the task. The task:

1. Launches a SOLIDWORKS session on the client computer.
2. Opens the SOLIDWORKS Drawing file.
3. Saves the file as PDF.
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Data Card Editor Undo

SOLIDWORKS PDM lets you undo the changes done in the Card Editor for an active card.
Previously, to undo the changes, you had to close and reopen the card without saving.
To undo the card editor changes, do one of the following:

¢ Click Edit > Undo.
¢ Click Undo in the Main toolbar.
e Ctrl + 2

You can undo the data card changes only if you have not saved the changes.

SOLIDWORKS PDM supports undo for:

e Modifying cards using control properties and card properties.
e Adding and deleting card controls.
e Moving and resizing card controls.

You cannot redo the data card changes that Undo discards.

Design Branching and Merging

SOLIDWORKS PDM Professional has improved handling of various design change scenarios
including multiple design improvement approaches, engineering change requests, and
working with external design consultants.

Branching an existing file structure is similar to Copy Tree, but SOLIDWORKS PDM
Professional maintains the history of source files and branched files. You can create new
versions of the source files from the modified versions of branched files regardless of
whether they have been moved or renamed.
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[ History on tool vise, SLDASK

View Get Save Compare &5 Print
Ewent “er,, User Date Comment
Eulnitial transit.,., 1 Ad.. 2017.. State changed by automatic transition.
¥4 Branched ‘brl 1 Ad.. 2017.

Eranched From Chwault_631%Toal Wise\tool vise, SLDASM
& Created 1 Ad. 2017.

History of branched file

[ History on tool vise, SLOASH

View Get Save Compare & Print
Event Wer., User  Date Camment
#% Branched 'brl’ 1 Ad.., 2017.. EBranched To CWault_631\Branching\taol vise SLDASM
?ulnitial tranzit.. 1 Ad.. 2017.. State changed by automatic transition,
& Created 1 Ad.. 2017.

History of source file

Branching functionality lets you create complete or partial copies of a file structure with
different names and place them in one or more folders. Placing the files into multiple
folders lets you edit the branched files, retaining the source files in their original state

and permission status. If the edits are approved, you can create new versions of the
source files. Otherwise, you can delete the branched files.

Branching Settings
You can branch a single file or a file with its references. After branching, the source file
history and branched file history are updated.

Administrators can also set user and group properties to exclude selected folders from
branching. The files in the excluded folders are not available for branching.

In the Administration tool, on the Settings - Branch page, you can select the following
predefined variables from the list to update the variable values.
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Branch File Narme

Branch File Mame without extension
Branch File Path

Branch Marne

Current time

Logged in user

Source File name

Source File narme without extension
Source File path

Today's date

User - Full name

User - initials

User - User data

In the file list, right-click a branched file and select Associated Branches to list all the
branches the file is a part of. Click a branch from the list to see the branch details.

Branch Dialog Box

The Branch dialog box is similar to the Copy Tree dialog box and lets you copy selected
file references, or retain the existing references.

If your administrator has excluded a folder from branching, a message appears in the
Warnings column and the Branch option is unavailable.

To display the Branch dialog box:
e Select a file and click Tools > Branch.

Branch Name

Enter a branch name.

You must enter a unique branch name.

Default Destination

Displays the current folder location of the selected file. You can enter a new path or
browse to specify the destination path for the folder in the vault.

Settings

This group is a collapsible interface that includes:
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Version to Use

Latest

Uses the latest version of the references for branching.

Referenced

Uses the attached version of the references for branching.

Options

Include simulation

Branches SOLIDWORKS Simulation results associated with
the selected files.

Preserve relative paths

Keeps the paths of references relative to the branched parent
file, creating a folder structure as needed. When you clear
Preserve relative paths, the folder hierarchy is flattened
and all referenced files are branched to the same destination
folder as the parent.

Include drawings

Shows any related drawing files in the file list so you can
include them when branching the reference tree.

Regenerate serial number in cards

If serial numbers are used in data cards, assigns the next
number in the sequence. For Rename with serial number
transformations, the same serial numbers used to name the
files are used in data cards.

Name drawings after their models

Sets drawing file names to the same as their associated
assembly or part file names.
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Transform Operations Modifies the file names of selected files using the transformation

you select.

Add Prefix
Adds the prefix you type to the file names.

Add Suffix
Adds the suffix you type to the file names.

Rename with serial number

Replaces file names with serial numbers.

Only available when serial humbers have been defined in
the Administration tool.

Replace

Replaces strings in file or folder names. In the Replace dialog
box:

1. For Find what, type the string to replace.

2. For Replace with, type the replacement string.

3. Select whether to apply the change to all files or only the
selected files.

4. Select to apply the change to file names, folder names,
or both.

Filter Display

Lets you enter text to refine the list of files displayed. A column selection drop-down lets
you limit the filtering to a specific column, for example, File name, or for All Columns.

By default, the filter is applied to All Columns. You can expand the All Columns list and
select a specific column to apply the filter to. The software searches for the text that you
enter, displays rows that contain the text, and highlights the text for easy identification.

The search field supports these wildcard characters: *, ?, %, -, .,

*string Displays rows that contain text that ends with the entered
string. The string in the filtered rows is highlighted in pink.

string* Displays rows that contain text that starts with the entered
string. The string in the filtered rows is highlighted in pink.

Instead of *, you can use ? or %.
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-string Or string-

Displays rows that contain the entered string.

If the hyphen is at the beginning, the text ending with the
string is highlighted in pink. If the hyphen is at the end, the
text starting with the string is highlighted.

"string or string"

Displays rows that contain the entered string. The string in the
filtered rows is highlighted in pink.

.string or string.

Displays rows that contain the entered string and highlights
the string with a preceding or a succeeding character depending
on the position of the dot.

The filter options include:

Invert Filter or !

You can invert the filter by clicking or by entering the !
character as a prefix to the text in the search field.

Files that do not include the entered text are displayed.

Filter

¢ File Type

e Assemblies
e Parts

e Drawings
e Others

o Selected For Branch

e Yes, Selected
¢ No, Not Selected

o Path/Name Changed

e Yes, Changed
e No, Not Changed
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All Columns

Filters the file list based on the text you enter and the column
you select. You can select one of the following columns:

e Source File Name

e Warnings

e Version

e Checked Out By
e Checked Out In

e Source File Found In
e Branch File Found In

¢ Branch File Name

o State
e All Columns

list.

This filter supports all custom columns that appear in the file

Clear Filter Text B

Removes all filters. This appears when you select an option in

Filter.

Toolbar Buttons

a8

Next
Warning/Previous
Warning

In the file list, changes the focus to
the next file with a warning or the
previous file with a warning.

S= Show All Levels =

“%= Top Level Only

[=]

2= Show All Levels

Levels

Displays file references for the entire
file hierarchy (Show All Levels) or
just the top level of the file hierarchy
(Top Level Only).

The setting defaults to the most
recent setting you used.

B Open File List Open All opens a list of files in
Microsoft Excel.
Open Visible opens a list of visible
files in Microsoft Excel.

E] Save File List Export All exports the file list of all

files as comma separated . txt file.

Export Visible exports the list of
visible files as a comma-separated
.txt file.

161



SOLIDWORKS PDM
File List

To change the columns that are displayed, right-click any column heading and select
columns to display them or clear columns to hide them. You can add up to 10 columns
based on variables by clicking More and choosing variables from the Choose Columns
dialog box.

You can sort the default and custom columns in tables in ascending, descending, or default
order by clicking column headers. Column sorting is useful within large datasets. If you
sort a column in ascending or descending order, the column is highlighted in green and
an arrowhead appears. When you sort a column in a table, SOLIDWORKS PDM removes
the file structure hierarchy. Sorting turns off Show Tree Lines and Show Reference
Selection Control.

Drag a column head to change the position of a column.

Type Displays a thumbnail preview of the file when you hover over
the file type icon.

Source File Name Displays the source file name.

Warnings Displays the warnings.

To quickly locate files with warnings or errors, use the Next

Warning A* and Previous Warning AT toolbar buttons or
Ctrl + the up-arrow or down-arrow on the numeric keypad.

Branch Lets you select the files to branch.

Version The first number is the local (cached) version of a source file
or a hyphen (-) if locally modified. The second number is the
latest version in the vault.

Checked Out By User who has the source file checked out, or blank if not
checked out.

Checked Out In Path to computer and local folder where the source file is
checked out, or blank if not checked out.

Source File Found In Path to the folder that contains the source file.

Branch File Found In Lets you change the path to a folder for the branched file.

The folder must be in the vault.

Branch File Name Lets you change the branched file name.

State State of the source file.
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Check-in after branching

Checks in files on branching.

You can optionally enter the check-in comments.

Total to Branch

Displays the number and type of files you have selected for branching.

The warning A indicates that other files are selected for branching but do not appear
in the file list because of the current filter.

Reset All

Resets all the changed file names and changed destination folder paths to default.

Merging Settings

In the Administration tool, on the Settings - Merge page, you can select the following
predefined variables from the list to update the variable values.

Branch File Marme

Branch File MNarme without extension
Branch File Path

Current time

Logged in user

Source File name

Source File narme without extension
Source File path

Today's date

Use frorn Branch File

Ise from Source File

User - Full name

User - initials

User - User data
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Merge Dialog Box

The Merge dialog box lets you merge the branched file with the source file using different
merging options.

To display the Merge dialog box:
e Select a branched file and click Tools > Merge.

Settings

Branch References

Latest

Uses the latest version of the branched file for merging.

Referenced

Uses the attached version of the branched file for merging.

New File Options Applicable for files that are newly created using merge option.

Include simulation

Merges SOLIDWORKS Simulation results associated with the
selected files.

Include drawings

Shows any related drawing files in the file list so you can
include them when merging the reference tree.

Regenerate serial number in cards

If serial numbers are used in data cards, assigns the next
number in the sequence. For Rename with serial number
transformations, the same serial numbers used to name the
files are used in data cards.

Name drawings after their models

Sets drawing file names to the same as their associated
assembly or part file names.
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Transform Operations Modifies the file names of selected files using the transformation

you select. Applicable for files that are newly created using
merge option.

Add Prefix
Adds the prefix you type to the file names.

Add Suffix
Adds the suffix you type to the file names.

Rename with serial number

Replaces file names with serial numbers.

Only available when serial humbers have been defined in
the Administration tool.

Replace

Replaces strings in file or folder names. In the Replace dialog
box:

1. For Find what, type the string to replace.

2. For Replace with, type the replacement string.

3. Select whether to apply the change to all files or only the
selected files.

4. Select to apply the change to file names, folder names,
or both.

Filter Display

Lets you enter text to refine the list of files displayed. A column selection drop-down lets
you limit the filtering to a specific column, for example, File name, or for All Columns.

By default, the filter is applied to All Columns. You can expand the All Columns list and
select a specific column to apply the filter to. The software searches for the text that you
enter, displays rows that contain the text, and highlights the text for easy identification.

The search field supports these wildcard characters: *, ?, %, -, .,

*string Displays rows that contain text that ends with the string. The
string in the filtered rows is highlighted in pink.

string* Displays rows that contain text that starts with the string. The
string in the filtered rows is highlighted in pink.

Instead of *, you can use ? or %.
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-string Or string-

Displays rows that contain the string.

If the hyphen is at the beginning, the text ending with the
string is highlighted in pink. If the hyphen is at the end, the
text starting with the string is highlighted.

"string or string"

Displays rows that contain the string. The string in the filtered
rows is highlighted in pink.

.string or string.

Displays rows that contain the string and highlights the string
with a preceding or a succeeding character depending on the
position of the dot.

The filter options include:

You can invert the filter by entering character ! as a prefix to
the text in the search field.

Files that do not include the entered text are displayed.

Filter

¢ File Type

e Assemblies
e Parts

e Drawings
e Others

e Selected For Merge

e Yes, Selected
¢ No, Not Selected

o Path/Name Changed

e Yes, Changed
e No, Not Changed
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All Columns

Filters the file list based on the text you enter and the column
you select. You can select one of the following columns:

e Branch File Name
e Branch File Version

¢ Branch File Found In
o Branch File Checked Out By
o Branch File Checked Out In

e Branch File State

e Warnings
e Merge
e Merge Option

e Source File Name

e Source File Found In
e Source File Checked Out By
e Source File Checked Out In

list.

This filter supports all custom columns that appear in the file

Clear Filter Text B

Removes all filters. This appears when you select an option in

Filter.

Toolbar Buttons

At At

Next
Warning/Previous
Warning

In the file list, changes the focus to
the next file with a warning or the
previous file with a warning.

Z= Show All Levels =

“%= Top Level Only

[=]

2= Show All Levels

Levels

Displays file references for the entire
file hierarchy (Show All Levels) or
just the top level of the file hierarchy
(Top Level Only).

The setting defaults to the most
recent setting you used.

Open File List

Open All opens a list of files in
Microsoft Excel.

Open Visible opens a list of visible
files in Microsoft Excel.
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E] Save File List Export All exports the file list of all
files as comma separated . txt file.

Export Visible exports the list of
visible files as a comma-separated
.txt file.

File List

To change the columns that are displayed, right-click any column heading and select
columns to display them or clear columns to hide them. You can add up to 10 columns
based on variables by clicking More and choosing variables from the Choose Columns
dialog box.

You can sort the default and custom columns in tables in ascending, descending, or default
order by clicking column headers. Column sorting is useful within large datasets. If you
sort a column in ascending or descending order, the column is highlighted in green and
an arrowhead appears. When you sort a column in a table, SOLIDWORKS PDM removes
the file structure hierarchy. Sorting turns off Show Tree Lines and Show Reference
Selection Control.

Drag a column head to change the position of a column.

Type Displays a thumbnail preview of the file when you hover over
the file type icon.

Branch File Name Displays the branched file name and its references.

Branch File Version The first number is the local (cached) version of a branched
file or a hyphen (-) if locally modified. The second number is
the latest version in the vault.

Branch File Found In Path to the folder that contains the branched file.

Branch File Checked User who has the branched file checked out, or blank if not

Out By checked out.

Branch File Checked Path to computer and local folder where the branched file is
Out In checked out, or blank if not checked out.

Branch File State State of the branched file.
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Warnings

Displays the warnings A specific to source files and branched
files. For multiple warnings for a file, a hyperlink appears. You
can click the link to see the details of the warnings.

To quickly locate files with warnings or errors, use the Next
Warning and Previous Warning toolbar buttons or Ctrl +
the up-arrow or down-arrow on the numeric keypad.

You cannot complete the merge action unless you
resolve the critical warnings.

Merge

Lets you select files to merge.

Merge Option

Merge

Selected by default for the branched file that is modified.
Creates a new version of a source file when a branched file
is checked in through the Merge user interface. You can keep
the file checked out and check it in later.

Use Source Reference

Selected by default for the unmodified branched file only if
its immediate parent file is selected to merge. SOLIDWORKS
PDM repoints the reference to the source file after the merge
action.

Merge As New File

Available for a branched file. The parent file refers to the new
file after the merge action.

By default, the Source File Name is the name of the branched
file and its target location is the parent file location. You can
change the file name and its target location.

Create New File

Available for the file that is not branched but is a part of the
reference tree. The parent file refers to the new file after the
merge action.

By default, the Source File Name is the name of the branched
file and its target location is the parent file location. You can
change the file name and its target location.

If the Merge check box is not selected for a file, the references
from the branched file are retained as they are, after the merge
action.
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Source File Name Lets you change the source file name only if the Merge Option
is set to Merge As New File or Create New File.

Source File Found In Lets you change the path to the vault folder that contains the
source file only if the Merge Option is set to Merge As New
File or Create New File.

Source File Checked User who has the source file checked out, or blank if not

Out By checked out.

Source File Checked Path to folder where the source file is checked out, or blank if
Out In not checked out.

Source File State State of the source file.

Check-in on Merge

Checks in files on merging.

You can optionally enter the check-in comments.

Total to Merge

Displays the number and type of files you have selected for branching.

The warning indicates that other files are selected for branching but do not appear in
the file list because of the current filter.

Reset All

Resets all the changed file names and changed destination folder paths to default.

Detailed Warning Messages

SOLIDWORKS PDM now provides more-detailed warning messages when a transition
fails.

If one or more conditions are not met, the Warnings column displays:

e A warning in case of one failed condition.
e A hyperlink in case of multiple failed conditions or all failed OR conditions.

You can click the hyperlink to see the details of the conditions that are not met. Based
on the conditions defined in the transition, the warning includes details like condition
type, comparison criteria, value, and configuration details.
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Enhanced Assignment of Explicit Folder Permission

SOLIDWORKS PDM lets you set explicit folder permissions on multiple folders at the same
time.

Previously, you could set explicit permissions on one selected folder at a time.
On the Assigned Folder Permissions tab, to select multiple folders, do one of the following:

¢ Shift + click
e Ctrl + select
e Left-drag

The Folder Permissions area displays the assignable permissions. The status of check
box changes as the folder permission assigned to selected folder changes.

Check box status Description

M (Selected) Permission is set to all selected folders.
E (Green) Permission is set to one or more selected folders, but not all.
O (Cleared) Permission is not set to any selected folder.

Enhanced File Version Upgrade Tool

In the SOLIDWORKS PDM File Version Upgrade tool, vault analysis and upgrade is now
quicker.

The enhancements in the upgrade tool let you:

e Upgrade files that are checked out on other client workstations.

e Upgrade files whose parent files are checked out on other client workstations.
e Add or remove folders to upgrade.

e Sort the file list in Search Results.

e Stop the upgrade process and resume.

e View the summary of the file versions to upgrade.

e Monitor the upgrade process.

e Notify users about the upgrade process.

File Version Upgrade Summary
The upgrade tool shows the summary of the file versions to upgrade on the Ready to
Upgrade Files screen.
The summary displays the following:

e Total number of SOLIDWORKS versions to update.
e Number of SOLIDWORKS part file versions.
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e Number of SOLIDWORKS drawing file versions.

e Number of SOLIDWORKS assembilies file versions.
e Work instruction file names.

e Number of files in each work instruction file.

Monitoring the Upgrade Process

To monitor the upgrade process, do one of the following:

¢ On the Welcome screen, click Monitor upgrade process.
e Initiate the upgrade process and, on the Ready to Upgrade Files screen, click Monitor.

The Monitor upgrade screen displays the overall upgrade process progress and the upgrade
progress of each work instruction file.

Host Name Machine name on which you initiate the upgrade process

Instruction file name Names of the work instruction files

Progress Upgrade completion status of work instruction files
Processed Batch Number of processed batches / total number of batches
Processed File Number of processed files / total number of files

Start time Time when the upgrade process is started

Elapsed time Time elapsed after the upgrade is started

Status Upgrade status of work instruction files

Notifying Users About the Upgrade Process

SOLIDWORKS PDM notifies users whenever the upgrade process is started, paused,
resumed, completed, or has failed.

To notify users about the upgrade process:

1. On the Upgrade Settings screen, select Notify success/failure to users.
2. Click Add and select the users to be notified.

SOLIDWORKS PDM sends notification emails to the designated users based on the
status of work instruction files.
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Enhanced Permission Control

The Admin user can allow users to undo check out or check in the files that are checked
out by another user.

The administrative permission, Can undo check out files checked out by other users,
is selected by default for the Admin user.

With this permission, users can do the following to the files checked out by other users:

e Undo the Check out or Check in of files on the same machine and in the same vault
view.

e Undo the Check out of files on a different machine and in a different vault view.

When a user does undo check out to a file checked out by another user, the details are
added in history.

Previously, only administrators could undo the check out or check in of files that are
checked out by another user.

Quality Enhancements in SOLIDWORKS PDM

You can open the search results from the embedded Windows Explorer search tool in
Microsoft Excel or export them as a comma-separated value (.csv) file. The Open search

result # and Export search result commands are available on the Search toolbar.

Click to export the search results as a comma-separated value (.csv) file. Click 3 to
open the search results in an Excel spreadsheet.

You can copy links of files and paste them to notification messages to your colleagues.
Right-click a file, select Copy Link, and paste the link in the new message. When you
click the link, SOLIDWORKS PDM navigates you to the appropriate file in the vault.

In the Administrative Export File dialog box, you can expand or collapse specific nodes
or all nodes. To expand or close all nodes, right-click a node or in the dialog box and
select Expand All Nodes or Close All Nodes. When you remove the specific setting or
variable, the expanded or collapsed structure is retained.

SOLIDWORKS PDM provides the _SW_Last_Saved With_ variable that cannot be deleted.
It provides mapping between Summary and Last Saved With for the files with extensions
slddrw, sldasm, and sldprt. SOLIDWORKS PDM updates the value of the variable
whenever you check in a file. In the Administration tool, in Customizable Columns dialog
box, you can select this variable to add the column in the file list or search result for
specific users.

Revision Table Integration

SOLIDWORKS PDM can now read and write values from or to a SOLIDWORKS revision
table. You can configure SOLIDWORKS PDM variables to automatically add information
such as revision date, description, and approver to a new row in the table or to update
the last row.

When you change the mapped variable values in the file's data card, the values in the
latest row of the table are updated and vice versa.
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The revision table row can be updated automatically by using:

Set variable transition actions
Set Revision command

Configuring Revision Table Integration

To configure revision table integration:

1.

Configure the mapping between SOLIDWORKS PDM variables and revision table
columns in the SOLIDWORKS drawing.

For details, see SOLIDWORKS PDM Administration Guide: Mapping Variables to File
Properties.

Configure the Revision Table node.

Set a variable that holds the custom property revision.

You must set the Revision variable for the current state of a file during the set revision
action and for the target state of a file during the change state action. For details,
see SOLIDWORKS PDM Administration Guide: Set Variables Dialog Box.

Define the Set Variable transition actions for each variable.

You need not define the Set Variable transition action for the Zone variable as it is
read-only.

Configuring the Revision Table Node

You must configure the Revision Table node to update the revision table rows.

To configure the revision table node:

1.
2.
3.

4.

In the Administration tool, expand SOLIDWORKS and double-click Revision Table.
Select Enable Revision Table to manage the revision table by SOLIDWORKS PDM.

Set the values on the Revision Table Settings and Set Revision Command
Settings tabs.

Click OK.

Configuring the Revision Table Settings

You can set options on the Revision Table Settings tab.

To configure the Revision Table Settings:

1.
2.

Open the Revision Table dialog box.

On the Revision Table Settings tab, set the number of visible rows in the revision
table.

In the Revision placeholder character, enter a placeholder character or characters.

174



SOLIDWORKS PDM

Configuring the Set Revision Command Settings

You can set options on the Set Revision Command Settings tab to update the revision
table when you use the Set Revision command.

In the File Explorer, in the Set Revision dialog box, you must select Update Variable to
update the revision table.

To configure the Set Revision Command Settings:

1.

2.

Open the Revision Table dialog box and select the Set Revision Command Settings
tab.

Select Update Revision Table in SOLIDWORKS Drawing through "Set Revision"
Command.

Select a check box under the Revision Table Column for a variable to appear in the
revision table.

Enter a value under Column Value.
You can click to select the system variable.

Select a corresponding variable under Variable Name.
Click OK.

Defining Variable Mapping

You can configure the mapping between SOLIDWORKS PDM variables and revision table
columns in SOLIDWORKS drawings.

To configure the variable mapping:

1.

A WwN

Expand the Variables node and edit the variables.

You can edit the current variables, Approved by, Description, Date, Revision, or
create new variables. You must create the Zone variable as read-only because the
value of this variable is read from the drawing.

In Variable name, type a name.

Set the Variable type as Text.

In Block name, type SWRevTable.

In Attribute name, select the attribute name.

For a custom column, you must type the attribute name that is the same as the
revision table column header.

When you use the SWRevTable block for the default revision table column, you can
select the attribute name from the list.

Type the file extension, s1ddrw, and click OK.

Revision Table Dialog Box

To open the Revision Table dialog box:

Expand the SOLIDWORKS node and double-click Revision Table.
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Enable Revision Table Select this option to manage the SOLIDWORKS drawing revision
table using SOLIDWORKS PDM.

Revision Table Settings

Number of visible rows Sets the number of rows to display in the
drawing revision table.

When the number of revision table rows in
a drawing exceeds the set number, the
oldest row is deleted.

Revision placeholder character Lets you enter characters that appear in the
revision column of the revision table. The
actual revision value replaces these
characters when you change the revision in
SOLIDWORKS PDM.

If you do not enter the placeholder
characters, SOLIDWORKS PDM adds a new
row to the table.

Set Revision Command Settings

Update Revision Table in SOLIDWORKS Updates the revision table when you:
Drawing through "Set Revision"

o Define the Set Revision action.
Command

o Select Update Variable in the File
Explorer in the Set Revision dialog box.

Select a check box to display a variable as a revision table column in the revision table.

Revision table Column value Variable Name

column

Revision By default, set to revision value Select the mapped variable,
set with Set Revision action. Revision.

The list displays the variables
that are mapped using the
SWRevTable block name.

Description, Date Select the variable.

" Click to select a variable to
Approver

be added to the column. You can
also type the text.
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Setting Dynamic Variable Values in Copy Tree

With the enhanced Copy Tree variable settings, it is possible to update variables with
dynamic values. You can set dynamic variable values in the Settings dialog box - Copy
Tree page.

Previously, you could only use static values.

To set dynamic variable values in Copy Tree:

1. In the Administration tool, in the Settings dialog box - Copy Tree page, under File
types, click Add.

2. Click Add Variable and select predefined variables from the list.

3. For Value, click to select a dynamic value.
The following dynamic values are available:

e Current time

e File Name

¢ File name without extension
e File Path

e Logged in user

e Target File Name

e Target File name without extension
e Target File Path

e Today's date

e User - Full name

e User - initials

e User - User data

SOLIDWORKS Inspection Integration

SOLIDWORKS Inspection now includes a tight integration with SOLIDWORKS PDM. The
integration covers both the SOLIDWORKS Inspection add-in to SOLIDWORKS and the
SOLIDWORKS Inspection Standalone application.

SOLIDWORKS Inspection Standalone supports:
e Variable mapping for inspection project files
SOLIDWORKS PDM lets you create block attribute mapping for the following properties:

e SWIPrjProperty defines mapping for Inspection Project Properties.

¢ SWICustomProperty defines mapping for Inspection Custom Properties.

The attribute names that you can use with SWIPrjProperty for Project Properties
are:

e Part Name

e Part Number

e Part Revision

e Document Name

¢ Document Number
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¢ Document Revision

File reference handing

SOLIDWORKS PDM creates references between the inspection project files (. ixprj)
and output deliverables (.x1sx, .pdf).In SOLIDWORKS PDM, the Contains tab
displays inspection project files as a parent file and output deliverables as child
references.

In SOLIDWORKS Inspection add-in, the references are created between a drawing
file and output deliverables files or between inspection project file and output files.

SOLIDWORKS PDM ribbon

The SOLIDWORKS PDM ribbon is added to SOLIDWORKS Inspection Standalone. You
can access SOLIDWORKS PDM features such as Check Out, Check In, Search, Get
Version, and Get Latest Version using the SOLIDWORKS PDM tab in the
CommandManager. This integration helps you manage and centralize the storage of
inspection projects as well as the files and reports related to them.

SOLIDWORKS PDM Application Programming
Interface

See SOLIDWORKS PDM Release Notes for late-breaking updates.
SOLIDWORKS PDM 2018 API includes the ability to:

Ability to add a custom tab to PDM vault views:

e Customers and partners can add custom tabs to PDM vault views in Windows Explorer
using a PDM API add-in.

e API hooks to partner development code can display special items in these custom
tabs.

e Add-ins can implement custom tabs with custom names and icons.

e Add-ins can add any number of custom tabs to the vault view in Windows Explorer.

e Add-ins can programmatically remove custom tabs.

Ability to programmatically refresh a data card when its card variables change.
Ability to restore deleted files from the Recycle Bin.

Ability to select the transition to use when changing a file’s state.

Ability to specify whether to batch update only the variables that are part of the file
data card.

Get a list of values associated with a drop-down control on a data card.

Provide more IEdmSearch comparators.
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SOLIDWORKS PDM Support for Non-SOLIDWORKS
CAD File References

SOLIDWORKS PDM supports the handling of references between SOLIDWORKS files and
non-SOLIDWORKS CAD data created through 3D Interconnect.

You must add the non-SOLIDWORKS CAD files to the vault at the beginning so that they
are referred from the file vault.

SOLIDWORKS PDM recognizes the non-SOLIDWORKS CAD references during check in of
the parent SOLIDWORKS part or assembly and lists them as CAD references after check
in is complete. You do not have to create any user-defined references. The CAD references
are listed in the Contains tab, Bill of Materials tab, Where Used tab, and in any operation
that lists the reference tree. This is true for both the parent SOLIDWORKS file and any
parent non-SOLIDWORKS file.

For example, when you check in a SOLIDWORKS assembly along with an Inventor
sub-assembly that is inserted in it, SOLIDWORKS PDM establishes PDM references between
parent and its first level of child references. This also includes references between Inventor
subassembly and its parts.

SOLIDWORKS PDM supports the following file formats through 3D Interconnect:

Autodesk® Inventor IPT, IAM

CATIA® V5 CATPART, CATPRODUCT
PTC®/CREO PRT, PRT., XPR, ASM, ASM., XAS
Siemens™ NX PRT

SOLID Edge® PAR, PSM, ASM
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This chapter includes the following topics:

e Clamp Force in Machine Opening Direction
e Density Result at End of PACK Analysis

e Exclude Area from Clamp Force Calculation
e Export Deformed Geometry

e Mesh Enhancements

e Shrinkage Percentage in Warp Measure

e Temperature Criteria for Short Shots

SOLIDWORKS Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics
Premium are available as separately purchased products that can be used with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Clamp Force in Machine Opening Direction

You can specify the Injection Molding Machine Opening direction to estimate the clamp
force in the selected direction.

In the Clamp Force PropertyManager, select one of the default axes (X, Y, or Z), or select
a plane, planar face, or linear edge of your model to define a machine direction that is
not aligned with a default axis.

To view the clamp force results:

e Create an X-Y plot.

e Access the Flow and Pack Summary where the clamp force in the user-defined
machine direction is listed.

Density Result at End of PACK Analysis

You can view density results at the end of a PACK analysis for solid meshes.

Use the Density at End of Pack simulation result as a guideline to evaluate the
effectiveness of your packing stage. The density should be relatively uniform across the
part geometry. Large variations in density can lead to non-uniform shrinkage and warpage.
Voids might form at areas with low density.
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Exclude Area from Clamp Force Calculation

If your model contains undercuts or slides, you can exclude these areas from the clamp
force estimation.

In the Clamp Force Property Manager click Exclude Area, and select the elements of
your model that represent the undercut or slide regions.

When you run the FLOW or PACK simulation, these elements are excluded from the
clamp force calculation, for example the red areas that represent undercuts in the image.

Export Deformed Geometry

An enhancement to the Export Deformed Geometry feature allows you to choose a
non-uniform deformation scaling factor for each of the three major axes.

With the new export deformed geometry feature, you can export warped mesh models
in Abaqus, STL, Nastran, and native SOLIDWORKS Plastics formats.

If you use the Automatic option to create the mesh, this feature is unavailable with
solid meshes.

Mesh Enhancements

Several mesh enhancements improve the mesh creation process.

e Application of previously defined mesh settings when creating a new surface mesh,
and ability to re-mesh the part in one step.

e Creation of Mesh groups enables an easier identification of dependent domains (cavity,
runner, inserts) and independent domains (mold, cooling channels) during surface
meshing. For all parts inside a dependent domain, the mesh is compatible in areas
where the parts come into contact.

o Identification of SOLIDWORKS CAD geometry as a mold domain.
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Shrinkage Percentage in Warp Measure

The Warp measure tool now displays the shrinkage amount (the distance between two
reference nodes) both in terms of the absolute value (dR) and percentage value (dR[%]).
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Temperature Criteria for Short Shots

A Flow Analysis setting Temperature Criteria for Short Shots improves the FLOW
simulation accuracy of predicting potential short shots.

Short shots may occur when the temperature at the melt-front falls below the Glass
Transition temperature of the plastic material.

The Temperature Criteria for Short Shots setting with the default temperature value
set to the Glass Transition temperature is enabled by default. When this setting is enabled,
the temperature within the elements along the melt front is continuously monitored, and
when the temperature falls below the specified value, a short shot is detected.
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This chapter includes the following topics:

Flattening Enhancements
General Routing Enhancements
Routing Library Manager Enhancements

Routing is available in SOLIDWORKS Premium.

Flattening Enhancements

Highlighting Route Segments of Selected Connectors

In the flattened state, you can view the connected routes and components of selected
route segments as highlighted routes in the graphics area.

When you right-click these entities, the shortcut menu options available are:

e Connectors: View Connected Segments.

e Route segments: View Connected Connectors.

Flattening Support for Clips with Multiple Route Segments

In the flattened state, where multiple, disjointed routes are present, clips are visually
associated with at least one route segment and placed parallel to the route segment.
Repositioning Disjointed Routes

You can manually drag route assemblies in the flattened state. Select Move Connected
Route Segments from the shortcut menu.

Connector table enhancements:

e You can view the following new options in the connector tables:

¢ Connected to Reference
e Connected to Pin

¢ You can add new columns in the connector table from a central location.
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General Routing Enhancements

Piping: Grouping of Spool Components in BOMs

You can view spools in the Bill of Materials as separate entries. In the Bill of Materials
PropertyManager, click Routing Component Grouping > Group spool components.

Electrical: Adding Splices to Routes

You can add splice components to routes with the Add to Route command. You can add
splices in the graphics area and connect existing routes to it.

Routing Library Manager Enhancements

SOLIDWORKS Electrical and Routing User Interface Integration

You can access the Routing Library Manager from the SOLIDWORKS Electrical 3D tab.
You can create CPoints and define mate references for electrical components from the

Routing Library Manager i instead of the Electrical Component Wizard.

To access the Routing Library Manager from the SOLIDWORKS Electrical 3D
CommandManager, click SOLIDWORKS Electrical 3D and click Routing Library Manager.

The SOLIDWORKS Electrical 3D enhancements on the Routing Component Wizard tab of
the Routing Library Manager include:

e Three new options in Routing Functionality Points under Point Type:

e Cpoint with circuit information
e Cpoint from manufacturer part
e Cable Cpoint

e Three new options in Mate Reference under Reference name:

¢ For Rail
e For Cabinet
¢ For Cabinet Door

¢ A new command in Mate Reference under Component Alignment Options:Status,
Define Faces.

General Routing Library Manager Enhancements

Routing Library Manager Support for Non-English Languages

The Routing Library Manager supports routing library components in all standard
SOLIDWORKS languages. When you create routing library parts in one language and
open them in the Routing Library Manager of other languages, the software recognizes
the routing-specific features.
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Component Library Wizard

The Component Library Wizard enhancements include:
e The Component library node of the Component Library Wizard is divided into two
sections - Connectors Library, and Interconnect and Accessories Library.

e For the Interconnect and Accessories Library, you can specify the library path and
the specifications in the Terminal List. You can also add new accessories to the library
with the Add New option.

e For the Connectors Library, you can specify the library path and the specifications
in the Component List and the Pin List.

e You can add new columns in the Pin List. Right-click an existing column and click
Insert Column Left or Insert Column Right on the shortcut menu.

Covering Library Wizard
The Covering Library Wizard enhancements include:

e The Covering library node of the Covering Library Wizard is divided into two sections
-Piping, Tubing, and Ducting, and Electrical.

e For Piping, Tubing, and Ducting, you can specify the library path and the
specifications in the Covering List and the Material List.

e For Electrical, you can specify the library path and the specifications in the Covering
List.

Enhancements for Cable Wire Library Wizard, Component Library Wizard, and
Covering Library Wizard

You can use vertical scroll bars to scroll through any of the lists in these wizards.

You can click |—| after any of the library paths, to browse to a file for viewing and editing
it.
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This chapter includes the following topics:

e Creating Normal Cuts
e Tab and Slot
e Three Bend Corner Reliefs

Creating Normal Cuts

With the Normal Cut tool, you can normalize all non-normal side walls in sheet metal
models.

The Normal Cut tool applies a normal cut feature that is independent from the tools that
removed the material. You can select several faces to define a normal sheet metal side
wall (not top or bottom faces).

Although you can create extruded cuts with the Normal Cut option, this option is
limited to individual extruded cut features.

To create a normal cut:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\sheet metal\normal cut.sldprt.

The part has lofted cuts with non-normal side walls.

2. Click Normal Cut & (Sheet Metal toolbar) or Insert > Sheet Metal > Normal Cut.

3. Inthe PropertyManager, under Faces For Normal Cut @, select Auto Propagation.
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4. In the graphics area, select the face of the cut.

The software selects all faces of the cut.

5. In the PropertyManager, under Normal Cut Parameters, select Extent.

With Extent, the maximum amount of geometry is cut based on the outline at the
top and bottom face.

6. Click v .

The faces of the cut are normal to the top and bottom faces of the part.

Tab and Slot

The Tab and Slot feature creates tabs on one body and slots (holes) on another body
to interlock the two bodies. You can specify how the tabs and slots look and how they
are distributed along the selected entities.

Tabs and slots make it easier to weld parts together and minimize the requirement to
build complicated fixtures because you can interlock several sheet metal parts. This
feature is available in all parts, not just sheet metal parts. You can use it in single bodies,
multibodies, and parts in the context of an assembly.

Edges and faces must correspond to each other - when you select an edge for the tabs,
you must select a matching face for the slots. The edges and faces must be planar or
cylindrical, but they do not have to touch.
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Tab and Slot feature Enlarged image

Creating a Tab and Slot

To create a tab and slot:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\sheet metal\tab and slot.sldprt.

2. Click Tab and Slot (Sheet Metal toolbar) or Insert > Sheet Metal > Tab and
Slot.

3. In the PropertyManager:
a) Under Spacing, select Equal Spacing and set Number of Instances e to 7.

b) Under Tabs, set Length o to smm, Height I to Blind and Tab Height Value
to 5mm.
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4. 1In the graphics area:

a) Select the edge shown for the Tab Edge @

b) Select the back face shown for the Slot Face @
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5. Click ¥.

Three Bend Corner Reliefs

Improvements to three bend corner reliefs include:

e If a corner relief is smaller than the required corner cutout, it is now visible in the
folded state.

e The ability to create a suitcase corner - a closed spherical corner without any cutouts.

Corner Relief Display
Three bend corners are improved to create corner reliefs that are smaller than the required
default corner treatment when in the folded state.

Previously, the software could only create three bend corner reliefs in the folded part

when the corner treatment was bigger than the necessary cutout that was required to
unfold the part.

The following shows a circular corner relief in the folded state.
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SOLIDWORKS 2018 SOLIDWORKS 2017

Creating Suitcase Corner Reliefs

A suitcase corner relief is a closed spherical corner without any cutouts. The sphere is
based on the existing sheet metal parameters.

To create a suitcase corner relief:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS

2018\samples\whatsnew\sheet metal\bracket.sldprt.

2. Click Corner Relief @ or Insert > Sheet Metal > Corner Relief.
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3. In the PropertyManager, under:
a) Corner Type, select 3 Bend Corner.
b) Corners, click Collect all corners.
c) Relief Options, select Suitcase and set the gap to one of the following:

Option Description

Leaves the gap unchanged.

Default Suitcase EE

Extends the corner relief material into the

Fill in some gap &4
gap gap.

4. Click ¥.
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This chapter includes the following topics:

e Topology Study

e Allow for Dismissal of Warning Messages

e Create Results Plot from Imported Data

e Displacement Control for Nonlinear Contact

e Email Notification for Completed Analysis

e Factor of Safety Plot for Nonlinear Static Studies

e Import Simulation Study Features into Assemblies
e Improved Pin Connector

e Mesh Refinement for Stress Singularities

e Sensor for Simulation Mass Properties

SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are available as separately purchased products that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Topology Study

Use a Topology study to explore design iterations of a component that satisfy a given
optimization goal and geometric constraints.

Available in SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium.

A Topology study performs nonparametric topology optimization of parts. Starting with

a maximum design space (which represents the maximum allowed size for a component)
and considering all applied loads, fixtures, and manufacturing constraints, the topology
optimization seeks a new material layout, within the boundaries of the maximum allowed
geometry, by redistributing the material. The optimized component satisfies all the required
mechanical and manufacturing requirements.

For example, you can optimize the part of a car hood opening mechanism, as shown in
the image below in blue, in terms of strength and weight (image courtesy of Ring Brothers
LLC).
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With a Topology study, you can set a design goal to find the best strength to weight ratio,
minimize the mass, or reduce the maximum displacement of a component.

It is recommended to start with the Best Strength to Weight ratio goal to get an
initial optimized shape of your component.

In addition to the optimization goal, you define design constraints to ensure that the
required mechanical properties, such as maximum deflection, percentage of mass removed,
and also manufacturing processes are satisfied. For a successful Topology study run, the
design proposal reached by the iterative optimization process should fulfill all structural
and manufacturing requirements entered.

In the Study PropertyManager, select Topology Study.
To set up a Topology study, you define:

One Goal The optimization goal drives the mathematical formulation of the
optimization algorithm. In a Topology Study tree, right-click Goals and
Constraints. In the Goals and Constraints PropertyManager, select one
of the optimization objectives: Best Strength to Weight Ratio,
Minimize Mass, or Minimize Maximum Displacement.

When you select Best Strength to Weight Ratio, the algorithm seeks
to minimize the global compliance of the model which is a measure of
the overall flexibility (reciprocal of stiffness). Compliance is defined by
the sum of strain energies of all elements.

Constraints Constraints limit the design space solutions by enforcing the percentage
of mass that can be eliminated to be under a certain value, or by setting
performance targets for the maximum displacement observed in your
model. You can define up to two constraints for one optimization goal
in the Goals and Constraints PropertyManager. The User Interface filters
the type of constraints you can apply based on the goal you select.

Preserved These are regions of your model that are excluded from the optimization
Regions process and are preserved in the final shape. The geometric entities
where you apply loads and fixtures are preserved by default. To select
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which regions to exclude from optimization, go to Topology >
Options > Preserved (Frozen) Region settings. To select additional
faces to preserve, right-click Manufacturing Control, and select Add
Preserved Region.

Manufacturing Geometric constraints enforced by manufacturing processes ensure that

Controls the optimized part is manufacturable. Right-click Manufacturing
Control, and define the desired controls like De-mold Direction,
Thickness Control, or Symmetry Control. In the De-mold Direction
PropertyManager, you can also apply a stamping constraint to create
holes across the thickness of a part. With the Symmetry Control, you
can enforce half, quarter, or one-eighth symmetry to the optimized
shape of the component.

Depending on the settings of the optimization goal, manufacturing controls, mesh, loads,
and boundary conditions, the optimization process yields an acceptable design that is a
derivative of the initial maximum design space.

Material Mass Plot

When the iterative optimization process completes, you view the optimized geometry of
the component in a Material Mass contour plot.

During a Topology Optimization, the program starts with the given maximum physical
space of a component, which includes all elements, and through an iterative process
determines a new material distribution by removing the "soft" elements that do not
contribute to the stiffness of the component for the particular load scenario, boundary
conditions, and manufacturing controls.

For each element, the optimization algorithm couples the material's Young's modulus
with a relative mass density factor ranging from 0.0001 (for a void element without any
load carrying capacity) to 1.0 (for a solid element with load carrying capacity).

Elements with low relative mass densities (less than 0.3) are considered "soft" elements.
These elements do not contribute to the overall stiffness of the component, and they can
be safely removed. Elements with high relative mass densities (larger than 0.7), are
considered "solid". These elements contribute the most to the overall stiffness (as a
measure of the load carrying capacity) of the component, and they should remain intact
in the final design. The "solid" elements distribute the applied loads more effectively than
the "soft" elements. An isovalue slider adjusts the inclusion of elements in the Material
Mass plot according to their relative mass density values. The default position of the
isovalue slider removes the elements with relative mass density values less than 0.3.
Moving the slider to Heavy includes all elements, whereas moving the slider to Light
plots only the solid elements which cannot be removed.

A Material Mass plot of the optimized car hood component is shown below. The "soft"
elements are removed from the optimized geometry (image courtesy of Ring Brothers
LLC).
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In the Material Mass PropertyManager, option Calculate Smoothed Mesh creates a
smooth mesh from the active Material Mass plot. A smoothed mesh plot of the optimized

car hood component is shown below (image courtesy of Ring Brothers LLC).
- prgemd v Fte O I'
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To save the smoothed mesh of the optimized part as new geometry, right-click the
Material Mass plot, and click Export Smoothed Mesh. You can save the mesh data in
a new configuration, or in a new part file.
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Topology Optimization of a Plate

In this tutorial, you set up a Topology study with the goal to find the best strength to
weight ratio of a plate while reducing its mass by 50%.

You create a Topology study to examine optimized shapes of a steel plate fixed on one
side and loaded with a 750 N load.

Opening the Part

To open the part file (plate.sldprt), browse to the file location

system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\Simulation\plate.sldprt

The TopLoad_Ready study includes:

e A static study with solid mesh

e ASTM A36 Steel material applied to the part
e A fixed restraint on a face

e Aload of 750 N

Creating a Topology Study

You create a Topology study with a goal to find the best strength to weight ratio of the
plate, while reducing its mass by 50%.

1. Click New Study (Simulation CommandManager).
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2.

Under Type, click Topology Study. Click ¥ .
The Topology Study 1 study tab is created.

Copy from the TopLoad_Ready static study the fixed restraint Fixed-1 and the load
TopForce (Per item: -750 N) to the new topology study.

In the Topology study tree, right-click Goals and Constraints, and click Best
Strength to Weight Ratio. In the Goals and Constraints PropertyManager:

a) Under Constraint 1, for Reduce mass by (percentage) set 50 (%) for
Constraint Value.
b) Click ¥ .

The optimization algorithm will try to minimize the compliance of the model (reciprocal
of stiffness) which is defined by the sum of strain energies of all elements.

Setting Study Properties and Running the Study

1.

Right-click the top Topology Study icon, and select Properties. In the Options tab
(Topology dialog box) do the following:

a) For Solver, select Intel Direct Sparse
b) Select Run Static analysis before running topology study.

c) Under Preserved (Frozen) Region settings, select Regions with loads and
fixtures. There regions remain unchanged by optimization.

d) Click OK.

Click Run This Study (Simulation CommandManager).
The optimization algorithm through several iterations will try to reach convergence.
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Viewing Results

1.

Under Results, double-click Material Mass 1(-Material Mass).

The Material Mass PropertyManager plots isovalues of the elements' relative mass
densities. Elements with higher mass densities are considered solid, and they must
remain in the "optimized" shape. Elements with lower mass densities are considered
"soft" and can be removed. Move the slider under Display to the rightmost position
Light to plot only elements with mass densities close to 1 (must keep). Move the
slider to the leftmost position Heavy to plot all elements. The color chart option of
the material mass plot is set to Optimized for Material Mass. Red and green color
are removed from the material mass plot color scale to better assist colorblind users
when viewing the plot.

The default position of the slider plots all elements with relative mass densities larger
than 0.3. The remaining mass of the plate (at the default slider position) measures
25.56 Kg which equals to 52% of the original mass of 49.06 kg.

Material Mass

Must Keep

Ok to remowve
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2. Click Calculate Smoothed Mesh E'-’aLE.

The program creates smooth surfaces of the optimized shape so that the final design
is ready to manufacture.

3. Click .

To save the smoothed mesh into a new configuration, or a new part, right-click
Material Mass1 (-Material Mass), and click Export Smoothed Mesh.

Allow for Dismissal of Warning Messages

You can suppress recurring warning messages that appear in a simulation workflow.

Select Do not show me this again in the message dialog to suppress the recurrence
of the message. You can restore the suppressed messages from the Simulation System
options dialog box.

Create Results Plot from Imported Data

You can create simulation results plots by importing data from an external file.
Right-click the top study icon of a study tree, and click Plot Imported Results.

Select the input file to import the external results data. The input file can be either a text
* _txt file, or a comma/space delimited *.csv file. Mapping of results is achieved per
node or element number. The current mesh of the active study and the mesh from which
the imported results are derived must be identical.

The data are stored in two columns. First column lists the node or element number, and
second column lists the scalar values associated to the respective node or element.
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Displacement Control for Nonlinear Contact

You can use the Displacement Control method to solve nonlinear contact analysis with
the Direct Sparse and Intel Direst Sparse solvers only.

The Displacement control method is enhanced to handle post buckling behavior in nonlinear
analysis. Only the surface-to-surface contact formulation is supported when activating
the Displacement Control.

Email Notification for Completed Analysis

Automatic email notification when the analysis completes allows you to track the status
of a running Simulation study.

Click System Options > Email Notification Settings to set up the email server settings.
You can set up email notification delivery to track the solution status of a simulation
study. You get email notifications for these cases:

e The solver completes the simulation. Select Email when simulation is completed
in the Notification tab of the study properties dialog box.
e The solver encounters numerical difficulties and does not complete the simulation.

e Time-based notification about the solution status of a study, for example every 20
min, 40 min, etc. Select Time based notification in the Notification tab of the study
properties dialog box.

Factor of Safety Plot for Nonlinear Static Studies

The factor of safety plot is extended to nonlinear static studies.

After a nonlinear static analysis completes, you can create a factor of safety plot based
on a defined failure criterion.

Right-click Results and click Define Factor of Safety Plot. Create a factor of safety
plot from results derived from a selected solution step or from the extreme values across
all solutions steps.

Import Simulation Study Features into Assemblies

When creating a new static study, you can copy simulation features defined on a part or
sub-assembly document into the new study created on an assembly document.

In the Study PropertyManager, under Options, select Import Study Features.

In the Import Study Features dialog box, you can select from the Assembly Hierarchy
the parts and sub-assemblies associated to the study features you want to import.

The simulation features you can import are material, element types, contact, connectors,
fixtures, loads, and mesh control definitions from static studies. You can import all
simulation features or select which features to import.
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For models that have multiple instances of parts or sub-assemblies, you can propagate
the selected study features to all instances in the assembly (or part) document. Click
Propagate imported study features to all instances (*).

Improved Pin Connector

You can define a pin connector through more than two cylindrical surfaces in one definition.

An improved user interface allows the definition of a single pin connector applied to
multiple cylindrical faces (maximum ten). You select all coaxial cylindrical surfaces that
are attached to the pin in a single selection box.

For example, for the two models shown below, you can define two pins (one for each
model) to connect the two rotating parts and the six cylinders of a hinged plate.

This improved pin connector definition is available for linear static, frequency, buckling,
and linear dynamic studies.

Mesh Refinement for Stress Singularities

The Stress Hot Spot Diagnostics functionality is improved with the addition of Stress
Singularity detection algorithm.

When the Stress Hot Spot diagnostics tool detects regions of the model that exhibit the
highest stress gradients, you can apply local mesh controls to selected geometric edges,
like sharp edges, in the hot spot regions. The improved algorithm with the addition of
mesh refinement filters stress singularities from the stress hot spot regions.

The enhanced stress hot spot diagnostics tool allows you to:

e Select edges to apply mesh controls and change the mesh size.
e Refine the mesh locally up to three levels.

e View stress variations across different mesh levels on the selected edges to confirm
the presence of stress singularities in your model.
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Sensor for Simulation Mass Properties

You can monitor Simulation mass properties with a sensor.

To create a Simulation mass properties sensor:

In the Sensor PropertyManager, select Simulation Data for Sensor Type Iz and
Simulation Mass Properties for Results.

The Simulation mass sensor tracks mass properties (mass, volume, surface area, and
center of mass coordinates) for bodies, remote masses, and bolts.

You can use a Simulation mass properties sensor either as a Constraint or as a Goal in
Design Studies.
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Sketching

This chapter includes the following topics:

e Controlling the Tangency Direction

e Creating Mirrored Entities in 3D Sketch

e Enabling and Disabling Automatic Solve and Undo for Sketches
e Instance Limit Removed for Circular Sketch Patterns

e Mirroring Entities Using Reference Planes and Planar Faces

e Pen, Touch, and Gesture-based Sketching

e Smart Dimension on the Context Toolbar

Controlling the Tangency Direction

You can flip the tangency direction of certain curved sketch entities. This includes arcs
and splines.

To control the tangency direction:

1. Open system dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2018\samples\whatsnew\sketching\Block.sldprt.

2. In the FeatureManager Design Tree, under Cut-Extrudel, right-click Sketch3 and
click Edit Sketch (.
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3. In the graphics area, right-click the arc and click Reverse Endpoint Tangent on
the shortcut menu.

The software reverses the
tangency and flips the arc.

4. Click Edit > Rebuild.

Creating Mirrored Entities in 3D Sketch

You can use the Mirror Entities tool in 3D Sketch.
To create mirrored entities in 3D Sketch:

Click 3D Sketch €D (Sketch toolbar) or Insert > 3D Sketch.
Create sketch entities.

Click Mirror Entities H‘ﬂ or Tools > Sketch Tools > Mirror.
Select sketch entities for Entities to mirror.

Select any plane or planar face for Mirror about Eg].
Click ¥ .

o v AW M=

Enabling and Disabling Automatic Solve and Undo for
Sketches

You can enable and disable Automatic Solve Mode and Undo, and modify the threshold
limit for sketch entities.

Previously, when you worked with large sketches, the Automatic Solve Mode and Undo
would repeatedly turn off in large sketches.
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Parts and Assemblies

To control Automatic Solve and Undo in Parts and Assemblies:
Click Tools > Options > System Options > Sketch.

¢ To disable the behavior of automatic turn off of Automatic Solve Mode and Undo,
clear Turn off Automatic Solve Mode and Undo when sketch contains more
than this number of sketch entities.

e To modify the threshold limit, select Turn off Automatic Solve Mode and Undo
when sketch contains more than this number of sketch entities and enter the
input value in the input box.

Click OK.

Drawings
To control Automatic Solve, Undo, and No Solve Move in Drawings:
Click Tools > Options > System Options > Drawings > Performance.

¢ To disable the behavior of automatic turn off of Automatic Solve Mode and Undo,
clear Turn off Automatic Solve Mode and Undo and turn on No Solve Move
when drawing view contains more than this number of sketch entities.

e To modify the threshold limit, select Turn off Automatic Solve Mode and Undo and
turn on No Solve Move when drawing view contains more than this number
of sketch entities and enter the input value in the input box.

Click OK.

The system options above are selected by default. If you clear the options, Automatic
Solve and Undo tools remain enabled regardless of the number of sketch entities you
create.

Instance Limit Removed for Circular Sketch Patterns

Circular sketch patterns are no longer limited to the number of instances allowed.

Mirroring Entities Using Reference Planes and Planar
Faces

You can mirror entities about reference planes or planar model faces.
Previously, you could only mirror entities about linear entities such as lines or edges.

Click Mirror K (Sketch Toolbar) or Tools > Sketch Tools > Mirror > Mirror About
and select a reference plane or a planar face in the graphics area.
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Pen, Touch, and Gesture-based Sketching

You can use pen and touch with compatible, touch-enabled devices to create free-hand
sketch strokes and convert them into sketch geometry with the tools in the Sketch Ink
CommandManager.

This functionality is available only on Windows 10 Creators Update.

To activate the Sketch Ink CommandManager, right-click the CommandManager tab and
click Sketch Ink or View > Toolbars > Sketch Ink.

To access the Sketch with Touch tool, in the Sketch Ink CommandManager, click Sketch
with Touch and use a finger to sketch entities in the graphics area.

To access the Pen tool, in the Sketch Ink CommandManager, click Pen and use a stylus
or pen to sketch entities in the graphics area.

You can create:

e Lines

e Arcs

e Polygons
e Circles

e Ellipses

Smart Dimension on the Context Toolbar

You can dimension certain entities from the Auto Insert Dimension tool on the context
toolbar.

Previously, you could only pre-select entities and then use the Smart Dimension &
tool to dimension entities.

The Smart Dimension & tool on the context menu no longer supports pre-selection.
If you want to add a dimension to your selection, use the Auto Insert Dimension on
the context menu.

The Auto Insert Dimension tool automatically inserts the most appropriate dimensions
for sketch entities.

The entities supported by the dimensioning tools on the context menu are:

e Line: Linear dimension

e Arc: Radial dimension

e Circle: Diameter dimension

e Two lines at an angle: Angular dimension between entities

e Two parallel lines: Linear dimension between entities

e Arc or circle, and line: Linear dimension between line and center point

e Point and line: Linear dimension between line and point

e Arc or circle, and point: Linear dimension between point and center point

e Arc/Arc or Circle/Circle or a combination thereof: Linear dimension between center
points.

208



Sketching

Controlling Dimensions with the Context Toolbar

To control dimensions with the context toolbar:
Create a sketch with two lines.
Ctrl + select two lines.

On the context toolbar, click Make Parallel %.
Ctrl + select the two lines and select Auto Insert Dimension on the context toolbar.
In the Modify dialog box, type a dimension.

Click ¥.

The dimension is applied to the entities.

o kW M=
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This chapter includes the following topics:

e Hexalobular Hardware
e Importing and Exporting Hole Wizard Data

SOLIDWORKS Toolbox is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Hexalobular Hardware

Hexalobular (Torx) hardware is available in Toolbox.

The following hardware has been added:

e IS0 14587 (2011) Hexalobular Socket Raised Countersunk (oval) Head Tapping Screws
e IS0 14581 (2013) Hexalobular Socket Countersunk Flat Head Screws

e ISO 14582 (2013) Hexalobular Socket Countersunk Head screws, High Head

e ISO 14584 (2011) Hexalobular Socket Raised Countersunk Head Screws

To access this hardware, click Design Library @ > Toolbox IS ISO > Bolts and
Screws > Self Tapping Screws or Hexalobular Socket Head Screws.

210



SOLIDWORKS Toolbox

Importing and Exporting Hole Wizard Data

You can import and export data from Microsoft Excel files for Hole Wizard holes. This is
helpful when you edit an entire standard or create several new sizes of holes.

To import and export hole wizard data:

1. Click Tools > Toolbox > Configure.
2. In the dialog box, click 1. Hole Wizard.

3. Browse to the type of hole to import or export data for, such as ISO > Straight
Holes > Tap Drills.

4. Under Standard Properties, click the arrow on the Microsoft Excel button and
click one of the following:

Option Description

Import Hole Data Tables Imports hole tab_Ie data into Toolbox. If
there are errors in the data, an error

report appears. After the import, you can:

e Replace existing data tables.
Removes all existing data from the
current data tables and replaces it with
data from the imported file.

e Append new data to existing data
tables. Adds the imported data to the
end of the current data tables.

Export Hole Data Tables @ Ei(\:/;sﬁtll';e hole table data to a Microsoft
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This chapter includes the following topics:

e SOLIDWORKS Design Checker

SOLIDWORKS Design Checker

SOLIDWORKS Design Checker can detect the presence of misaligned concentric mates.
You can check for:

¢ Any misaligned mates
e Misaligned mates where the deviation exceeds a maximum deviation value
e Misaligned mates where the deviation exceeds a specified value
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This chapter includes the following topics:

e 3DConnexion Spacemouse Support

e Area Light Enhancements

e Cloud Library Enhancements

e Decal Improvements

e Help Menu Improvements

e Import all SOLIDWORKS Cameras, Custom Views, and Lights
e Interactivity Performance Improvements

e Remove Camera Post-Processing from Backplates

e Spherical and Stereoscopic Cameras for VR

e Updated User Interface

SOLIDWORKS Visualize is available as a separately purchased product that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium or as a
completely separate application.

3DConnexion Spacemouse Support

SOLIDWORKS Visualize 2018 supports all 3DConnexion® 3D motion controllers.

Navigation Modes

You can apply the controller motion information to three different navigation modes. To
specify the Navigation Mode, click Tools > Options > User Interface > Spacemouse

Options.

Navigation Object mode navigation makes the user believe he is holding the

Mode - Object object in his hand. This mode is used in the modeling and inspection

(Default) of parts and assemblies. This mode uses a smart algorithm to
automatically set the rotation center of the camera. While the entire
scene is visible in the viewport, the center of the scene is taken as
the rotation center. When a user zooms close to objects to investigate
details, the rotation center will be set to a point on the 3D object’s
surface that is in the middle of the viewport. This mode is also most
commonly used in the SOLIDWORKS software.

Navigation Camera mode gives the user the impression that he is moving around

Mode - Camera in the scene he is observing. A typical use for a camera mode is
exploring virtual sceneries, similar to the navigation known from first
person games. This mode requires the user to move and turn in the
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direction that the cap on the 3D Mouse moves, and causes the objects
displayed to move in the opposite direction to object mode described
above. In camera mode, the center of rotation is at the eye or view
point (actually the position of the camera itself).

Navigation Fly mode is used to describe navigation mode where the horizon is
Mode - Fly required to always remain leveled or horizontal. Fly mode is the same
as camera mode with the additional horizontal constraint.

Object Manipulation

In addition to changing the view or camera, you can use the 3D motion controller to move
and transform the currently selected 3D objects (Models, Groups and Parts). Press the
SHIFT key while using the 3D motion controller.

The selection of 3D objects can not be empty.

These object manipulation modes are supported:

x Move When the Object Transformation Tool in the Main Toolbar
is set to Move (or disabled), the selected objects are
translated and/or rotated according to the input from
the 3D motion controller.

] Scale When the Object Transformation Tool in the Main Toolbar

e is set to Scale, the selected objects will be scaled along
the X, Y, and Z axes.

,,L_ Pivot When the Object Transformation Tool in the Main Toolbar

is set to Pivot, the Pivot or rotation center of the
selected objects are translated along the X, Y, and Z
axes.

Virtual 3D Mouse Commands

SOLIDWORKS Visualize supports a set of commands that are predefined by 3DConnexion®
to reset the view or choose commonly used orthographic and isometric views. These
commands are supported by a wide range of 3D applications and often have dedicated
buttons on the motion controller devices.

Application Commands

SOLIDWORKS Visualize offers a very wide range of application or action commands that
let you customize and allocate to device buttons or virtual menus to speed up their most
common workflows.

SOLIDWORKS Visualize includes more than 90 application commands that can be
customized using the 3DConnexion® properties menu from the motion controller’s device
driver.
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Area Light Enhancements

You can create light sources simulated as rectangles, discs, spheres, and cylinders.

These new, area light sources are extremely efficient in Fast mode and can replace the
“emissive plane” technique for creating simulated light cards in a scene used to provide
more reflections in your geometry, as well as actual emissivity in Fast mode.

Other light creation and placement improvements allow you to create lights “on the fly”
that are either matched to the current camera’s position and direction, or placed with a
single click on the model to indicate where you want the light to shine.

You can create new lights by selecting Pick Target or Match Current Camera from the
New Light menu. For example, on the Scenes tab, click Add and choose New Light,
Pick Target, or Match Current Camera.

New area light types in Fast mode, from left to right: Cylinder, Disc, Rectangle, and
Sphere

Cloud Library Enhancements

The Cloud Library performance improvements let you quickly select individual or multiple
assets to download without interrupting your workflow.

e Hover over an asset's thumbnail of content that hasn’t been downloaded for quick and
easy downloading.

e Cancel a download at any time.
e Press CTRL and select multiple assets to download them all at once.

e This download is now a separate process, so you can continue using SOLIDWORKS
Visualize while downloading assets.

Decal Improvements

SOLIDWORKS Visualize 2018 introduces an all new decal system, providing several key
improvements and new functionality.

Support of all SOLIDWORKS Decal Types

Cylindrical Maps all points onto a cylinder
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Spherical Maps all points onto a sphere

Planar/Projection Maps all points onto a specified plane and then projects the
decal onto the reference entity

Label Maps decals onto the model faces, including multiple
contiguous nonplanar surfaces with no stretching or shrinking

SOLIDWORKS

SOLIDWORKS Visualize

Animation Keyframe Support

You can create unique decal animations by right-clicking a decal and clicking Add
Keyframe. You can scale and position decals. In addition, you can animate the Opacity
(visibility) to show multiple decal options, slide shows, flashing billboard, and flickering
TV screen, for example.

Additional Key Improvements

e Floating decal issues, with noticeable drop shadow, are resolved

e Improved overall performance and files with many decals are handled properly
¢ No limit on the number of decals per project/part

e Support for up to 6 overlapping decals on a single part
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Help Menu Improvements

The Help menu improves access to the help and documentation resources and aligns with
other SOLIDWORKS products.

All documentation resources, including SOLIDWORKS Visualize Help, Tutorials, Release
Notes, and What's New, are accessible from the Help menu. To guarantee the documents
remain up-to-date and to minimize the required installation and installer size, the links
reference online resources.

All SOLIDWORKS Visualize documentation is now available online only. An internet
connection is required to access the documentation, however, you can then download
the documents for future offline use.

The following actions to manage licenses are now accessible from the Help menu:

e Activate License (for Standalone licenses)
e Deactivate License (for Standalone licenses)
e SolidNetWork License Manager (for Network licenses)

Import all SOLIDWORKS Cameras, Custom Views,
and Lights

When you import a SOLIDWORKS model into SOLIDWORKS Visualize, you can now import
all custom defined SOLIDWORKS Cameras, custom saved views, and physical lights.

Cameras and Saved Views

When you import a SOLIDWORKS model and choose to import Cameras, all cameras
and custom SOLIDWORKS views are imported into SOLIDWORKS Visualize. These import
as SOLIDWORKS Visualize Cameras and are displayed in the Camera’s tab in SOLIDWORKS
Visualize. All aspects of SOLIDWORKS cameras and saved views are maintained and
replicated in SOLIDWORKS Visualize.

To import cameras and saved views, the model must be saved in SOLIDWORKS 2018.
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point, and spot lights saved in the SOLIDWORKS model are imported as SOLIDWORKS
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when translated to SOLIDWORKS Visualize.
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Interactivity Performance Improvements

SOLIDWORKS Visualize 2018 includes three main improvements to the raytracing
performance:

e Faster interactivity directly in the Viewport with Fast and Accurate raytracing modes
e Added new Fast raytracing mode switch for even faster Fast mode
e Ability to set the default humber of passes for Fast raytracing mode

Faster Interactivity Directly in the Viewport

Officially included in the 2017 SP2 release, Viewport interactivity performance was
significantly improved when interacting with the camera and/or geometry with Fast or
Accurate modes enabled. No setting change is required to see these performance
improvements.

Fast Raytracing Mode Switch

SOLIDWORKS Visualize 2018 includes a Fast mode toggle switch: Speed or Quality.
You can access this switch from the Main Toolbar.

t®sRLALECO

Quality
Speed

Quality

Speed: Recommended for fastest interactivity in the Viewport.

e This new Fast render setting completes renders almost 2X faster than in previous
versions by removing self-shadowing and time-consuming reflections.

e This is ideal for projects without glass, clear plastics, or transparent objects.

Quality: Recommended for final renders.

e This new Fast render mode is actually more realistic and advanced than the previous
Fast render mode. This mode has some of the more photorealistic features found in
Accurate mode, but with the faster raytracing speeds of Fast mode.

e This new Fast mode allows for a greater usage of Fast raytracing mode throughout
more and more projects. Accurate raytracing mode is only needed for interior scenes.
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Fast: Speed Fast: Quality Accurate
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45 seconds Tmin 13sec 2 minutes

For more information, see this Visualize Forum thread.

Set Default Number of Passes for Fast Raytracing Mode

With the Fast mode toggle switch between Speed and Quality, you have the option to
set the default number of Render Passes for the Fast render mode. Click Tools >
Options > 3D Viewport > Fast Rendering Mode.

Some Fast mode renders can still be noisy, so this setting allows you to adjust the default
number of Fast mode render passes to reduce any visible noise in final Fast mode renders.

The accumulation process stops once this number is reached. Small values lead to shorter
render times but may produce noisy images. The default number is sufficient for most
projects.

~ Fast Rendering Mode

Optimaze For:

Render Passes

The Fast mode setting (Speed or Quality) and Render Pass count selected in the Viewport
are the settings used during an offline render if you select Fast mode.

* Render Settings

Renderer Selection
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Remove Camera Post-Processing from Backplates

When using a backplate image or background color as the visible background in your
scene, you can choose to have the Camera Post Processing Options only impact the model.

Click Cameras > Filters . Under Post-Processing Options, select Apply To Geometry
Only. This option results in the post-processing effects only applying to the model, and
not a backplate or background color.

If the visible background is the HDR environment image itself, this option has no visible
affect.

Apply To Geometry Only cleared

Spherical and Stereoscopic Cameras for VR

SOLIDWORKS Visualize Professional 2018 introduces new tools and methods to create
360° images and videos (animations) that can be used to prepare interactive Virtual
Reality content.

These new VR features are only available in SOLIDWORKS Visualize Professional.
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Spherical Lens

In addition to Perspective and Orthographic camera projections, Spherical is now
available.

Spherical is not supported in the Preview render mode.

The Spherical lens is a nonlinear type of projection that captures the whole 360 degree
environment around the camera’s position into a single wide screen image. The result
displays in a Lat/Long or Equirectangular image that resembles a photo with an
extreme fish eye lens.

In this example, two images of an interior scene are created from the same camera
position using Perspective and Spherical projections.
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Perspective

Spherical

Stereoscopy

Stereo rendering computes two images at the same time, one for the left eye and one
for the right eye, respectively.

To use Stereo rendering, click Palette > Cameras > Advanced > Stereoscopy .

You can control the intensity of the stereo effect using the Eye Separation and Focal
Distance parameters. The Focal Distance (distance from camera position in viewing
direction) defines the zero parallax or point of convergence between the left and right
images for a given Eye Separation. Click Pick and select an object in the 3D viewport
using the crosshairs cursor to specify the Focal Distance.

Perspective and Spherical camera projection types support stereo rendering.
SOLIDWORKS Visualize provides two modes to display the left and right eye images.

Stereo TwoUp Mode

Stereo TwoUp Mode displays both images at the same time. The left image is on top; the
right image is on the bottom.
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Stereo Anaglyph Mode

Stereo Anaglyph Mode overlays the two images using color filters (chromatically opposite
colors red and cyan) to produce 3D images that you can view using inexpensive red/cyan
stereo glasses. Moreover, it helps to see the stereo parallax effect. In this example, the
zero parallax or focal point is set on the wine bottle in the center of the image.

Application Examples

Social Media

You can post spherical images on social media sites such as Facebook® 360 Photos to
create interactive, panoramic experiences. You can also export spherical videos that are
handled in a similar way e.g., Facebook® 360 Videos). While these videos are playing,
users can choose their perspective throughout the entire 360°. When played on mobile
devices that employ gyroscopes, the motion of the device defines the perspective or
viewing direction, giving the user the illusion of having a window into the virtual world.
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VR Headsets

You can use stereographic and spherical images as input for VR headsets giving users
the impression they are in the virtual scene while allowing them to look in every direction.
These stereographic and spherical images can also be exported as videos and uploaded
to YouTube® where they appear as VR-360 videos, ready to be streamed and consumed
from any VR device.

HDR Environments

When you export spherical images in a high dynamic range format such as .HDR or .EXR,
you can reload the resulting images as HDR Environments into SOLIDWORKS Visualize.
This gives you the ability to set up your own scenes to customize reflections and lighting
for subsequent visualization purposes.

Updated User Interface

SOLIDWORKS Visualize 2018 has a restyled user interface with a modern, clean design
theme that reflects current industry and market trends. This modernized user interface
includes restyled icons that complement the new design theme and increased spacing
that helps with touchscreen support.

Use Tools > Options > User Interface > Interface Options to switch between Dark
and Light themes.
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Light

Other Main User Interface Updates
e Palette sub-tabs simplify lengthy settings

General

Appearance Name

Appearance Type

Paint

Color

226



SOLIDWORKS Visualize

e Simplified right-click context menu

Properties

Model..

Pick
icl Part._

Manipulate -
Group..

Add
Appearance..,
View
Edlit
Ararnation

Lo

* Output File

Filename

Output Mode
Render

Render Output Passes
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Inchude Alpha

= Resclution

pocels

pixelsfin

e New Camera Orthographic and Isometric view presets on the Main toolbar that are
similar to SOLIDWORKS
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This chapter includes the following topics:

e Customizing Description for Bounding Box Properties
e Linking a Cut List Folder to a Cut List Property

Customizing Description for Bounding Box Properties

You can customize the default description settings of bounding box properties for new or
existing solid and sheet metal cut list bodies in Tools > Options > Document
Properties > Weldments.

To customize description settings in bounding box properties:

1. With a document open, click Options & (Standard toolbar). On the Document
Properties tab, select Weldments.

2. In the Bounding Box Properties section, to change a description for solid bodies:

a) Clear Use default description.

b) In the description field, overwrite Plate and type a new description.

c) Click the drop down arrow to change the order of SW-Thickness, SW-Length,
or SW-Width. If you select None from the drop down list, the element is removed
from the text expression.

3. To change a description for sheet metal bodies:
a) Clear Use default description.
b) In the description field, type a new description.

4. Select an option to apply the changes to existing and new bounding boxes, or new
bounding boxes only.

Changes to existing bounding box descriptions cannot be reversed.

5. Click OK.

Linking a Cut List Folder to a Cut List Property

In the Cut-List Properties dialog box, you can add a custom property that links a cut list
folder to its cut list folder name. You can then include this cut-list property in BOMs,
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notes, and sheet formats. This property helps to identify members in large multibody
weldments.

To link a cut list folder to a cut list property:

1. Inthe FeatureManager design tree, right-click a Cut-List-Folder and click Properties.

2. On the Cut List Summary tab, click an empty cell under Property Name and add
a new property.

3. Under Value/Text Expression, choose Cut List Item Name from the list.

The text in Value/Text Expression displays SW-CutListItemName@R@<Cutlist folder
name>@<Part name.Sldprt and the evaluated value displays the cut list folder name.
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